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Introduction

The pre-work listed here is required prior to attending the Salesforce Commerce
Cloud (SFCC) Digital Fast Path workshop. It can also be used by anyone getting
started with SFCC Digital programming. In this exercise, you will install UX Studio,
an Eclipse plugin that is your development environment. You will connect UX Studio
to a remote SFCC sandbox instance which was assigned to you by your company or
by your instructor.

Without this pre-work, you won’t be able to attend the Fast Path course.

If you have questions regarding the completion of these steps or for more
information, please refer to these documentation links (also bookmark them):

Getting Started for Developers:
https:/ /documentation.demandware.com/DOC2/topic/com.demandware.dochel
p/SiteDevelopment/GettingStartedforDevelopers.html#D3289

UX Studio Download: https://xchange.demandware.com/docs/DOC-1936

UX Studio Update Site URLs: https:/ /xchange.demandware.com/docs/DOC-41220

File System Locations Used

Files Location example Notes

UXStudio <your_chosen_dir>/CCProjects/workspaces/fastpath | Contains server
Workspace connection project

.metadata (plug-in
subdirectories)

Project Root | <your_chosen_dir>/CCProjects/fastpath Contains all cartridges
Folder used for development
Custom <your_chosen_dir>/CCProjects/fastpath/cartridges  |Storefront and solution
Cartridges cartridges.
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Step 1: Import the SiteGenesis Site into Your Sandbox

Goals Import the SiteGenesis demo site in Business Manager.

Scenario A site needs to be created in Business Manager before you can work with it.

Importing the SiteGenesis site into your sandbox installs a demonstration site
that you can view, modify, and use as a basis for your eCommerce site.

Time 15 minutes

Instructions

1.

Login to Business Manager using the sandbox URL and login provided to you:
https://<your_sb_url>/on/demandware.store/Sites-Site where the URL varies
depending upon the realm your SB is located.

Navigate to Administration > Site Development > Site Import & Export.
Select the SiteGenesis Demo Site radio button, and click the Import button.

Click Ok on the prompt to import the SiteGenesis Demo Site:

Administration > Site Development > Site Import & Export

Site Import & Export

This page allows you to export the current configuration of your organization including all of its sites. To download an archive, just click its file name.

Import

6 Are you sure that you want to import the SiteGenesis Demo Site? OK  Cancel
Upload Archive:
OLocal . Remote

Choose File  No file chosen Upload

Select Name A Location File Size Last Modified
SiteGenesis Demo Site

Import Delete

Verify that the SiteGenesis site has imported correctly: on the Status area, the
status Running will change to Success after several minutes:

You can now view the SiteGenesis site that you imported: on the upper-left
corner of Business Manager, select the SiteGenesis site, then click on the
Storefront link on the same row:

)

P

) Storefront
®

Merchant Tools w Administration v

\
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7. Navigate the SiteGenesis site as you would any other eCommerce site.
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Step 2: Download and Install the UX Studio Plugin

Goals Install the UX Studio plugin inside Eclipse

Scenario Developers use UX Studio to write code for Commerce Cloud sites. UX Studio is

installed as a plugin for Eclipse. You must first install Eclipse and then open it and
install the UX Studio plugin.

Time 20 minutes

Instructions

1.

Download and install Eclipse as described in the following page, steps 1 through
3:
https://documentation.demandware.com/DOC2/topic/com.demandware.doc
help/SiteDevelopment/InstallingDemandwareUXStudio.html?cp=0_1_5_1. If
you already installed Eclipse, you can continue.

The first time you launch Eclipse, it will ask for a workspace to store settings.
Enter <your_chosen_dir>/CCProjects/workspaces/fastpath, and click Launch:

@ Eclipse Launcher

Select a directory as workspace

Eclipse uses the workspace directory to store its preferences and development artifacts.

Workspace: /Usersfjorge.hernandez/Documents/CCProjects/workspaces/fastpath a Browse...

» Recent Workspaces

» Copy Settings

Y L L
@ Cancel | (QECIS

In Eclipse, select Help > Install New Software...
Click Add...

Enter UX Studio in the Name fields, and
https:/ /developer.salesforce.com/media/commercecloud/uxstudio/4.6 in the

Location field:
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O Add Repository
Name: ‘ UX Studid| Local...
Location: https://developer.salesforce.com/media/commercecioud) Archive...

)
©) ok |
(2 Cancel

6. Click OK to save this repository.

7. Select the Salesforce Commerce Cloud checkbox, and click Next to install the
UX Studio plugin:

® 0 Install
| Available Software ‘
; Check the items that you wish to install. = |
| D,
| —
1
Work with: | UX Studio - https://developer.salesforce.com/media/commercecloud/uxstudio/4.6 a Add... Manage...

Name Version
» (00 Salesforce Commerce Cloud

Select All Deselect All 1 item selected
Details
Show only the latest versions of available software Hide items that are already installed
Group items by category What is already installed?

Show only software applicable to target environment

Contact all update sites during install to find required software

@ I o

8. Continue the installation by accepting the terms of use, and restart Eclipse.

9. To verify that UX Studio has installed correctly, navigate to:
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[ Winion [ |

| Minimize [Eclipse

Zoom . —

(SR el [r= @ R v v v v
Toggle Full Screen  ~3F - ’
New Window = 5
Editor >
Appearance >
Show View >
Perspective > Open Perspective > %5 Debug

J
Navigation > Customize Perspective... &' Java
Save Perspective As... Dane

W?b Browser > Reset Perspective... {5 Resource
Bring All to Front | Close Perspective & Web

Close All Perspectives m

10.Select the Digital Development option. This changes the workspace to the
Digital Development perspective, as seen below:

o0 e fastpath - Eclipse

mil Pe-r-BrrreNee SR B My QO Qe S v St ® g

& cartrid 83 | B Pipelin (@ Pipelet Templa s Scripts lj! Control . Navigat = B 5= Outline 52 = [m]
SFEE e hd =8 -

An outline is not available.
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Step 3: Connect UX Studio to Your Sandbox

Goals Create a Digital Server Connection project to your sandbox.

Scenario Initially, your workspace will be empty. You need to create a connection to your
sandbox in order to be able to upload code to it.

Time 15 minutes

Instructions

1. From within UX Studio, click File > New > Digital Server Connection.
Result: The New Digital Server Connection dialog appears.

2. Inthe Project name and Host name fields, use the sandbox host name. For
example, if the sandbox URL is

https://jhernandez-inside-na06-dw.demandware.net/on/demandware.store/Sites-Site,

you would use the hostname jhernandez-inside-na06-dw.demandware.net.
3. Keep the Use default location checked. This is the workspace you created.

4. Enter the User name and Password (passwords are case-sensitive) that were
provided by the person who assigned you a sandbox.

@ o New Digital Server Connection

New Digital Server Connection
Create a new connection to a Digital Server.
Project name:  jhernandez-inside-na06-dw.demandware.net

Use default location
Location:

Choose file system:

Connection Settings

Host name: | jhernandez-inside-na06-dw.demandware.net
User name: admin

Password: | eesssecsee

Use Certificate Authentication

Keystore File:

Keystore Password:

@ [ Next > JEEEONY
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Note: If you changed the user's password within Business Manager, you will need
to change it for this server connection as well.

5. Click Next >.

6. In the following screen, select versionl from the dropdown:

@® o New Digital Server Connection
Code staging directory

Select the target upload staging version directory

Target version directory: = version? u
Active directory: version1
@ < Back concel | (D

7. Click Finish.
8. To verify your steps:
a. Switch to Eclipse
b. Open the Navigator tag: a server connection to your sandbox exists

c. Right-click the connection: Active Server and Auto-Upload are checked
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[ YoK ) fastpath - Eclipse
N EHR® e SR OB BE® H A O Qe A L i
&, cartridge Explor % Pipelines (D Pipelets Templates s Scripts !i! Controllers |%. Navigator 83 = B

B%S v

» & jhernandez-inside-na06-dw.demandware.net

New >
Go Into
Open in New Window

Copy

¥ Delete
Move...
Rename...

gy Import...
2y Export...

] Refresh
Close Project
Close Unrelated Projects

Show in Remote Systems view
Validate

Coverage As

Run As

Debug As

Profile As

Restore from Local History...

Digital Server »  Active Server

Team »  Auto-Upload

vyvyVvyy

Copyright Salesforce.com 2018 Confidential & proprietary information—duplication is prohibited



Commerce Cloud Sandbox Setup and UX Studio Installation

Step 4: Download the SiteGenesis Storefront Cartridges

Goals Download the SiteGenesis Storefront cartridges and upload them to your
sandbox.
Scenario The SiteGenesis sites works with default cartridges that were installed

automatically. You download that code into your file system so you can modify,
and upload new code to your site.

Time 10 minutes

Instructions

In your file system, create a new fastpath folder inside the
<your_chosen_dir>\CCProjects folder that you created before. This will be the
location for the projects in this Fast Path program.

1. Open Eclipse.

2. Select the fastpath workspace.

3. Select File > New > SiteGenesis Storefront

4. Complete the New Site Genesis StoreFront Cartridge dialog as follows:

a. Name: storefront. This is the prefix for your cartridges. Use any prefix you
like.

b. Location: use the full path to the fastpath directory you created.

c. Attach to Digital Servers: select the checkbox next to the sandbox hostname
provided in step 3.

d. See the following image to make sure all entries are correct:
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® 0 New SiteGenesis Storefront Cartridges
SiteGenesis Storefront Cartridges
This wizard creates three cartridges representing the SiteGenesis storefront. 5
Enter the root name for your three SiteGenesis storefront cartridges.
Name: storefront
Location: | /Usersfjorge.nernandez/Documents/CCProjects/fastpath Browse...

SiteGenesis Cartridges

Core Cartridge: storefront_core
Controllers Cartridge: storefront_controllers

Pipelines Cartridge: storefront_pipelines

Attach to Digital Servers

jhernandez-inside-na06-dw.demandware.net

@

Click Finish.

Open the Progress tab to see a slider indicating that cartridges are being
uploaded:

[T Properties [*| Problems « Search [ Console =g Progress &%

Building workspace

=]

Uploading new folder /storefront_core/cartridge/js/pages/checkout

To verify that the cartridges were created, check the Navigator tab. You will see 3
new cartridges below the connection project:

00

kg @ B2 = 3 L BESB &8 04 =

& cartridge ¥ Pipelines (D Pipelets Templates s Scripts !i! Controller T. Navigator 83 = = B
2% v

» 2% jhernandez-inside-na06-dw.demandware.net

» (= storefront_controllers

b (== storefront_core
b (== storefront_pipelines
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8. Inyour sandbox, you can verify the uploaded cartridges:
a. Navigate to Administration > Site Development > Code Deployment.
b. Click versionl.

c. Check that the cartridges present are: storefront_core,
storefront_controllers and storefront_pipelines

9. If the cartridges are not present, you need to make sure the uploading process
from Step 4.6 is finished.
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Step 5: Check the Cartridge Path

Goals Check that the SiteGenesis site is using the uploaded cartridges.

Scenario After you have uploaded the storefront cartridges to your sandbox, you must
check the site’s cartridge path in Business Manager. Any code modified in the
cartridges will affect the site.

Time 5 minutes

Instructions

1. Open Business Manager.
2. Click Administration > Sites > Manage Sites > SiteGenesis.
3. Click the Settings tab.

4. Look at the Cartridges field: it contains the default cartridges that get
automatically installed when you created the SiteGenesis site in Step 1:

Click Apply to save the details. Click Reset to revert to the last saved state.

Instance Type: = Sandbox/Development %

Deprecated. The preferred way of configuring HTTP and HTTPS hostnames is by using new features of the site aliases configuration (*Site URLs/Aliases Configuration®). The HTTP/HTTPS hostnames values set in this section w
aliases configuration and are intended only to support an older configuration style.

HTTP Hostname:

HTTPS Hostname:
Instance Type: All

Cartridges: sitegenesis_storefront_controllers:sitegenesis_storefront_core

Effective Cartridge Path: sitegenesis_storefront_controllers:sitegenesis_storefront_core:plugin_apple_pay:plugin_facebook:plugin_pinterest commerce:plugin_web_payments:core

5. Change the cartridge path to specify the cartridges you uploaded from UX

«,

Studio into your sandbox, using “:” as a separator:
storefront_controllers:storefront_core

6. Check that they appear as follows:
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Administration > Sites > Manage Sites > SiteGenesis - Settings

General Settings Cache Site Status

SiteGenesis - Settings

Click Apply to save the details. Click Reset to revert to the last saved state.

Instance Type: | Sandbox/Development %

Deprecated. The preferred way of configuring HTTP and HTTPS hostnames is by using new features of the site aliases configuration (*Site URLs/Al
configuration and are intended only to support an older configuration style.

HTTP Hostname:
HTTPS Hostname:

Instance Type: All

Cartridges: storefront_controllers:storefront_core

7. Click Apply.

Result: The SiteGenesis site will now use the cartridges you uploaded, not the
default ones that came as part of the SiteGenesis installation.
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Step 6: Disable Caching and Making the Site Online

Goals Disable cache and make the site ready to be online.
Scenario To ensure code changes are reflected immediately in your storefront, page
caching needs to be disabled in your sandbox. Also, making the site online

without a password makes testing easier.

Time 2 minutes

Instructions

1. Open Commerce Cloud Business Manager.

2. Click Administration > Sites > Manage Sites > SiteGenesis.
3. Click the Cache tab.

4. Set Time to Live (TTL) to O.

5. Uncheck the Enable Page Caching checkbox:

Instance Type:| Sandbox/Development ¥

Static Content and Page Caches

The field Time to Live (TTL) of Static Content defines the time span in se
static files set this field to 0. For Production instances the configured time

Time to Live (TTL) of Static Content: 0

Page Cache Only
Check the Enable Page Caching checkbox to allow the web server to cac

Enable Page Caching

6. Click Apply.

7. Click Invalidate under the Static Content and Page Caches section.
8. Click the Site Status tab.

9. Check the different options.

10.Select Online as the site status.

11.Click Apply.
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Step 7: View Products in the Storefront

Goals Confirm your site is ready for development by viewing products in the storefront.
Scenario After uploading your cartridges, your site is ready for development.
Time 2 minutes

Instructions

1. In Business Manager, select the SiteGenesis site, then click on the Storefront
link on the same row:

L
) Storefront e

0-—‘/0

Merchant Tools v Administration v

2. The SiteGenesis site opens in a new tab.
3. Bookmark this page: it is the homepage of the site.

4. Click on the Womens > Clothing > Outfits category: the site should work as

FREE 2-Day SHIPPING FOR ORDERS OVER $300
0

@ commerce cloud | Enter Keyword or Item No Q Q & E

NEW ARRIVALS WOMENS MENS ELECTRONICS TOP SELLERS

g / Outfits

SHOP WOMENS
~ Clothing

Outfits

Price High to Low % 222 2= Showing 1 - 4 of 4 Results

Spring Has Sprung Spring Look

Buy All or One Buy All or One Buy A

Congratulations! You have now finished installing UX Studio and setting up your
sandbox. You are now ready to start the Fast Path to Commerce Cloud Certification.
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