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About the Release Notes
The Release Notes are a comprehensive user guide for the latest release of Salesforce. Unlike a traditional release notes document
that includes only a simple list of enhancements, the Salesforce Release Notes give you everything you need to get up and
running with the new features and enhancements in the latest release.

What's Included in the Release Notes
For every new major enhancement, the Release Notes provide:

• A brief, high-level description of the functionality
• Implementation tips to help you get started with setup and administration
• Best practice tips to help you maximize the benefit of the functionality
• Complete end-to-end instructions on how to set up and use the functionality

Beyond the major new features, the Additional Enhancements sections include a list and brief description of every other
enhancement or functional change included in the latest release—everything from email enhancements, to new report types,
to security and packaging enhancements.

Let the Release Notes be your guide to success with the latest release from salesforce.com!

Your Feedback Matters
We know how important the Release Notes, online help, and documentation are to your company's success with Salesforce.
To continually improve the content we deliver to you, we want to know what works and what doesn't. Let us know!

• Feedback forms—Every HTML documentation page, both in the online help and in our developer guides at Developer
Force, includes a feedback form for you to submit your suggestions, corrections, and feedback about the documentation.
Let us know what you think!

• IdeaExchange—We're listening to your ideas too. Spring '11 includes some of your top ideas. Visit IdeaExchange for a
complete list of ideas coming in Spring '11.

Want to be notified whenever we publish new documentation or make significant updates to existing documentation? Follow
us on Twitter: @salesforcedocs.
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Summary of Spring '11 Features and Impact on Salesforce
Users

Spring '11 has features that immediately impact all users after the release. You might want to communicate these changes to
your users beforehand so they are prepared. Other features require direct action by an administrator before users can benefit
from the new functionality.

The following table summarizes the Spring '11 features and their impact on users. Review the feature details for the applicable
Salesforce Editions.

Collaboration Cloud Enhancements

Chatter

Contact
salesforce.com to

enable this feature.

Not automatically
visible. Feature is

available but
requires some

setup.

Automatically
visible to all

administrators. No
setup required.

Automatically
visible to all users.
No setup required.

Feature

Free Chatter Users

Chatter Desktop Enhancements

Chatter Feeds Enhancements

Chatter Files Enhancements

Chatter Groups Enhancements

Chatter Topics Enhancements

Chatter for Mobile Devices

Chatter Notifications Enhancements

Chatter Recommendation Enhancements

Chatter Search Enhancements

Additional Chatter Enhancements
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Sales Cloud Enhancements

Sales Productivity

Contact
salesforce.com to

enable this feature.

Not automatically
visible. Feature is

available but
requires some

setup.

Automatically
visible to all

administrators. No
setup required.

Automatically
visible to all users.
No setup required.

Feature

Cloud Scheduler Enhancements

Email Attachment Enhancements

Activity Attachment Enhancements

Email Association Enhancements

Email to Salesforce Enhancements

Salesforce Mobile Usage Data in Custom
Report Types

Salesforce for Outlook

Contact
salesforce.com to

enable this feature.

Not automatically
visible. Feature is

available but
requires some

setup.

Automatically
visible to all

administrators. No
setup required.

Automatically
visible to all users.
No setup required.

Feature

Desktop Notifications

Retry Sync

OAuth

Auto-Sync People You Follow

Opportunities

Contact
salesforce.com to

enable this feature.

Not automatically
visible. Feature is

available but
requires some

setup.

Automatically
visible to all

administrators. No
setup required.

Automatically
visible to all users.
No setup required.

Feature

Sorting for Opportunity Products
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Partner Relationship Management

Contact
salesforce.com to

enable this feature.

Not automatically
visible. Feature is

available but
requires some

setup.

Automatically
visible to all

administrators. No
setup required.

Automatically
visible to all users.
No setup required.

Feature

Flows in Force.com Sites, the Customer
Portal and the Partner Portal

Quotes

Contact
salesforce.com to

enable this feature.

Not automatically
visible. Feature is

available but
requires some

setup.

Automatically
visible to all

administrators. No
setup required.

Automatically
visible to all users.
No setup required.

Feature

Product Code Field on Quote Line
Items

Sorting for Quote Line Items

Salesforce CRM Content

Contact
salesforce.com to

enable this feature.

Not automatically
visible. Feature is

available but
requires some

setup.

Automatically
visible to all

administrators. No
setup required.

Automatically
visible to all users.
No setup required.

Feature

Share Salesforce CRM Content Files in
Chatter with Updated Workspace
Permission

Service Cloud Enhancements

Salesforce Knowledge

Contact
salesforce.com to

enable this feature.

Not automatically
visible. Feature is

available but
requires some

setup.

Automatically
visible to all

administrators. No
setup required.

Automatically
visible to all users.
No setup required.

Feature

Multiple Languages for Salesforce
Knowledge
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Contact
salesforce.com to

enable this feature.

Not automatically
visible. Feature is

available but
requires some

setup.

Automatically
visible to all

administrators. No
setup required.

Automatically
visible to all users.
No setup required.

Feature

Salesforce Knowledge Article Number

Additional Case Article Fields Available
for Reports and the Articles Related List

Service Cloud Console

Contact
salesforce.com to

enable this feature.

Not automatically
visible. Feature is

available but
requires some

setup.

Available to
Enterprise and

Unlimited
Editions with the

Service Cloud.

Automatically
visible to all

administrators. No
setup required.

Automatically
visible to all users.
No setup required.

Available to
Enterprise and

Unlimited
Editions with the

Service Cloud.

Feature

Salesforce Knowledge Sidebar for the
Service Cloud Console (Contextual
Knowledge)

Global Search for the Service Cloud
Console

Customer Portal

Contact
salesforce.com to

enable this feature.

Not automatically
visible. Feature is

available but
requires some

setup.

Automatically
visible to all

administrators. No
setup required.

Automatically
visible to all users.
No setup required.

Feature

Flows in Force.com Sites, the Customer
Portal and the Partner Portal
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Entitlement Management

Contact
salesforce.com to

enable this feature.

Not automatically
visible. Feature is

available but
requires some

setup.

Available to
Enterprise and

Unlimited
Editions with the

Service Cloud.

Automatically
visible to all

administrators. No
setup required.

Automatically
visible to all users.
No setup required.

Feature

Validation Rules for Case Milestones

Call Center

Contact
salesforce.com to

enable this feature.

Not automatically
visible. Feature is

available but
requires some

setup.

Automatically
visible to all

administrators. No
setup required.

Automatically
visible to all users.
No setup required.

Feature

Version 3.0 of the CTI Toolkit Is
Compatible with the 64–bit Version of
Internet Explorer 8 on Windows 7

Analytics Enhancements

Report Builder Enhancements

Contact
salesforce.com to

enable this feature.

Not automatically
visible. Feature is

available but
requires some

setup.

Automatically
visible to all

administrators. No
setup required.

Automatically
visible to all users.
No setup required.

Feature

Report Builder Upgrade

Report Builder for Group and
Professional Editions

Scatter Charts

Report Builder for Force.com and
Salesforce Platform Users

Improved Report Builder Filters
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Dashboard Enhancements

Contact
salesforce.com to

enable this feature.

Not automatically
visible. Feature is

available but
requires some

setup.

Automatically
visible to all

administrators. No
setup required.

Automatically
visible to all users.
No setup required.

Feature

Dashboard Builder for All Users

Dynamic Dashboards for Enterprise
Edition, with Higher Limits

Dashboard Alerts

Chatter Dashboard Component Posts

Profile Photos on Dashboards

API and Metadata API Enhancements

Contact
salesforce.com to

enable this feature.

Not automatically
visible. Feature is

available but
requires some

setup.

Automatically
visible to all

administrators. No
setup required.

Automatically
visible to all users.
No setup required.

Feature

API and Metadata API Enhancements

Force.com Enhancements

Globalization

Contact
salesforce.com to

enable this feature.

Not automatically
visible. Feature is

available but
requires some

setup.

Automatically
visible to all

administrators. No
setup required.

Automatically
visible to all users.
No setup required.

Feature

Translation Workbench Export and
Import Options

Additional End User Language Support

Ability to Translate and Override Names
of Custom Objects from Managed
Packages
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Apex and Visualforce

Contact
salesforce.com to

enable this feature.

Not automatically
visible. Feature is

available but
requires some

setup.

Automatically
visible to all

administrators. No
setup required.

Automatically
visible to all users.
No setup required.

Feature

Force.com Apex Code Enhancements

Revised Apex Governor Limits

Apex Test Framework—Pilot

System Log Console

Visualforce Enhancements

Customization

Contact
salesforce.com to

enable this feature.

Not automatically
visible. Feature is

available but
requires some

setup.

Automatically
visible to all

administrators. No
setup required.

Automatically
visible to all users.
No setup required.

Feature

Field Sets—Beta

Sites

Contact
salesforce.com to

enable this feature.

Not automatically
visible. Feature is

available but
requires some

setup.

Automatically
visible to all

administrators. No
setup required.

Automatically
visible to all users.
No setup required.

Feature

Flows in Force.com Sites, the Customer
Portal and the Partner Portal

Security

Contact
salesforce.com to

enable this feature.

Not automatically
visible. Feature is

available but
requires some

setup.

Automatically
visible to all

administrators. No
setup required.

Automatically
visible to all users.
No setup required.

Feature

Criteria-Based Sharing Rules—Generally
Available

Sharing Rule Management for Large
Organizations
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Contact
salesforce.com to

enable this feature.

Not automatically
visible. Feature is

available but
requires some

setup.

Automatically
visible to all

administrators. No
setup required.

Automatically
visible to all users.
No setup required.

Feature

Apex Sharing Reasons Available in
Professional Edition

Encryption Management

Create a Filtered View of the Login
History Page

Customizable Error Messages

Delegated Authentication for Single
Sign-On

New Error Messages for Access Token
Request

New Administrative Permission for Reset
User Passwords and Unlock Users

Enforce Password History Now Can
Remember Up To 15 Passwords

Email Security for Remote Access Apps

User Interface Settings and Other Force.com Platform Enhancements

Contact
salesforce.com to

enable this feature.

Not automatically
visible. Feature is
available requires

some setup.

Automatically
visible to all

administrators. No
setup required.

Automatically
visible to all users.
No setup required.

Feature

Google Chrome Browser Support

Web Services API and Developer Tools

Contact
salesforce.com to

enable this feature.

Not automatically
visible. Feature is

available but
requires some

setup.

Automatically
visible to all

administrators. No
setup required.

Automatically
visible to all users.
No setup required.

Feature

API Enhancements

Force.com Development as a Service
Enhancements

Packaging Enhancements on page 59
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Workflow and Approvals

Contact
salesforce.com to

enable this feature.

Not automatically
visible. Feature is

available but
requires some

setup.

Automatically
visible to all

administrators. No
setup required.

Automatically
visible to all users.
No setup required.

Feature

Delegated Approval Email Settings

Daily Limit on Workflow Alert Emails

Force.com Flow—Generally Available

Adding a Flow to a Visualforce Page

Flows in Force.com Sites, the Customer
Portal and the Partner Portal

What's New in the Flow Designer
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Free Chatter Users
Every Salesforce organization now has Chatter Free licenses available for use. Assign these licenses to people in your company
that don't have a Salesforce license or turn on invitations so users in your organization can invite coworkers directly.

Note: To take full advantage of your Chatter Free licenses, we recommend that you enable Chatter invitations.

Chatter Free users can access:

• People
• Profiles
• Groups
• Files

They can't view any Salesforce objects, records, or data unless you grant them a Salesforce license or Chatter Plus license.

Note: You can upgrade a Chatter Free license to a standard Salesforce license at any time, however, you can't convert
a standard Salesforce license to a Chatter Free license.

If you want invited co-workers to have access to Salesforce accounts and contacts, and be able to modify up to ten custom
objects, contact your Salesforce sales representative about Chatter Plus licenses.

Note:  In previous releases, Chatter Plus licenses were known as Chatter Only licenses.

The following table shows the differences between Chatter Free and Chatter Plus licenses.

Chatter PlusChatter FreeFeature

Chatter Tab

People Tab

Groups tab

Profile tab

Accounts (read-only access)

Contacts (read-only access)

Tasks and Activities

COLLABORATION CLOUD
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Chatter PlusChatter FreeFeature

 (up to 10)Custom Objects

Content

Ideas

Answers

Enabling Chatter Invitations
1. Go to Your Name➤ Setup ➤ Customize ➤ Chatter ➤ Settings.
2. Select Allow Invitations to let users invite people to join Chatter for your company.

Invited users have access to Chatter people, profiles, groups, and files but can’t see record data unless they have a Salesforce
license.

Note: Portal users cannot send invitations.

A user has up to 60 days to accept an invitation to join Chatter. If during that time, an administrator deselects
Allow Invitations or removes the user's domain from the list, the user won't be able to accept the invitation.

3. Enter email domains to define who can join Chatter for your organization. The domains you enter should include those
used in email addresses for your company, such as yourcompany.com.

Important: We recommend that you don't enter any public email domains such as hotmail.com, yahoo.com, or
gmail.com. If invited, anyone with an email address in these domains can join and see user profiles, feeds, and
Chatter groups.

Chatter Desktop Enhancements
Available in: Group, Professional, Enterprise, Unlimited, Contact Manager, and Developer Editions

October 2010 saw the first release of Chatter Desktop—a desktop app for collaborating in Chatter outside of the browser.
Now with Spring '11, a new version of Chatter Desktop is available with performance optimizations and enhancements that
let you:

• Click files to preview them
• Select the To: Me tab to see posts directed to you
• Click groups and users to view their feeds
• Post to a group or user's feed

In addition, Spring '11 includes a managed version of Chatter Desktop for enterprise deployments, and administration controls
for controlling access to Chatter Desktop in your organization.
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Chatter Desktop Overview

Available in: Group, Professional, Enterprise, Unlimited, Contact Manager, and Developer Editions

Chatter Desktop is a free desktop application that lets you collaborate in Chatter without a browser. Use Chatter Desktop to
post and comment in Chatter, and receive updates about the people, records, and files you follow and your groups. Chatter
Desktop also displays Chatter updates in popup notifications in your Windows taskbar or Mac OS X Dock.

Chatter Desktop is enabled for most organizations, but administrators can control access to Chatter Desktop as follows:

1. Click Your Name➤ Setup ➤ Desktop Administration ➤ Chatter Desktop Settings.
2. Select Enable Chatter Desktop if you want to allow users to access Chatter data from Chatter Desktop. Deselect

this option if you want to prevent all instances of Chatter Desktop in your organization from accessing Chatter data, and
block access to the Chatter Desktop self-installation page.

3. Select Allow Chatter Desktop Managed Installations Only if you want to prevent non-administrators from
installing Chatter Desktop. For example, select this option if your IT department plans to deploy Chatter Desktop to your
organization.

4. Click Save.

Installing Chatter Desktop

Available in: Group, Professional, Enterprise, Unlimited, Contact Manager, and Developer Editions

Salesforce.com provides two Chatter Desktop installers: a standard version for individual installations and a managed version
for enterprise deployments.

Managed VersionStandard Version

For enterprises deploying Chatter Desktop to users who don't
have administrator privileges on their machines

For individuals with administrator privileges on their machines

Requires administrator privileges in Salesforce to access the
installer

Does not require administrator privileges in Salesforce to access
the installer

Does not automatically install AIR—your IT department must
obtain a redistribution agreement from Adobe Systems

Automatically installs the required version of Adobe®

Integrated Runtime (AIR®)
Incorporated and deploy the required version of AIR before
deploying Chatter Desktop

Requires your IT department to accept the Chatter Desktop
managed version end user license agreement on behalf of the
users to which Chatter Desktop is deployed

Requires the acceptance of an end user license agreement the
first time Chatter Desktop launches

Does not automatically post to Chatter the first time Chatter
Desktop launches

Posts “Installed Chatter Desktop” to Chatter the first time
Chatter Desktop launches

Does not regularly check Salesforce for updatesPeriodically checks Salesforce for updates
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To install the standard version, go to the Chatter tab and click Get Chatter Desktop under What To Do Next. Alternatively,
you can install the standard version as follows:

1. Click Your Name➤ Setup ➤ Desktop Integration ➤ Chatter Desktop, or click .
2. Click the install badge.
3. Follow the on-screen instructions.

Note:  Administrators can disable the Chatter Desktop download page and block users from accessing Chatter Desktop.

To install the managed version:

1. Deploy Adobe® Integrated Runtime (AIR®) version 2.0.4 or later to the machines on which you plan to deploy Chatter
Desktop. AIR is Adobe's cross-platform runtime environment for desktop applications, and is a prerequisite for Chatter
Desktop.

Tip: Visit these links before deploying AIR:

• AIR® overview:http://www.adobe.com/devnet/air/articles/distributing_air_in_enterprise.html
• Information on obtaining an AIR® redistribution license from Adobe System Incorporated:

http://www.adobe.com/products/air/runtime_distribution1.html

• Installation information:
http://help.adobe.com/en_US/air/redist/WS485a42d56cd19641-70d979a8124ef20a34b-8000.html

• Administration information:
http://help.adobe.com/en_US/air/admin/WS485a42d56cd1964167ea49bd124ef17d52a-8000.html

2. Click Your Name➤ Setup ➤ Desktop Integration ➤ Chatter Desktop.
3. Click the link to download the managed version.

Important: Chatter Desktop uses Adobe® Acrobat® Reader to preview PDF files. Before previewing files with
Chatter Desktop, install Adobe Acrobat and open it at least one time to complete the installation. You can download
it from Adobe's website.

Connecting Chatter Desktop

Available in: Group, Professional, Enterprise, Unlimited, Contact Manager, and Developer Editions

By default, Chatter Desktop connects to the Production instance of Salesforce. If your organization uses multiple instances
of Salesforce on different servers, manually configure Chatter Desktop to connect with those instances:

1. Click the  icon in the upper right corner of the Chatter Desktop interface and select Settings.
2. In the Connections section, enter a name for the connection and the URL you use to log into the instance. The URL must

begin with https:// and end with salesforce.com. For example, if your organization has a European subsidiary that
you log into from https://emea.salesforce.com, enter that URL and name the connection Europe.

3. Click Add.
4. To optionally configure Chatter Desktop to connect to this instance by default, select the radio button next to the name

of the connection.
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5. Restart Chatter Desktop. When Chatter Desktop relaunches, an authentication screen appears. Follow the on-screen
instructions to authenticate Chatter Desktop to connect with the new instance.

Using Chatter Desktop

Available in: Group, Professional, Enterprise, Unlimited, Contact Manager, and Developer Editions

To view updates directed towards you, select the To: Me tab.

To view updates for a particular group, select the Groups tab and click the group.

To post to a group, navigate to the group, type your post, and click Share.

To post a file from your computer to Chatter, drag the file to the feed on which you want to post. A box appears showing you

where to drop the file. Alternatively, click the  icon, which appears when you type a post.

To post a link to Chatter, type the link in the text box at the top of the Chatter tab, or click the  icon that appears when
you type a post.

Tip: Chatter Desktop synchronizes with Salesforce automatically; however, synchronization does not always happen

instantly. To manually synchronize, click the  in the lower left corner.

Configuring Chatter Desktop

Available in: Group, Professional, Enterprise, Unlimited, Contact Manager, and Developer Editions

The default Chatter Desktop configuration is appropriate for most users, but several Chatter Desktop settings are configurable.

To access Chatter Desktop settings, click the  icon in the upper right corner and select Settings. From the Settings screen,
you can:

• Configure Chatter Desktop to launch when you start your computer.
• Configure Chatter Desktop to minimize when you close it.
• Configure Chatter Desktop to display comments in your feed.This is the default option, and it configures Chatter Desktop

to display comments in your feed chronologically and on the same level as the other types of Chatter updates. If you deselect
this option, comments do not appear in your feed. Instead, Chatter Desktop lets you drill down into the post by clicking
the Comments link on the post associated with the comment.
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Figure 1: Comparison of Chatter Desktop Setting with and without Comments in Feed

• Enable popup notifications. Popup notifications are enabled by default.

Disabling Chatter Desktop Remotely

Available in: Group, Professional, Enterprise, Unlimited, Contact Manager, and Developer Editions

To disallow Chatter Desktop from accessing your Salesforce data, click Your Name➤ Setup ➤ My Personal Information
➤ Personal Information, and click Revoke next to Chatter Desktop in the Remote Access section. Do this if the computer
on which you installed Chatter Desktop is stolen or lost.

Troubleshooting Chatter Desktop

Available in: Group, Professional, Enterprise, Unlimited, Contact Manager, and Developer Editions

Chatter Desktop uses Adobe® Integrated Runtime (AIR®), Adobe's cross-platform runtime environment for desktop applications.
This table provides troubleshooting information for the most common AIR application issues. For more information, see the
Adobe® knowledge base.
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SolutionProblem

Change your default browser to another application and then
back to your preferred browser. This ensures that your

Chatter Desktop installation fails.

operating system opens the Chatter Desktop installation files
correctly.

Troubleshoot your Encrypted Local Storage (ELS) keystore.
See
http://kb2.adobe.com/cps/492/cpsid_49267.html.

Chatter Desktop on Linux freezes, presents an empty window,
does not save your password, or malfunctions in another way.

Chatter Desktop uses Adobe® Acrobat® Reader to preview
PDF files. Before previewing files with Chatter Desktop,

Chatter Desktop does not preview PDF files.

install Adobe Acrobat and open it at least one time to complete
the installation. You can download it from Adobe's website.

Chatter Feeds Enhancements
Available in: Group, Professional, Enterprise, Unlimited, Contact Manager, and Developer Editions

@Mentions
When you post an update in Chatter, you can mention a person's name to make sure that person sees your update. Mentioning
a person is a way to keep them informed when you're discussing something relevant to their job.

For example, let's say you see a post from a coworker who is looking for leads at the company Universal Paper, and you know
that Bob Smith has contacts at that company. You can reply to your coworker's post with the following comment: “Talk to
@Bob Smith—he knows a few folks at the company.” Bob Smith would then be notified about your post and your coworker
could click on “@Bob Smith” in the update to view Bob's Chatter profile and learn more about him.

To mention someone in an update:

1. Enter @ followed by the first few letters of the person's name.
2. Select the person from the list of matches.
3. Post your update.

The following happens:

• The person's name becomes a blue link that others can click to view the person's profile.
• Your update appears on the mentioned person's profile feed and in their To: Me filter.
• Chatter emails a notification to the person you mentioned.The person also receives a notification every time somebody

comments on the update where they were mentioned.

You can't have more than 10 mentions in a single post or comment.

Chatter enforces all the security and sharing rules in Salesforce. If you post an update to a record or private group and mention
someone who doesn't have access to that record or isn't a member of the private group, the mentioned person won't see your
update. Specifically:

• The mentioned person isn't notified about the update.
• The update doesn't appear in the mentioned person's profile feed or in their To: Me filter.
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• The mention appears as a gray link (instead of a blue link). Whenever you see a mention in gray, the mentioned person
isn't able to see the update.

For example, let's say you create a private group for your sales team and forget to add your coworker Sandy Dunn to the group.
When you post an update to this group and mention Sandy Dunn, she won't be notified about the update and won't see the
update because she's not a member of the private group. If you later add Sandy to the group, Chatter doesn't notify her about
the previous mentions.

Live Updates

You asked for it! This enhancement is from an idea on IdeaExchange.

Click You have new updates at the top of a feed to see updates added to your Chatter feed since your last refresh.

Liking Posts

You asked for it! This enhancement is from an idea on IdeaExchange.

After you click Like on a post, you'll receive email notifications if others comment on that post.

Note:  Currently, you can't like comments.

• To stop liking a post, click Unlike. When you stop liking a post, you won't receive email notifications for subsequent
comments.

• View the profiles of others who have liked a post by clicking their name at the bottom of the post, for example, “John
Smith likes this.”

• If more than three people like a post, click the link to see the full list; for example, “You, John Smith, and 2 others like
this.” From that list, you can follow or stop following people.

Status Update Source
View the source of a post or comment in a feed, for example, Yesterday at 12:57 AM via Chatter for BlackBerry. This link
displays when a person posts to a feed using a Chatter Mobile client.

Expanding Long Posts and Comments
Click More to expand a long post or comment.

Viewing Tips When Posting in Chatter

When posting in Chatter, click the new info icon ( ) to view tips for enhancing your posts. This icon appears on the right
side when you hover over the box used to enter your updates.

The tips show you how to add a topic and mention a coworker to make your posts more effective. You can also click the Watch
and Learn link to view a short video.
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Chatter Files Enhancements
Available in: Group, Professional, Enterprise, Unlimited, Contact Manager, and Developer Editions

Private File Sharing
Share a file privately so only specific Chatter users in your company can see it. Anyone who can see a file, can share it. When
you share a file with someone, they are automatically given viewer permission.

To share a file with one or more Chatter users in your company:

1. On the detail page of the file you want to share, click either Share File or Show All on the Shared With list.
2. Click Share with more people on the Sharing dialog box.
3. Type the name of the person you want to share the file with.
4. Click the name to select it. Share with more than one person by entering another name.
5. Optionally, deselect Send email notifications if you don't want an email notification sent to the people you're sharing the

file with. This option is selected by default. The email is the only notification people get when you've privately shared a
file with them.

6. Optionally, add a message to the sharing notification email.
7. Click Share. If selected, an email notification is sent to the specific people you shared the file with.

Unless the file was already shared with your company, it's privately shared and displays the privately shared icon ( ). It's not
posted anywhere and only the people you specifically shared it with can find and view it. If it was already shared with your

company, it retains the your company icon ( ) and all Chatter users in your company can find and view it.

Click  next to a person's name to stop sharing the file with them.

Note:

• Links are listed on the Files tab, but can't be shared in Chatter.
• Web links and Google Docs from Salesforce CRM Content are listed on the Files tab, but can't be shared in

Chatter.
• Documents from the Documents tab and attachments from the Notes and Attachments related list aren't listed

on the Files tab and can't be shared in Chatter.
• Salesforce CRM Content files in Chatter may be shared with more people than shown on the Sharing dialog box

if they are part of a content pack or delivery.
• The maximum number of times a file can be shared is 100. Sharing a file includes when a file is privately shared

or shared with your company. If a file is privately shared and nears the 100 share maximum, consider making the
file public by posting it to your feed.
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Email Notification After Sharing a File
Notify someone automatically when you share a file with them. Send email notifications is selected by default when you share
a file. This option automatically sends an email notification to the person you're sharing the file with. You can include text in
the email by adding an optional message.

See Where a File is Shared
The Shared With list on a file detail page shows you the file owner and who the file is shared with.

Click Show All to view the full list. From the Sharing dialog box you can:

• See the file's sharing setting:

-  Private—The file is only available to you. It hasn't been shared with anyone else.
-  Privately Shared—The file is only available to the specific people it is shared with.
- Your Company—All Chatter users in your company can find and view this file.

• See who the file is shared with and their permission: owner or viewer.
• Click Share with more people to share the file with specific people. Anyone who can see a file, can share it. Note that files

in your personal workspace must first be published before they can be shared.
• Click Make private to remove the file from everywhere it's been shared. Or click Restrict access if the file originated in

a Salesforce CRM Content workspace. Only owners and user's with the “Modify all Data” permission can make a file
private ( ) or restrict access. Alternately, click Restrict access (if the file originated in a Salesforce CRM Content workspace)
to remove the file from everywhere it's been shared except the workspace.

• Click  next to a person's name to stop sharing the file with them.
• Click Next and Previous to see more of the list, or click Done to close the window.

Make a File Private
File owners and users with the “Modify All Data” permission can make a file private ( ) if they decide they don't want it to
be shared anymore. Making a file private removes it from any posts it's attached to and removes it from everywhere it's been
shared. Only the owner and users with the “Modify All Data” permission will have access to it. Alternately, file owners and
users with the “Modify All Data” permission can restrict access to a file that originated in a Salesforce CRM Content workspace
to remove the file from everywhere it's been shared, except the workspace.

1. From the file detail page of the file you want to make private or restrict access, click either Share File or Show All on
the Shared With list.

2. On the Sharing dialog box, click Make private (or Restrict access if the file originated in a Salesforce CRM Content
workspace).

3. On the confirmation dialog box, click Make private (or Restrict access).

Recently Viewed Files
The Files tab now shows the most recent files you've viewed by default. The Recently Viewed filter shows the 25 most recent
files you've viewed in Chatter or Salesforce CRM Content.

View and Search Files Shared with Me
A new list view on the Files tabs called Files Shared with Me lets you view and search files that have been shared with you
either by a private share or a public post to your profile.

Edit File Details
To edit a file's name and description:
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1. On a file detail page, click Edit Details or click the edit icon ( ) next to the description.
2. Optionally, edit the file name and description.
3. Click Save.

If there is no description and you want to add one, click Add Description or click the edit icon ( ) next to the description

File owners and users with the “Modify All Data” permission can edit file details.

Upload a New Version with What Changed
You can now provide information about what changed each time you upload a new version of a file. The information about
what changed is shown on the Version History list so you and anyone with access to the file can read about the changes from
one version to another. To add information about what changed when uploading a new version:

1. Click Upload New Version on the file detail page.
2. Click Browse, and select a file from your computer.
3. Optionally, add information about the changes you made to the file in the What Changed dialog box. The information

is shown on the Version History list.
4. Click Upload New Version.

Previews on New Version Update Notification
Previously, when you uploaded a new version of a file in Chatter, a preview wasn't available in the notification posted on the
Chatter feed. Now you and anyone with access to the file can preview the new version.When you upload a new version of a
file, a notification is posted to your Chatter feed on the Home tab and the Chatter tab, and anyone following the previous
version will also get a notification in their Chatter feed. If the file is private, only the file owner will see the notification. The
notification of the new version includes a file preview, the ability to download, and the file description if provided. Uploading
a new version replaces all previous versions in Chatter, but previous versions are still available by clicking Show all versions
on the file detail page.

File Version History
The Version History list shows all the versions of a file that have been uploaded in Chatter. The file detail page shows the
current version number of the file. Click Show all versions to see the Version History list. The list shows you all the versions
of the file uploaded in Chatter, including the current version. From the list you can preview or download the file, see who
updated it and when, and see the description if provided. The file detail page always shows the most current version of a file.

File Sharing Settings and Permissions
This table describes file sharing settings which are determined by how the file is shared. The sharing setting and icon appear
on a file's detail page and on the Shared With list on a file detail page.

When Does a File Have This Setting?DefinitionSharing Setting

A file is private when you:The file is private. It hasn't been shared
with anyone else besides the owner. Only

Private ( )
• Upload it to My Files

the file owner and users with “Modify All • Publish it to your personal workspace
Data” permission can find and view this
file, unless it is in a personal workspace,
then only the file owner has access to it.

• Stop sharing it with everyone (Make
Private)

• Delete posts that include the file and
the file isn't shared anywhere else

A file is privately-shared when it's:The file has only been shared with specific
people and locations. It's not available to

Privately Shared ( )
• Only shared with specific people
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When Does a File Have This Setting?DefinitionSharing Setting

all Chatter users in your company. Only
the file owner, users with “Modify All

• Posted to a private group
• Posted to a feed on a record

Data” or “View all Data” permission, and • Published to a shared workspace
specific file viewers can find and view this
file.

A file is shared with your company when
it's posted to a feed on the Home tab,

All Chatter users in your company can find
and view this file.

Your Company ( )

Chatter tab, a profile, a record or a public
group

This table describes the actions that can be performed by users based on their permission:

File ViewerFile OwnerAction

YesYesView/Preview

YesYesDownload

YesYesShare

YesYesAttach a file to a post

YesUpload New Version

YesMake a File Private

YesRestrict Access

YesEdit Details

YesDelete

Note:

• Users with the “Modify All Data” permission can view, preview, download, share, attach, make private, restrict
access, edit, and delete files they don't own (unless the file is in a personal workspace, then only the file owner has
access to it), but they can't upload a new version.

• Users with the “View All Data” permission can view and preview files they don't own (unless the file is in a personal
workspace, then only the file owner has access to it).

• Groups (including group members) and records have viewer permission for files posted to their feeds.
• Permissions for files shared with workspaces are determined by the workspace.
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Chatter Groups Enhancements
Available in: Group, Professional, Enterprise, Unlimited, Contact Manager, and Developer Editions

Private Group Requests by Email
Previously, you could click Ask Owner on the Groups tab or a group detail page to view a private group owner's profile and
ask them to add you to the group. Now, you can click Ask to Join, which automatically emails a request to the group's owner
and managers.

As the owner or manager of a private Chatter group, you can accept or decline requests to join the group. Additionally, users
with the “Modify All Data” permission can view and manage requests for all groups.

1. View the list of requests by doing one of the following:

• On a group detail page, click the Request link, for example, 3 Requests
• On a group detail page, click Add/Remove Members and then click the Requests filter, or scan for requests in the

Everyone filter
• Click the link provided in the email request

2. Accept or decline the requests.

Note: An email is sent to each person to tell them that their request was accepted or declined.

• Click Accept to accept. If there are more than two requests, you can accept them all by clicking Accept x of y, for
example, Accept 3 of 3.

• Click  to decline. Optionally enter a message that will be included with your decline email and click Send. If you
change your mind, you can click Cancel to go back.

3. Click Done to close the window.

Group Filters
You can now filter the groups list on the Groups tab:

• All Groups shows all groups in your company
• Recently Viewed shows the groups you recently looked at, starting with the group you viewed last
• My Groups shows the groups you belong to, own, or manage

Group Columns
The columns on the Groups tab, which allow you to sort the groups list, have changed:

• Group: Sorts by the group name. Also includes the group description, number of members, and owner's name.
• Last Activity: Sorts by the date of the last post or comment on the group feed.
• Membership: Sorts by your membership status in the group, either Member, Manager, or Owner. You can also Join public

groups or Ask to Join private groups.
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CollaborationGroupMemberRequest API Object
The CollaborationGroupMemberRequest object, which represents a request to join a private Chatter group, is now available
in the API; see Chatter API Objects.

Chatter Topics Enhancements
Available in: Group, Professional, Enterprise, Unlimited, Contact Manager, and Developer Editions

Trending Topics
The Chatter tab now includes a Trending Topics area that shows the topics your coworkers are discussing right now in Chatter.
The more frequently people include a specific topic in their posts and comments over a short period of time, the more likely
it is to become a trending topic. For example, if your coworkers are attending the upcoming Dreamforce conference and have
started discussing it in Chatter, you may see a trending topic for #Dreamforce.

A trending topic usually relates to a one-time or infrequent event that has a spike in activity, such as a conference or a project
deadline. A topic that is consistently used in posts and comments over a long period of time isn't considered a trending topic.
A topic falls off the trending topics list when fewer people add that topic to their posts and comments, or when people start
using new topics more frequently.

When determining which topics are trending, Chatter doesn't look at record and private group feeds. Only topics you include
when updating your status, posting to a person's profile, or posting to a public group can become a trending topic.

View the Topics People Use Most
When you go to people's profiles, you can now see the topics they use most frequently in their posts and comments. The
Topics I Use Most section in people's profiles lets others know which topics they're knowledgeable about or interested
in.

When you click a topic in the Topics I Use Most section, you see just the updates that person has posted that include the
topic. You can then expand your search to see all the Chatter updates with that topic by either clicking the highlighted topic
in the profile feed or clicking Search Everywhere.

Autocomplete Lets You Quickly Add Previously Used or Popular Topics to Your Updates
When you enter “#” followed by the first few characters of a topic, you now see a list of your recently used topics as well as
your company's most popular topics. You can then select one of these topics to add it to your post or comment, or continue
typing to add a topic that's not in the autocomplete list.

Chatter for Mobile Devices
Available in: All Editions

Spring '11 features new ways to collaborate in Chatter on the go:

• The Chatter mobile app for Apple and BlackBerry devices
• A pilot version of Chatter for mobile Web browsers
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Chatter Mobile App Overview

Available in: All Editions

Install the free Chatter mobile app on your Apple or BlackBerry device to collaborate in Chatter on the go.

• Receive updates about the people and records you follow and your groups.
• View and create posts and comments.
• Post photos from your device.
• Find and follow people in your organization.
• Find and join groups in your organization.
• View your coworkers' profiles to see their contact information, bio, who they're following, and who's following them.
• Email, call, or text people directly from their profiles.

The Chatter mobile app is available for the Apple iPhone, iPad, and iPod Touch with iOS 4.0 or higher. A beta version is
available for BlackBerry devices with BlackBerry 5 OS or higher. To download the app for Apple devices, search for it on the
Apple App Store. To download the app for BlackBerry devices, access www.salesforce.com/blackberrybeta from
your BlackBerry.

Tip:  If you don't have a device that the Chatter mobile app supports, you can still access Chatter on your mobile
device with Chatter for mobile browsers.

The Chatter mobile app is enabled for use in most organizations by default. If it is not enabled in your organization or you
want to change the default settings, see Configuring the Chatter Mobile App.

Tips
• To post to the Chatter feed you're viewing, choose  on Apple devices or Post on BlackBerry devices.
• When posting, choose  to select from the photos on your device. When posting from a device with a camera, choose

 to take a picture to attach to the post.
• To comment on a post, navigate to the post and choose  on Apple devices or Comment on BlackBerry devices.
• To refresh a feed on Apple devices, scroll to top of the feed, then drag your finger down and release.
• To log out on your Apple device, choose Chatter in your device settings and toggle Log Out Now.
• To add to your Favorites on an iPad, press your finger on the icon next to a person, group, or record until the icon highlights

and drag it to the Favorites section.
• To view information about a user or group on an iPad, navigate to the user's or group's feed and choose .
• To search for users or groups on an iPad, choose .
• To email, call, or text people directly from their profiles, first configure email and telephony on your device.
• Use the following keyboard shortcuts on BlackBerry devices:

- c = Enter a comment.
- t = Go to the top of the feed.
- b = Go to the bottom of the feed.
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Limitations
The Chatter mobile app does not have all of the functionality of Chatter in Salesforce. The following matrix shows the
limitations of the mobile app on each device.

BlackBerryiPadiPhone/iPod Touch

NoNoNoUpdate your profile or change
your profile photo

YesYesNoPost files other than images

NoNoNoAdd topics to posts or
comments

NoNoNoView the Files tab and Chatter
feeds for files

NoYesNoFollow files

NoNoNoSearch for Chatter feeds for
files and records

YesNoNoView files related to a person
or group

NoNoNoCreate groups

NoNoNoInvite coworkers to sign up for
Chatter

The beta version of the Chatter mobile app for BlackBerry has the following additional limitations:

• Detail views and search functionality are unavailable.
• You cannot deauthorize the use of the Chatter mobile app for BlackBerry devices in your organization.
• The Chatter mobile app for BlackBerry does not let users protect their mobile device with a passcode.

Configuring the Chatter Mobile App

Available in: All Editions

User Permissions Needed

“View Setup and Configuration”To view mobile settings:

“Manage Mobile Configurations”To change mobile settings:

To configure access to the Chatter mobile app in your organization:

1. Log into Salesforce.
2. Click Your Name➤ Setup ➤ Mobile Administration ➤ Chatter Mobile ➤ Settings.
3. Click Edit.
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4. Select Enable Chatter Mobile. Users receive an error message if they try to use the Chatter mobile app in an
organization in which the app is disabled.

Note: You cannot deauthorize the use of the Chatter mobile app for BlackBerry devices in your organization.

5. Select the mobile device types your organization allows to use Chatter mobile app. The Chatter mobile app displays an
error message if a user tries to use the Chatter mobile app on a restricted device.

6. Optionally set the session security timeout for the Chatter mobile app. When a session expires, users must enter their
passcode to access the Chatter mobile app on their mobile device. You don’t need to set this option if the operating system
automatically locks the device after a period of inactivity.

7. Click Save.
8. If your organization restricts login IP ranges, exempt the users and groups that need to access the Chatter mobile app

outside of your organization's login IP range. You do not need to exempt users with BlackBerry devices; BlackBerry devices
must already have Internet connectivity through a BlackBerry Enterprise Server with an IP address that falls within the
Salesforce login IP ranges.

Restart the Chatter mobile app if configuration changes in Salesforce do not appear on your mobile device.

Bypassing IP Restrictions for Chatter Mobile App Users

Available in: All Editions

User Permissions Needed

“View Setup and Configuration”To view mobile settings:

“Manage Mobile Configurations”To change mobile settings:

If your organization restricts login IP ranges, exempt the users and groups that need to access the Chatter mobile app. You
do not need to exempt users with BlackBerry devices, which must already connect through a BlackBerry Enterprise Server
with an IP address that falls within the Salesforce login IP ranges.

1. Click Your Name➤ Setup ➤ Mobile Administration ➤ Chatter Mobile ➤ IP Restricted Users.

Note: The IP restriction bypass settings appear only in organizations with profile-based IP restrictions.

2. Specify the users and groups that can bypass the restrictions with the Chatter mobile app.
3. Click Send Email. Salesforce sends them an email with download links for the mobile apps your organization supports

and a unique activation link. Users must click the activation link on their device to use the Chatter mobile app.

Important:  Users with IP restrictions cannot use the Chatter mobile app unless they click the activation link
from their mobile device. The activation link cannot be shared or transferred.
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Viewing Chatter Mobile App Activity and Revoking Access

Available in: All Editions

User Permissions Needed

“Manage Mobile Configurations”To view Chatter mobile app activity and revoke access to the
Chatter mobile app:

To view Chatter mobile app activity in your organization, including the date each user activated or used the app, click Your
Name➤ Setup ➤ Mobile Administration ➤ Chatter Mobile ➤ Users and Devices.

You can also remotely revoke access to the Chatter mobile app for a specific device if the device is lost or stolen. Revoking
access prevents the device from accessing Chatter and deletes Chatter data from the device the next time the device attempts
to synchronize with Salesforce.

To revoke access for your own mobile device:

1. Click Your Name➤ Setup ➤ Manage Users ➤ Users.
2. Click your name.
3. In the Remote Access related list, click Revoke next to the entry for the Chatter mobile app.

To revoke access for mobile devices owned by other users:

1. Click Your Name➤ Setup ➤ Mobile Administration ➤ Chatter Mobile ➤ Users and Devices.
2. Select the users for whom you want to revoke access.
3. Click Revoke.

Chatter for Mobile Browsers—Pilot

Available in: All Editions

In addition to the Chatter mobile app for Apple and BlackBerry devices, salesforce.com provides a mobilized Web version of
Chatter that you can access from a mobile device browser without installing an app.

Note: Chatter for mobile browsers is currently available as a pilot feature and has the following limitations:

• You can only post text; you cannot post photos and other files from your mobile device.
• You cannot search for people and groups.
• Apple and Android devices are supported but BlackBerry is not.
• If your organization has IP restrictions, your mobile device must be within your organization's IP range to access

Chatter for mobile browsers. In some instances, this may require users to log into their company's internal wireless
network or virtual private network.

Contact salesforce.com to enable Chatter for mobile browsers for you organization.
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In organizations that enable Chatter for mobile browsers, pointing a mobile browser to www.salesforce.com redirects to
the mobilized Web version of Chatter at www.salesforce.com/m. From the mobilized Web version, users can click More...
➤ Full Site to access the standard Web version of Salesforce.

Organizations without Chatter for mobile browsers cannot access the URLs for the mobilized version of Chatter.

Chatter Notifications Enhancements
Available in: Group, Professional, Enterprise, Unlimited, Contact Manager, and Developer Editions

Posting Comments via Email Replies
When users receive Chatter email notifications about comments and posts, they can now conveniently post comments by
replying to the email. Administrators can turn this feature on or off for their organization by selecting or deselecting Allow
Comments via Email Replies from Your Name➤ Setup ➤ Customize ➤ Chatter ➤ Settings. If Chatter email
notifications are enabled, this feature is on by default.

Consider these tips when posting comments via email replies.

• Replies must be sent from the email address specified inYour Name➤ My Profile. If you use email aliases or email
forwarding services that send replies from a different email address, your replies won't be processed.

• Replies can be up to 1,000 characters.
• If replies contain your personal email signature, the signature text is treated as part of your comment. Default signatures

inserted by mobile devices, such as Sent from my iPhone, are automatically removed from replies. Before replying,
delete custom signatures and any extra text you don't want posted to Chatter.

• Attachments in replies are ignored.
• Before replying, check the email address that displays in the To field of your email. Valid addresses contain tokens, or long

character strings, both before and after the @ symbol, such as
w8t27apy1@j321imd9gbs.d8rx.d.chatter.na1.salesforce.com. Some email applications may automatically
use the From address from the original email, reply@chatter.salesforce.com, which is not a valid address for
receiving replies. If you see this shortened address in the To field of your reply email, replace it with the valid reply-to
address in the email header information. For example, in an application such as IBM® Lotus Notes®:

1. Open the original email.
2. Click View ➤ Show ➤ Page Source.
3. In the Reply-To section, copy the email address that looks like:

w8t27apy1@j321imd9gbs.d8rx.d.chatter.na1.salesforce.com.
4. Paste the reply-to address in the To field of your reply email.

Note: Replies are subject to these advanced email authentication protocols to verify the sender's legitimacy before
processing the message: SPF, SenderId, DomainKeys, and DKIM. If the sending server doesn’t fail any of these
protocols, the reply email is processed. If the server fails a protocol, the email is ignored.

Group Email Notification Frequency
For Contact Manager and Group Edition organizations, group email notifications are now turned off by default when users
join or are added to groups. For Professional, Enterprise, Unlimited, and Developer Edition organizations who haven't changed
the default configuration, users continue to automatically receive daily digests when joining groups.

Administrators with API access can control the default frequency for users using a new field on the User object,
DefaultGroupNotificationFrequency. In addition, users with API access can use this field to control their own default
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email frequency. This setting only applies to new groups that a user joins or is added to, and users can still customize email
frequency for each group after they've joined. It doesn't change the notification frequency for groups that the user is already
a member of.

Chatter Recommendation Enhancements
Available in: Group, Professional, Enterprise, Unlimited, Contact Manager, and Developer Editions

Recommended Records
In addition to recommending people and groups, Chatter now recommends records to follow. Following records helps keep
you up-to-date on important changes to accounts, contacts, opportunities, and more. Chatter recommends records that you've
viewed or edited, as well as records that you own (and aren't already following).

Chatter won't recommend records that your Salesforce administrator has disabled feed tracking for. Only opportunities,
accounts, leads, contacts, and articles are included in record recommendations.

View your record recommendations on the Chatter tab. To see an expanded list of your recommendations, click More. If no
recommendations appear, then you're already following all the recommended records.

Enhanced People Recommendations
Chatter now recommends people to follow based on a shared interest in records. For example, if someone has looked at or
edited an account that you've recently viewed, that person is more likely to be included in your people recommendations.

Chatter Search Enhancements
Available in: Group, Professional, Enterprise, Unlimited, Contact Manager, and Developer Editions

Searchable Chatter Fields
With Spring '11, you can search new Chatter fields using Global Search.

Fields SearchedChatter Item

Parent Record Name

Poster Name

Feeds

Extension (such as ppt)

Owner

Files

For more information, see “Search Fields” in the Salesforce online help.

Chatter Feeds Search Results Enhancements
You can comment on, like, and delete posts on the Search Results page, just as in other feeds.
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Additional Chatter Enhancements
Available in: Group, Professional, Enterprise, Unlimited, Contact Manager, and Developer Editions

Following Dashboard Components
You can now follow certain dashboard components. See Dashboard Alerts on page 53 for details.

New Chatter Workbook
Need to get started quickly integrating Chatter with your custom apps? The Chatter Workbook introduces the major components
of Chatter and shows you how to develop your own applications using Chatter features.
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Sales Cloud Enhancements
Cloud Scheduler Enhancements

Available in: Group, Professional, Enterprise, Unlimited, Contact Manager, and Developer Editions

User Permissions Needed

“Customize Application”To customize page layouts and activity settings:

Cloud Scheduler is now enabled by default for all organizations, making it much simpler for administrators to offer this feature
to users. You can now automatically see the New Meeting Request  button on all eligible contact, lead, and person account
detail pages. Meeting organizers can use Cloud Scheduler to request meetings with customers, and have customers select
preferred times before confirming the meeting. For an overview and demo, see “About Cloud Scheduler” in the Salesforce
online help.

In addition, administrators can add or remove the New Meeting Request button on multiple page layouts using the new
Cloud Scheduler quick setup method. This method complements the manual setup method, which involves customizing page
layouts individually to add or remove the button. If you want finer control over whether the button displays on individual page
layouts, consider using the manual setup method instead of or in combination with the quick method.

To add or remove the New Meeting Request button on multiple page layouts:

1. Click Your Name➤ Setup ➤ Customize ➤ Activities ➤ Cloud Scheduler.
2. If you're adding the button and the new user interface theme isn't already enabled, you must enable it from Your Name
➤ Setup ➤ Customize ➤ User Interface.

3. Click Add Button to add the New Meeting Request button to the Open Activities related list on all eligible page layouts.
Eligible layouts have fewer than four buttons in the Open Activities related list (to prevent unintended crowding). Click
Remove Button to remove the button from all current page layouts.

Note: Cloud Scheduler isn't supported in Microsoft® Internet Explorer version 6.0. Users will see the New Meeting
Request button on page layouts but won't be able to use Cloud Scheduler meeting request pages.

Activity Attachment Enhancements

Available in: All Editions

For new organizations, the Attachments related list is now automatically added to task and event records. Existing organizations
still need to manually add the related list to the activity page layout. In addition, attachments are now searchable for tasks and
events. HTML attachments aren't allowed if the Disallow HTML documents and attachments checkbox is selected
in sYour Name➤ Setup ➤ Security Controls ➤ HTML Documents and Attachments Settings.

SALES CLOUD

34



Email Attachment Enhancements

You asked for it! This enhancement is from an idea on IdeaExchange.

Available in: Professional, Enterprise, Unlimited, and Developer Editions

Attachments on emails that are sent using Email to Salesforce or Salesforce for Outlook can now be saved with the email's
task record in Salesforce. Click Your Name➤ Setup➤ Email➤My Email to Salesforce and select Always save email
attachments to enable this feature. The size limit for an attached file is 5 MB. The size limit for all files attached to an
email is 10 MB.

Email Association Enhancements

You asked for it! These ideas are from an idea on IdeaExchange.

Email to Any Object

Available in: All Editions

When emails are sent to Salesforce using Email to Salesforce or Salesforce for Outlook, some are automatically assigned
to related records based on your Email to Salesforce settings. The rest are added to My Unresolved Items, where you
can either assign them to related Salesforce records or confirm that you want to leave them unassigned.

1. Access your unresolved emails in any of these ways:

• Click My Unresolved Items in the banner on an individual email that hasn't been assigned to other records.
• Click My Unresolved Emails in the My Tasks section on the Home tab.
• Click My Unresolved Items on the My Email to Salesforce page, located at Your Name➤ Setup ➤ Email ➤

My Email to Salesforce.
• If you're syncing contacts or events using Salesforce for Outlook, right-click the Salesforce for Outlook system

tray icon ( ) and click Salesforce ➤ My Unresolved Items.... Click the Emails tab.

2. Depending on how you want to resolve an email, choose either of these actions.

• Assign to related records—Enter a related record in one or both fields. If you need to, first select the correct
record type from the drop-down list. If you assign a lead, you can't assign additional records. Clear an entry to
cancel an assignment.

• Leave unassigned—Click Don't Assign. The text Unresolved Email: is removed from the subject line and
the email is assigned to you as a completed task. If the task's Status picklist includes more than one “completed”
status, we use the first one.

3. Click Save to save your changes. All modified items are removed from the list. You can return any time to resolve
remaining items. Clicking Cancel cancels all changes on the page. The email is added to the Activity History or
Open Activities related list of the associated records.
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Email to Salesforce Enhancements

Available in: All Editions

Email to Salesforce includes some new settings that let users further specify what happens when emails are sent to
Salesforce using their Email to Salesforce address or the Salesforce for Outlook Add Email button. To access these
settings: Click Your Name➤ Setup ➤ Email ➤ My Email to Salesforce.

You can now:

• Choose whether you'd like all emails to be sent to My Unresolved Items so you can manually assign them to related
records or whether you'd like us to first try to automatically assign them.

• Choose whether you'd like emails we couldn't automatically assign to be sent to My Unresolved Items.

Salesforce for Outlook Enhancements

Available in: Contact Manager, Group, Professional, Enterprise, Unlimited, and Developer Editions

Desktop Notifications
Salesforce for Outlook configurations include a new checkbox that lets administrators notify users when product updates
are available. When a new version of the product is available, users see a system tray notification that takes them to the
Salesforce for Outlook download page in Salesforce. Users are alerted every 14 days until they download the new version
or hide system tray alerts.

Retry Sync
The Salesforce for Outlook Error dialog box includes a new Try Again button that allows you to refresh the list of errors.
When you click this button, Salesforce for Outlook syncs your data and removes any errors that have been resolved.

OAuth
Salesforce for Outlook now uses OAuth-based authentication to securely store user login information. As part of this
enhancement, the setup wizard displays updated login steps, and users no longer need to manage password changes in
Salesforce for Outlook. API tokens are also no longer required.

Auto-Sync People You Follow
Outlook configurations include a new Sync all contacts users follow in Chatter checkbox that automatically
syncs users' Chatter contacts.

Opportunity Enhancements

Available in: All Editions that signed up prior to Summer '09

Available in: Group, Professional, Enterprise, Unlimited, and Developer Editions that signed up during or after Summer
'09

Sorting for Opportunity Products

You can now sort products in the Products related list on an opportunity. Syncing a quote with an opportunity also syncs
product sort order.
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Quote Line Item Enhancements

Available in: Professional, Enterprise, Unlimited, and Developer Editions

Product Code Field on Quote Line Items

Quote line items now include the Product Code field.To display the field in the Quote Line Items list on your quotes,
use the page layout editor.

Sorting for Quote Line Items

You can now sort line items in the Quote Line Items related list on a quote. Syncing a quote with an opportunity also
syncs product sort order.

Salesforce CRM Content Enhancements

Share Salesforce CRM Content Files in Chatter with Updated Workspace Permission

Available in: Contact Manager, Group, Professional, Enterprise, Unlimited, and Developer Editions

In Spring '11, Chatter users can share files privately with other people in Chatter. The Salesforce CRM Content workspace
permission Post Content to Chatter Feeds, is now Attach or Share Content in Chatter to make Salesforce
CRM Content files from a workspace available to attach to posts and share in Chatter.

Salesforce Mobile Usage Data in Custom Report Types

Available in: Professional, Enterprise, Unlimited, and Developer Editions

User Permissions Needed

“Manage Custom Report Types”To create or update custom report types:

“Modify All Data”To delete custom report types:

In Spring '11, you can create custom report types with data that shows how your organization uses Salesforce Mobile. For
example, the reports can show how often users access Salesforce Mobile, which mobile device models are in use, and so forth.

To create a custom report type with Salesforce Mobile usage data, select the Mobile Session Primary Object when defining
a custom report type. When you select the fields for the custom report type, choose from the following Salesforce Mobile-specific
fields.

DefinitionMobile Usage Data Point

Wireless carrierBrand

Total size of records on deviceData Size (Bytes)

Unique physical address of device (PIN for BlackBerry or
UDID for iOS)

Device Address
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Installed version of Salesforce MobileDevice Application Version

Model of deviceDevice Model

Version of operating system installed on deviceDevice Operating System Version

Date of last registration or activationLast Registration Date

Date of last communication received from deviceLast Status Date

Manufacturer of deviceManufacturer

Size of metadata (page layouts, picklist values, and so forth)
on the device

Metadata Size (Bytes)

Name of the device userOwner: Full Name

Date the mobile session startedSession Start Date

Indicator that the user's data set exceeds the maximum allowed
size by the mobile configuration

Status

Note:

• Mobile sessions are similar to Web-based sessions in login history reports; however, mobile sessions have a fixed
timeout value of 20 minutes. Salesforce creates a new Mobile Session when a user logs into or launches Salesforce
Mobile after 20 minutes of inactivity in the app or on the device in general.

• Mobile session reports only have usage data for the Salesforce Mobile app and not the Chatter mobile app.
• Some devices do not provide every physical attribute. For example, Apple devices do not provide brand.
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Multiple Languages for Salesforce Knowledge
Salesforce Knowledge is a knowledge base where users can easily create and manage content, known as articles, and quickly
find and view the articles they need. With Spring '11, you can translate articles into multiple languages so that customers and
support agents can find content in their preferred languages.

With multiple languages for Salesforce Knowledge you can lower support costs by translating articles into the languages your
audience prefers. After an administrator selects your language settings, two translation methods are available: translating articles
in-house using the editing tool in the knowledge base, or sending articles to a localization vendor. Different languages can
use different methods. For example, you may want to export articles to a vendor for French translations, but assign articles to
a Salesforce Knowledge user for Spanish translations.

Translating an article within the knowledge base usually follows these steps:

1. An author or reviewer submits an article for translation to another knowledge base user (the assignee).
2. The assignee translates the article using the article editor, then assigns the finished translation to a reviewer or publisher.
3. The reviewer publishes the article. Publishing an article automatically includes both the source article and its completed

translations. Note that a translated version of an article can be published before its source article, but it will only be visible
to readers when its source article is also published.

Translating an article using a vendor usually follows these steps:

1. An author or reviewer assigns an article to a queue for translation.
2. An administrator creates an export file from the queue and sends the file to the localization vendor.
3. After the vendor returns the translated articles, an administrator imports the translated articles into the knowledge base.

Imported articles can be published automatically or assigned to a reviewer.
4. If the translations weren't published automatically, the assignee reviews and publishes them.

Implementation Tips
• Before you add languages to your knowledge base, decide for each language whether you want to translate articles directly

in Salesforce or export articles to a translation vendor. Communicate your decision to the people involved in the translation
process (authors, reviewers, translation managers, publishers).

• When adding a language to your knowledge base, keep in mind that it can't be deleted; however, you can hide a language
by making it inactive. Deactivating a language means it no longer appears as a choice in the New Article dialog or the
Submit for Translation dialog. Also, if articles are already published in the language, those articles are no longer visible to
readers as soon as the language is deactivated.

• You can only add languages supported by Salesforce to your knowledge base.
• To enable the article export feature, you must create one or more queues; authors and reviewers will select the queue when

they submit an article for translation. Make sure they know which queue to choose for which language.
• You must place all the translation files (meaning, those exported from Salesforce and translated by your vendor) in a folder

whose name is the same as the language code . For example, put French articles in a fr folder. Zip up this folder to create
your import file.
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Best Practices
• To hide translated articles for a specific language, deactivate the language by unchecking Active on the Settings page.
• To successfully import translated articles, verify that the file structure of the articles to import matches the file structure

of the articles exported for translation. For example, if the target language is French, the file structure begins as follows:

export.properties
-fr
--articletypearticlename_kav
---articlename.csv
---[Article collateral, html, images, etc.]

Setting up a Multilingual Knowledge Base

Available in: Enterprise, Unlimited, and Developer Editions

User Permissions Needed

“Customize Application”

AND

“Manage Salesforce Knowledge”

To set up multiple languages for Salesforce Knowledge:

To set up your knowledge base to support multiple languages:

1. If you will send articles to a vendor for translation, you must create a translation queue. For a description of the translation
process, see “Supporting Multiple Languages in Your Knowledge Base” in the Salesforce online help.

2. On the Your Name➤ Setup ➤ Customize ➤ Knowledge ➤ Settings page click Edit.
3. Select Multiple Languages and add the languages you want to include in your knowledge base. You can only add

languages supported by Salesforce.
4. Optionally, choose the following settings for each language:

DescriptionSetting

Only active languages appear in the New Article dialog and
the Submit for Translation dialog. Also, active/inactive status

Active

determines whether a published article is visible. For
example, if articles are published in Spanish to your partner
portal and then you make Spanish an inactive language, the
articles are no longer visible to partners.

This value appears in the Assign To field of the Submit
for Translation dialog. Choose a person or a queue: the

Default Assignee

individual responsible for translating articles into this
language, or the queue used for exporting articles to a
localization vendor.

40

Service Cloud Multiple Languages for Salesforce Knowledge



DescriptionSetting

Select the person who should be assigned to review or publish
translations imported in this language.

Default Reviewer

5. Click Save.

Translating Articles within Salesforce Knowledge

Available in: Enterprise, Unlimited, and Developer Editions

User Permissions Needed

“View Articles”To view articles:

“Edit Articles”To create, edit, translate, archive, or delete articles:

To translate an article within Salesforce:

1. Click the Article Management tab and select Translations in the View area.
2. Select Draft Translations.
3. Optionally, change the Assigned To filter to view articles that are not assigned to you for translation. For example, you

may want to view articles assigned to a translation queue.
4. Click Edit next to the article and language you want to translate.
5. Enter your translation.
6. Click Save.

Note: You can also edit a published translation. It reverts to draft status until you republish it, although you can
choose to keep the existing version published while you update it.
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Exporting Articles for Translation

Available in: Enterprise, Unlimited, and Developer Editions

User Permissions Needed

“Manage Knowledge”

AND

“Export Articles”

To export articles:

“View Articles”To view articles:

“Edit Articles”To create, edit, archive, or delete articles:

If your organization sends Salesforce Knowledge articles to a vendor for translation, articles are put into a translation queue.
To generate an export file containing the articles that have been submitted for translation:

1. Click Your Name➤ Setup ➤ Data Management ➤ Export Articles for Translation.
2. Select the queue that contains the articles you're exporting.
3. Click either:

• All articles to export every article in the queue.
• Updated articles to only export articles that have been modified or added.

4. Click Continue.
5. Select the source and target language pairs you want to export. Salesforce creates a separate zip file for every article type

in each language pair.

Attention: You must retain the zip file structure for a successful import. For more information, see Importing
Article Translations on page 44.

6. Select a user or a queue to assign the translations to after export for review or publishing.
7. Select the file character encoding:

• ISO-8859-1 (General US & Westion European, ISO-LATIN-1)
• Unicode
• Unicode (UTF-8) default

• Japanese (Windows)
• Japanese (Shift_JIIS)
• Chinese National Standard (GB18030)
• Chinese Simplified (GB2312)
• Chinese Traditional (Big5)
• Korean
• Unicode (UTF-16, Big Endian)

8. Select the delimiter for the cvs files. The delimiter is the separator for columns when the file is coverted to table form.
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• Tab default

• Comma

9. Click Export Now.

You're notified by email when your export is complete. You can also check the status of your export by viewing the Article
Import and Export Queue at Your Name➤ Setup ➤ Monitoring ➤ Article Imports and Exports.

For description of status states, see “View Import and Export Status.” in the Salesforce online help
10. Unzip the exported files, but retain the file structure for a successful import.

Creating an Article Queue

Available in: Enterprise, Unlimited, and Developer Editions

User Permissions Needed

“Customize Application”

AND

“Manage Public List Views”

To create or change queues:

“Customize Application”

AND

“Manage Public List Views”

AND

“Manage Users”

To create or change queues created by other users:

If your organization sends articles for translation outside of Salesforce, , you must create one or more translation queues. When
authors or reviewers submit an article for translation, they select the queue. . You can create one queue for each language or
combine languages within queues.

To create a queue:

1. Click Your Name➤ Setup ➤ Manage Users ➤ Queues.
2. Click New.
3. Enter a name for the queue.
4. Choose email notification settings for the queue:

You MustTo Notify

Add an email address to Queue Email

You can add an email address for an individual user or an
email distribution list.

One email address when new records are placed in the queue
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You MustTo Notify

Leave Queue Email blankAll queue members individually when new records are placed
in the queue

Add an email address to Queue Email and check Send
Email to Members

All queue members and the Queue Email individually
when new records are placed in the queue

5. Add Knowledge Article Version as the object available to the queue.
6. Choose queue members.

You can select individual users, roles, public groups, territories, connections, or partner users. Only queue members and
users above them in the role hierarchy can take ownership of records in the queue, depending on your organization's sharing
settings.

7. Click Save.

Importing Article Translations

Available in: Enterprise, Unlimited, and Developer Editions

User Permissions Needed

“Manage Knowledge”

AND

“Import Articles”

To import article translations:

“View Articles”To view articles:

“Edit Articles”To create, edit, archive, or delete articles:

Before you can import translated articles into Salesforce, consider the following information:

• You can only import articles that have been exported from the same Salesforce organization. For example, you can't export
articles from your test or sandbox organization and import them into your production organization.

• You must place all the translation files (meaning, those exported from Salesforce and translated by your vendor) in a folder
whose name is the same as the language code . For example, put French articles in a fr folder. Zip up this folder to create
your import file.

• To successfully import translated articles, verify that the file structure of the articles to import matches the file structure
of the articles exported for translation. For example, if the target language is French, the file structure begins as follows:

export.properties
-fr
--articletypearticlename_kav
---articlename.csv
---[Article collateral, html, images, etc.]
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To import translated articles:

1. Click Your Name➤ Setup ➤ Data Management ➤ Import Article Translations.
2. Choose how Salesforce handles translations after they're imported.

DescriptionOption

Add imported translations to a queue from which users can
review them.

Review imported translations on the Article
Management tab before publishing

Publish imported translations without reviews.Publish translations immediately on import

3. Select the language of the articles you're importing.
4. Optionally, if you chose to have articles reviewed before publishing, select a user or queue for the review.
5. Click Browse, choose the translation Zip file to upload, and click Open.
6. Click Import Now.

If you have more translated articles to upload, repeat steps four through six.

7. Click Finish.

An email notification is sent to you when your import is finished. You can view the status of your import by clicking Your
Name➤ Setup ➤ Monitoring ➤ Article Imports and Exports.

Adding Languages to Salesforce Knowledge Synonyms

Available in: Enterprise, Unlimited, and Developer Editions

User Permissions Needed

“Manage Synonyms”To create, edit, and delete synonym groups:

Salesforce Knowledge synonyms are words or phrases that are treated as equivalent in article searches, letting you optimize
search results. When searching articles, users can enter search terms that don't match any terms in your articles, but are
synonymous with those terms.

When building synonym groups, work with knowledge managers and other subject matter experts in your organization to
create relevant synonyms.

With Spring '11, you can add supported Salesforce Knowledge languages to synonym groups.

1. Click Your Name➤ Setup ➤ Customize ➤ Search ➤ Knowledge Synonyms.
2. Click Edit next to the synonym group.
3. Select an available language.

If the synonyms are specific to a single language, select only that language. For example, if zum biespiel and zB applies to
German users only, select only German. If the synonyms apply regardless of the language your users are searching in, select
several languages for one synonym group. For example, if the synonym group Business Objects and BO applies to English,
German, and Spanish users, select all of these languages.
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4. Click Save.

For more information, see “Managing Salesforce Knowledge Synonyms” in the Salesforce online help.

Salesforce Knowledge Sidebar for the Service Cloud
Console (Contextual Knowledge)

With Spring '11, it's even easier to solve cases with the Service Cloud console. If Salesforce Knowledge is set up, console users
see a sidebar that displays titles of Salesforce Knowledge articles that may solve the case they're working on. It automatically
searches and returns articles from your knowledge base that match any of the words typed in the Subject of a case. The
sidebar only displays for Salesforce Knowledge users after administrators set it up.

Implementation Tips
• To learn more about Salesforce Knowledge, see “What is Salesforce Knowledge?” in the Salesforce online help.
• To see the Salesforce Knowledge sidebar, console users need the Service Cloud User and Knowledge User feature licenses.

To add these licenses to a user:

1. Click Your Name➤ Setup ➤ Manage Users ➤ Users.
2. Click Edit next to a user's name.
3. Select the feature licenses and click Save.

For more information, see “Viewing Feature Licenses” in the Salesforce online help.

• Only Salesforce Knowledge articles updated within the last 30 days are automatically displayed in the sidebar, but you can
view older articles by specifying a search term or filtering search results.

Setting Up the Salesforce Knowledge Sidebar

Available in: Enterprise, Unlimited, and Developer Editions with the Service Cloud

User Permissions Needed

“Customize Application”To set up the Salesforce Knowledge sidebar:

After you set up Salesforce Knowledge and a Service Cloud console app, you can turn on the Knowledge sidebar:

1. Click Your Name➤ Setup ➤ Customize ➤ Cases ➤ Page Layouts.
2. Click Edit next to a page layout.
3. Click Layout Properties.
4. Check Knowledge Sidebar, and click OK.
5. Click Save.

Repeat these steps for each case page layout assigned to console users.

For more information, see “Setting Up Salesforce Knowledge” and “Setting Up a Service Cloud Console” in the Salesforce
online help.

46

Service Cloud Salesforce Knowledge Sidebar for the Service Cloud Console (Contextual Knowledge)



Finding Articles to Solve Cases

Available in: Enterprise, Unlimited, and Developer Editions with the Service Cloud

User Permissions Needed

“View Articles”To view Salesforce Knowledge articles:

“Edit” on casesTo add Salesforce Knowledge articles to cases:

The Salesforce Knowledge sidebar automatically displays when you select a case in a Service Cloud console. Suggested articles
display in the sidebar as you enter details in the Subject of a case. Only articles updated within the last 30 days are displayed,
but you can view older articles by specifying a search term or filtering search results. The sidebar appears if it's set up by your
administrator and Salesforce Knowledge is enabled.

• To view an article, click its title.
• To filter articles by a specific category, click  and choose filter options.
• To find articles to help you solve a case, click , type keywords into Search, and click Go.
• To attach an article to a case, click the checkbox next to the article and click Attach to Case. You can only attach an article

to a saved case.  displays next to an article already attached to a case.
• To remove an article attached to a case, click Detach next to the article on the Articles related list.
• To change the number of articles displayed, click the article count indicator in the lower left corner of the sidebar and

choose a setting. You can view 10, 25, 50, 100, or 200 articles at a time. When you change this setting, you return to the
first page of the list.

• Navigate through the list of articles by clicking the first page icon (<<), Previous, Next, or the last page icon (>>).
•

To show or hide the articles sidebar, click  or .
• New, Article Title, and Most Viewed are the only columns in the sidebar. You can drag the bar in between the

columns to resize them, but you can't add, remove, or rearrange columns.
• You can drag the bar in between the articles sidebar and a detail page to resize the width of either one.

Additional Service Cloud Enhancements
Salesforce Knowledge Article Number

Available in: Enterprise, Unlimited, and Developer Editions

Salesforce Knowledge is a knowledge base where users can easily create and manage content, known as articles, and quickly
find and view the articles they need. Now, all articles are automatically assigned a unique Article Number so that you can
better identify, search, and report on articles. Numbering for articles starts at “000001000.” You can't change the format or
numbering for this field.

For more information, see “What is Salesforce Knowledge?” in the Salesforce online help.
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Additional Case Article Fields Available for Reports and the Articles Related List

Available in: Enterprise, Unlimited, and Developer Editions

Salesforce Knowledge is a knowledge base where users can easily create and manage content, known as articles, and quickly
find and view the articles they need. With Spring '11, you can view even more information about articles attached to cases by
adding the following fields to the Cases with Articles report and the Articles related list on cases:

• Case Article Created By

• Case Article Created Date

• Case Article Created By Alias

For more information, see “What is Salesforce Knowledge?,” “Support Reports,” and “Customizing Related Lists” in the
Salesforce online help.

Validation Rules for Case Milestones

Available in: Enterprise, Unlimited, and Developer Editions with the Service Cloud

Milestones are required steps in your support process, such as first response and resolution times on cases. They're available
if you've enabled the entitlement management feature. With Spring '11, you can add validation rules to case milestones so
that when users update a milestone on a case, it meets the standards you specify before they can save it. For example, you can
create a validation rule that ensures users select milestone completion dates that occur after case creation dates.

If you have the “Customize Application” permission, you can create validation rules for case milestones:

1. Click Your Name➤ Setup ➤ Customize ➤ Cases ➤ Case Milestones ➤ Validation Rules ➤ New.
2. Enter details for the rule:

ExampleDescriptionField

Prevent Case Milestone Completion
Before Case Creation Dates

Unique identifier of up to 80 characters
with no spaces or special characters such
as extended characters.

Rule Name

Not applicable.Checkbox that indicates if the rule is
enabled.

Active

Validates that the milestone's
Completion Date has occurred after
the case's Date/Time Opened.

A 255 character or less description that
distinguishes the validation rule from
others. For internal purposes only.

Description

CompletionDate >=
Case.CreatedDate &&

The expression used to validate the
field.

Error Condition Formula

CompletionDate <=
Case.ClosedDate

The milestone Completion Date must
occur after the date the case was created
and before the case was closed.

The message that displays to the user
when a field fails the validation rule.

If your organization uses the
Translation Workbench, you can

Error Message

translate the error message into the
languages Salesforce supports. See

48

Service Cloud Additional Service Cloud Enhancements



ExampleDescriptionField

“Setting Up the Translation
Workbench” in the Salesforce online
help.

Top of PageDetermines where on the page to
display the error.

Error Location

3. Click Check Syntax to check your formula for errors.
4. Click Save.

For more information, see “About Validation Rules,” “Defining Validation Rules,” “Examples of Validation Rules,” and
“Entitlement Management Overview” in the Salesforce online help.

Global Search for the Service Cloud Console

Available in: Enterprise, Unlimited, and Developer Editions with the Service Cloud

The Service Cloud console is designed for users in fast-paced environments who need to find, update, and create records
quickly. With Spring '11, Global Search is the sole search tool for the console, so more items are automatically searched when
you type keywords in the Search box in the header and click Search. Unlike the advance search and sidebar search capabilities
that used to be available for the console, Global Search searches more record types, including articles, documents, products,
solutions, and Chatter feeds, files, groups, and people. Global Search also searches more field types, including custom fields
and long text fields such as descriptions, notes, and task and event comments.

For more information, see “Service Cloud Console Overview” in the Salesforce online help.

Version 3.0 of the CTI Toolkit Is Compatible with the 64–bit Version of Internet Explorer 8 on
Windows 7
Developers use a CTI (computer-telephony integration) toolkit provided by salesforce.com to build CTI adapters that integrate
Salesforce with third-party CTI systems. The CTI Toolkit helps developers build CTI adapters that Salesforce CRM Call
Center users install on their machines so they can use the features of a CTI system through the Salesforce SoftPhone.

With Spring '11, CTI Toolkit versions 3.0 or higher are only compatible with the 64–bit version of Internet Explorer 8 on
Windows 7. This lets Call Center users with Windows 7 machines work with SoftPhones on 64–bit Internet Explorer 8
(Firefox is not supported).

For more information, see “Salesforce CTI Toolkit Overview” in the Salesforce online help.
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Analytics Enhancements
Salesforce analytics enhancements in Spring '11 include:

• Report Builder Enhancements
• Dashboard Enhancements
• API and Metadata API Enhancements

Report Builder Enhancements

Available in: All Editions

With Spring '11, we're delivering the following enhancements to report builder:

Report Builder Upgrade
We've released an updated version of report builder, the powerful drag-and-drop editor for reports. With this upgrade:

• All profiles get access to the report builder by default.
• The old report wizard will be available only to users in Accessibility Mode.
• Group and Professional Edition organizations can use report builder.
• You get scatter charts, a new chart type for reports.

Administrators for existing organizations must manually enable this upgrade. New organizations automatically get the latest
version of report builder. If you don't see the Report Builder Upgrade section, the upgrade has already been enabled for your
organization.

To enable report builder for all users:

1. Click Your Name➤ Setup ➤ Customize ➤ Reports & Dashboards ➤ User Interface Settings.
2. Review the Report Builder Upgrade section of the page and click Enable.
3. Confirm your choice by clicking Yes, Enable Report Builder for All Users.

Note: Once you upgrade your organization, you no longer see the “Report Builder” permission on profiles.

Report Builder for Group and Professional Editions

You asked for it! This enhancement is from an idea on IdeaExchange.
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Report builder is now available to all users of Group and Professional Editions! Previously, only users with the System
Administrator profile could use it.

To enable report builder for a Group or Professional Edition organization, enable the report builder upgrade.

Scatter Charts
We're providing a new chart type for reports—scatter! To use them, enable the report builder upgrade.

Use this type when you want to show the correlation between the axis values for one important grouping. Optionally, set the
Group By option to show the Plot By values broken down by another group. For example, to see the correlation between
the stage duration and the number of activities for opportunities, group your report by Opportunity Name and select it for
Plot By. Then set Stage Duration as the Y-axis and Record Count as the X-axis. The chart displays a point for
each opportunity, and you can see whether the stage duration is shorter for opportunities that have more activities.

To use scatter charts in dashboards, use the Use chart as defined in source report option.

Report Builder for Force.com and Salesforce Platform Users

You asked for it! This enhancement is from an idea on IdeaExchange.

Report builder is now available to users with Force.com and Salesforce Platform licenses. Previously, you couldn't use report
builder with those licenses.

Improved Report Builder Filters

You asked for it! This enhancement is from an idea on IdeaExchange.

We've made the report builder's Filters pane easier to use. Filter options are available in the Add menu. You can create field
filters, add filter logic, or limit rows. There's also a new help topic, “Choosing Report Filters” in the Salesforce online help,
to help you choose the right filter for your report.

You can also now type to search for fields in field filters! When you click Add ➤ Field Filter, the default value for the Field
drop-down is the first one in the list. To change it, simply type in the field.
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Filters are now editable inline. In report builder, double-click a filter, or hover over it to see the Edit and Remove links.

If you've already created a logical condition for your filters, such as 1 AND (2 OR 3), then add a fourth field filter, Salesforce
automatically updates the filter logic by adding it at the end with the AND operator. The new logic becomes:

(1 AND (2 OR 3)) AND 4

Previously, you'd receive a validation error.

Dashboard Enhancements

Available in: Group, Professional, Enterprise, Unlimited, and Developer Editions

With Spring '11, we're delivering the following enhancements to dashboards:

Dashboard Builder for All Users
Now, dashboard builder is automatically enabled for all users! Previously, only users with the System Administrator profile
saw the dashboard builder by default. New and existing organizations no longer see the “Drag-and-Drop Dashboard Builder”
permission on profiles.

Dynamic Dashboards for Enterprise Edition, with Higher Limits

Available in: Enterprise, Unlimited, and Developer Editions

You asked for it! Spring '11 addresses these ideas for dynamic dashboards on IdeaExchange: make dynamic
dashboards available for Enterprise Edition, increase the dynamic dashboards limit.

Dynamic dashboards are now available for Enterprise Edition, in addition to Unlimited and Developer Editions. And we
increased the limits:

• Enterprise Edition—Up to five per organization
• Unlimited Edition—Up to 10 per organization
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• Developer Edition—Up to three per organization

Dashboard Alerts
You can now follow individual dashboard components in Chatter!

If feed tracking is enabled for dashboards, you can view updates and field changes in the Chatter feed. You can also follow
dashboards and certain dashboard components. When you follow a dashboard, you automatically follow all eligible components.
Following components isn't supported for dynamic dashboards.

Only metrics and gauges with conditional highlighting set are eligible for following. When the dashboard is refreshed, if the
value for a followed component crosses a breakpoint, an alert is posted to your Chatter feed. If you don't see feeds on dashboards,
ask your administrator to enable them.

For example, to receive alerts when total sales for a gauge fall below a certain amount, set conditional highlighting on that
component, then follow it.

To follow a component:

1. Hover over a component to display the  menu. To clear the hover menu, click an empty part of the screen.
2. Click Follow this Component.

To stop following a component, click  and select Following.

Chatter Dashboard Component Posts
Now, you can post a snapshot of a dashboard component to dashboard or user feeds. A snapshot is a static image of a dashboard
component at a specific point in time posted to a Chatter feed.

• Post a component snapshot to its dashboard feed to share information with everyone following the dashboard. For example,
post a snapshot of a regional sales chart to let your team know that sales are down in the Midwest. If you don't see this
option, ask your administrator to enable feed tracking for dashboards.

• Post a component snapshot to a user feed to share and comment on that component. For example, post a snapshot of team
sales to the best salespeople to congratulate them. If you don't see this option, talk to your administrator about enabling
dashboard component snapshots.

Important:  Posting a snapshot to a user feed makes it visible to the whole company. People can see it whether they
have access to the dashboard or not. Make sure the component doesn't contain sensitive information!

To post a component snapshot to a feed:

1. Hover over a component to display the  menu. To clear the hover menu, click an empty part of the screen.

2. Do one of the following:

• Select Post Snapshot to Dashboard Feed
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• Select Post Snapshot to User Feed and choose a user.

3. Write a comment in the text box and click OK. The snapshot and comment immediately appear in the selected Chatter
feed.

Note:  Snapshot images display in feeds for four months. After four months, only the comments remain.

Profile Photos on Dashboards
Now, you can show Chatter user and group photos, such as Opportunity Owner, on horizontal bar charts and tables in
dashboards. The underlying source report for that dashboard component must be grouped by a user or group name field. If
there are more than 20 records with photos, record names are shown instead of photos.

Set the Drill Down to option to Record Detail Page to take users directly to user profile or group pages when they
click photos.

To use this option, select Show Chatter Photos when editing an eligible dashboard component.

API and Metadata API Enhancements
New objects, DashboardComponent and DashboardComponentFeed, have been added to API version 21.0. See Chatter API
Objects on page 71 for details.

The Dashboard and Report metadata types have been updated. See Force.com Development as a Service Enhancements on
page 75 for details.
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Criteria-Based Sharing Rules—Generally Available
Available in: Professional, Enterprise, Unlimited, and Developer Editions

In Spring '11, you can create sharing rules based on record criteria. Criteria-based sharing rules determine whom to share
records with based on field values in records. For example, let's say you use a custom object for job applications, with a custom
picklist field named “Department.” You can create a criteria-based sharing rule that shares all job applications in which the
Department field is set to “IT” with all IT managers in your organization.

Criteria-based sharing rules are ideal for complex business scenarios or companies with complex sharing requirements that
extend beyond owner-based sharing. Don't use criteria-based sharing rules if your company has open access to all records, or
if sharing is based only on record ownership.

Note: Currently, you can't use Apex or the Metadata API to create criteria-based sharing rules.

Criteria for Sharing Rules
You can create criteria-based sharing rules for accounts, opportunities, cases, contacts, and custom objects. You can create up
to 50 criteria-based sharing rules per object. Use any of these as criteria for sharing.

• Record types
• These field types:

- Auto Number
- Checkbox
- Date
- Date/Time
- Email
- Number
- Percent
- Phone
- Picklist
- Text
- Text Area
- URL
- Lookup Relationship (to user ID or queue ID)

Note: Text and Text Area are case-sensitive. For example, a criteria-based sharing rule that specifies “Manager”
in a text field won't share records with “manager” in the field. To create a rule with several common cases of a
word, enter each value separated by a comma.

FORCE.COM
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Creating Criteria-Based Sharing Rules

User Permissions Needed

“Manage Users”To create, edit, and delete sharing rules:

1. Click Your Name➤ Setup ➤ Security Controls ➤ Sharing Settings.
2. In the Sharing Rules related list for accounts, contacts, opportunities, cases, or custom objects, click New.
3. For Rule Type, select Based on criteria.
4. Specify the Field, Operator, and Value criteria that records must match to be included in the sharing rule. The fields

available depend on the object selected, and the value is always a literal number or string. Click Advanced Options... to
change the default AND relationship between each filter.

Note: To use a field that's not supported by criteria-based sharing rules, you can create a workflow rule or Apex
trigger to copy the value of the field into a text or numeric field, and use that field as the criterion.

5. In the Share with line, specify the users who should have access to the data: select a category from the first drop-down
list and a set of users from the second drop-down list or lookup field.

6. Select the sharing access setting for users.

DescriptionAccess Setting

Users can't view or update records, unless access is granted
outside of this sharing rule.

Private

(This setting appears in account sharing rules only, in the
access settings for associated contacts, opportunities, and
cases.)

Users can view, but not update, records.Read Only

Users can view and update records.Read/Write

Note:

• For account and account territory sharing rules, the Contact Access, Opportunity Access, and Case
Access options only apply to the contacts, opportunities, and cases associated with the shared accounts.
Contact Access isn't available if the organization-wide default for contacts is set to Controlled by Parent.

• In opportunity sharing rules (either owner-based or criteria-based with ownership as criteria), the Opportunity
Access level applies to opportunities owned by the group, role, or territory members, regardless of the associated
account.

7. Click Save.

For existing criteria-based sharing rules, you can edit the criteria as well as the sharing access settings.

Note:

• Although criteria-based sharing rules are based on values in the records and not the record owners, a role or territory
hierarchy still allows users higher in the hierarchy to access the records.

• You can't include high-volume portal users in sharing rules because they don't have roles and can't be in public
groups.
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Force.com Flow—Generally Available
Available in: Enterprise, Unlimited, and Developer Editions

In Winter '11, we introduced you to the pilot of Visual Process Manager, now known as Force.com Flow and formerly known
as Firefly, which provides a robust, business-friendly scripting tool for the Force.com platform.

With Spring '11, Force.com Flow is generally available, and we've added new functionality:

• The setup audit trail now tracks changes to Force.com Flow files.
• Flows are now formatted using Visualforce.
• You can now embed flows in Visualforce pages using the <flow:interview /> component, enabling you to use, secure,

and customize flows in the same way as any Visualforce page.
• Flows are now enabled for Force.com Sites, the Customer Portal and the partner portal.
• Requirements have changed for variables, API code, and flow elements in the Flow Designer.

Important: If you have flows in Salesforce that were uploaded in previous releases, their format may not be
compatible with changes made in the current release. To ensure that all your flows are up-to-date and will run
properly, download the latest version of the Flow Designer from the flow list page, open the original flow files,
clean up their contents based on any errors you get, then save them and re-upload. You may have to do this more
than once if you receive any new errors upon re-uploading the flow.

Adding a Flow to a Visualforce Page

Available in: Enterprise, Unlimited, and Developer Editions

User Permissions Needed

“Customize Application”To create, edit, and set version settings for Visualforce pages:

If your organization has Force.com Flow enabled, you can make any active flow available in your Force.com site, Customer
Portal, or partner portal by embedding it as a component in a Visualforce page.

Note: Users can only run flows that have an active version. If the flow you embed doesn't have an active version, users
see an error message. If the flow you embed includes a subflow, that subflow must have an active version.

To add a Force.com flow to a Visualforce page, embed it using the <flow:interview> component:

1. Find the flow's unique name:

a. Go to the flow list page at Your Name➤ Setup ➤ Create ➤ Workflow & Approvals ➤ Flows.
b. Click the name of the flow you want to embed.

2. Define a new Visualforce page or open one that you want to edit.
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3. Add the <flow:interview> component, somewhere between the <apex:page> tags.
4. Set the name attribute to the unique name of the flow. For example:

<apex:page>
<flow:interview name="MyUniqueFlowName">
</apex:page>

5. Restrict which users can run the flow by setting the page security for the Visualforce page that contains it. Any user with
a profile assigned to the Visualforce page can run the embedded flow.

In addition to the other flow customizations available with Visualforce, you can also shape what happens when a user clicks
Finish on the final screen. Here's a simple example, using the URLFOR function. You can use URLFOR to:

• Route users to a relative URL, such as the Salesforce home page.

<apex:page>
<flow:interview name="flowname" finishLocation="{URLFOR('/home/home.jsp')}"/>

</apex:page>

• Route users to a specific record or detail page using its ID. For example, if you wanted to route users to a detail page with
an ID of 001D000000IpE9X:

<apex:page>
<flow:interview name="flowname" finishLocation="{URLFOR('/001D000000IpE9X')}"/>

</apex:page>

Note:  If finishLocation isn't specified, users that click Finish are routed back to the first screen of the flow.

For more examples of using flows in Visualforce, including other ways of setting finishLocation, and how to make a flow
interact with other components on the page, see the Visualforce Developer's Guide.

Flows in Force.com Sites, the Customer Portal and the Partner Portal

Available in: Enterprise, Unlimited, and Developer Editions

If your organization has Force.com Flow enabled, you can make any active flow available in your Force.com site, Customer
Portal, or partner portal by embedding it as a component in a Visualforce page. Give your site and portal users access to
sophisticated self-service tools and dynamic applications that you build with Force.com Flow and customize with Visualforce.
Since the flow is embedded in a Visualforce page, you can customize the appearance of the flow so it uses your company's
branding and style.

Note: When making a flow available to site or portal users through a custom link or Visualforce tab, point the tab or
link to the URL of the Visualforce page that contains the embedded flow, not to the URL of the flow itself. Site and
portal users don't have the privileges to run flows directly.
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What's New in the Flow Designer

Available in: Enterprise, Unlimited, and Developer Editions

When moving from version 5.5 to version 7.0 of the Flow Designer, you may encounter errors when importing older flows.
Requirements have changed for variables, API code, and flow elements. The following internal functions are no longer
supported and are treated as regular text in the Flow Designer:

• [(Event Description)]
• [(Event Message)]
• [(Event Name)]
• [(Event Number)]
• [(Fault Stack Trace)]
• [(Space ID)]
• [(Spark ID)]

Packaging Enhancements
With Spring '11, Salesforce supports new features for both subscribers and publishers of AppExchange packages.

Customer Success Console
Granting Publishers Support Access — Beta

If you've installed an application from the AppExchange, you can grant the publisher setup access to your organization
without exchanging passwords or login information. Setup access allows the publisher's support personnel to view your
organization's setup configuration in a read-only mode. They can look at information in the App Setup area of your
organization, including the pages under the Create, Customize, and Develop sections, but can't make any changes to
setup configuration or modify any data. Typically setup access is enough to troubleshoot most configuration problems.

In order to grant publisher access to your organization:

• You must have installed a licensed package from the publisher.
• The licensed package must have an "active" or "trial" status.
• An administrator must grant access to the publisher. An administrator with the default Administrator user profile

may perform this grant, or any administrator with the "Permit User to grant login access to salesforce.com partner"
user perm.

To grant a package publisher access to your organization:

1. Click Your Name➤ Setup ➤ Administration Setup ➤ Security Controls ➤ Package Support Access.
2. Click in the field next to the publisher's name.
3. Enter a date in the future. Access is revoked on the specified expiration date.

Note: You can revoke a grant by removing the date from the field.

4. Click Save.
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Note: You can see a log of all publisher setup accesses to your organization by clicking Your Name➤ Setup
➤ Administration Setup ➤ Manage Users ➤ Login History.

Package Support Access — Beta

Available in: Developer Edition

Package Support Access allows AppExchange publishers to access an organization that has installed their licensed
package, to identify installation problems or perform other support activities without exchanging credentials. As an
AppExchange publisher, Package Support Access gives you read-only access to the App Setup area of a subscriber
organization, including the pages under the Create, Customize, and Develop sections. Configuration issues commonly
occur on initial package installation, particularly when the package requires manual configuration on the part of the
subscriber administrator. Setup access is usually enough to troubleshoot configuration issues.

Prerequisites:

• The package must be licensed with the License Management Organization (LMA).
• You need to log a case in the Partner Portal and ask for package support access to be enabled for your package. If

you have previously used push upgrades, then you already have access to this feature.
• Users who want to access subscriber organizations must be given the "Permit User to login in to subscriber org" user

permission by an administrator in the publisher's LMO organization. To protect the security of the subscriber
organization, it's important that only trusted support and engineering personnel be given this permission. We
recommend adding this permission to a custom profile for people whose main role is customer support.

To add the Subscriber Support tab to the LMA:

1. In the License Management Organization, click <your name> ➤ Setup ➤ Create ➤ Apps.
2. Click Select License Management App.
3. Click Edit.
4. Add the Subscriber Support tab to the Selected Tabs.
5. Assign to the customer support rep profile (the profile of users who are authorized to use this feature).

To grant "Permit User to login in to subscriber org":

1. Click <your name> ➤ Setup ➤ Manage Users ➤ Profiles.
2. Select an appropriate profile name.
3. Use Ctrl-F to search for the perm name "Permit User to login in to subscriber org" and select the box.
4. Click Save.

To access a subscriber organization:

1. Select the License Management Application in the app picker in the upper right hand side of their screen.
2. Select the Subscriber Support tab to see a list of subscriber organizations that have granted access.

Note:  If you don't see the subscriber listed, the subscriber's system administrator has not granted you access.
Ask the administrator to go to Your Name➤ Setup ➤ Administration ➤ Security Controls ➤ Package
Support Access and grant you permission.

3. Find the subscriber's organization name or id and click Access. You will be redirected and logged into the subscriber's
organization.

4. Once inside the subscriber organization, navigate into App Setup tree to view the subscriber's configuration.
5. When you have completed troubleshooting, be sure to log out of the subscriber organization using the logout link.
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Trialforce Email Branding

Available in: Developer Edition

You asked for it! This enhancement is an idea from the IdeaExchange.

Trialforce Email Branding allows you to modify system-generated emails so that they appear to come from your company
rather than from Salesforce.com. Trialforce Email Branding only applies to users who sign up for your application through
Trialforce.

If you are a partner that is already using Trialforce, you must log a ticket through Partner Portal to request this branding, and
provide your package development organization ID. For new partners, Trialforce Email Branding is automatically enabled
when you request Trialforce.

To change Trialforce Email Branding:

1. Click Your Name➤ Setup ➤ Create ➤ Packages.
2. Click the package you want to change the branding on.
3. Click Branding.
4. On the Package Branding detail page, click Edit.
5. Select Enable to use your own branding or clear the checkbox to use salesforce.com branding.
6. Enter information about your company in the fields provided.
7. Click Save.

Note: Trialforce Email Branding is specific to a version of the uploaded package, to change branding, you must upload
a new package.

To select the branding in your Trialforce organization:

1. Log in to your Trialforce organization.
2. Install the package that contains the branding you want to use.
3. Click Your name➤ Setup ➤ App Setup ➤ Trialforce
4. Click Edit.
5. Use the drop down list to select package branding.
6. Click Save.
7. Click Snapshot Organization to generate a Trialforce organization for use in an AppExchange trial or your own Web

site's trial sign-up form.

How to Use Trialforce
1. Build your Force.com app.
2. Create a beta package, upload it, install it, and test it thoroughly.
3. Optionally define the branding for the package. For more information, see “Trialforce Email Branding” in the Salesforce

online help.
4. Upload a managed released version of the package.
5. Create your License Management Organization (LMO). Your LMO is where you will manage your customers' access to

your application. Typically you install the LMA in an existing Salesforce CRM organization. If you don't already have a
Salesforce CRM organization, log in to the Partner Portal and create a Case in the OEMRequest CRM for ISV Partners
category.
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Caution:  Do not install the LMA in the Developer Edition organization used to package the application.

6. Associate your managed package to a LMO. This step is important. It insures that every time someone creates a trial of
your application, your LMO receives the updated records. To associate your package to your LMO, you will need to log
in to the AppExchange.

7. Log a Case in the Partner Portal, and specify the topic as Trialforce and the sub-topic as Initiate Trialforce
Process. Once you've received your login credentials and installed your package, you can begin customizing the organization
exactly the way you want your prospective customers to experience it.

Note:  As a best practice, you should load some data into your Trialforce Master org so that your prospects have
something that they can play with when they first log in.

8. Log into the AppExchange and click on the associated List It link. You will be prompted to register new managed packages
— be sure to do this; it's an important step.

Note:  Even if you're not distributing via the AppExchange, you will need to register your package on the
AppExchange because that's where you specify default license values. You should get in the habit of registering
your package every time you upload a new version, especially when you install a new version into your Trialforce
Master organization.

9. With your Trialforce Master org configured, you are now ready to build your DOT. To DOT your org:

a. Navigate to Setup ➤ Administration Setup ➤ Data Management ➤ Export to DOT file
b. Depending on the size of your DOT, you will either be presented a Save dialog, or it will be automatically stored as a

document in your Documents tab. Use the following settings with the Save dialog:

i. In the Include Entities section, select All.
ii. Deselect the Include debugging info checkbox.
iii. Optionally, select the Don't rebase dates checkbox if you don't want the date values in your data to change.

The default behavior moves dates up based on the signup date.
iv. In the Store File In section, select the location that's most convenient for you.
v. Click Save.

Depending on the size of your Trialforce DOT, you either see a message with your Trialforce DOT ID or see a screen
saying that you will receive an email when it has been created. If your Trialforce DOT creation doesn't complete within
a minute or so, you will receive an email when it has finished. Once you receive the "ready for use" confirmation email,
your Trialforce DOT is ready.

c. Log a case in the Partner Portal with the Topic set to Trialforce and the sub-topic set to DOT Update. Be sure
to attach your zipped-up DOT file after you've saved the case.

Note: With every new release of Salesforce, your DOT will expire. Therefore, after your Trialforce Master org
has upgraded to the new release, you will need to:

a. Create your DOT.
b. Log a case in Partner Portal.
c. Send us your new DOT.

Future release schedules can be found at trust.salesforce.com/trust/status/#maint.

10. After we have received your DOT, you will need to copy the HTML source code from our sample Trialforce page. Access
to this source code is in the Partner Portal:

a. Log into Partner Portal.
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b. Click Content.
c. Search for "Trialforce Sample Source Code".
d. Click on the result.
e. Click Download.

11. Once modified, this page will allow prospective customers to create trials of your application. This page is just a template
though, and you must modify it. First you will need to update variables and hidden elements throughout the sample code.
Search the source for commented items marked TODO and replace them with the appropriate values.

12. Once the form is working properly, you should modify the HTML and CSS to match the look and layout of your website.
Be sure not remove any of the form elements. Once you're done, every time a prospective user enters their information
and submits your form, salesforce.com will provision a trial based off of your DOT.

Note:  It is recommended that you siphon the prospect data off of the HTML trial form before it posts to the
salesforce.com provisioning server. This way, you can manage your prospect information, create a lead associated
to that prospect, and begin your own email drip campaign to guide the prospect through the trial process and
towards a buying decision. This follow-up process is critical to realizing results from the Trialforce approach. It is
strongly recommended that you completely define the post-sales and marketing process to support your prospects
during the trial phase, before you begin to offer free trials from your Web site.

Mass User Licensing for Managed Packages
Managing your package licenses just got easier. You can now add or remove licenses for a group of users based on the selected
view.

To add licenses for a group of users:

1. Click Your Name➤ Setup ➤ View Installed Packages to find the installed package that has available licenses.
2. Click the Manage Licenses link next to the package name.
3. Click Add Users.
4. Choose a view from the drop-down list, or click Create New View to build a new custom view.
5. Click Add All Users, then click OK.

To remove licenses from a group of users:

1. Click Your Name➤ Setup ➤ View Installed Packages.
2. Click Manage Licenses next to the package name.
3. Click Remove Multiple Users.
4. Choose a view from the drop-down list, or click Create New View to build a new custom view.
5. Click Remove All Users, then click OK.

Force.com Apex Code Enhancements
Available in: Unlimited, Developer, and Enterprise Editions

Force.com Apex code includes the following enhancements in Spring '11. Refer to the Force.com Apex Code Developer's
Guide for complete information about Apex.

The following enhancement is pilot:
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ReadOnly Annotation

The @ReadOnly annotation provides developers the ability to perform unrestricted queries against the Force.com
database. It is important to note this annotation, while removing the limit of the number of returned rows for a request,
blocks the developer from performing any DML within the request.

All other limits still apply.

The @ReadOnly annotation is only available for Web services and the schedulable interface. To use the @ReadOnly
annotation, the top level request must be in the schedule execution of a batch job or the webservice invocation.

The following enhancements are generally available:

Chatter Triggers

You can now associate Apex with FeedComment and FeedItem objects. Things to consider about FeedItem and
FeedComment triggers:

• FeedItem and FeedComment objects don't support updates. Don't use before update or after update triggers.
• FeedItem and FeedComment objects can't be undeleted. Don't use the after undelete trigger.
• Only FeedItems of Type TextPost, LinkPost, and ContentPost can be inserted, and therefore invoke the

before or after insert trigger.
• While FeedPost objects were supported for API versions 18.0, 19.0, and 20.0, don't use any insert or delete triggers

saved against versions prior to 21.0.

New Process.Plugin Interface for Force.com Flow

With Force.com Flow, you can outline and manage procedures such as approval processes, interviews, or call center
questionnaires. Flows represent your business processes and run in your Salesforce organization as rule-based applications.
Flows are built with the Flow Designer and usually require no additional programming. If you want to add additional
complex logic to your Flows, such as queries or looping, use the Process.Plugin interface.

Revised Apex Governor Limits
For Spring '11, Salesforce is reducing the number of Apex governor limits.

Prior to Spring '11, governor limits worked in two contexts. Different amounts of resources were allocated for a limit depending
on where the code originated. For Spring '11, there is a single context. All governor limits have the same amount of resources
allocated to them, regardless if you're calling it from trigger, an anonymous block, a test, and so on.

No longer a separate limit

The following methods no longer have a separate limit. Calls to these methods now counts against the total number of
the specified method.

Counts againstMethod

Total number of DML statements issuedrollback

Total number of DML statements issuedrunAs

Total number of DML statements issuedsetSavepoint

Total number of SOSL queries issuedfindSimilar
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No limit to the number of items returned by the findSimilar method

The limit on the number of items returned by the findSimilar method has been eliminated.

Increases to existing limits

• The total number of DML statements issued for a process has gone from 20 for triggers, and 100 for everything else,
to 150 for all contexts.

• Total number of records retrieved by SOQL queries has gone from 10,000 to 50,000

Deprecated limits

The following limit methods have been deprecated. Existing code with these methods now returns the same value as
the specified method.

Returns same value asMethod

getSoslQueriesgetFindSimilarCalls

getLimitSoslQueriesgetLimitFindSimilarCalls

getDMLStatementsgetRunAs

getLimitDMLStatementsgetLimitRunAs

getDMLStatementsgetSavepointRollbacks

getLimitDMLStatementsgetLimitSavepointRollbacks

getDMLStatementsgetSavepoints

getLimitDMLStatementsgetLimitSavepoints

Apex Test Framework—Pilot
Note: Apex Test Execution and Apex Test Results are part of a pilot program. To enable these tools for your
organization, contact salesforce.com.

You asked for it! This enhancement is from these ideas on the IdeaExchange.

With Spring '11, it's even easier to run your Apex unit tests. Two new pages have been added:

Apex Test Execution

Run just one, a set, or all the tests in your organization. Tests are run asynchronously: start them, then go work on other
things. You can then monitor the tests, add more tests to the ones that are running, or abort running tests. Once a test
finishes running, you can see additional information about that test run. For example, if there were any errors, the first
error message displays, as well as the stack trace. Click Your Name➤ Setup ➤ Develop ➤ Apex Test Execution.
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Apex Test Results

See all the test results for your organization. Click Your Name➤ Setup ➤ Develop ➤ Apex Test Results. You can
add filters to view just the results you want to see. Test results remain for 30 days after they finish running, or until
cleared.

In addition, after you execute your unit tests, you can see how much of your existing code is covered. Click Your Name➤
Setup ➤ Develop ➤ Apex Classes, then click Calculate your organization's code coverage.

You can also verify which lines of code are covered by tests for an individual class. Click Your Name➤ Setup ➤ Develop
➤ Apex Classes, then click the percentage number in the Code Coverage column for a class.

System Log Console Execution Summary
The System Log console has the following improvements:

• A new tab in the Executed Units section: Summary. This tab highlights the duration and composition of a request. With
this perspective, developers can easily identify and isolate execution hotspots, simplifying the overall development experience.

• A new section: Variables. This section details the value of variables during a request. With this new section, developers
can verify that variable assignments are being made correctly.

Note: Variable assignments only display in the debug log when the logging level for Apex Code is set to Finest.

Visualforce Enhancements
Available in: Group, Professional, Enterprise, Unlimited, and Developer Editions

Custom controllers and standard controller extensions are not supported in Group or Professional Editions.

Spring '11 introduces several new features that enhance the capabilities of previous versions of Visualforce. For detailed
information on these new features, see the Visualforce Developer's Guide.

The following enhancements are now available in Visualforce:

Visualforce Dynamic Bindings

This release introduces the concept of dynamic Visualforce bindings, which is a way of writing generic Visualforce pages
that display information about records without necessarily knowing which fields to show. In other words, fields on the
page are determined at runtime, rather than compile time.

Dynamic bindings are useful for Visualforce pages included in managed packages, as they allow for the presentation of
data specific to each subscriber with very little coding involved.

For more information on dynamic bindings, see Dynamic Visualforce Bindings.
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Development Mode Footer Shows Controller Extensions

The Visualforce development footer now lists the controller extensions used by your Visualforce page. You can edit these
Apex classes inline, the same way you edit a custom controller. If you have multiple controller extensions, each extension
is displayed in its own tab.

Visualforce Inline Editing

You asked for it! This enhancement is from an idea on IdeaExchange.

API version 21.0 provides inline editing support to the <apex:detail> component. It also introduces the
<apex:inlineEditingSupport> component, which gives inline editing functionality to several container components.
Inline editing allows users to quickly change field values on a record's detail page, saving the user from having to access
the record's edit page first. As a requirement, these components must also be descendants of an <apex:form> tag
whenever inline editing is used.

Components that are supported by <apex:inlineEditingSupport> include:

• <apex:dataList>

• <apex:dataTable>

• <apex:form>

• <apex:outputField>

• <apex:pageBlock>

• <apex:pageBlockSection>

• <apex:pageBlockTable>

• <apex:repeat>

Inline editing is not supported for rich text areas (RTAs) or dependent picklists when using <apex:outputField>.

For more information, see the Enabling Inline Editing Quick Start tutorial.

Javascript Remoting for Apex Controllers

Note: The @RemoteAction annotation is currently available as a Developer Preview. You must contact
Salesforce.com Support to enable this feature.

Starting with API version 21.0, Visualforce now provides support for some methods in Apex controllers to be called via
Javascript. Your Visualforce pages and Apex classes must be running API version 21.0.

Javascript remoting calls use the following syntax:

[<namespace>.]<controller>.<method>([params...,] <callbackFunction>(result, event)
{

// callback function logic

}, {escape:true});

In Apex, method declarations are preceded with the @RemoteAction annotation:

@RemoteAction
global static String getItemId(String objectName) { ... }
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For more information, see Javascript Remoting for Apex Controllers.

Text in Title and Subtitle Attributes Is Now Escaped

Any text placed in the title and subtitle attributes is now escaped for the <apex:page>,<apex:sectionHeader>,
and <apex:pageBlockSection> components. This improves your page's security against attacks such as Cross-Site
Scripting. For more information on escaping content, see Unescaped Output and Formulas in Visualforce Pages.

New <flow:interview> Component for Flows

If your organization has Force.com Flow enabled, you can use the <flow:interview> component to embed an active
flow in a Visualforce page.

New Visualforce Workbook
Want to learn more about Visualforce? The Visualforce Workbook gives you a tour of the many features of the framework,
helps you build components and user interfaces, and shows you how to hook Visualforce into your applications. You'll also
learn about the Model-View-Controller foundations of Visualforce, and use a little Apex code.

Field Sets—Beta
Available in: Group, Professional, Enterprise, Unlimited, and Developer Editions

Note: This release contains a beta version of field sets that is production-quality but has known limitations.

The Winter '11 release introduces a new customization feature called field sets. A field set is a grouping of fields. For example,
you could have a field set that contains fields describing a user's first name, middle name, last name, and business title. When
a field set is added to a Visualforce page, developers can loop over its fields and render them. If the page is added to a managed
package, administrators can add, remove, or reorder fields in a field set to modify the fields presented on the Visualforce page
without modifying any code. The same Visualforce page can present different sets of information, depending on which fields
a subscriber prefers to keep.

Field sets can be created through the user interface or the Metadata API.

Implementation Tips
• As an administrator, you can create or edit field sets for your organization, or edit any installed field set. Field sets are

available on all standard objects that support custom fields, and any organization that supports creating Visualforce pages.

• Fields added to a field set can be in one of two categories:

- If a field is marked as Available for the Field Set, it exists in the field set, but the developer hasn’t presented
it on the packaged Visualforce page. Administrators can display the field after the field set is deployed by moving it
from the Available column to the In the Field Set column.

- If a field is marked as In the Field Set, the developer has rendered the field on the packaged Visualforce page by
default. Administrators can remove the field from the page after the field set is deployed by removing it from the In
the Field Set column.
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Package Upgrade Behavior
When you install a field set from a package, the fields in your field set may be modified from a later package upgrade. The
following table lists the impact on your field set after a package upgrade:

...Then In the Package Upgrade...If a package developer...

The modified field is placed at the end of the upgraded field
set in whichever column it was added to.

Changes a field from Unavailable to Available for the
Field Set or In the Field Set

The new field is placed at the end of the upgraded field set in
whichever column it was added to.

Adds a new field

The field is removed from the upgraded field set.Changes a field from Available for the Field Set or In the
Field Set to Unavailable

The change is not reflected in the upgraded field set.Changes a field from In the Field Set to Available for the
Field Set (or vice versa)

Note: Merging has the potential to remove fields in your field set. The only way to prevent this is to not install the
upgraded package. To retrieve data associated with removed fields, you will need to make a custom tab or implement
your own layout that uses the field.

Creating Field Sets
To create a new field set:

1. Navigate to the field set list of the appropriate object:

• For standard objects, click Your Name➤ Setup ➤ Customize, select the appropriate object from the Customize
menu, and click Field Sets.

• For custom objects, click Your Name➤ Setup ➤ Create ➤ Objects, and select one of the custom objects in the list.
Then click New above the field sets related list.

2. Enter a Field Set Label. This is the name presented to subscribers who install the field through a managed package.
3. Enter a Field Set Name for your field set. This is used by your Visualforce page to reference the field set.
4. In the Where is this used? area, provide a brief description of which Visualforce pages use the field set, and for what

purpose. This information helps a subscriber understand where and how an installed field set is being used, so that they
can populate it with their own fields.

5. To add fields to the field set, select which fields on the object to include and which to display. The first list contains all
the object's fields that are available to add to your field set. The second list contains fields marked as Available for
the Field Set. These fields are not initially visible on the Visualforce page. The third list contains fields marked as In
the Field Set. These fields are visible by default on a Visualforce page.

To move a field between the lists, highlight it by clicking on the field's name, and then click the appropriate left or right
arrows. The vertical order of the In the Field Set list indicates the order of how the fields render on Visualforce
pages.

6. Click Save.
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Adding Field Sets to Visualforce Pages
Field sets are referenced in Visualforce by combining the $ObjectType global variable with the keyword FieldSets. For
example, if your Contact object has a field set called properNames that displays three fields, your Visualforce page can
reference the field data through the following iteration:

<apex:page standardController="Contact">
<apex:repeat value="{!$ObjectType.Contact.FieldSets.properNames}" var="f">

<apex:outputField value="{!Contact[f]}" />
</apex:repeat>

</apex:page>

To properly render additional information, such as field labels or types, you must make your references like this:

<apex:page standardController="Contact">
<apex:repeat value="{!$ObjectType.Contact.FieldSets.properNames}" var="f">

{!$ObjectType.Contact.Fields[f].label}
({!$ObjectType.Contact.Fields[f].type}):
<apex:outputField value="{!Contact[f]}"/>
<br/>

</apex:repeat>
</apex:page>

You can have up to 50 field sets referenced on a single page.

As a developer, keep the following practices in mind:

• Subscribers with installed field sets can always add fields that your page didn't account for. Since there is no logic checking
involved, make sure that any field rendered through your field set works for all field types.

• We recommend that you add only non-essential fields to your field set. This ensures the scenario in which even if a
subscriber does remove all the fields in the field set, the Visualforce page still functions normally.

API Enhancements
Available in: Enterprise, Unlimited, and Developer Editions

Force.com API protocols, version 21.0, contain new features and bug fixes that improve the capabilities of applications that
leverage the Force.com platform. Considerable effort has been made to ensure backwards capability for applications that have
been written against previous versions of the API, starting with the SOAP Web ServicesAPI 2.5.

The new API protocols provide a number of powerful enhancements that further improve any integration already in place
between Salesforce and your other systems.

Spring '11 (API version 21.0) improvements:

• New and Changed Objects on page 71, including Chatter API Objects on page 71
• Bulk API Enhancements on page 74
• REST API Enhancements on page 74
• Web Service Connector on page 75
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New and Changed Objects
Objects are available using any Force.comAPI unless otherwise noted. Review the changes to existing objects and availability
of new objects in this release. You can also find links to changes in previous versions of objects.

Generally Available Enhancements
New Objects

The following new objects have been added in API version 21.0:

DescriptionObject

Represents the login history for all successful and failed
login attempts for organizations and enabled portals.

LoginHistory

Represents the link between a Salesforce CRM Content
document or Chatter file and where it's shared. A file can

ContentDocumentLink

be shared with other users, Chatter groups, records, and
Salesforce CRM Content workspaces.

Changed Objects
The following objects have been changed in API version 21.0:

• The KnowledgeArticle object now includes the ArticleNumber field, which is a unique number automatically
assigned to each article when it's created. You can't change the format or value for this field.

• The KnowledgeArticleVersion object now includes the Language field, which describes the language that the article
is written in, such as “French” or “Chinese (Traditional).”

Querying or searching articles in SOQL or SOSL requires that you specify the Language field in the WHERE clause.
The language must be the same for all article types.

• You can now perform the following actions on Chatter files via existing API objects:

- Update the name and description of an existing Chatter file by providing the ContentVersionId using the
ContentVersion object.

- Edit, revise, and delete Chatter files using the ContentVersion and ContentDocument objects.
- Retrieve and query Chatter files using the ContentVersion and ContentDocument objects.

• The ContentVersion object now supports search().
• The User object now includes the DefaultGroup Notification Frequency field, which specifies how often

a user receives Chatter group email notifications when joining groups. The default value is D for daily digests.

Chatter API Objects

New Chatter Objects
The following new objects have been added in API version 21.0.
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DescriptionObject

Indicates that a user has liked a feed item.FeedLike

Represents a request to join a private Chatter
group.

CollaborationGroupMemberRequest

Represents a dashboard component, which can
be a chart, metric, table, or gauge on a dashboard.
Access is read-only.

DashboardComponent

Represents a single feed item in the feed displayed
on a dashboard component.

DashboardComponentFeed

Represents the link between a Salesforce CRM
Content document or Chatter file and where it's

ContentDocumentLink

shared. A file can be shared with other users,
Chatter groups, records, and Salesforce CRM
Content workspaces.

Changed Chatter Objects
The following objects have been changed in API version 21.0.

Now includes
the

DefaultGroup
Notification
Frequency field

Now includes the
InsertedById

field

Now includes the
CommentCount
and LikeCount

fields

Can now be
deleted by users

with the
“Moderate

Chatter”
permission

Now includes the
LastModifiedDate

field

Object

AccountFeed

AssetFeed

CampaignFeed

CaseFeed

CollaborationGroupFeed

ContactFeed

ContentDocumentFeed

ContractFeed

DashboardFeed

EventFeed

FeedComment

FeedItem

FeedLike

FeedPost
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Now includes
the

DefaultGroup
Notification
Frequency field

Now includes the
InsertedById

field

Now includes the
CommentCount
and LikeCount

fields

Can now be
deleted by users

with the
“Moderate

Chatter”
permission

Now includes the
LastModifiedDate

field

Object

LeadFeed

NewsFeed

OpportunityFeed

Product2Feed

ReportFeed

SolutionFeed

TaskFeed

User

UserFeed

UserProfileFeed

UserProfileFeed

Now includes the LastModifiedDate field

Allows you to sort a feed by either:

• The most recent feed item only
• The most recent feed item or comment

When a feed item is created, LastModifiedDate is the same as CreatedDate. If a FeedComment is inserted on
that feed item, then LastModifiedDate becomes the CreatedDate for that FeedComment. Deleting the
FeedComment does not change the LastModifiedDate.

Ordering by CreatedDate DESC sorts the feed by the most recent feed item. Ordering by LastModifiedDate
DESC sorts the feed by both the most recent feed item or comment.

Can now be deleted by users with the “Moderate Chatter” permission
Users with the “Moderate Chatter” permission can now delete feed items and comments.

Note:  Because it does not include “View All Data”, users with the “Moderate Chatter” permission are able to
delete only the feed items and comments they are able to see.

Now includes the CommentCount and LikeCount fields
These fields denote the number of FeedLikes and FeedComments associated with a feed item.

73

Force.com API Enhancements



Now includes the InsertedById field
This field is the ID of the user who added this object to the feed. For example, if a client application migrates multiple
posts and comments from another application into a feed, then InsertedById is set to the ID of the logged-in user.

If the logged-in user has the Insert System Field Values for Chatter Feeds user permission, the create field property
is available on CreatedById and CreatedDate system fields for this object. This allows the logged-in user to set
these fields to the original post author and creation date upon migration instead of accepting the system field value when
migrated, which would be the logged-in user and the date the migration was performed, respectively. The fields can't
be updated after migration.

Now includes the DefaultGroup Notification Frequency field
The User object now includes the DefaultGroup Notification Frequency field, which specifies how often a
user receives Chatter group email notifications when joining groups.The default value is D for daily digests. This setting
only applies to new groups that a user joins or is added to, and users can still customize email frequency for each group
after they've joined. It doesn't change the notification frequency for groups that the user is already a member of.

Other Enhancements
• NewsFeed and UserProfileFeed: Queries retrieve feed items that include mentions from other users.
• CollaborationGroup now includes the LastFeedModifiedDate field, which shows the date of the last post or comment

on the group.
• You can now perform the following actions on Chatter files via existing API objects:

- Update the name and description of an existing Chatter file by providing the ContentVersionId using the
ContentVersion object.

- Edit, revise, and delete Chatter files using the ContentVersion and ContentDocument objects.
- Retrieve and query Chatter files using the ContentVersion and ContentDocument objects.

Bulk API Enhancements
The Bulk API uses REST principles and is optimized to process a large number of records asynchronously. Use it to load
large batches of data that are processed in the background. The Bulk API has been improved for API version 21.0:

Bulk API Queries—Pilot
The Bulk API pilot supports the query operation, with a few restrictions on SOQL. For more information, see the Bulk API
Developer's Guide.

Note:  Pilot services or features are exposed only for testing and are not currently available. Pilot services or features
may not be delivered on time or at all. Customers who purchase our services should make their purchase decisions
based upon features that are currently available.

REST API Enhancements
Force.com REST API leverages the simplified approach of REST to allow developers to more easily interact with other Web
2.0 applications such as Amazon.com AWS, Microsoft Azure, Google, Facebook, Twitter, and others:

• Interact with the application in a simplified way
• Integrate with third-party cloud systems and services
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• Support mashup and Web 2.0 projects

If you need to move large amounts of data, use the Bulk API, which is built on RESTful principles, but is asynchronous and
optimized for large data-loading tasks.

General Availability for the REST API
The REST API is generally available starting with version 21.0. Your organization must have API access enabled to use the
REST API. This feature is enabled by default for Unlimited, Enterprise, and Developer Editions. Some Professional Edition
organizations may also have the API enabled. If you cannot access REST API features, contact salesforce.com.

For more information, see the Force.com REST API Guide.

Web Service Connector

Available in: Enterprise, Unlimited, and Developer Editions

In API version 21.0, WSC (Web Service Connector) replaces Apache Axis 1.3 as the preferred SOAP Java client framework.
WSC is an open-source project and contains a command utility that generates Java source and bytecode files from WSDL
files. The Java samples illustrating use of API calls for the API, and Metadata API have been rewritten in the Web Services
API Developer's Guide..

Force.com Development as a Service Enhancements
Available in: Enterprise, Unlimited, and Developer Editions

Force.com Development as a Service (DaaS) provides the tools and technologies used by professional developers who build
applications for the Force.com platform, as well as those who migrate application changes between development organizations
and production. The DaaS feature area includes support for creating, retrieving, and deploying changes to your organization's
metadata.

Updated Metadata
The following metadata fields have been added or changed in Metadata API version 21.0:

DescriptionChangeFieldMetadata Type or Related
Object

Controls whether new records created by action
overrides are forwarded to the record type selection
page.

AddedskipRecordTypeSelectActionOverride

Display Chatter photos for up to 20 records in a
horizontal bar chart whose source report is
grouped by a user or group name field.

AddedshowPicturesOnChartsDashboard
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DescriptionChangeFieldMetadata Type or Related
Object

Display Chatter photos for up to 20 records in a
table component whose source report is grouped
by a user or group name field.

AddedshowPicturesOnTablesDashboard

Defines the field set on a standard or custom
object.

New typeFieldSet

Only allowed on Case layouts. If set, the
Knowledge sidebar displays on cases in the Service
Cloud console.

AddedshowKnowledgeComponentLayout

Allows partners to define branded emails.AddedbrandingPackage

A new valid value has been added:

x—The summary value to use for the X-axis of a
scatter chart.

UpdatedChartAxisReport

New valid values have been added: Scatter and
ScatterGrouped.

UpdatedChartTypeReport

Force.com IDE

Available in: Enterprise, Unlimited, and Developer Editions

This release includes new enhancements to the Force.com IDE. For complete details, visit the Force.com IDE release notes
page at http://wiki.developerforce.com/index.php/Force.com_IDE_Release_Notes.

Note: The latest version of the Force.com IDE is released after all instances have been upgraded. Release notes and
downloads are not available until that time.

Change Sets—Generally Available
Use change sets to move configuration changes using the Web interface. If you've struggled with moving changes from sandbox
to production, or have been searching for an easier tool to use than the Force.com IDE or the Force.com Migration Tool,
change sets will drastically increase your productivity.

The general availability release of change sets includes the following enhancements: You asked for it! This
enhancement is an idea from the IdeaExchange.

Delete

You can delete change sets that have been uploaded.

Named Filters Supported

Lookup filters are now automatically added before an outbound change set is uploaded.
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Change Sets

Available in Enterprise, Unlimited, and Free Editions

A change set is a means by which one organization can send customizations to another organization. For example, you could
create a new object in a sandbox organization and send it to your production organization using a change set. Change sets can
only contain modifications you can make through the Setup menu; therefore, you can't use a change set to upload a list of
contact records. In other words, change sets contain metadata, not data.

When you want to send customizations from your current organization to another organization, you create an outbound change
set. Once you send the change set, the receiving organization sees it as an inbound change set.

Figure 2: Outbound and Inbound Change Sets

Sending a change set between two organizations requires a deployment connection. Currently, change sets can only be sent
between organizations that are affiliated with a production organization, for example, a production organization and a sandbox,
or two sandboxes created from the same organization.

Components Available in Change Sets
The following types of components may be added to a change set:

• Analytic Snapshot
• Apex Class
• Apex Sharing Reason
• Apex Trigger
• App
• Button or Link
• Custom Field
• Custom Object
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• Custom Report Type
• Custom Setting
• Dashboard
• Document
• Email Template
• Folder
• Home Page Component
• Home Page Layout
• Letterhead
• List View
• Page Layout
• Record Type
• Remote Site
• Report
• S-Control
• Static resource
• Tab
• Validation Rule
• Visualforce Component
• Visualforce Page
• Workflow Email Alert
• Workflow Field Update
• Workflow Outbound Message
• Workflow Rule
• Workflow Task

Note:  If you create or modify components that are not available in a change set, you can't send those components
from one organization to another in a change set. In this case, migrate the changes manually by repeating the steps
you performed when you created or modified the component.

Deployment Connections

User Permissions Needed

“Deploy Change Sets”To edit deployment connections:

In order for change sets to be sent from one organization to another, a deployment connection is required between the
organizations. Deployment connections can't be created between arbitrary organizations; instead, a deployment connection
is created between all organizations affiliated with a production organization. For example, if you have a production organization
(Prod) and two sandboxes (Dev and Test), a deployment connection is created between production and each sandbox (Prod
and Dev, and another connection between Prod and Test), as well as between the sandboxes (Dev and Test).

A deployment connection alone doesn't enable change sets to be sent between organizations. Each organization must be
authorized to send and receive change sets.This added level of security enforces code promotion paths and keeps organizations'
setup metadata from being overwritten by mistake.
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For example, the following figure illustrates one possible migration path for a production organization and two sandboxes. In
this example, the production organization can only receive changes that have been fully tested, so only the Test sandbox is
authorized to upload change sets to production. In order to synchronize development projects with the production organization,
the Prod organization can send change sets to the Dev sandbox, but not to the Test sandbox. Finally, because the features in
development need iterative testing, Dev and Test sandboxes should be able to send change sets back and forth.

Figure 3: Change Set Authorization Enforces Code Path

Note: This illustration describes one possible code migration path. Your department must create its own policies for
organizations to send and receive change sets to one another.

Viewing Available Deployment Connections

A deployment connection enables customizations to be copied from one organization to another.The deployment connections
list shows which organizations are authorized to upload changes to this organization, and which organizations allow this
organization to upload changes to them.

To view available connections, click Your Name➤ Setup ➤ Deploy ➤ Deployment Connections

Action

Click Edit next to the organization that you want to allow or disallow change sets from.

Name

A list of organizations that have deployment connections to the organization you are currently logged into. Click the
name of an organization to view more information about the connection.

Description

A brief description of the connected organizations.

Type

The type of organization you are connected to. Possible values are Production, Full Copy Sandbox, Configuration-only
Sandbox, and Developer Sandbox.

Upload Authorization Direction

The arrows show the direction in which uploads can occur. A broken line means that no change sets are authorized in
either direction.To authorize the connected organization to send you inbound change sets, edit the deployment connection
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for this organization. If you want to send outbound change sets to a connected organization, the administrator for that
organization must edit the connection for that organization.

Viewing Details of a Deployment Connection

A deployment connection enables customizations to be copied from one organization to another.The deployment connections
list shows which organizations are authorized to upload changes to this organization, and which organizations allow this
organization to upload changes to them.

To view connection details:

1. Click Your Name➤ Setup ➤ Deploy ➤ Deployment Connections.
2. Click the name of the organization you want to view.

Name

The name of the selected organization. This is not the organization you are logged into.

Description

A brief description of the organization.

Type

The type of organization you are connected to. Possible values are Production, Full Copy, Configuration-only, and
Developer.

Allow Inbound Changes

If selected, the named organization can send change sets to the organization you are currently logged into. This is a
read-only field and can only be modified by selecting Allow Inbound Changes in the target organization.

Accepts Outbound Changes

If selected, the named organization allows change sets to be sent to it from the organization you are currently logged
into.

Authorizing a Deployment Connection

In order for another organization to send change sets to the organization you are logged into, you must authorize the inbound
change set:

1. Click Your Name➤ Setup ➤ Deploy ➤ Deployment Connections.
2. Click Edit next to the organization you want to authorize.
3. Select Allow Inbound Changes.
4. Click Save.
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Outbound Change Sets

User Permissions Needed

“Create and Upload Change Sets,”

“Create AppExchange Packages,”

AND

“Upload AppExchange Packages”

To create, edit, or upload outbound change sets:

An outbound change set is a change set created in the organization you are logged into and that you want to send to another
organization. Typically, an outbound change set is used for customizations created and tested in a sandbox and then sent to
a production organization.

Sending an outbound change set to another organization doesn't guarantee that the changes will be implemented in that
organization. The change set must deployed (accepted) by the target organization before the changes take effect.

Note:  Change sets are limited to 2,500 components and a total file size of 400 MB.

Outbound Change Sets

An outbound change set is a change you want to send from the organization you are logged into to another organization. To
view outbound change sets, click Your Name➤ Setup ➤ Deploy ➤ Outbound Change Sets.

• To create a new change set, click New.
• To view the details of an existing change set, click its name.

Cloning an Outbound Change Set

You can create a copy of an existing change set by cloning it.

1. Click Your Name➤ Setup ➤ Deploy ➤ Outbound Change Sets.
2. Click the name of the change set you want to clone.
3. Click Clone.

Selecting Components for an Outbound Change Set

To select the components in an outbound change set:

1. Click Your Name➤ Setup ➤ Deploy ➤ Outbound Change Sets.
2. In the Change Sets list, click the name of a change set, or create a new one.
3. Click Add to add components.
4. Choose the type of component and the components you want to add, and then click Add to Change Set.
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5. Click Add Profiles to add profile settings to the change set.
6. Optionally, click View/Add Dependencies to add dependent components.

Note:  Dependent components rely on the existence of other components. Unless you are certain that the dependent
components exist in every organization this change set will be deployed to, it's a good idea to add dependent
components to the change set.

Uploading an Outbound Change Set

Once you've assembled the components in a change set, you can upload it to another organization. Note that once you upload
a change set, you can't edit it or recall it.

1. Click Your Name➤ Setup ➤ Deploy ➤ Outbound Change Sets.
2. Click the name of a change set.
3. Select the organization you want to send the change set to.
4. Click Upload.

Note:  Outbound change sets expire six months after upload, at which time the change set is permanently deleted.

Uploading Change Sets During Server Upgrades

During server upgrades, production and sandbox environments may not be running the same version of the platform. Some
components may have new functionality or other changes that will not allow you to deploy that type of component until the
production organization is running the same version as sandbox.

If you upload a change set that has components that can't be deployed, the system detects which components can't be deployed,
and gives you the option of uploading the remaining components.

For example, Apex classes are automatically upgraded whenever a new version of the platform is released. If you create a change
set in a sandbox during the sandbox preview and then upload that change set to a production organization, the system won't
allow you to upload Apex classes. Likewise, other types of components that have changes that are incompatible between
versions will be removed from the change set. However, components that remained unchanged between versions can be
migrated freely.

Viewing and Adding Dependent Components to a Change Set

A dependency is a relationship where one or more components must exist for another component to exist. It's a good idea to
add dependent components to a change set, unless you are sure that the dependent components exist in every organization
where this change set will be deployed.

To add dependent components to an outbound change set:

1. Click Your Name➤ Setup ➤ Deploy ➤ Outbound Change Sets.
2. In the Change Sets list, click the name of a change set.
3. Click View/Add Dependencies.
4. On the Component Dependencies page, select the dependent components you wish to deploy and click Add to Change

Set.
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Viewing the Source of a Metadata Component

Before you upload or deploy a change set, you can view the source of each metadata component in the change set. This allows
you to verify that you are uploading or deploying the correct changes.

If the metadata component in the change set is a profile, then the XML source displayed depends on the contents of the
change set. For example, profiles only contain field-level security for fields included in the custom object that are part of the
change set.

For information about the fields, attributes, and settings of the available metadata types, see the Metadata API Developers
Guide

Note: You can't view the source of a Static Resource, Document, or Folder.

Outbound Change Set Validation Errors

If you receive an error about cross-version validation, then the organization used to create the outbound change set is running
on a different platform version than the organization receiving the change set. This error typically occurs during upgrades,
because organizations may be upgraded at different times. If you receive this error, you can only deploy those components that
are compatible between versions.

Deleting an Outbound Change Set

To delete an outbound change set:

1. Click Your Name➤ Setup ➤ Deploy ➤ Outbound Change Sets.
2. Click the name of the change set you want to delete.
3. Click Delete.

Inbound Change Sets

User Permissions Needed

“Deploy Change Sets”To deploy inbound change sets:

An inbound change set is a change set that has been sent from another organization to the organization you are logged into. A
change sent must be deployed for the changes to take effect. You can deploy the contents of an inbound change set as a whole,
but not on a component-by-component basis.

Viewing Inbound Change Sets

The Inbound Change Sets page lists change sets awaiting deployment, as well as the history of deployed change sets. To view
inbound change sets, click Your Name➤ Setup ➤ Deploy ➤ Inbound Change Sets.
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Note:  Inbound change sets are permanently deleted six months after the change set is uploaded.

Viewing Change Set Details

The Change Sets detail page lists information about a particular change set.

1. Click Your Name➤ Setup ➤ Deploy ➤ Inbound Change Sets.
2. Click the name of a change set.

Validating a Change Set

You can validate a change set without deploying changes. Validating a change set allows you to view the success or failure
messages you would receive with an actual deploy.

1. Click Your Name➤ Setup ➤ Deploy ➤ Inbound Change Sets.
2. Click the name of a change set.
3. Click Validate.

Note: You can't make any changes to your organization while a test deployment is in progress.

4. After the validation completes, click View Results.

Deploying a Change Set

To deploy a change set:

1. Click Your Name➤ Setup ➤ Deploy ➤ Inbound Change Sets.
2. In the Change Sets Awaiting Deployment list, click the name of the change set you want to deploy.
3. Click Deploy.

A change set is deployed in a single transaction. If the deployment is unable to complete for any reason, the entire transaction
is rolled back. After a deployment completes successfully, all changes are committed to your organization and the change set
cannot be rolled back.

Note: The Force.com platform requires at least 75% of your code to be covered by unit tests before you can deploy it
to a production organization. Ideally, you should strive for 100% coverage.The code coverage restriction is not enforced
for sandbox or Developer Edition organizations.

Implementation Tips
Permissions required to use change sets

To send a change set to another organization, a user must have “Create and Upload Change Sets,” “Create AppExchange
Packages,” and “Upload AppExchange Packages” profile permissions.
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To deploy a change set received from another organization, a user must have the “Deploy Change Sets” profile permission.

Authorization required to upload changes

Before you can deploy a change set from one organization to another, an administrator in the target organization must
authorize uploads across the deployment connection between the two organizations.

Deployment Connections list displays all connections

The Deployment Connections list is automatically populated with your production organization and all sandboxes. It
is possible to deploy between any of these organizations, but no other organizations.

Change set connections unavailable during maintenance

Authorizing deployment connections and uploading pages require information from the production organization, and
are unavailable when production is undergoing maintenance. During this time you can construct outbound change sets
but not upload them.

Sandboxes must be available

If an organization has no sandboxes provisioned, the user may see an Insufficient Privileges error on the Deployment
Connections page.

Deployment is a one-way transaction

A change set is deployed in a single transaction. If the deployment is unable to complete for any reason, the entire
transaction is rolled back. After a deployment completes successfully, all changes are committed to your organization
and the change set cannot be rolled back.

Best Practices
Deploy all dependent components

Make sure each change set contains all interdependent components that don't exist in the target organization. If you try
to deploy a component that refers to another component missing from the target organization and from the change set,
the deployment fails.

Change sets give you fine-grained control over what you deploy. For example, you can migrate custom fields individually.
To deploy a custom object and all of its fields, you must add the custom object and every field to the change set; adding
just the custom object to the change set won't cause deployment to fail, but results in an empty custom object.

Clone a change set to add dependent components to an uploaded change set

After you upload a change set, you can't change its contents. If you need to add dependent components to a change set
you already uploaded, clone the change set, add the dependent components, and then upload it again.

Plan deployments around maintenance schedule

Plan your deployment activities around the maintenance schedule for both your production and sandbox organizations.
Some features require information from your production organization when accessed from a sandbox.

Validate change sets before deployment

You can perform a test deployment of an inbound change set to view the success or failure messages that would occur
with an actual deployment. This is a good idea if you are planning a deployment on a schedule (for example during
low-use hours) and want to determine if the deployment will succeed ahead of time. However, you don't need to perform
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a test deployment every time you deploy, as this process takes time to complete. To test deploy an inbound change set,
click its name and then click Validate.

View component details

You can view the XML representation of a component before you upload an outbound change set or deploy an inbound
change set.

Change sets limited to 2500 components and 400 MB

Change sets are limited to 2500 components and a total file size of 400 MB. If your change set exceeds either of these
limits, you can create separate change sets for email templates, dashboards, and reports. These components are often the
most numerous and have fewer dependencies.

Deleting and renaming components

You can't use change sets to delete or rename components. To delete components, use the Web interface on the target
organization. To rename a component, first delete the component on the target organization and then upload the new
component in a change set.

Security Enhancements
Available in: All Editions

Spring '11 introduces several new features that enhance security.

Enforce Password History Now Can Remember Up To 15 Passwords

As part of your organization's password policies, you can now set Enforce Password History to remember up to 15
passwords. Use this to force users to create a new, unique password when their password expires. You can set the Enforce
Password History by clicking Your Name➤ Setup ➤ Security And Sharing ➤ Setting Password Policies.

Email Security for Remote Access Apps

A remote access application is an application external to Salesforce that uses the OAuth protocol to verify both the
Salesforce user and the external application. When creating a new remote access application definition, the Contact
Email field is now required. Create remote access applications by clicking Your Name➤ Setup➤Develop➤Remote
Access.

New Administrative Permission for Reset User Passwords and Unlock Users

When creating a user profile, there is a new administrative permission called Reset User Passwords and Unlock Users.
Users with this permission enabled can reset passwords and unlock users. Specify this permission by clicking Your Name
➤ Setup ➤ Manage Users ➤ Profiles

New Error Messages for Access Token Request

There are three new error messages if there is a problem with an access token request.

user has been set to inactive by the administratorinactive_user

organization is locked, closed, or suspendedinactive_org

number of login attempts has been exceededrate_limit_exceeded
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Delegated Authentication for Single Sign-On

This feature is only available if you have delegated authentication enabled for you organization. Delegated authentication
must be turned on by salesforce.com. When delegated authentication is enabled, Salesforce does not validate a user's
password. Instead, it makes a Web services call to your organization to establish authentication credentials for the user.

There is new Force Delegated Authentication Callout checkbox on the single sign-on settings page. Check this box
if you always want Salesforce to make a callout to the Web services authentication endpoint in your organization,
regardless of profile restriction failures. You can set this field by clicking Your Name➤ Setup➤ Security Controls➤
Single Sign-On Settings.

Customizable Error Messages

You can now customize the error message a user receives when their password is locked, or when they are in the process
of changing their password.There are new customizable Message and Help Link fields. Customize these error messages
by clicking Your Name➤ Setup ➤ Security Controls ➤ Password Policies.

Create a Filtered View of the Login History Page

You can now add and save customized views on the Login History page. Filter your results by Login URL or Login
Time to help search for particular entries in the list by clicking Your Name➤ Setup➤Manage Users➤Login History.

Encryption Management

Fields that are encrypted using encrypted custom fields, such as social security number or credit card number, use a
master encryption key to encrypt the data. This key is automatically assigned when you enable encrypted fields for your
organization. You can manage the master key based on your organization’s security needs and regulatory requirements.
Contact salesforce.com to enable master encryption key administration. Manage your master encryption key by clicking
Your Name➤ Setup ➤ Security ➤ Manage Certificates and Keys

Additional Force.com Enhancements
Google Chrome Browser Support

Available in: All Editions

You asked for it! Salesforce addresses the following ideas on the IdeaExchange: Google Chrome and Google
Chrome Frame plug-in for Microsoft® Internet Explorer.

With Spring '11, Salesforce now supports Google Chrome version 8.0.x and Google Chrome Frame plug-in for Microsoft®
Internet Explorer. For more information, see “Supported Browsers” in the Salesforce online help.

Setup Audit Trail Enhancements

Available in: Contact Manager, Group, Professional, Enterprise, Unlimited, and Developer Editions

With Spring '11, the setup audit trail now tracks changes to Force.com Flow files.
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Delegated Approval Email Settings

Available in: Enterprise, Unlimited, and Developer Editions

In Summer '10, we gave you the ability to set your approval request email preferences. With Spring '11, you can set preferences
as a delegated approver.

In the Approver Settings section of the User detail page, two new options have been added to the Receive Approval Request
Emails drop-down list. To get there, click Your Name➤ Setup ➤ My Personal Information ➤ Personal Information,
then click Edit on the User detail page.

The two new items on the Receive Approval Request Emails drop-down list are:

• If I am an approver or delegated approver

• Only if I am a delegated approver

When an approval request email is sent to the assigned approver, the delegated approver also receives an email notification
that there is an approval request to review. Delegated approvers can't reassign approval requests; they can only approve or
reject approval requests.

Note: When an approval request is assigned to a queue, each queue member's delegated approver also receives an
approval request email notification. For more information about approval requests and queues, see “Approval Process
Considerations” in the Salesforce online help.

Daily Limit on Workflow Alert Emails

Available in: Enterprise, Unlimited, and Developer Editions

To prevent abuse of email limits, Spring '11 introduces a limit on the number of email alerts that an organization can send
using workflow or approval processes in a 24-hour period. The daily limit for emails sent from workflow and approval-related
email alerts is 1,000 per standard Salesforce license per organization. The overall organization limit is 2 million. When the
daily limit is reached, a warning email goes out to the default workflow user. If the default workflow user isn't set, then the
warning email is sent to an active system administrator.

After your organization has reached its limit:

• If a workflow rule with an action and an email alert is triggered, only the email action is blocked.
• Final approval, final rejection, approval, rejection, and recall email actions are blocked.
• An error message is added to the debug log.

The following items don't count against the workflow email limit:

• Approval notification emails
• Task assignment notifications
• Lead assignment rules notifications
• Case assignment rules notifications
• Case escalation rules notifications
• Force.com sites usage alerts

The limit restriction is based on activity in the 24-hour period starting and ending at midnight GMT. Adding or removing
a user license immediately adjusts the limit's total. If you send an email alert to a group, every recipient in that group counts
against your daily workflow email limit.
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Sharing Enhancements

Available in: Professional, Enterprise, Unlimited, and Developer Editions

Sharing Rule Management for Large Organizations
Now it's easier to manage large numbers of queues, public groups, roles, or territories in sharing rules. Typically, when
creating a sharing rule, the second field in the owned by members of and Share with lines is a drop-down list.
With Spring '11, if your organization has more than 200 queues, public groups, roles, or territories, the second field is
a lookup field.

For more information on creating sharing rules, see “Working with Sharing Rules” in the Salesforce online help.

Apex Sharing Reasons Available in Professional Edition
Starting in Spring '11, Apex sharing reasons are available in Professional Edition, as well as Enterprise, Unlimited, and
Developer Editions. You can create Apex sharing reasons for individual custom objects to indicate why sharing was
implemented, simplify the coding required to update and delete sharing records, and share a record multiple times with
the same user or group. For more information, see “Creating Apex Sharing Reasons” in the Salesforce online help.

Globalization Enhancements
Translation Workbench Export and Import Options

You asked for it! This enhancement is from an idea on IdeaExchange.

Available in: Professional, Enterprise, Unlimited, and Developer Editions

Spring '11 introduces export and import options for the Translation Workbench, which you can use to export, edit, and
import all of your Salesforce organization's translatable customization labels and efficiently translate them into Salesforce's
supported languages.

To access these features, go to Your Name ➤ Setup ➤ Administration Setup ➤ Translation Workbench, and select
either the Export or Import option.

Additional Language Support for Force.com

Available in: Professional, Enterprise, Unlimited, and Developer Editions

Salesforce now supports the following platform languages:

• Bosnian (bs)
• Croatian (hr)
• Macedonian (mk)
• Moldovan (ro_MD)
• Slovenian (sl)

To use any of these languages, ask your salesforce.com representative to enable platform languages.
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Additional End User Language Support

Available in: Professional, Enterprise, Unlimited, and Developer Editions

Salesforce now supports Norwegian (no) as an end user language.To use Norwegian, ask your salesforce.com representative
to enable end user languages.

Ability to Translate and Override Names of Custom Objects from Managed Packages

Available in: Professional, Enterprise, Unlimited, and Developer Editions

Administrators can now translate and override names of custom objects that come from managed packages by renaming
tab and field labels.

Outbound Port Enhancement
The outbound ports you can specify for remote sites has been expanded:

• 80: This port only accepts HTTP connections.
• 443: This port only accepts HTTPS connections.
• 1024–66535 (inclusive): These ports accept HTTP or HTTPS connections.

Previously, you could only connect to ports 80, 443, and 7000–10000 (inclusive).
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