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About the Release Notes
The Release Notes are a comprehensive user guide for the latest release of Salesforce.com. Unlike a traditional release notes
document that includes only a simple list of enhancements, the Salesforce.com Release Notes give you everything you need
to get up and running with the new features and enhancements in the latest release.

What's Included in the Release Notes
For every new major enhancement, the Release Notes provide:

• A brief, high-level description of the functionality
• Implementation tips to help you get started with setup and administration
• Best practice tips to help you maximize the benefit of the functionality
• Complete end-to-end instructions on how to set up and use the functionality

Beyond the major new features, the Additional Enhancements sections include a list and brief description of every other
enhancement or functional change included in the latest release—everything from email enhancements, to new report types,
to security and packaging enhancements.

Let the Release Notes be your guide to success with the latest release from salesforce.com!

Your Feedback Matters
We know how important the Release Notes, online help, and documentation are to your company's success with Salesforce.com.
To continually improve the content we deliver to you, we want to know what works and what doesn't. Let us know!

• Feedback forms—Every HTML documentation page, both in the online help and in our developer guides at Developer
Force, includes a feedback form for you to submit your suggestions, corrections, and feedback about the documentation.
Let us know what you think!

• IdeaExchange—We're listening to your ideas too. Summer '10 includes some of your top ideas. Visit IdeaExchange for a
complete list of ideas coming in Summer '10.

Want to be notified whenever we publish new documentation or make significant updates to existing documentation? Follow
us on Twitter: @salesforcedocs.
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Summary of Summer '10 Features and Impact on
Salesforce.com Users

Summer '10 has features that immediately impact all users after the release. You may want to communicate these changes to
your users beforehand so they are prepared. Other features require direct action by an administrator before users can benefit
from the new functionality.

The following table summarizes the Summer '10 features and their impact on users. Review the feature details for the applicable
Salesforce.com Editions.

Collaboration Cloud Enhancements

Salesforce Chatter

Contact
salesforce.com to

enable this feature.

Not automatically
visible. Feature is

available but
requires some

setup.

Automatically
visible to all

administrators. No
setup required.

Automatically
visible to all users.
No setup required.

Feature

Salesforce Chatter

Chatter in the Mobile Application

Sales Cloud Enhancements

Campaigns

Contact
salesforce.com to

enable this feature.

Not automatically
visible. Feature is

available but
requires some

setup.

Automatically
visible to all

administrators. No
setup required.

Automatically
visible to all users.
No setup required.

Feature

Campaign Sales Alerts

Lead and Contact Fields Available in
Campaign Member Custom Formula
Field

Enhanced Campaign History
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Email

Contact
salesforce.com to

enable this
feature.

Not automatically
visible. Feature is

available but
requires some

setup.

Automatically
visible to all

administrators.
No setup
required.

Automatically
visible to all users.

No setup
required.

Feature

Cloud Scheduler

Deleting Attachments Sent as Links

Warning When Sending Emails to Contacts
or Leads Who Don't Receive Mass Emails

Multiple Email Addresses for Contacts and
Leads

Email Compliance Footers

New Merge Field for Converting Articles to
PDF Attachments

Opportunities and Quotes

Contact
salesforce.com to

enable this feature.

Not automatically
visible. Feature is

available but
requires some

setup.

Automatically
visible to all

administrators. No
setup required.

Automatically
visible to all users.
No setup required.

Feature

Quotes Template Editor—Beta

Quotes Available in Professional Edition
Organizations

Opportunities with Quotes and Quote
Line Items Report

Opportunities with Quotes and Quote
PDFs Report

Opportunity Reports Have New
Opportunity Owner Columns

Opportunity Stage Picklist Value Update
Behavior Enhanced

New Opportunity Page—Pilot
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Partner Relationship Management

Contact
salesforce.com to

enable this feature.

Not automatically
visible. Feature is

available but
requires some

setup.

Automatically
visible to all

administrators. No
setup required.

Automatically
visible to all users.
No setup required.

Feature

New: PRM Portal Implementation
Guide

Partner Portal Lead Inbox Home Page
Component

Salesforce CRM Content

Contact
salesforce.com to

enable this feature.

Not automatically
visible. Feature is

available but
requires some

setup.

Automatically
visible to all

administrators. No
setup required.

Automatically
visible to all users.
No setup required.

Feature

Salesforce CRM Content Included in
All Organizations

Enable or Disable Salesforce CRM
Content for Your Organization

Autoassign Salesforce CRM Content
Feature Licenses

Salesforce CRM Content Search
Includes Salesforce Chatter Files

Previews for Microsoft Office 2007
Files—Pilot

Content Delivery Recipients Can
Preview Microsoft 2007 Files—Pilot

Post Content to Chatter Feeds with New
Workspace Privilege

Salesforce Mobile

Contact
salesforce.com to

enable this feature.

Not automatically
visible. Feature is

available but
requires some

setup.

Automatically
visible to all

administrators. No
setup required.

Automatically
visible to all users.
No setup required.

Feature

Chatter in the Mobile Application

Salesforce Mobile for BlackBerry
Enhancements
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Contact
salesforce.com to

enable this feature.

Not automatically
visible. Feature is

available but
requires some

setup.

Automatically
visible to all

administrators. No
setup required.

Automatically
visible to all users.
No setup required.

Feature

Salesforce Mobile for iPhone
Enhancements

Windows Mobile Peripheral Support

Support for Attachments in Salesforce
Mobile for Windows Mobile

Mobile Views Enhancement

Other Sales Cloud Enhancements

Contact
salesforce.com to

enable this feature.

Not automatically
visible. Feature is

available but
requires some

setup.

Automatically
visible to all

administrators. No
setup required.

Automatically
visible to all users.
No setup required.

Feature

Previews Available for Chatter Feed
Attachments in the Notes and
Attachments Related List

Service Cloud Enhancements

Community

Contact
salesforce.com to

enable this feature.

Not automatically
visible. Feature is

available but
requires some

setup.

Automatically
visible to all

administrators. No
setup required.

Automatically
visible to all users.
No setup required.

Feature

Answers Available in Force.com Sites

Escalating a Question to a Case

Creating an Article from a Reply

Workflow Support for Questions

Data Categories Visible to Users
Without Roles

Community Members Can Delete Their
Posts
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Contact
salesforce.com to

enable this feature.

Not automatically
visible. Feature is

available but
requires some

setup.

Automatically
visible to all

administrators. No
setup required.

Automatically
visible to all users.
No setup required.

Feature

Standard Users Can Change Their
Community Nicknames

New API Object for Data Category
Selections

Customer Portal

Contact
salesforce.com to

enable this feature.

Not automatically
visible. Feature is

available but
requires some

setup.

Automatically
visible to all

administrators. No
setup required.

Automatically
visible to all users.
No setup required.

Feature

Enabling High Volume Customer Portal
Users

Salesforce Knowledge

Contact
salesforce.com to

enable this feature.

Not automatically
visible. Feature is

available but
requires some

setup.

Automatically
visible to all

administrators. No
setup required.

Automatically
visible to all users.
No setup required.

Feature

Creating an Article While Closing a
Case

Creating an Article from a Reply

Sending Articles as PDF Attachments
on Case Email

Using Suggested Articles to Solve Cases

Customizing Access for Article
Managers

Following Articles in Salesforce Chatter
Feeds

New Custom Report Options

Data Categories Visible to Users
Without Roles

Email Notification of Assigned Articles

Article Previews for all Channels
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Contact
salesforce.com to

enable this feature.

Not automatically
visible. Feature is

available but
requires some

setup.

Automatically
visible to all

administrators. No
setup required.

Automatically
visible to all users.
No setup required.

Feature

Showing Article Summaries in List
Views

File Fields Supported in Custom
Templates

New API Object for Articles

New API Object for Data Category
Selections

New Metadata API Component for
Article Types

Custom Cloud Enhancements

Administration and Sharing

Contact
salesforce.com to

enable this feature.

Not automatically
visible. Feature is

available but
requires some

setup.

Automatically
visible to all

administrators. No
setup required.

Automatically
visible to all users.
No setup required.

Feature

Enhanced Security for Custom Fields in
Portal Profiles

Analytics

Contact
salesforce.com to

enable this feature.

Not automatically
visible. Feature is

available but
requires some

setup.

Automatically
visible to all

administrators. No
setup required.

Automatically
visible to all users.
No setup required.

Feature

Dynamic Dashboards

Drag-and-Drop Dashboard Builder

Dashboard Table Summaries

Report Builder
Enhancements—Developer Preview
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Apex and Visualforce

Contact
salesforce.com to

enable this feature.

Not automatically
visible. Feature is

available but
requires some

setup.

Automatically
visible to all

administrators. No
setup required.

Automatically
visible to all users.
No setup required.

Feature

Force.com Apex Code Enhancements

Well-formed XML Required for All
Visualforce Pages and Components

Ability to Add Dependent Picklists

View State Inspector—Pilot

Postback Requests Return ID Parameter

Rendering of Contact Information Detail
Page Prohibited for Person Accounts

Removed Rendering of Related List
Hover Panels

String Literals for value Attribute in
<apex:attribute> Must Evaluate to
an Object Type

Customization

Contact
salesforce.com to

enable this feature.

Not automatically
visible. Feature is

available but
requires some

setup.

Automatically
visible to all

administrators. No
setup required.

Automatically
visible to all users.
No setup required.

Feature

Rich Text Area Enhancements

Dependent Lookups and Other Lookup
Filters Enhancements—Beta

Globalization and User Interface Enhancements

Contact
salesforce.com to

enable this feature.

Not automatically
visible. Feature is

available but
requires some

setup.

Automatically
visible to all

administrators. No
setup required.

Automatically
visible to all users.
No setup required.

Feature

Globalization Enhancements

New User Interface Theme Enabled
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Packaging

Contact
salesforce.com to

enable this feature.

Not automatically
visible. Feature is

available but
requires some

setup.

Automatically
visible to all

administrators. No
setup required.

Automatically
visible to all users.
No setup required.

Feature

Push Patch Updates

Changes to Deleted Components in a
Managed Package

Packageable Remote Site Settings

Security

Contact
salesforce.com to

enable this feature.

Not automatically
visible. Feature is

available but
requires some

setup.

Automatically
visible to all

administrators. No
setup required.

Automatically
visible to all users.
No setup required.

Feature

Increased Security When Logged in as
Another User

Default Certificate Key Size Changed

Maximum Number of Certificates Now
Enforced

New Custom Page URL for SAML
Errors

Download SAML Metadata

Invalid SAML Assertion Used to
Populate SAML Assertion Validator

New Encryption, Decryption, and Key
Generating Methods

Callback URL Now Takes Protocols
Other than HTTPS

Remote Access Applications and
Packaging Changes

Sites Single Sign-On

My Domain on Sandbox
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Sites

Contact
salesforce.com to

enable this feature.

Not automatically
visible. Feature is

available but
requires some

setup.

Automatically
visible to all

administrators. No
setup required.

Automatically
visible to all users.
No setup required.

Feature

Sites Single Sign-On

Administrator Preview for Force.com
Sites

Rewriting URLs for Sites

New Cookie Class for Force.com Sites

New getCookies and setCookies
Methods for PageReference to create
and store cookies in Apex.

Web Services API and Developer Tools

Contact
salesforce.com to

enable this feature.

Not automatically
visible. Feature is

available but
requires some

setup.

Automatically
visible to all

administrators. No
setup required.

Automatically
visible to all users.
No setup required.

Feature

Adobe Flash Builder for Force.com
General Availability

Web Services API Enhancements

Bulk API Enhancements

Force.com Development as a Service

Workflow and Approvals

Contact
salesforce.com to

enable this feature.

Not automatically
visible. Feature is

available but
requires some

setup.

Automatically
visible to all

administrators. No
setup required.

Automatically
visible to all users.
No setup required.

Feature

Approval Email Settings

Workflow Support for Questions
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Documentation Enhancements

Contact
salesforce.com to

enable this feature.

Not automatically
visible. Feature is

available but
requires some

setup.

Automatically
visible to all

administrators. No
setup required.

Automatically
visible to all users.
No setup required.

Feature

New: PRM Portal Implementation
Guide

New: Salesforce.com Limits Quick
Reference
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Salesforce Chatter
Available in: Group, Professional, Enterprise, Unlimited, Contact Manager, and Developer Editions

Note: Salesforce Chatter is enabled by default for organizations created after June 22, 2010. For existing organizations,
you must enable Salesforce Chatter.

Summer '10 introduces Salesforce Chatter, a collaboration application that helps you connect with coworkers inside your
Salesforce.com organization and share business information securely and in real time. Salesforce Chatter includes the following
features:

Profiles

Every user now has a Chatter profile that can be customized with a photo, contact information, and description. View
your profile on the new Profile tab or by clicking your name at the top of any page, on the header bar of the Home tab,
or in a Chatter feed. View profiles for other people in your organization on the new People tab or by clicking a person's
name in a Chatter feed or on a record detail page.

Chatter Groups

Use Chatter groups to collaborate with specific people. Create public or private groups, depending on who you want to
be able to join your group and see group activities.

Profile Tab

Use the Profile tab to view and update your own profile and to update your status.

People Tab

Use the People tab to see a list all of the people in your organization, search for people, view profiles, and follow and
unfollow people.

Groups Tab

The Groups tab provides a list of Chatter groups in your organization. From the Groups tab, you can search for and
join groups.

Salesforce Chatter App

Use the Salesforce Chatter app, available in the app menu in the top right corner of any page, to easily access the People
and Profile tabs.

Feeds

View Chatter feeds to see updates from people and records. You can also post to feeds and comment on updates. Feeds
appear:

COLLABORATION CLOUD
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• On Chatter profiles, where you can see updates by a single user. View your own profile to see your updates and to
update your status.

• On record detail pages, where you can see updates to a single record.
• On the Home tab, where you can see your updates, status updates of people you follow, and updates to records you

follow.
• On Chatter groups, where you can see updates to a group by its members. You'll only see feeds for public groups and

private groups you're a member of.

Feed Attachments

Share files and links by attaching them to a post on a Chatter feed. Attachments can include all file types, from traditional
business documents such as Microsoft® PowerPoint presentations to audio files, video files, Web pages, and Web links.

Feed Tracking

Enabling feed tracking for objects, such as opportunities or accounts, allows people to follow records of that object type.
Following a record means that you see updates to that record in your Chatter feed on the Home tab. Administrators
can enable feed tracking in Setup ➤ Customize ➤ Chatter ➤ Feed Tracking. Additionally, administrators can select
the fields that are tracked for each object, so that people can see changes to those fields in their Chatter feed. For details
on tracking knowledge base articles in Chatter feeds, see Salesforce Knowledge Enhancements on page 66.

Follow and Unfollow Links

You can toggle the Follow and Unfollow links on profiles and records. When you follow a person or record, status
updates or changes to the record display in your feed on the Home tab. When you unfollow a person or record, you no
longer see feed updates from that person or record.

Stop Automatically Following Records Checkbox

You automatically follow records that you own. Select the Stop automatically following records checkbox
in Setup ➤ My Chatter Settings ➤ My Feeds to stop automatically following records you own.

Email Notifications

You can receive email notifications when updates occur in Salesforce Chatter, including when people: follow you, post
on your profile, comment on your status or a change you make, comment on a post on your profile, or comment after
you comment in a feed. Administrators can enable email notifications by selecting Allow Emails in Setup➤Customize
➤ Chatter ➤ Settings. To enable and edit your own email notifications, click Setup ➤ My Chatter Settings ➤ My
Chatter Emails.

Salesforce Chatter for the Mobile Application

You can access a subset of Salesforce Chatter features on your BlackBerry or iPhone. For more information, see Salesforce
Chatter for the Mobile Application on page 31.

Weekly Export

You can export Salesforce Chatter feed data in Setup ➤ Data Management ➤ Data Export.

Salesforce Chatter API

Use the Salesforce Chatter API objects to build collaborative apps for the Force.com platform. For more information,
see New Objects on page 117.
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File and Data Storage

Salesforce Chatter feed data, including posts and tracked changes, are counted against data storage usage. Chatter feed
posts and comments account for .25KB of data storage. Salesforce Chatter user photos are counted against file storage.

Implementation Tips
• Quickly access the Salesforce Chatter People, Profile, and Groups tabs using the Salesforce Chatter app, available in the

app menu in the top right corner of any page.
• Review “Setting Up Salesforce Chatter” in the Salesforce.com online help and “Using Salesforce Chatter” in the

Salesforce.com online help for information on enabling and using Salesforce Chatter.
• Salesforce Chatter isn't supported:

- Using Microsoft® Internet Explorer version 6.0
- For portal users
- In the console

Best Practices
• Get started by filling out your profile, including your contact information and a picture.
• Use the People tab to find people to follow. You'll see their status updates in the Chatter feed on the Home tab.
• Follow records you're interested in. You'll see posts and field updates, depending on how your administrator has configured

feed tracking, in the Chatter feed on the Home tab.

About Salesforce Chatter

Salesforce Chatter Overview

Available in: Group, Professional, Enterprise, Unlimited, Contact Manager, and Developer Editions

Watch a Demo (English only, 3:30 minutes)

Salesforce Chatter is a collaboration application that helps you connect with coworkers inside your Salesforce.com organization
and share business information securely and in real time. Salesforce Chatter works in accordance with all of the security and
permission settings in your Salesforce.com organization. Salesforce Chatter is enabled by default for organizations created
after June 22, 2010. For existing organizations, you must enable Salesforce Chatter.

You can use Chatter to share information and learn about your colleagues with profiles, connect with people using groups,
and use feeds to keep up with the latest record updates. You can easily find the Salesforce Chatter People, Profile, and Groups
tabs in the Salesforce Chatter app, available in the app menu in the top right corner of any page. If your administrator has
added these tabs to other apps, you'll see the tabs in those apps unless you previously customized your display. In that case,
you'll need to add the tabs to those apps.

Salesforce Chatter is not supported:

• Using Microsoft® Internet Explorer version 6.0
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• For portal users
• In the console

Salesforce Chatter includes limits on:

• The number of posts, comments, and tracked field changes stored on the Salesforce.com servers
• How long posts, comments, and tracked field changes are stored on the Salesforce.com servers
• The number of posts, comments, and tracked field changes an organization can make per day
• The number of email notifications that can be sent per organization per hour

These limits are subject to change at any time. Contact salesforce.com for more information.

Salesforce Chatter Terminology
The following terminology is used for Salesforce Chatter:

Chatter Feed
A list of recent activities in Salesforce.com. Chatter feeds display:

• On the Home tab, where you can see your updates, status updates of people you follow, and updates to records you
follow and groups you're a member of

• On profiles, where you can see updates made by the person whose profile you're viewing
• On records, where you can see updates to the record you're viewing
• On Chatter groups, where you can see updates to the group you're viewing

Chatter Group
Chatter groups let you share information with specific people. For example, if you're working on a project and want to
share information only with your team members, you can create a Chatter group for your team. Chatter groups include
a list of members, a Chatter feed, and a photo. You can create the following types of Chatter groups:

• Public: Anyone can see the group's updates, but only members can post updates. Anyone can join a public group.
• Private: Only members can see and post updates. The group's owner or managers must add members.

Comment, Salesforce Chatter
A reply to an update in a Chatter feed.

Feed Tracking, Salesforce Chatter
Administrator settings that determine which records can be followed and which fields can be tracked in Chatter feeds.
Enabling an object for feed tracking allows people to follow records of that object type. Enabling fields for feed tracking
allows users to see updates on the Chatter feed on the Home tab when those fields are changed on records they follow.

Follow
A subscription to a user or record that lets you see related updates in your Chatter feed on the Home tab. Follow a user
to see status updates. Follow a record to see posts, comments, and field changes.

People
Users in your Salesforce.com organization. A list of people is available on the People tab in Salesforce Chatter.

Post
A top-level comment in a Chatter feed.

17

Collaboration Cloud Salesforce Chatter



Profile, Salesforce Chatter
A personal page for each Salesforce.com user that includes contact information, following and followers lists, a Chatter
feed, and a photo.

Record Update
An update in a Chatter feed that is the result of a field change on a record that is being followed.

Status Update
An update made by posting to the Chatter feed on your profile or Home tab, usually to tell other people what you're
working on. Your status update displays on your Home tab, on your profile, and in the Chatter feeds of people following
you.

Unfollow
To stop following a user or record and stop seeing their updates in your Chatter feed on the Home tab.

Update
A single activity that displays in a Chatter feed, such as a status update, post, or field change.

Enabling Chatter

Available in: Group, Professional, Enterprise, Unlimited, Contact Manager, and Developer Editions

User Permissions Needed

“Customize Application”To enable Salesforce Chatter:

Enable Salesforce Chatter to turn on Chatter feeds, groups, and profiles so people in your organization can collaborate with
each other in real time.

Note: Salesforce Chatter is enabled by default for organizations created after June 22, 2010. Existing organizations
must enable Salesforce Chatter.

1. Click Setup ➤ Customize ➤ Chatter ➤ Settings.
2. Click Edit.
3. Select Enable.
4. Optionally select Allow Emails so users can choose to receive email notifications about Salesforce Chatter updates.
5. Click Save.

Consider the following tips for enabling Salesforce Chatter:

• Enabling Salesforce Chatter also enables the new user interface theme, which updates the look and feel of Salesforce.com.
• When Chatter is enabled for organizations with 15 or fewer users, all users automatically follow each other.
• After enabling Salesforce Chatter for your organization, you can also enable it for the mobile application so users can access

their feeds from an iPhone or BlackBerry device. Salesforce Chatter doesn't require setup for Mobile Lite users; however,
you must enable Salesforce Chatter for Salesforce Mobile users by including the News Feed object in your mobile
configurations' data sets.
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Customizing Chatter Feed Tracking

Available in: Group, Professional, Enterprise, Unlimited, Contact Manager, and Developer Editions

User Permissions Needed

“Customize Application”To customize fields tracked in feeds:

“View Setup and Configuration”To view the field tracking setup page:

Feed tracking is available for objects and fields:

• Enable objects for feed tracking so people can follow records of that object type and see Chatter feed updates when records
of that object type are created. For example, if you enable the account object, people can follow account records and will
see feed updates when they create accounts. Additionally, enabling feed tracking for leads allows people to see Chatter
feed updates when leads are converted.

• Enable fields for feed tracking so people can see Chatter feed updates about changes to fields on records they follow. For
example, if you enable the Billing Address field on accounts, people will see updates when Billing Address is
changed on accounts they follow.

Sharing rules and field-level security determine visibility of record changes in Chatter feeds; you must be able to see a record
in order to see changes to that record in feeds.

You can configure feed tracking for users, Chatter groups, custom objects, and the following standard objects: accounts, article
types, assets, campaigns, cases, contacts, contracts, leads, opportunities, products, and solutions.

1. Click Setup ➤ Customize ➤ Chatter ➤ Feed Tracking.
2. Select an object.
3. Select Enable Feed Tracking. The user and Chatter group objects don't have this checkbox.
4. Select up to 20 fields to track. You can't select fields for article types.
5. Click Save.
6. Optionally repeat steps 2 through 5 for additional objects.

Consider the following feed tracking tips:

• To stop tracking an object, deselect Enable Feed Tracking. You can't disable feed tracking for the user or Chatter
group objects.

• You must track the owner field to enable a new record owner to automatically follow that record. For example, if the
Account Owner field isn't tracked and someone changes the owner of an account , the new owner won't automatically
follow the account.

• To restore the default feed tracking settings for an object, click Restore Defaults.
• If leads are tracked, but accounts, contacts, or opportunities are not, users won't be able to follow or see updates related to

the accounts, contacts, and opportunities created during lead conversion.
• The following standard field types can't be tracked:

- Auto-number, formula, and roll-up summary fields
- Encrypted and read-only system fields
- The Expected Revenue field on opportunities

19

Collaboration Cloud Salesforce Chatter



- The Solution Title and Solution Details fields on solutions; these fields display only for translated solutions
in organizations with multilingual solutions enabled

Profile Overview

Available in: Group, Professional, Enterprise, Unlimited, Contact Manager, and Developer Editions

Customize your profile with a photo and information about yourself so people in your organization can learn more about you.
View your profile on the Profile tab or by clicking your name at the top of any page, on the header bar of your Home tab, in
a feed, or on a record detail page.

View other people's profiles by clicking their name in the People tab, a feed, or on a record detail page. If hover details are
enabled, you can also see contact details by hovering over names in the recent items list and owner fields on records.

The Profile, and People, and Groups tabs are available by default in the Salesforce Chatter app. Select this app from the app
menu in the top right corner of any page. If your administrator has added these tabs to other apps, you'll see the tabs in those
apps unless you previously customized your display. In that case, you'll need to add the tabs to those apps.

From your profile, you can:

• Edit your contact information
• Add additional information about yourself in the About Me section
• Update your status in the What are you working on? field
• Upload or delete a profile photo
• See who's following you and who you're following
• See your recent updates in your Chatter feed
• View, download, and search files you've posted in Chatter.

When using profiles, consider these tips:

• Your status displays on your profile, Home tab, hover details, and in the Chatter feed on the Home tab of people following
you. Click Clear to remove your status from these locations. Clearing your status does not remove it from feeds. Click
Delete under your status in a feed to remove it from feeds.

• You can optionally attach files and links to your status updates.
• Your contact information is also visible in your user detail and is subject to validation or other rules set by your administrator.

Click the User Detail link on your profile to view your user detail page.
• When you change your email address in your contact information, a confirmation is sent to the new address. You must

click the link provided in that email for the change to take effect.
• To search the contents of other people's About Me, click Advanced Search... in the sidebar of the Home tab or an object

tab, enter a search term, and select Users as the scope.
• Portal users don't have profiles.
• For organizations using Salesforce to Salesforce, the Connection User may display in feeds, but does not have a profile.
• Users with the "Manage Users" permission can edit profiles and photos for other users.
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Updating Chatter Group and Profile Photos

Available in: Group, Professional, Enterprise, Unlimited, Contact Manager, and Developer Editions

Upload a photo to your profile so people can see who you are, or upload a photo for Chatter groups that you own or manage.

1. View your profile or a group detail page:

• View your profile by clicking your name at the top of any page or by clicking the Profile tab
• View a group detail page by clicking the group name on the Groups tab

2. Click Update Photo.
3. Click Browse....
4. Select a file to upload and click Open.

Note:  Photos can be JPG, GIF, or PNG format up to 4 MB.

5. Drag the dotted lines in the photo to create a thumbnail image that will display next to your name or the group's name
around the application.

6. Click Save.

To delete a photo, click Delete, then click OK.

Using the Following and Followers Lists

Available in: Group, Professional, Enterprise, Unlimited, Contact Manager, and Developer Editions

The Following and Followers lists on your profile show you who and what you are following and who is following you,
respectively. You can also view Following and Followers lists on other people's profiles to see who and what they are following
and who is following them. Click Show All in either section to view the full list in alphabetical order.

Note: When your administrator initially turns on Chatter you automatically follow some users and records in your
organization.

You can filter Following lists by users or objects, for example, accounts or contacts. In your Following list, click Unfollow to
stop following a person or record. In another person's Following list, you can also click Follow to follow a person or record.

In any Followers list, click Follow to follow a person, or Unfollow to stop following them.

In both lists, use the Next and Previous links to see more of the list. Click Done to close the window.
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Using the Files Added List

Available in: Group, Professional, Enterprise, Unlimited, Contact Manager, and Developer Editions

Note:  Microsoft Office 2007 file previews are currently available through a pilot program.

The Files Added list on a profile shows the five files the profile owner posted most recently in Salesforce Chatter and Salesforce
CRM Content. You can preview or download files directly from this list.

To see a list of all the files someone has posted in Chatter orSalesforce CRM Content, or to search for a specific file, click
Show All. You can preview, download, sort, or search for files. If you can't find the file you're looking for, enter characters of
the name of the file in Search files... and click Go!. The search results are filtered based on the characters entered.

Note the following about the Files Added by list:

• Only files posted by the profile owner are listed, including files posted to the owner's profile and other people's profiles.
• Only files you have access to are listed.

Note: Not all files can be previewed, such as copy-protected PDFs. For files that can't be previewed, the View option
isn't available and files appear as generic file type icons in the feed. Some Microsoft Office 2007 features don't display
correctly in previews.

Chatter Feeds Overview

Available in: Group, Professional, Enterprise, Unlimited, Contact Manager, and Developer Editions

Chatter feeds show you recent activities performed by people and on records in your Salesforce.com organization. Salesforce
Chatter feeds display:

• On Chatter profiles, where you can see updates by a single user. View your own profile to see your updates and to update
your status.

• On record detail pages, where you can see updates to a single record.
• On the Home tab, where you can see your updates, status updates of people you follow, and updates to records you follow.
• On Chatter groups, where you can see updates to a group by its members. You'll only see feeds for public groups and

private groups you're a member of.

Depending on how your administrator has configured feed tracking, you can see feed updates for:

• Record field changes, for example:

- Changes to record owner
- Closed opportunities and cases

• Created records
• Converted leads
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• People's status updates
• Chatter feed comments and posts
• Shared files and links
• Posts, comments, and files on Chatter groups you're a member of

You must follow people and records to see their updates in your Chatter feed on the Home tab. Sharing rules and field-level
security determine visibility of record changes in Chatter feeds; you must be able to see a record in order to see changes to that
record in feeds.

Using Chatter Feeds

Available in: Group, Professional, Enterprise, Unlimited, Contact Manager, and Developer Editions

You can view Chatter feeds in the following locations:

• On Chatter profiles, where you can see updates by a single user. View your own profile to see your updates and to update
your status.

• On record detail pages, where you can see updates to a single record.
• On the Home tab, where you can see your updates, status updates of people you follow, and updates to records you follow.
• On Chatter groups, where you can see updates to a group by its members. You'll only see feeds for public groups and

private groups you're a member of.

To use Chatter feeds:

• Show or hide Chatter feeds using the Show Chatter and Hide Chatter links at the top of a feed. If enabled by your
administrator, related list hover links display below Chatter feeds.

• Post to Chatter feeds by typing in the text box at the top of a feed. You can also attach files and links to posts. Anyone
who can see a record can see your post on the record's feed. Additionally, people following a record can see your post in
their Chatter feed on the Home tab. Posts to other people's profiles can be viewed by anyone.

• Update your status by posting to the Chatter feed on the Home tab or on your profile. Anyone can see your status update
by looking at your profile, and people following you can see your status update in their Chatter feed on the Home tab.

• Click Comment to comment on feed updates.
• Click Delete to delete posts and comments. You can delete posts and comments you've made and posts and comments

made by other people on the Chatter feed on your profile, on records you own, and on posts you've made in other feeds.
Users with the “Modify All Data” permission can delete all comments and posts.

• Click Unfollow in the Chatter feed on the Home tab to stop following people or records.

Attaching a File or Link to a Chatter Feed

Available in: Group, Professional, Enterprise, Unlimited, Contact Manager, and Developer Editions

You can share files and links with people by attaching them to posts in a Chatter feed on the Home tab, a profile, a group, or
a record. You can attach files from your computer, from Chatter feeds, or from Salesforce CRM Content workspaces.
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Attachments can include all file types, from traditional business documents such as Microsoft® PowerPoint presentations to
audio files, video files, Web pages, and Web links.

To attach a file to a post:

1. Enter your post in the field at the top of the feed. If you don't enter any text, a generic update is posted with your attachment.
2. Click File below your post.
3. Attach a file:

• To attach a file from your computer, click Upload a file from your computer.
• To attach a file from a Chatter feed or from a group or workspace that you're a member of, click Select a file from

Salesforce, find your file, and click Attach. Attaching a file from a group or workspace doesn't create a copy of the
file, it creates a reference to the file. So if you update the file in Salesforce CRM Content, the updates are reflected in
the feed. Links, Google docs, documents (from the Documents tab), and attachments (from the Notes and Attachments
related list, for example) aren't included in the list of files to attach.

4. Enter the Name of the file and a Description.
5. Click Share.

Note:

• The upload may take some time depending on your file size.
• The size limit for a file attached from your computer to a feed is 25 MB.
• When you attach a file to feed on a record, the file is also added to the record's Notes and Attachments related

list. If you don't see the Notes and Attachments related list on your page layout, contact your administrator.
• When you attach a file to a record's Notes and Attachments related list, the file is not added to the record's feed.
• Feed attachments are not included in the sidebar search.
• On some objects, the Notes and Attachments related list is titled Attachments because the object does not offer notes.

Also, the same related list may be titled Google Docs, Notes, and Attachments or Google Docs and Attachments depending
on the setting in your org. References to the Notes and Attachments related list include all versions of the related
list, regardless of title.

• Salesforce.com is not responsible for content posted by users.

To attach a link to a post:

1. Enter your post in the field at the top of the feed. If you don't enter any text, a generic update is posted with your attachment.
2. Click Link below your post.
3. Enter the URL to share.
4. Enter the Link Name.
5. Click Share.

Searching for Files to Attach to a Chatter Feed

Available in: Group, Professional, Enterprise, Unlimited, Contact Manager, and Developer Editions

Search for files in Chatter feeds or in Salesforce CRM Content. Enter the characters of the name of the file in Search
files... and click Go!. Salesforce CRM Content performs a full-text search of the following document types in Salesforce
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Chatter and in your workspace(s): rich text format (RTF), UTF-8 encoded TXT, HTML, XML, Adobe® PDF, and Microsoft®

Office 97 through Microsoft Office 2007 Word, Excel, and PowerPoint files. Wildcard searches (*) are not supported.

Note the following about the files included in the Select a File to Attach list:

• Files posted to Chatter feeds on the Home tab, a profile, a group (that you're a member of ), or a record are listed.
• Files from workspaces that you're a member of and where you have Post Content to Chatter Feeds or Manage

Workspace checked in your workspace permission definition are listed.
• Links, Google docs, documents (from the Documents tab), and attachments (from the Notes and Attachments related

list, for example) aren't included in the list.

Viewing and Editing Chatter File Details

Available in: Group, Professional, Enterprise, Unlimited, Contact Manager, and Developer Editions

Note:  Microsoft Office 2007 file previews are currently available through a pilot program.

You can view and edit the properties of a file posted on a Chatter feed through Salesforce CRM Content. Clicking on a
Chatter file name on the Workspaces, Content, or Subscriptions tab opens the content details page, which provides the
following options:

• Click Download to open or save the file.
• Click Subscribe or Subscribed to toggle your subscription on or off.
• Click Edit ➤ Edit Content Details to edit the file's title, description, and language. These edits are reflected in the feed.
• Click Edit ➤ Upload New Version to replace the file with a new version. This edit is reflected in the feed.
• Click Edit➤Delete Content to delete the file. Deleting a Chatter file from the content details page deletes the file from

Salesforce CRM Content and from Chatter.To restore deleted content, click on the Recycle Bin link in any tab. Select
the content and click Undelete.

• Click the Preview subtab to view the following types of files:

- Microsoft® Office 97 through Microsoft Office 2007 Word, Excel, and PowerPoint. Some Microsoft Office 2007
features don't display correctly in previews.

- Adobe® PDF. Copy-protected PDFs can't be previewed.
- JPG, BMP, GIF, and PNG

• Click the Versions subtab to view a list of all file versions and the reason-for-change statements provided by the authors.
• Click the Downloads subtab to view a list of all Salesforce CRM Content users who have downloaded the file.
• Click the Subscribers subtab to view a list of all Salesforce CRM Content users subscribed to the file.

Note: The Edit option is only available to the owner of the file.
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Downloading and Viewing a File in a Chatter Feed

Available in: Group, Professional, Enterprise, Unlimited, Contact Manager, and Developer Editions

Note:  Microsoft Office 2007 file previews are currently available through a pilot program.

Not only can you download and save files posted to Salesforce Chatter feeds, you can also preview files in your browser without
downloading them.

There are several places in Chatter where you can download and preview files:

• On any Chatter feed, click Download next to the file, or to preview the file, click the file icon or click View.
• On a profile, you can download or preview a file from the Files Added list by clicking the Download or View icons next

to the file.
• On a group, you can download or view a file from the Recent Files list by clicking the Download or View icons next to

the file.
• In the Notes and Attachments related list on a record, click Download next to the feed attachment, or to preview the file,

click View next to the feed attachment.

Note: Not all files can be previewed, such as copy-protected PDFs. For files that can't be previewed, the View option
isn't available and files appear as generic file type icons in the feed. Some Microsoft Office 2007 features don't display
correctly in previews.

Clicking View next to a Chatter file opens the file in your browser with the enhanced document viewer. The enhanced
document viewer provides the following capabilities for viewing documents:

• In addition to using the next page ( ), previous page ( ), first page ( ), and last page ( ) icons on the document toolbar,
you can navigate page-by-page through a document by right-clicking and choosing Next Page and Previous Page.

• You can use the scroll bar to move continuously through a document without needing to click the Next Page and Previous
Page icons. Continuous scrolling is not available for PowerPoint files.

• You can jump directly to a page by entering the page number in the page field and pressing Enter.
• From the right-click menu you can choose Fit Width to expand the width of the document, or Fit Full Page to view the

whole page of the document. The fit width icon ( ) and fit full page icon ( ) are also available on the toolbar.
• From the right-click menu you can choose Full Screen to view the document in full screen mode, or Exit to exit full screen

mode. The full screen icon ( ) and exit icon ( ) are also available on the toolbar.
• From the right-click menu you can Zoom In or Zoom Out. The zoom-in icon ( ) and zoom-out icon ( ) are also

available on the toolbar.
• You can use the keyboard arrow keys to navigate page-by-page through a document. Click on the document viewer and

use the keys as follows:

- Right-arrow key: moves a PowerPoint document forward one slide and moves a PDF, Word, or Excel document
forward one page.

- Left-arrow key: moves a PowerPoint document backward one slide and moves a PDF, Word, or Excel document
backward one page.
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- Up-arrow key: moves a PowerPoint document forward one slide and scrolls a PDF, Word, or Excel document up the
page.

- Down-arrow key: moves a PowerPoint document backward one slide and scrolls a PDF, Word, or Excel document
down the page.

Deleting a File or Link from a Chatter Feed

Available in: Group, Professional, Enterprise, Unlimited, Contact Manager, and Developer Editions

There are different ways to delete Salesforce Chatter files and links depending on where they appear. You can't delete files
and links posted by other people.

Deleting a File or Link from a Chatter Feed on the Home Tab, a Profile, or a Group
To delete a file or link on a Chatter feed, you must delete its post. Before deleting a post on the Home tab, a profile, or a
group, consider the following:

• If the file was attached from your computer, deleting the post also deletes the file on the post.
• If the file was attached from a Chatter feed, group, or a Salesforce CRM Content workspace, deleting the post also deletes

the file on the post, but doesn't delete the file from its original location.
• If the file was attached to a post and is shared in other locations, deleting the post also deletes the file on the post and other

locations where it's been shared.

Deleting a File from a Chatter Feed on a Record
There are two ways to delete a file on a Chatter feed on a record:

• Delete the file on a Chatter feed by deleting its post. This deletes the file, the post, and deletes the file from the Notes and
Attachments related list.

• Delete the file by clicking Del next to the feed attachment on the Notes and Attachments related list. Restore the file by
clicking on the Recycle Bin, selecting the file, and clicking Undelete. Before deleting a feed attachment on the Notes and
Attachments related list, consider the following:

- If the file was attached from your computer, deleting it from the Notes and Attachments related list also deletes it from
the post.

- If the file was attached from a Chatter feed, group, or a Salesforce CRM Content workspace, deleting it from the Notes
and Attachments related list also deletes it from the post and from the workspace.

Deleting a File from a Content Detail Page
When you post a file in Chatter, the file also appears in Salesforce CRM Content.To delete the file from Chatter and Salesforce
CRM Content, click the name of the file on the Workspaces, Content, or Subscriptions tab. From the content details page,
click Edit ➤ Delete Content to delete the file. Deleting a Chatter file from the content details page deletes the file from
Salesforce CRM Content and from Chatter.To restore deleted content, click on the Recycle Bin link in any tab. Select the
content and click Undelete. Only the owner of the file can edit or delete it.
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Editing Salesforce Chatter Email Notifications

Available in: Group, Professional, Enterprise, Unlimited, Contact Manager, and Developer Editions

If your administrator has enabled email notifications, you can choose to receive notifications when Salesforce Chatter activities
occur.

1. Click Setup ➤ My Chatter Settings ➤ My Chatter Emails.
2. Select Receive Emails to receive email notifications.
3. Select the desired checkboxes to receive an email notification when people:

• Follow you
• Post on your profile
• Comment on your status or a change you make, such as a post on a profile
• Comment on posts on your profile
• Comment after you comment in a Chatter feed

4. Click Save.

Consider the following tips for email notifications:

• When Receive Emails is selected, you automatically receive email notifications when you're added to Chatter groups.
• If you select Comments on a post on my profile, you won't receive a notification when someone comments on

changes to your profile by an administrator.
• If you select Comments after me, you will only receive email notifications for up to four comments after you.
• Salesforce Chatter includes limits the number of email notifications that can be sent per organization per hour. These

limits are subject to change at any time.

Salesforce Chatter Groups Overview

Available in: Group, Professional, Enterprise, Unlimited, Contact Manager, and Developer Editions

The Groups tab displays a list of Salesforce Chatter groups in your organization. Chatter groups let you collaborate with
specific people. For example, if you're working on a team project, you can create a Chatter group for your team to share
project-related files and information with each other. There are two types of Chatter groups:

• Public: Anyone can see the group's posts, comments, and files, but only members can add posts, comments, and files.
Anyone can join a public group.

• Private: Only members can see and add posts, comments, and files. People with the ”Modify All Data” and “View All
Data” permissions can see posts, updates, and files. The group's owner or managers must add members.

On the Groups tab:

• Search for groups by typing two or more letters of a group name in the quick find box at the top of the page. The list
automatically filters based on what you type.

• Click New Group to create a new group.
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• Click Join in the Membership column next to a public group to join the group.
• Click Ask Owner in the Membership column next to a private group to view the group owner's profile. You can then ask

the owner to add you to the group.
• Click X in the Membership column next to a group you're a member of to leave the group.
• Click a group name to view the group detail page. You can view detail pages for all groups, but you'll only see updates and

files for public groups, and for private groups that you're a member of.
• Click a group owner's name to see his or her profile.
• Click the Group, Owner, or Membership column headers to sort the list.The list is automatically sorted by the Membership

column to show you the groups you own, manage, and are a member of.

Note: The Profile, and People, and Groups tabs are available by default in the Salesforce Chatter app. Select this app
from the app menu in the top right corner of any page. If your administrator has added these tabs to other apps, you'll
see the tabs in those apps unless you previously customized your display. In that case, you'll need to add the tabs to
those apps.

Creating Chatter Groups

Available in: Group, Professional, Enterprise, Unlimited, Contact Manager, and Developer Editions

To create a Chatter group:

1. Click New Group on the Groups tab.
2. Enter a group name and description.

Note: You own groups you create. To assign a new owner, finish creating the group, then edit the group settings.

3. Select an access level:

• Public: Anyone can see the group's posts, comments, and files, but only members can add posts, comments, and files.
Anyone can join a public group.

• Private: Only members can see and add posts, comments, and files. People with the ”Modify All Data” and “View All
Data” permissions can see posts, updates, and files. The group's owner or managers must add members.

4. Click Save.

Using the Recent Files List

Available in: Group, Professional, Enterprise, Unlimited, Contact Manager, and Developer Editions

Note:  Microsoft Office 2007 file previews are currently available through a pilot program.
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The Recent Files list on a Salesforce Chatter group shows the five most recent files posted to that group. You can preview or
download files directly from this list.

To see a list of all the files posted to a group or to search for a specific file, click Show All. You can preview, download, sort,
or search for files. If you can't find the file you're looking for, enter characters of the name of the file in Search files...
and click Go!. The search results are filtered based on the characters entered. Only files you have access to are listed in the
Files Shared with list. For example, you won't see files from groups you're not a member of.

Note: Not all files can be previewed, such as copy-protected PDFs. For files that can't be previewed, the View option
isn't available and files appear as generic file type icons in the feed. Some Microsoft Office 2007 features don't display
correctly in previews.

File Previews in Feeds on Records

Available in: Contact Manager, Group, Professional, Enterprise, Unlimited, and Developer Editions

If Salesforce Chatter is enabled and files have been posted to a feed on a record, you can now preview those files in the record's
feed and Notes and Attachments related list. In the feed, click the file icon or click View. In the related list, click View next
to a feed attachment to display a preview of the file. Not all files can be previewed, such as copy-protected PDFs. For files
that can't be previewed, the View option isn't available and files appear as generic file type icons in the feed. Some Microsoft
Office 2007 features don't display correctly in previews.

Note: On some objects, the Notes and Attachments related list is titled Attachments because the object does not offer
notes. Also, the same related list may be titled Google Docs, Notes, and Attachments or Google Docs and Attachments
depending on the setting in your org. References to the Notes and Attachments related list include all versions of the
related list, regardless of title.

Chatter in Salesforce CRM Content

Available in: Contact Manager, Group, Professional, Enterprise, Unlimited, and Developer Editions

Salesforce CRM Content Search Includes Salesforce Chatter Files

Clicking the Content tab displays files, content packs, Web links, and Google docs published in your Salesforce CRM
Content workspaces. If Salesforce Chatter is enabled, files posted to Chatter groups and other Chatter files are also
displayed on the Content tab. The top twenty most recently modified items are listed by default. You can filter the list
using the Filter Your Results sidebar.

From the Search drop-down list, restrict your search to a specific workspace or choose to search in all workspaces. If
Salesforce Chatter is enabled, you can restrict your search using:

• All Files—All workspaces and Chatter groups you're a member of and files posted to the Chatter feed on the Home
tab and on profiles.

• Chatter Files—All Chatter groups you're a member of and files posted to the Chatter feed on the Home tab and on
profiles.
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• My Chatter Groups—All Chatter groups you're a member of.
• My Workspaces—All workspaces you're a member of and your personal workspace.

In the Filter Your Results sidebar, filter your search results by file format, featured content, author, tag, workspaces,
content type, language, or a custom field. If Salesforce Chatter is enabled, you can also filter your search results by Chatter
groups. The number in parentheses next to each filter type shows you how many matching files, content packs, Web
links, and Google docs are in the search results.

Post Content to Chatter Feeds with New Workspace Privilege

The Post Content to Chatter Feeds privilege makes content from a workspace accessible on Salesforce Chatter
feeds. From a Chatter feed, users can select a file from a workspace they are a member of and post it to a feed.
Administrators enable this privilege when creating or editing a workspace permission. This privilege is off by default for
existing organizations and on by default for new organizations.

Note:

• Both Salesforce CRM Content and Salesforce Chatter must be enabled.
• Links, Google docs, documents (from the Documents tab), and attachments (from the Notes and Attachments

related list, for example) aren't included in the list of files to attach.

Chatter in the Mobile Application

Available in: All Editions

Note:  Chatter Mobile is currently available through a pilot program. For information on enabling Chatter Mobile
for your organization, contact salesforce.com.

If you're away from your desk, use Chatter in the mobile application on your BlackBerry or iPhone to stay connected with
coworkers. An administrator must enable Chatter for Salesforce Mobile users; Chatter doesn't require setup for Mobile Lite
users.

Salesforce Chatter in the mobile application consists of the Chatter, Profile, and People tabs. The feed that displays on the
online application's Home tab appears on the mobile application's Chatter tab.

Not all of the functionality in Chatter is available from your mobile device. In the mobile application, you can:

• View and refresh Chatter feeds
• View coworkers' profiles
• Update your status
• View and edit your profile
• Post updates
• Follow and unfollow people and records

In the mobile application, you can't:

• Upload profile photos
• View Following or Followers lists
• Attach files to posts
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• View files attached to posts
• Attach links to posts (although you can type a URL in the body of a post)
• Refresh feeds while working offline

Setting Up Chatter for Mobile

Chatter is automatically available in Mobile Lite. You can enable Mobile Lite for your organization by editing your mobile
settings. The mobile settings also let you control whether Mobile Lite users have access to all available CRM tabs, or just to
dashboards and Chatter.

To enable Chatter for Mobile Lite:

1. Click Setup ➤ Mobile Administration ➤ Mobile Settings.
2. Click Edit.
3. Select Enable Mobile Lite to allow users without a mobile license to install and run Mobile Lite, the free, restricted

version of Salesforce Mobile.

Starting with Spring '09, Mobile Lite is enabled by default in all new organizations.

4. Optionally select Enable Limited Configuration to restrict the features available in Mobile Lite to dashboards and
Chatter. If you select this option, Mobile Lite users only have access to the Chatter, Profile, People, and Dashboards tabs.

Starting with Summer '10,Enable Limited Configuration is enabled by default in all new organizations.To provide
Mobile Lite users with all the available CRM tabs, deselect the option.

Mobilizing feeds in your organization's mobile configurations enables Chatter in Salesforce Mobile. To enable Chatter for
Salesforce Mobile:

1. Click Setup ➤ Mobile Administration ➤ Mobile Configurations, and then click the name of a mobile configuration.
2. In the Data Sets related list, click Edit.
3. Click Add....
4. In the popup window, select News Feed, then click OK.
5. Enter the maximum number of updates across all feeds that this configuration can transfer to mobile devices:

a. The value defaults to 100, but you can enter any number up to 100.
b. Use the Order By drop-down list to specify which records are synchronized. You can order by the Last Feed

Activity Date or Created Date fields. Updates are sorted chronologically in descending order; you can't change
the sort order.

If the limit is reached, Salesforce.com synchronizes the updates in accordance with the Order By and Sort settings. For
example, if the settings are Created Date and Descending, Salesforce.com transfers the most recently created updates
to mobile devices and removes the same number of updates that were least recently created.

6. Click Done when you're finished.
7. Optionally modify other mobile configurations and mobilize Chatter feeds.
8. Optionally reorder the tabs in the mobile application. If you add Chatter feeds to a mobile configuration, you can't remove

any Chatter tabs from that configuration, but you can change the tab order.

Using Chatter in the Mobile Application

Refer to the user guides to find out how to use Chatter on your BlackBerry or iPhone:
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• Salesforce Mobile User Guide for BlackBerry
• Salesforce Mobile User Guide for iPhone

Chatter in Salesforce Knowledge

Available in: Enterprise, Unlimited, and Developer Editions

User Permissions Needed

“Customize Application”To enable feed tracking:

“View Articles”To view published articles:

“Manage Articles”To create, edit, assign, publish, archive, and delete articles:

Salesforce Knowledge users can receive updates about articles in their Chatter feeds. To enable feed tracking for article types:

1. Click Setup ➤ Customize ➤ Chatter ➤ Feed Tracking.
2. Select an article type. Each article type appears by name in the Object list. For example, if your organization has three

article types named Offer, FAQ, and Warranty, all three appear alphabetically in the Objects list.
3. Select Enable Feed Tracking, then click Save when you're done with the page.

Unlike other objects, individual fields on article types are not tracked. After a user opens a published article and clicks Follow
in the header, posts about that article on the user's home page feed can include:

• If the article is removed from the knowledge base for edit (unpublished). Three Months Free — Al Smith unpublished this
offer

• If the article is republished. Three Months Free — Al Smith published a new version of this offer

• If the article is republished and flagged as new by the publisher. Three Months Free — Al Smith published this new offer

• If the article is archived. Three Months Free — Al Smith archived this offer

The title link in all posts about a specific article opens the current version of that article in the knowledge base, whether
published, archived, or draft. A user without the “Manage Articles” permission who is following an article will not see posts
if the article's status changes from published to draft. When the article is republished, posts about the article resume. Users
with the “Manage Articles” permission see all posts about articles they follow except for article deletions. If an article is deleted
from the knowledge base, all posts about the article disappear from feeds regardless of user.
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Cloud Scheduler
Available in: All Editions

Cloud Scheduler allows you to request meetings with your customers, and have your customers select when they can meet
before you confirm the meeting.

When you use Cloud Scheduler to request a meeting, Salesforce.com creates a unique Web page for your meeting that displays
the proposed meeting times. When invitees visit the page, they select the times that work for them, and send you a reply.
Salesforce.com tracks all the responses so you can pick the best time to meet when you confirm the meeting.

Implementation Tips
• Cloud Scheduler isn't supported using Microsoft® Internet Explorer version 6.0.
• For users to request meetings using Cloud Scheduler, administrators must:

1. Enable the new user interface theme.
2. Add the New Meeting Request button to the Open Activities related list for contacts, leads and person accounts.

The “Setting Up Cloud Scheduler” section below describes how to enable the new user interface and add the New Meeting
Request button.

Best Practices
Before you request a meeting, note the following:

• You must have at least read access to the contacts, leads and person accounts that you request a meeting with.
• Each invitee must have an email address specified in their record so Salesforce.com can send them a meeting request.
• You can invite up to 50 people to a meeting.
• We recommend you install Connect for Outlook or Connect for Lotus Notes so you can sync your calendar events between

Salesforce.com and Outlook or Lotus Notes.

When proposing meeting times, it's helpful to have your Salesforce.com calendar up-to-date so you can see your free and
busy times.

SALES CLOUD
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About Cloud Scheduler

Cloud Scheduler Overview

Watch a Demo (2:45 minutes)

The following sections provide an overview of how to request a meeting with your customers.

Step 1: You Request a Meeting and Propose Meeting Times

Go to the contact or lead detail page of the customer you want to request a meeting with, and click New Meeting
Request on the Open Activities related list. The Meeting Request page opens.

1. Click To to invite other Salesforce.com users, leads, contacts, or person accounts to the meeting.
2. Click in the calendar to propose up to five meeting times, or let Salesforce.com propose times for you.

Step 2: Invitees Pick the Times They Can Meet

Salesforce.com emails a meeting request to the invitees so they can pick the times they are available.
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1. In the meeting request, invitees click Respond to This Request to open your meeting's Web page.
2. On the meeting Web page, invitees pick the proposed times that work for them and send you a reply.

Step 3: You Confirm the Meeting

Salesforce.com keeps track of all the responses so you can see when each invitee is available. You then select the best
time to meet and confirm the meeting.

Setting Up Cloud Scheduler

User Permissions Needed

“Customize Application”To customize page layouts and activity settings:

To let your users request meetings with customers:

1. Enable the new user interface theme:

a. Click Setup ➤ Customize ➤ User Interface.
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b. Select Enable New User Interface Theme.
c. Click Save.

2. Add the New Meeting Request button to the Open Activities related list for contacts, leads, and person accounts:

a. Click Setup ➤ Customize.
b. Select either Contacts or Leads (whichever object you want your users to request a meeting with).

If you have person accounts enabled and want users to request meetings with them, add the New Meeting Request
button and the Email field to the page layout, which is located at Setup ➤ Customize ➤ Accounts ➤ Person
Accounts ➤ Page Layouts.

c. Click Page Layouts.
d. Click Edit next to the page layout.
e. Click Related Lists in the upper left corner.
f. Double-click the Open Activities related list. You can also click the wrench icon ( ).
g. Expand the Buttons section, and select New Meeting Request.
h. Click OK.
i. Click Save.

3. Make sure users have the “Send Email” and “Edit Events” user permissions (these permissions are automatically selected
in most standard profiles). For more information, see “Viewing Profile Lists” in the Salesforce.com online help.

If users don't have this permission, they:

• Won't see the New Meeting Request button on the Open Activities related list
• Can't edit, reschedule, or cancel requested meetings

4. (Optional) Add your company logo to the meeting requests sent to invitees:

a. Upload your logo to the Documents tab, and make it externally available. Note the following guidelines:

• The image must be in GIF, JPEG, or PNG format and be less than 20 KB.
• For best results, use an image that is no more than 130 pixels wide by 100 pixels high at 72 pixels per inch. Images

that are larger than these dimensions may not display correctly in some email clients due to automatic resizing.
• If your custom logo is in the Shared Documents folder on the Documents tab, other users can replace it and indirectly

change the logo that appears in meeting invitations. We recommend uploading the logo to your personal folder on
the Documents tab so only you can replace it.

b. Click Setup ➤ Customize ➤ Activities ➤ Activity Settings.
c. Select Show Custom Logo in Meeting Requests.
d. Select your logo, and click Submit.

5. (Optional) Add the Requested Meetings subtab to the Calendar section of the Home tab so that users can see a list of the
meetings they've requested but not confirmed:

a. Click Setup ➤ Customize ➤ Activities ➤ Activity Settings.
b. Select Show Requested Meetings in the Calendar Section on the Home Tab.
c. Click Submit.

6. (Optional) Enable your Partner users to request meetings:

a. Update your custom Partner User profiles:
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Include the “Send Email” and “Edit Events” user permissions.i.
ii. Verify that the tab visibility for the Contacts and Leads tabs is Default On.

b. At the bottom of the partner portal detail page, click Edit Profiles and activate the custom Partner Userprofile.
c. Assign the custom Partner User profile to your Partner users:

i. To create a new partner portal user, click Work with Portal and choose Enable Partner Portal Login on the contact
detail page.

ii. To update an existing user, click Work with Portal and choose View Partner User on the contact detail page. You
can then edit the user and assign the custom profile.

iii. Click Save.

Field-Level Security Requirements

In most cases, you don't need to change field-level security settings to allow users to request meetings. However, if your
organization has changed the default field-level security settings for certain profiles, refer to the following table to make sure
those changes don't prevent users from requesting meetings.

DescriptionRequired Field-Level
Security Setting

FieldObject

If this field isn't set to Visible, the New Meeting
Request button doesn't display on the Open Activities

Visible (with Read-Only
not selected)

NameEvent

related list, and an “insufficient privileges” message
appears when trying to change (confirm or reschedule)
or view a requested meeting.

If this field is set to Visible and Read-Only, the New
Meeting Request button doesn't display on the Open
Activities related list, and requested meetings open as
read-only (preventing users from confirming or
rescheduling the meeting).

By default, when a requested meeting is confirmed,
the last message sent from the meeting organizer

VisibleDescription

appears in the Description field for the new group
event.

However, if field-level security for the Description
field isn't set to Visible, then the last message doesn't
appear in the Description field even if field-level
security is later set to Visible.
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Using Cloud Scheduler

Requesting a Meeting With Contacts, Leads or Person Accounts

Available in: All Editions

User Permissions Needed

“Edit Events”

AND

“Send Email”

To request a meeting:

To request a meeting:

1. Go to the detail page for the contact, lead, or person account you want to invite to a meeting.
2. Click New Meeting Request from the Open Activities related list.

If this button doesn't display, ask your Salesforce.com administrator to add it.

3. Click To to invite other Salesforce.com users, leads, contacts, or person accounts to the meeting.

a. Select the type of invitee from the drop-down list.

Person accounts are returned in contact searches and can be added as invitees.

b. Enter a name or part of a name in the text field, or leave the field blank to expand the search.
c. Click Go!.
d. In the Search Results area, select the boxes next to the people you want to invite and click Insert Selected.

To add more invitees, perform a new search and select more people as needed.

If there's a warning icon ( ) next to a person's name, you can't invite them to the meeting because they don't have an
email address specified in their record. Once you add an email address to their record, you can invite them to meetings.

e. Click Done.

To remove someone you just invited, click “x” next to their name in the To field. You can remove all invitees except
the first contact, lead or person account that you requested a meeting with.

4. Enter a subject and location.

The default subject is a combination of the account name for the lead or contact and the company name specified in your
personal information. For example, if you're meeting with a contact from the Sterling company and you work for ACME,
the default subject is Sterling and ACME. The default location is always To be determined.

5. Select one of the following tabs:

• I propose meeting times—Propose up to five meeting times by picking times in the calendar. See “Tips for Proposing
Meeting Times” in the Salesforce.com online help
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• Let Salesforce.com propose meeting times—Choose the duration and time frame of the meeting and let Salesforce.com
propose up to five meeting times for you. See “Tips for Letting Salesforce.com Propose Meeting Times” in the
Salesforce.com online help

6. Click Next.
7. Write a message to the invitees, and click Send.

Note the following:

• Your email signature is automatically added to your message.
• After you click Send, Salesforce.com emails a meeting request to the invitees.

In the meeting request, invitees click Respond to This Request to open your meeting's Web page. On the meeting
Web page, invitees pick the proposed times that work for them and send you a reply.

• Your meeting's Web page displays all messages between you and the invitees.This includes messages that invitees write
when responding to your request.

• The meeting appears on the Open Activities related list for the person you requested a meeting with, but not on the
Open Activities related list for any of the other contacts or leads you invited to the meeting. For example, if you requested
a meeting with Jane Smith and then clicked the To field to invite John Doe, the requested meeting only appears on
the Open Activities related list for Jane Smith and not John Doe.

Tips for Proposing Meeting Times

When you request a meeting with customers, you can either propose meeting times or let Salesforce.com propose times for
you.

When you propose meeting times:

• Proposed times aren't saved to your Salesforce.com calendar. The meeting only appears in your calendar after you confirm
the meeting.

• When the invitees view your meeting request, the proposed times are shown in your time zone. Proposed times aren't
shown in the invitees' time zones.

• You can't propose a time that occurs in the past (before the black line in the calendar).
• The calendar's shaded areas show when you and the other invited Salesforce.com users are busy based on your Salesforce.com

calendars. Darker shades show when multiple Salesforce.com users are busy at the same time.
• Use the Duration field to change the length of your meeting.
• To remove a time you proposed, hover over the proposed time and click “x”.

Tips for Letting Salesforce.com Propose Meeting Times

When you request a meeting with customers, you can either propose meeting times or let Salesforce.com propose times for
you.

When Salesforce.com proposes meeting times:

• You won't know which times are proposed until after you send the meeting request. Once the first invitee views your
request, Salesforce.com checks the calendars of all Salesforce.com users invited to the meeting and proposes meeting times
based on their availability.
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Salesforce.com tries not to propose the same times that invitees have already selected for other unconfirmed meetings. For
example, if you request a meeting for the next five business days and your invitees respond that they can meet on Tuesday
and Wednesday from 2:00 to 3:00 p.m., and then you request another meeting for the same time frame, Salesforce.com
won't propose times for Tuesday and Wednesday from 2:00 to 3:00 p.m. unless your calendar is completely booked with
confirmed meetings and other events.

• By default, Salesforce.com proposes meeting times between 9:00 a.m. and 5:00 p.m. in your time zone. However, if you
have changed the Start of day and End of day fields in your Personal Information Settings page, Salesforce.com
uses those settings instead.

One of the benefits of letting Salesforce.com propose meeting times happens when there's a long delay between the time you
send the meeting request and when the first invitee views it. For example, if you request a meeting with a contact on a Monday
and that contact doesn't view your request until Thursday, Salesforce.com proposes times from Thursday forward instead of
when the meeting request was sent.

Note:  If you don't want to meet at a specific time of day (like your lunch hour), schedule a recurring event in your
Salesforce.com calender to block out that time.

The following table describes the settings that control how Salesforce.com proposes meeting times.

DescriptionField

The length of your meeting.Duration

How far in advance Salesforce.com proposes meeting times:Time Frame

• Next 5 Business Days/Next 10 Business
Days—Salesforce.com tries to spread out the proposed
times over the specified time frame. For example, if your
time frame is Next 5 Business Days and the first invitee
views the request on a Monday, Salesforce.com tries to
propose a time for each day of that week. If some of your
days are booked, Salesforce.com condenses the proposed
times into fewer days.

Business days exclude Saturdays and Sundays.

• Whenever—Salesforce.com tries to propose five meeting
times over the next five business days, and if it can't
propose enough times, it extends the range over the next
10 business days. If Salesforce.com still can't find five times
to propose, it looks for available times over the next four
weeks.

When you select this option, some of the times
Salesforce.com proposes could be seven weeks away (5
business days + 10 business days + 20 business days = 7
weeks).
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Confirming a Requested Meeting

Available in: All Editions

User Permissions Needed

“Edit Events”

AND

“Send Email”

To confirm a meeting:

Note: The request a meeting feature isn't supported in Microsoft® Internet Explorer version 6.0.

After you request a meeting, wait for the invitees to reply with the times they can meet. When this happens, the meeting
organizer receives an email notification, and the meeting in Salesforce.com is automatically updated with the times the invitees
selected. You can then choose the best time to meet and confirm the meeting.

The meeting confirmation page displays as read-only to users without the “Edit Events” permission and users without the
“Edit” permission on the contact or lead record associated with a proposed meeting.

To confirm a meeting:

1. Open your meeting using one of the following methods:

• From the Calendar section on the Home tab, click the Requested Meetings subtab and then click the subject of your
meeting.

• From the Open Activities related list for the contact, lead, or person account you requested a meeting with, click the
subject of your meeting.

• From the email notification that you received when an invitee responded to your meeting request, click View Response
and Schedule Meeting.

2. Select a time, and click Confirm.

The Confirm button displays after you select a meeting time. If you don't select a time, the Send Update button displays
instead so you can send the invitees a message without confirming a meeting time.

Use the following tools to help you pick a time:

• Green check marks show when each invitee can meet.
• Free shows when you are available based on your Salesforce.com calendar.
• If none of the times work for the invitees, reschedule the meeting to propose new times.

3. Optionally, enter a message to the invitee.
4. Click Send to confirm the meeting.

Salesforce.com then:

• Emails the invitees with the final date and time of the meeting.
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• Converts the requested meeting to a new group event. The last message you sent to the invitees appears in the event's
Description field, but all other messages between you and the invitees aren't saved.

This group event appears in the “Open Activities related list” in the Salesforce.com online help and in the Calendar
section on the Home tab.

Note:  If your administrator added required fields to events, you're prompted to update those fields before the meeting
is converted to an event.

Cancelling a Requested Meeting

Available in: All Editions

User Permissions Needed

“Edit Events”

AND

“Send Email”

To cancel a meeting:

Note: The request a meeting feature isn't supported in Microsoft® Internet Explorer version 6.0.

If you requested a meeting that hasn't been confirmed, you can cancel the meeting and Salesforce.com automatically sends a
cancellation notice to the invitees. However, if you confirmed the meeting then it has been converted to a group event that
you can delete like all other activities.

To cancel a requested meeting:

1. From the Calendar section on the Home tab, click the Requested Meetings subtab.

If you're administrator hasn't added the Requested Meetings subtab, go to the detail page for the person you requested
a meeting with. For example, if you requested a meeting with the contact Jane Smith, go to her contact detail page and
view the Open Activities related list.

2. Click the subject of the requested meeting, and click Cancel Meeting.

You can also click Del next to the meeting from the Open Activities related list.

Note:  If Close is the only button on the page, you don't have permission to modify the requested meeting. Either
ask the organizer to change the meeting details for you, or contact your Salesforce.com administrator to grant you
the required permissions.

3. Click OK to confirm the cancellation.

Salesforce.com emails a meeting cancellation to all invitees. Cancelled meetings are permanently removed and aren't stored
in the Recycle Bin.
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Rescheduling a Requested Meeting

Available in: All Editions

User Permissions Needed

“Edit Events”

AND

“Send Email”

To reschedule a meeting:

Note: The request a meeting feature isn't supported in Microsoft® Internet Explorer version 6.0.

If you requested a meeting that hasn't been confirmed, you can reschedule it and propose new times. However, you can't
propose new times for a confirmed meeting because it's been converted to a group event. To reschedule a group event, edit
the event to change its date and send an update to the invitees.

To reschedule a requested meeting:

1. Open your meeting using one of the following methods:

• From the Calendar section on the Home tab, click the Requested Meetings subtab and then click the subject of your
meeting.

• From the Open Activities related list for the contact, lead, or person account you requested a meeting with, click the
subject of your meeting.

• From the email notification that you received when an invitee responded to your meeting request, click View Response
and Schedule Meeting.

2. Click Reschedule and propose new times.

Once the invitees reply to your updated request, you can confirm the meeting.

Note:  If Close is the only button on the page, you don't have permission to modify the requested meeting. Either
ask the organizer to change the meeting details for you, or contact your Salesforce.com administrator to grant you the
required permissions.
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Adding and Removing Invitees from a Requested Meeting

Available in: All Editions

User Permissions Needed

“Edit Events”

AND

“Send Email”

To add and remove invitees from a requested meeting:

Note: The request a meeting feature isn't supported in Microsoft® Internet Explorer version 6.0.

You can add and remove invitees to a requested meeting if it hasn't been confirmed. Confirmed meetings are converted to
group events. You can edit group events to add and remove invitees.

To add or remove invitees from a requested meeting:

1. Open your meeting using one of the following methods:

• From the Calendar section on the Home tab, click the Requested Meetings subtab and then click the subject of your
meeting.

• From the Open Activities related list for the contact, lead, or person account you requested a meeting with, click the
subject of your meeting.

• From the email notification that you received when an invitee responded to your meeting request, click View Response
and Schedule Meeting.

2. Do either of the following:

• Click To to invite other Salesforce.com users, leads, contacts, or person accounts to the meeting.
• Click “x” next to an invitee's name to remove them from the meeting.

You can remove all invitees except the first contact, lead or person account that you requested a meeting with.

The calendar automatically updates based on the Salesforce.com users you added or removed from the meeting.

Note:  If Close is the only button on the page, you don't have permission to modify the requested meeting. Either
ask the organizer to change the meeting details for you, or contact your Salesforce.com administrator to grant you
the required permissions.

3. Click Send Update.
4. Enter a message. For example, you might want to inform your invitees who you're adding or removing from the meeting.
5. Click one of the following:

• Send to All Invitees—Sends an update to all existing and added invitees and a cancellation notice to removed invitees.
• Send Only to Changed Invitees—Sends an update to added invitees and a cancellation notice to removed invitees.
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Quotes Template Editor—Beta

You asked for it! This enhancement is from an idea on the IdeaExchange.

Available in: Professional, Enterprise, Unlimited, and Developer Editions

Note: This release contains a beta version of the quotes template editor that is production-quality but has known
limitations, including the following.

• You can't add repeating headers and footers, page breaks, or page numbers to templates.
• All templates include a quote acceptance section, but you can't customize it or remove it from the template.
• You can use only one logo for all templates. The logo does not repeat on multiple-page quotes.
• You can't preview your template as you're creating it or making edits. The only way to view the output is to create

a quote PDF from the quote detail page.
• All quote templates you create and save are immediately available for users to select when they create quote PDFs.

You can't prevent access by deactivating a template.

To standardize the look and feel of your quotes, you can use either the standard quote template or custom templates that you
create. Sales reps can choose a template when they create the quote PDFs they send to customers.

The quotes template editor looks and works a lot like the enhanced page layout editor: you can drag quote fields directly onto
the template layout, and present information from quotes and other objects, such as quote line item, in table format.

Best Practices
• All quote templates you create and save are immediately available for users to select when they create quote PDFs. Make

sure to communicate clearly which templates should be used, and delete any templates that should not. Consider adding
the word “DRAFT” to the title of any template that's not yet ready for use.

About the Quotes Template Editor

Quotes Template Editor Overview—Beta

Available in: Professional, Enterprise, Unlimited, and Developer Editions

Note: This release contains a beta version of the quotes template editor that is production-quality but has known
limitations, including the following.

• You can't add repeating headers and footers, page breaks, or page numbers to templates.
• All templates include a quote acceptance section, but you can't customize it or remove it from the template.
• You can use only one logo for all templates. The logo does not repeat on multiple-page quotes.

46

Sales Cloud Quotes Template Editor—Beta

http://sites.force.com/ideaexchange/ideaView?c=09a30000000D9xt&id=087300000007oYpAAI


• You can't preview your template as you're creating it or making edits. The only way to view the output is to create
a quote PDF from the quote detail page.

• All quote templates you create and save are immediately available for users to select when they create quote PDFs.
You can't prevent access by deactivating a template.

User Permissions Needed

"Customize Application"To create quote templates:

"View Setup and Configuration"To view quote templates:

Caution: All quote templates you create and save are immediately available for users to select when they create quote
PDFs. Make sure to communicate clearly which templates should be used, and delete any templates that should not.

Use the quotes template editor to design custom templates for the quotes you send to your customers.

You can add and arrange sections containing the content you want to share—such as standard and custom quote fields. The
list element lets you add fields from other standard or custom objects, such as quote line item, that have lookup relationships
with the quote object.

All quote templates (both standard and custom) include a standard quote acceptance information section. If you upload a logo
for your quotes, you'll see it at the top of your template. If not, your company name will appear.

Users can select quote templates from their quote records, generate quote PDFs, and email them to their customers.

The quotes template editor looks and works a lot like the enhanced page layout editor, so if you're familiar with editing page
layouts, you'll find the template editor just as easy to use.

Customizing Quote PDFs with the Quotes Template Editor

Available in: Professional, Enterprise, Unlimited, and Developer Editions

User Permissions Needed

"Customize Application"To create quote templates:

"View Setup and Configuration"To view quote templates:

Use the quotes template editor to design custom templates for the quotes you send to your customers.

Navigating the Quotes Template Editor

The template editor has two parts: a palette at the top and a template layout below.

The palette contains the elements you can add to the layout, including list and section, and fields that you can add to
sections.

• Click  beneath the palette to expand or collapse it.
• Use Quick Find to easily locate items on the palette.
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• Use CTRL+click and SHIFT+click to select multiple fields.

Working with the Quotes Template Editor

• To add an element to the template, drag it from the palette to the layout. Use a section to add and arrange fields
from the quote object. Use a list to create a table with fields from another object, such as quote line item.

• To remove an element from the layout, drag it back to the palette, or hover over its title bar and click .
• If you want to change, hide, or show the title of a section or list after it's in place, click its wrench icon . Edit the

title and select or deselect Hide Title.
• To step backward or forward, click Undo and Redo.
• To change the properties of a list or section on the layout, double-click its title bar or click .
• To rename the template, click Quote Template Properties.
• To save your changes and continue editing the template, click Quick Save.
• To save your changes when you're finished editing the template, click Save. Don't navigate away from the template

before clicking Save or you'll lose your changes.

Creating Quote Templates

Available in: Professional, Enterprise, Unlimited, and Developer Editions

User Permissions Needed

"Customize Application"To create quote templates:

"View Setup and Configuration"To view quote templates:

Use the quotes template editor to design custom templates for the quotes you send to your customers.

1. Click Setup ➤ Customize ➤ Quotes ➤ Templates.
2. Click New and select an existing template, such as Standard Template, on which to base your new template.
3. Give your new template a name and click Save.
4. On the template editor, drag the elements you want, and then fill in the details. If you want:

• One or more quote fields, use a section and add fields to it.
• A table of quote fields or fields from a different object, such as quote line item, use a list.

5. Click Quick Save to save your changes and continue working on the template. Click Save when you're finished.

Tip: To test out a new template, open a quote and “create a PDF” in the Salesforce.com online help using that
template.
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Viewing and Editing Quote Templates

Available in: Professional, Enterprise, Unlimited, and Developer Editions

User Permissions Needed

"Customize Application"To create quote templates:

"View Setup and Configuration"To view quote templates:

1. Click Setup ➤ Customize ➤ Quotes ➤ Templates .
2. Click Edit for the template you want.
3. If you need to edit the template name, click Quote Template Properties and enter the new name in the Template Name

field. Click OK.
4. Add or edit sections (for fields) or lists as needed.
5. If you want to change, hide, or show the title of a section or list after it's in place, click its wrench icon . Edit the title

and select or deselect Hide Title.

Adding Fields to Quote Templates

Available in: Professional, Enterprise, Unlimited, and Developer Editions

User Permissions Needed

"Customize Application"To create quote templates:

"View Setup and Configuration"To view quote templates:

Use a section to add standard and custom quote fields to your quote template.

Note:

In some cases, a field may not appear on the quote template editor's palette or on a PDF created from a template.

• If you're unable to view or update the field because of field-level security settings, that field won't appear on the
quotes template editor or any PDFs you create. Read-only fields will appear.

• A field that appears on the quote page layout but does not have a value for a given quote will appear on the quote
template editor's palette, but won't appear on PDFs created from that quote.

• If a field is not on the quote page layout, it won't appear on the template editor or any quote PDFs for quotes that
use that page layout.

• Quote line item fields that don't contain data won't appear as columns in your list when you create a PDF, even
if your template includes that field. For example, if no quote line items offer a discount, the Discount column
won't appear, even if the list includes the Discount field.
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1. Drag a field section from the palette to the template.
2. Enter a title for the section. Select Hide Title if you don't want it to appear on the template or PDF. Click OK.
3. Drag the fields you want into the new section. Press CTRL+click to select multiple fields and SHIFT+click to select a

range.
4. If you want to change, hide, or show the title of a section or list after it's in place, click its wrench icon . Edit the title

and select or deselect Hide Title.

Adding Lists to Quote Templates

Available in: Professional, Enterprise, Unlimited, and Developer Editions

User Permissions Needed

"Customize Application"To create quote templates:

"View Setup and Configuration"To view quote templates:

Use lists in your quote template to arrange and display fields from quote line item and any other standard or custom object
that has a lookup relationship to the quote object. A list looks like a table, with field names appearing as columns.

Note:

In some cases, a field may not appear on the quote template editor's palette or on a PDF created from a template.

• If you're unable to view or update the field because of field-level security settings, that field won't appear on the
quotes template editor or any PDFs you create. Read-only fields will appear.

• A field that appears on the quote page layout but does not have a value for a given quote will appear on the quote
template editor's palette, but won't appear on PDFs created from that quote.

• If a field is not on the quote page layout, it won't appear on the template editor or any quote PDFs for quotes that
use that page layout.

• Quote line item fields that don't contain data won't appear as columns in your list when you create a PDF, even
if your template includes that field. For example, if no quote line items offer a discount, the Discount column
won't appear, even if the list includes the Discount field.

1. Drag a list from the palette to the template.
2. Enter a title for the list. Select Hide Title if you don't want it to appear on the template or PDF.
3. In the Object field, select the object whose fields you want to appear in the list.
4. Use the Add and Remove arrows to move columns from the Available Fields list to the Selected Fields list and use the

Up and Down arrows to change the order of the columns. A list can include up to 10 fields.
5. Click OK.
6. If you want to change, hide, or show the title of a section or list after it's in place, click its wrench icon . Edit the title

and select or deselect Hide Title.
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Creating Quote PDFs

Available in: Professional, Enterprise, Unlimited, and Developer Editions

User Permissions Needed

“Edit” on quotesTo create quote PDFs:

You can generate quote PDFs to print or email to customers. You can generate a quote PDF from either the standard template,
which comes built in, or a custom template you design. Quote PDFs use the language and locale of the running user.

Note:

In some cases, a field may not appear on the quote template editor's palette or on a PDF created from a template.

• If you're unable to view or update the field because of field-level security settings, that field won't appear on the
quotes template editor or any PDFs you create. Read-only fields will appear.

• A field that appears on the quote page layout but does not have a value for a given quote will appear on the quote
template editor's palette, but won't appear on PDFs created from that quote.

• If a field is not on the quote page layout, it won't appear on the template editor or any quote PDFs for quotes that
use that page layout.

• Quote line item fields that don't contain data won't appear as columns in your list when you create a PDF, even
if your template includes that field. For example, if no quote line items offer a discount, the Discount column
won't appear, even if the list includes the Discount field.

Creating Quote PDFs from the Standard Template

If you haven't created any custom templates or generated any PDFs, you start from the standard template.

1. On the quote detail page, click Create PDF to generate a preview.
2. Click Save to Quote to save the PDF to the Quote PDFs related list. The PDF name is the quote name plus a

version number, such as AcmeQuote_V1.

You can also save and email your quote directly from the preview page.

Creating Quote PDFs by Selecting a Template

If you've already created a PDF, you can select a template from a list of those you've recently used. If you haven't created
a PDF, or you want to use a template that's not listed, you can search for the one you want. The standard template is
always available.

1. On the quote detail page, click the Create PDF drop-down list.
2. Either select your template from the Recent Templates list (if available), or click Choose Template and search

for the one you want.

Tip: To bypass the list of recent templates and select a different one, click the Create PDF button on the
quote detail page.

3. Click Create PDF to generate a preview.
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4. Click Save to Quote to save the PDF to the Quote PDFs related list. The PDF name is the quote name plus a
version number, such as AcmeQuote_V1.

You can also save and email your quote directly from the preview page.

Adding a Logo to Quote PDFs

Available in: Professional, Enterprise, Unlimited, and Developer Editions

User Permissions Needed

“Create” on documentsTo upload new logos:

“Edit” on documentsTo replace logos:

To add your organization's logo to quote PDFs, upload the logo to the Shared Documents folder on the Documents tab. This
ensures that all users can access it. If you don't add a logo, quote PDFs display your organization's name. Your logo will appear
on quotes from all templates, including the standard template and any custom templates you create.

Logo requirements:

• The unique name must begin with QUOTE_PDF_LOGO. The PDF will use the most recently modified logo that begins
with this unique name.

• You can upload documents that have file names of up to 255 characters including the extension.
• The maximum logo height is 150 pixels. The logo will automatically scale to this height in the PDF.
• The maximum logo size is 5 MB. To reduce load time and limit PDF size, we recommend 200 KB or smaller.
• The logo must be in GIF, JPEG, or PNG format.
• For the best display on-screen, we recommend you use an image with a transparent background.
• If you need to replace the logo image for quote PDFs, select the image on the Documents tab's Recent Documents related

list. On the Document Detail page, click Replace Document and upload the new file.

Emailing Quote PDFs

Available in: Professional, Enterprise, Unlimited, and Developer Editions

User Permissions Needed

“Edit” on quotesTo email quote PDFs:

When you create a quote PDF, you can email it to your customer for approval. The quote must have a status that allows
emailing.

1. Start by generating the email. You can:
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Click Save and Email Quote on the “PDF preview” in the Salesforce.com online help.•
• Click Email Quote on the quote detail page.
• Click Email next to the PDF in the Quote PDFs related list.

An email task opens with the current quote PDF attached.

Tip: To email a previous version, click Email next to that version in the Quote PDFs related list.

2. Enter the customer's email address, a subject, and body text, and then click Send.

Tips for Using the Quotes Template Editor

Available in: Professional, Enterprise, Unlimited, and Developer Editions

User Permissions Needed

"Customize Application"To create quote templates:

"View Setup and Configuration"To view quote templates:

Understanding Template Field Names

To help you understand the information you'll get when you select fields for your template, some field names provide
additional information that does not appear on PDFs created from the template.

PDF Field NameTemplate Field NameObject FieldObject

Prepared ByPrepared By (Name)First Name, Last NameUser

E-mailPrepared By (Email)EmailUser

PhonePrepared By (Phone)PhoneUser

FaxPrepared By (Fax)FaxUser

Company AddressOrganization
(Address)

AddressCompany Information

Created DateQuote PDF (Created
Date)

Hidden. The date the PDF
was generated and saved in
the quote documents object.

Quote Documents

Creating a Totals Section

Use a totals section to show grand total amounts for your quote. To create a totals section, you have a couple of options.

• Select Standard Template when you create a new template. The standard template contains a totals section,
and you can modify it as you wish.
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• Drag a section onto the layout of any template, then drag total-related fields (such as Subtotal and Grand Total)
to the right half of the section. Hide the title if you are placing the section directly beneath a list.

Note:  Fields within sections have different alignment than columns within lists, so if you place your totals section
beneath a list, its field values will not line up beneath the rightmost list values.

For example, your template might include a list of quote line items, including a Total Price column at the
far right that shows the total for each line item. If you add a totals section beneath the list, and include Subtotal,
Total Price, and Grand Total fields, their values will show the total of all line items, but the amounts will
not line up beneath the list's Total Price column.

Testing Quote Templates

To test out a new template, open a quote and “create a PDF” in the Salesforce.com online help using that template.

Making Templates Available for Use

All quote templates you create and save are immediately available for users to select when they create quote PDFs.Make
sure to communicate clearly which templates should be used, and delete any templates that should not. Consider adding
the word “DRAFT” to the title of any template that's not yet ready for use.

New Opportunity Page—Pilot
Available in: Enterprise, Unlimited and Developer Editions

User Permissions Needed

“Read” on opportunitiesTo view opportunities:

“Edit” on opportunitiesTo edit opportunities:

Note: The new opportunity page is available through a pilot program. For information on enabling this feature for
your organization, contact salesforce.com.

Watch a Demo (1.5 minutes)

Summer '10 includes a new opportunity detail page so you can get to the information you need and update the details more
quickly.

Key features:

• Highlights panel—lets you view key information at a glance. You can quickly assess deal status and make better-informed
decisions about each opportunity.

• Chatter feeds— lets you see an opportunity's latest updates and comments, or review an opportunity's history.
• Recommendations—lets you tap into your sales organization's knowledge by connecting you with people who won similar

deals.
• Drag and drop side tabs—let you quickly and easily navigate and personalize your page.
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For more information, see “Using Opportunities — New Opportunity Page Pilot” in the Salesforce.com online help.

Mobile Enhancements
Summer '10 includes many new features that improve the capabilities of the mobile application, including:

• Chatter in the Mobile Application
• Salesforce Mobile for BlackBerry Enhancements
• Salesforce Mobile for iPhone Enhancements
• Windows Mobile Peripheral Support
• Support for Attachments in Salesforce Mobile for Windows Mobile
• Mobile Views Enhancement

To enjoy the product improvements, existing users must upgrade to the latest version of the mobile application. New users
must install the application. Refer to the user guides for installation and upgrade instructions:

• Salesforce Mobile User Guide for BlackBerry
• Salesforce Mobile User Guide for iPhone

About Mobile Enhancements

Salesforce Mobile for BlackBerry Enhancements
Improved User Experience for Related List Search

Summer '10 streamlines the experience of searching for related items by maintaining focus on the related list. For example,
when searching for contacts related to an account, the application displays the search results in the related list instead
of switching to the Contacts tab. To search for an item's related records:

1. Open a record, then open the menu and select a related list.
2. Click Search server for more.

The mobile application retrieves any related records from Salesforce.com and displays the search results.

3. To download a related item to your device, simply open the item. From the Search Results view, highlight the item
and press ENTER or select Open from menu.

4. Press Escape to return to the search results and download additional related items.

The mobile application can't automatically download all the related items because a large amount of records could
force the device to exceed the total data limit set by your Salesforce.com administrator.

Configurable Reports Tab

With Summer '10, administrators can decide whether mobile configurations include the Reports tab in Salesforce Mobile.
Previously, the Reports tab was hard-coded in the mobile application. To configure the Reports tab:

1. From the reports home page in Salesforce.com, click Create New Folder.
2. In the Report Folder field, enter: Mobile Reports.
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The server does not load reports on the mobile device unless the folder is named Mobile Reports. Be sure to
check for any typos in the name before saving the folder. Additionally, Salesforce.com does not require folder names
to be unique. Mobile users can see any report stored in folders named Mobile Reports unless you restrict access with
the folder visibility option.

3. Choose a Public Folder Access option. This option does not affect the ability of mobile users to run reports.
4. Optionally, select any unfiled reports and click Add to store them in the Mobile Reports folder. You can also add

reports to the folder after saving the folder.
5. Choose a folder visibility option.

• This folder is accessible by all users gives every user in your organization the ability to see the
list of mobile reports from their devices.

• This folder is accessible only by the following users lets you grant access to a desired set of
users.

Do not make the folder private unless you want to hide mobile reports from all users, including yourself.

6. Click Save.
7. To add a report to the Mobile Reports folder, click the report name on the reports home page, and then click Save

As. Save the report in the Mobile Reports folder.

After saving the report, you can edit the options to make the report easier to view on a mobile device. For example,
you might reduce the number of columns or enter additional filtering criteria.

8. Click Setup➤Mobile Administration➤Mobile Configurations, and then click the name of a mobile configuration.
9. In the Mobile Tabs related list, click Customize Tabs to define mobile tabs for the first time. If you have already

set up the mobile tabs, click Edit.
10. Select Reports from the Available Tabs list, and click the Add arrow to add it to the mobile configuration. The

Available Tabs list includes standard object tabs and custom object tabs. It can also include web and Visualforce tabs.

Caution:  If you have not yet customized tabs in the mobile configuration, you must select all the tabs that
should appear in the mobile application, not just the Reports tab.

11. In the Selected Tabs list, choose the Reports tab and click the Up and Down arrows to define where the Reports
tab should appear in the mobile application.

12. Click Save.

Note:  Reports are not currently available in Salesforce Mobile for iPhone.

Salesforce Mobile for iPhone Enhancements
Enhanced Search Capabilities

With Summer '10, it's easier than ever to find the specific piece of data you need. The Search tab now supports both
local and remote search, which means your searches return records stored locally on your device and records online in
Salesforce.com. Search results include matches found for any mobilized object, separated by object type.
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Performance Improvements

Summer '10 introduces performance improvements that make the application faster. For customers with large data sets,
the application more efficiently fetches data in the background and allows use of the application without interruption.
Additionally, it’s more obvious when the application is synchronizing.

Windows Mobile Peripheral Support

Available in: All Editions

With Summer '10, you can now use Salesforce CRM’s mobile capability for Windows for field service management.

The mobile application includes functionality for field service professionals by providing integration with the barcode scanner
and magnetic stripe card reader in select Motorola Windows Mobile devices. Windows Mobile users can:

• Use the barcode scanner to populate fields or search for records.
• Swipe credit cards to capture payment information.
• Capture signatures.
• Attach new or existing images to records.

Using peripherals with the mobile application requires Windows Mobile 6 Professional and a minimum of Salesforce Mobile
version 11.0. At least 5 MB of free memory should be available on the device. The mobile application can integrate with the
peripherals on these Windows Mobile devices:

• MC55
• MC75
• MC90
• MC95

This feature requires setup in Salesforce.com before you can use it in the mobile application. For detailed information about
setting up peripherals and using them in Salesforce.com for Windows Mobile, see the Windows Mobile Peripheral Support
Implementation Guide.

Note:  Not all components of the Windows Mobile peripherals feature are available in Mobile Lite. Enabling image
attachment requires the ability to edit a mobile configuration's data sets, and enabling signature capture requires the
ability to mobilize custom objects. With Mobile Lite, you can't edit data sets or mobilize custom objects. Organizations
using Mobile Lite can only set up barcode and credit card fields.

Support for Attachments in Salesforce Mobile for Windows Mobile

Available in: Unlimited and Developer Editions

Available for an additional cost in: Professional and Enterprise Editions

Summer '10 extends the functionality of Salesforce Mobile for Windows Mobile. Now mobile users can view the Attachments
related list and attach images to records. An administrator must mobilize attachments in order for users to access the Attachments
related list in the Windows Mobile client application.
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Note:  Attachments are not currently available in Salesforce Mobile for BlackBerry or iPhone. Attachments are also
not available in Mobile Lite.

Mobilizing Attachments

User Permissions Needed

“View Setup and Configuration”To view mobile configurations:

“Manage Mobile Configurations”To create, change, or delete mobile configurations:

To enable attachments in the mobile application, include the attachments object in your organization's mobile configurations.
Mobile users access attachments from a record's Attachments related list. Currently the only type of attachment users can add
to from the mobile application are image files. Users can either take pictures, or select existing pictures from their phone's
photo album.

To mobilize attachments:

1. Click Setup ➤ Mobile Administration ➤ Mobile Configurations, then click the name of a mobile configuration.
2. In the Data Sets related list, click Edit.
3. In the data tree, click the name of a parent data set.
4. Click Add... to add a child data set.
5. In the popup window, select Attachment, then click OK.

As long as you mobilize attachments for one object, the Attachments related list appears in the mobile application for every
object that supports attachments.

6. Continue adding attachments as a child data set until you're finished.
7. Click Done.

Attaching Images in the Mobile Application

The Attachments related list is available in the mobile application for certain types of records. To view a list of a record's
attachments, open a record, scroll down, and select Attachments. You can also highlight or open a record and select Actions
➤ Related To ➤ Attachments.

With the appropriate permissions, you can edit an attachment's details or delete an attachment. The only type of attachment
you can add to Salesforce.com from the mobile application is an image file. The mobile application lets you attach JPG, BMP,
PNG, and GIF files under 5 MB. You can either take a picture, or select existing images from your device's My Pictures folder.

To attach a new image file to a record:

1. Open a record, or highlight it in a list view.
2. Select Actions ➤ Attach Images ➤ New Image.
3. Take a picture by selecting Capture.
4. If you like the preview, select Accept. If not, select Retake.
5. Enter the attachment's file name.
6. Optionally, enter details about the attachment, then select Save.
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To attach existing image files to a record:

1. Open a record, or highlight it in a list view.
2. Select Actions ➤ Attach Images ➤ Existing Images.
3. Select the checkboxes next to the pictures you want to upload.

Folders and images are sorted in descending order by the last modified date. Use the Up icon to navigate through the folder
structure. Image selection doesn't persist across folders, so you can only upload images from one folder at a time.

4. Select Upload:

• To accept the default attachment file name and field values and immediately upload the images to Salesforce.com,
select Quick Upload.

• To edit the information about each image attachment, select Edit Details.

5. If you chose Edit Details, enter information about the first image attachment. You can preview the image if you want to
see it before completing the fields on the page.

6. Select Save.
7. If you're uploading multiple images, continue entering the attachment details and clicking Save until you're done with all

the images.

If you cancel while editing the attachment details for multiple images, all pending attachment records are be discarded,
but the images you already uploaded are submitted to Salesforce.com.

Mobile Views Enhancement
Summer '10 offers greater flexibility in the filter criteria for mobile views. Now administrators can use the $User.ID global
variable in custom fields with a lookup to the user object. Previously, it was only possible to use the global variable in standard
fields with a lookup to the user object. The $User.ID global variable lets you reference the current user in the filter criteria for
a mobile view. For more information about the $User.ID global variable, see ”Merge Fields for Mobile Filter Criteria” in the
Salesforce.com online help.

Additional Sales Cloud Enhancements
Campaign Enhancements

Available in: Professional, Enterprise, Unlimited, and Developer Editions

Campaign Sales Alerts
You can now create alerts to lead and contact owners when the leads and contacts are added to a campaign, or create
alerts to respond to a campaign using campaign member workflow email alerts.

From Setup ➤ Create ➤ Workflow & Approvals ➤ Email Alerts, click New Email Alert and set the following:

1. Choose Campaign Member as the Object.
2. Choose Related Lead or Contact Owner as the Recipient Type. When this Recipient Type is selected, the

Available Recipients defaults to Lead or Contact Owner.
3. Add Lead or Contact Owner to Selected Recipients.
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For more information on creating email alerts, see “Creating Email Alerts for Workflow, Approvals, or Milestones” in
the Salesforce.com online help.

Lead and Contact Fields Available in Campaign Member Custom Formula Field
When you create a new campaign member custom formula field, Lead and Contact are now available in Advanced
Formula ➤ Insert Field ➤ Campaign Member. Now you can display lead and contact custom field information on
campaign member page layouts with the formula field enhancements. Click the Advanced Formula tab to use functions
and view additional operators and merge fields. See “Building Formulas” in the Salesforce.com online help.

Enhanced Campaign History
You can now add campaign member custom fields to the lead or contact Campaign History related list. From the
Campaign History related list on a contact, lead, or person account, you can add, edit, update, and remove campaign
members.To add campaign member custom fields to the Campaign History related list, see “Customizing Related Lists”
in the Salesforce.com online help.

Email Enhancements

Available in: All Editions

Mass email not available in: Personal, Contact Manager, and Group Editions

Deleting Attachments Sent as Links
Attachments are sent as links when:

• Attachments of any size are sent using mass email
• An email's attachments total 3 MB or more

You can find and delete attachments sent as links. Recipients who subsequently click on the attachment link see a message
asking them to contact the email sender to view the attachment. You can search only within your organization's email
retention period (typically 30 days, but contact salesforce.com Support for your organization's details).

To find and delete email attachments sent as links:

1. Click Setup ➤ Email Administration ➤ Attachments Sent as Links
2. Enter either of these:

• File name (optional), username, and date range:

- Optionally, attachment file name, including the file extension (for example, ThisYearResults.pdf).
You can use wildcards (for example, ThisYearRes would find ThisYearResults.pdf).

- Sender's username
- Date range during which the email was sent

• Attachment URL: Click the attachment link (.html) in the email to open it in a browser, and copy and paste
the URL.

3. Click Search.

• Search results show up to 100 matching entries.
• If the attachment was sent using mass email, search results show one entry for every 100 emails sent—delete one

of these entries to delete the attachment.

4. In Search Results, click Del next to the attachment you want to delete. Recipients who subsequently click on the
attachment link see a message asking them to contact the email sender to view the attachment.
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Note: You cannot recover deleted attachments from the Recycle Bin.

Warning When Sending Emails to Contacts or Leads Who Don't Receive Mass Emails
When you click Send an Email on contact or lead detail pages, Salesforce.com now warns you if Email Opt Out is
selected for the contact or lead. Email Opt Out excludes the contact or lead from receiving mass emails.

Multiple Email Addresses for Contacts and Leads
If contacts or leads have multiple email addresses, users can now choose an address when clicking Send an Email. To
specify multiple email addresses, create a custom field using the Email custom field type and place it on the appropriate
contact or lead page layouts. See “Custom Field Types” in the Salesforce.com online help.

Email Compliance Footers
You can create personalized footers or disclaimers that appear at the bottom of all outgoing email messages sent from
Salesforce.com or the API. You can create a separate email footer for each encoding and choose default footers for single
and mass email. The defaults are used when no footer matches an outgoing email's encoding. To create an email footer:

1. Click Setup ➤ Email Administration ➤ Email Footers.
2. Click New.
3. Enter a name.
4. Choose if you want the footer to be available for single emails, mass emails, or both.
5. Select the email encoding. The email encoding determines which emails the footer appears on. For each encoding

you can have one active single email footer and one active mass email footer.
6. Enter the text of the footer.

Note:  Footers are text only; HTML tags aren't rendered. Maximum is 32 KB.

To select default footers:

1. Click Setup ➤ Email Administration ➤ Email Footers.
2. Using Default for Single Mail and Default for Mass Mail, select default footers.
3. Click Save.

Note:  If you don't click Save, your default footer choice is lost when you leave the page.

Notes & Attachments Enhancements

Available in: Contact Manager, Group, Professional, Enterprise, Unlimited, and Developer Editions

Previews Available for Chatter Feed Attachments in the Notes and Attachments Related List
If Salesforce Chatter is enabled for your organization and files have been posted to a feed on a record, you can now
preview those files in the record's Notes and Attachments related list. In the Notes and Attachments related list, click
View next to a feed attachment to display a preview of the file. Not all files can be previewed, such as copy-protected
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PDFs. For files that can't be previewed, the View option isn't available and files appear as generic file type icons in the
feed. Some Microsoft Office 2007 features don't display correctly in previews.

Note: On some objects, the Notes and Attachments related list is titled Attachments because the object does not
offer notes. Also, the same related list may be titled Google Docs, Notes, and Attachments or Google Docs and
Attachments depending on the setting in your org. References to the Notes and Attachments related list include
all versions of the related list, regardless of title.

Opportunities and Quotes Enhancements

Opportunities available in: All Editions that signed up prior to the Summer '09 Release in June 2009

Available in Group, Professional, Enterprise, Unlimited, and Developer Editions that signed up during or after the
Summer '09 Release in June 2009

Quotes available in: Professional, Enterprise, Unlimited, and Developer Editions

Quotes Available in Professional Edition Organizations
With Summer '10, quotes are included in all Professional Edition organizations. Quotes are automatically available for
organizations that subscribe during Summer '10 or later. Existing organizations will be upgraded with Summer '10. To
learn more about quotes, see “Quotes Overview” in the Salesforce.com online help.

Opportunities with Quotes and Quote Line Items Report

View details about the quotes associated with opportunities, and the line items for each quote. The default settings
provide the most commonly used information from each object, but you can customize the report to see any opportunity,
quote, or quote line item field.

Opportunities with Quotes and Quote PDFs Report

View details about the quote PDFs created for each quote associated to an opportunity. The default settings show you
the most commonly used information from each object, but you can customize the report to view other information,
such as who created or last modified each listed quote PDF.

Opportunity Reports Have New Opportunity Owner Columns
The following fields are now available as columns in all opportunity reports. They appear in the custom report wizard
within a new section called Opportunity Owner Information.

• Opportunity Owner Email

• Opportunity Owner: Manager

• Opportunity Owner: Company

• Opportunity Owner: Title

• Opportunity Owner: Department

• Opportunity Owner: Division

• Opportunity Owner: Profile

• Opportunity Owner: Active

Also, Owner Role and Opportunity Owner Alias now appear in the Opportunity Owner Information section.
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Opportunity Stage Picklist Value Update Behavior Enhanced
The Stage picklist affects the Type and Forecast Category values of an opportunity. Specifically, changing the
Type or Forecast Category for a Stage picklist value updates all opportunities that have that stage value.

Partner Portal Enhancements

Available in: Enterprise and Unlimited Editions

Partner Portal Lead Inbox Home Page Component

Include the Partner Portal Lead Inbox component on home page layouts assigned to partner portal users. When a user
logs in to your portal they see a list of leads for their lead queues. The user can click Accept next to a lead to take
ownership of it and follow up.

Note:  Partner portal users must click Accept next to a lead to access complete lead details.

After you add the component to home page layouts assigned to portal users, you can choose the columns that show up:

1. Click Setup ➤ Customize ➤ Partners ➤ Settings.
2. Click the name of your partner portal.
3. Click Customize Lead Inbox.
4. Add, remove, or rearrange fields from the Selected Fields list.

Note: We recommend hiding important lead fields, such as Company Name and Lead Name, from partner
portal users so that they aren't selectively choosing which leads to accept.

5. Click Save.

Note:  Partner portal users can view details in the Leads tab prior to accepting leads from the Lead Inbox
component; PRM portal users cannot view details until they accept a lead from the Available Leads list on the
PRM portal home page.

Salesforce CRM Content Enhancements

Available in: Contact Manager, Group, Professional, Enterprise, Unlimited, and Developer Editions

Salesforce CRM Content Included in All Organizations
In Summer '10, the Salesforce CRM Content feature license is included in all organizations at no additional cost.

To turn on Salesforce CRM Content for an organization, administrators can now select Enable Salesforce CRM
Content from Setup ➤ Customize ➤ Salesforce CRM Content ➤ Settings.

To give users access to Salesforce CRM Content, administrators now have two options:

• To assign feature licenses to users automatically, click Setup➤Customize➤ Salesforce CRM Content➤ Settings
and select Autoassign feature licenses to existing and new users.

• To assign feature licenses to users manually, click Setup➤Manage Users➤ Users and click Edit next to the user's
name. Select the Salesforce CRM Content User checkbox and click Save.
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To set up Salesforce CRM Content for your organization, see “Setting Up Salesforce CRM Content” in the Salesforce.com
online help.
.

Enable or Disable Salesforce CRM Content for Your Organization
Administrators can now turn Salesforce CRM Content on or off for their organization by selecting or deselecting Enable
Salesforce CRM Content from Setup ➤ Customize ➤ Salesforce CRM Content ➤ Settings. This setting is
enabled by default for existing organizations, and disabled by default for new organizations.

Autoassign Salesforce CRM Content Feature Licenses
Administrators can now assign feature licenses to users automatically by selecting Autoassign feature licenses
to existing and new users from Setup ➤ Customize ➤ Salesforce CRM Content ➤ Settings. If this option
is checked, Salesforce.com automatically attempts to assign Salesforce CRM Content feature licenses to all existing
users. If there aren't enough licenses available, no licenses are assigned. Contact salesforce.com to request additional
feature licenses. When a new user is created, a Salesforce CRM Content feature license is automatically assigned as long
as licenses are available. A feature license corresponds to the Salesforce CRM Content User checkbox on the user
detail page.

Salesforce CRM Content Search Includes Salesforce Chatter Files

Clicking the Content tab displays files, content packs, Web links, and Google docs published in your Salesforce CRM
Content workspaces. If Salesforce Chatter is enabled, files posted to Chatter groups and other Chatter files are also
displayed on the Content tab. The top twenty most recently modified items are listed by default. You can filter the list
using the Filter Your Results sidebar.

From the Search drop-down list, restrict your search to a specific workspace or choose to search in all workspaces. If
Salesforce Chatter is enabled, you can restrict your search using:

• All Files—All workspaces and Chatter groups you're a member of and files posted to the Chatter feed on the Home
tab and on profiles.

• Chatter Files—All Chatter groups you're a member of and files posted to the Chatter feed on the Home tab and on
profiles.

• My Chatter Groups—All Chatter groups you're a member of.
• My Workspaces—All workspaces you're a member of and your personal workspace.

In the Filter Your Results sidebar, filter your search results by file format, featured content, author, tag, workspaces,
content type, language, or a custom field. If Salesforce Chatter is enabled, you can also filter your search results by Chatter
groups. The number in parentheses next to each filter type shows you how many matching files, content packs, Web
links, and Google docs are in the search results.

Previews for Microsoft Office 2007 Files—Pilot
In Salesforce CRM Content, you can now preview Microsoft Office 2007 files, including PowerPoint, Word, and
Excel.The document viewer allows users to view a document without downloading, whether the document be a content
delivery sent to a lead, prospect, or colleague, or a document viewed internally in Salesforce CRM Content.

To enable this feature for your organization, click Setup ➤ Customize ➤ Salesforce CRM Content ➤ Settings and
select Enable Office 2007 previews in Content—Pilot. This setting is enabled by default. Note that
copy-protected PDFs can't be previewed and some Microsoft Office 2007 features don't display correctly in previews.

Content Delivery Recipients Can Preview Microsoft 2007 Files—Pilot
With Summer '10, content delivery recipients can now preview Office 2007 files. A content delivery can be created from
the Content Deliveries related list on most Salesforce objects. Salesforce CRM Content users can also create a content
delivery from the content details page or the Related Content related list. Be sure to preview your content delivery to
verify that you are happy with the quality of the preview.

64

Sales Cloud Additional Sales Cloud Enhancements



If you are enabling content deliveries for your organization and want recipients to be able to preview Office 2007 files,
click Setup➤ Customize➤ Content Deliveries Settings, and select Enable recipients to preview Office
2007 content deliveries. This setting is off by default. Note that copy-protected PDFs can't be previewed and
some Microsoft Office 2007 features don't display correctly in previews.

Post Content to Chatter Feeds with New Workspace Privilege
The Post Content to Chatter Feeds privilege makes content from a workspace accessible on Salesforce Chatter
feeds. From a Chatter feed, users can select a file from a workspace they are a member of and post it to a feed.
Administrators enable this privilege when creating or editing a workspace permission. This privilege is off by default for
existing organizations and on by default for new organizations.

Note:

• Both Salesforce CRM Content and Salesforce Chatter must be enabled.
• Links, Google docs, documents (from the Documents tab), and attachments (from the Notes and Attachments

related list, for example) aren't included in the list of files to attach.
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Salesforce Knowledge Enhancements
Available in: Enterprise, Unlimited, and Developer Editions

Salesforce Knowledge enhancements in Summer '10 include:

Creating an Article While Closing a Case

When closing a case, users can now capture important information and help solve future cases more quickly by creating
a new draft article. Once the article is reviewed and published, it is automatically attached to the case and available in
the knowledge base.

Creating an Article from a Reply

Seamlessly integrate your answers community with your knowledge base by allowing community members to convert
helpful replies into articles. After a reply is promoted to the knowledge base, members browsing or searching the answers
community can click a link on the reply to read the published article. If the article is not yet published, the reply provides
the name of the draft article, the author who promoted the reply, and the date and time the article was created.

Sending Articles as PDF Attachments on Case Email

If your organization uses Email-to-Case or On-Demand-Email-to-Case, you can create an email template that gives
support reps a fast and easy way to send knowledge base articles to contacts. The template automatically converts articles
associated with the case into PDF attachments on an email.

Using Suggested Articles to Solve Cases

Searching the knowledge base is more efficient than ever for case users. Rather than creating a new case and then using
the search function on the Articles related list, if autosuggestion is enabled a list of potentially relevant articles appears
as soon as a new case is saved. Salesforce Knowledge automatically searches for keywords in articles that match a keyword
in the case subject. Autosuggestion is available for all channels except the public knowledge base.

Customizing Access for Article Managers

Previously, users who had access to the Article Management tab could perform all the actions found there, including
creating, editing, publishing, assigning, and deleting articles. In Summer '10, administrators can control access to article
actions on a more granular level by assigning public groups to specific actions. For example, you might create a public
group called Superusers and assign it to the Delete Articles action, meaning only article managers who are members of
Superuser can delete articles.

Following Articles in Chatter Feeds

Using Salesforce Chatter to stay up-to-date on important information now includes the latest changes to your knowledge
base. If feed tracking is enabled for one or more article types, you can follow published articles that belong to the tracked
types. Posts about an article you're following appear on your home page feed and the profile feed of the article manager
who updated the article.

SERVICE CLOUD
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New Custom Report Options

Two new custom report types are available to help you improve the knowledge base: Cases with Articles and Knowledge
Keyword Search. Reports created from these report types reveal which articles are helping solve cases and which topics
users are hoping to find when searching for information. Also, you can now include statistics about article views on
reports created from the Knowledge Articles custom report type.

Data Categories Visible to Users Without Roles

Previously, visibility of data categories and articles associated with them depended on user role. In organizations that
use roles, users who were not assigned to a role, such as high-volume Customer Portal users, could only see uncategorized
articles. With the addition of default visibility settings in Summer '10, you can designate certain data categories as visible
to all users while still restricting access as needed for each role.

Email Notification of Assigned Articles

Rather than rely on article reviewers to constantly monitor their draft article lists, you now have a Send Email option
to notify the reviewer when you assign one or more articles. The email alert contains your instructions, the due date, and
links to each article. If you're assigning multiple articles with more than one article type, a notification is sent for each
article type.

Article Previews for all Channels

Article managers can now preview any article for all audiences. Click Preview next to an article on the Article Management
tab to view the article in the Internal App, Customer Portal, Partner Portal, or Public Knowledge Base. The Customer
Portal and Partner Portal options are only available in the preview menu if portals are enabled in your organization.

Showing Article Summaries in List Views

You can now decide whether each article's Summary field appears on lists in the Articles tab. Summary information on
the list view can help users decide whether an article is worth opening, thus saving valuable time. On Setup➤Customize
➤ Knowledge ➤ Settings, choose the list-view behavior for each channel.

File Fields Supported in Custom Templates

The File custom field allows authors to attach a file to an article. Previously, only standard templates supported the File
field; if an article had a file, the attachment did not appear when the article was viewed in a custom template. Now, you
can add markup to the custom template's Visualforce page that will render the contents of File fields as links in the
published article. See “Creating Custom Article-Type Templates” in the Salesforce.com online help for more information.

New API Object for Articles

With KnowledgeArticle you can now retrieve a Salesforce Knowledge article independent of its version (status).
Unlike KnowledgeArticleVersion, the ID of a KnowledgeArticle record is identical irrespective of the article's version
(status). For more information, see the Web Services API Developer's Guide.

New API Object for Data Category Selections

A data category selection represents a data category that classifies an article.This object can be used to associate an article
with data categories from a data category group or to query the category selections for an article. The object name is
variable and has a syntax of Article__DataCategorySelection, where Article is the Object Name for the article
type associated with the article. For example, Offer__DataCategorySelection represents the association between
the Offer article type and its data categories. Every article is associated with an article type. For more information, see
the Web Services API Developer's Guide.

67

Service Cloud Salesforce Knowledge Enhancements

http://www.salesforce.com/us/developer/docs/api/index_Left.htm#StartTopic=Content/sforce_api_objects_knowledgearticle.htm?SearchType=Stem
http://www.salesforce.com/us/developer/docs/api/index_Left.htm#StartTopic=Content/sforce_api_objects_articledatacategoryselection.htm?SearchType=Stem


New Metadata API Component for Article Types

You can now deploy article types in Salesforce Knowledge using the ArticleType component. An ArticleType is defined
as a custom object and is stored in the objects folder. ArticleTypes have a suffix __kav (instead of __c  for custom
objects). For more information, see the Metadata API Developer's Guide.

create() call support for KnowledgeArticleVersion

The KnowledgeArticleVersion object now supports the create() call.

About the Salesforce Knowledge Enhancements

Creating an Article While Closing a Case

You asked for it! This enhancement is from an idea on the IdeaExchange.

User Permissions Needed

“Customize Application”To edit Salesforce Knowledge settings:

“Customize Application”To modify page layouts:

“View Articles”

AND

Knowledge User checked on the user detail page

To create articles:

“Create” on casesTo create cases:

To quickly capture information that helped solve a case, users can close a case and be taken directly to a draft article. When
the article is published, it is automatically attached to the original case and is available in the knowledge base for easy search
and reference.

To enable the Save and Create Article button on the close-case page:

1. Click Setup ➤ Customize ➤ Knowledge ➤ Settings.
2. Select Allow users to create an article when closing a case. You must also choose:

• A default article type.This determines which fields appear on the draft article. By default the Title field on all articles
contains the case subject.

• An article assignee. All draft articles created when a case is closed are sent to this user for review. The assignee can edit,
publish, delete, or reassign the article. If the article is published, the Articles related list on the case contains the attached
article.

3. When you're done with the Settings page, click Save.
4. Click Setup ➤ Customize ➤ Cases ➤ Page Layout and edit each close-case layout:

• Click Layout Properties.
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• Select the Enable submissions during case close checkbox and choose Submit Articles. You can only
submit articles or solutions, not both.

• Click Save.

Creating an Article from a Reply

User Permissions Needed

“Customize Application”To edit Salesforce Knowledge settings:

“Read” on questionsTo view the Answers tab:

“Create” on questionsTo ask and reply to questions:

“Manage Articles”

AND

“Edit” on questions

To promote a reply:

You can turn a particularly helpful reply in your answers community into an article in your knowledge base. After the reply is
promoted to an article, it has a status message showing its association with the draft article. When the article is published, the
message on the reply includes a link to the article. The message disappears only if the article is deleted from the knowledge
base.

To enable the Promote to Article button on a reply:

1. Click Setup ➤ Customize ➤ Knowledge ➤ Settings.
2. Select Allow users to create an article from a reply. You must also choose:

• A default article type.The article type determines which fields appear on the draft article. By default, on all draft articles
the Title contains the question and the Summary contains the reply.

• An article assignee. All draft articles created from a reply are sent to this user for review. The assignee can edit, publish,
delete, or reassign the article.

3. When you're done with the Settings page, click Save.
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Sending Articles as PDF Attachments on Case Email

You asked for it! This enhancement is from an idea on the IdeaExchange.

User Permissions Needed

“Customize Application”To set up Email-to-Case or On-Demand Email-to-Case:

“Modify all Data”

AND

“Customize Application”

To enable Email-to-Case or On-Demand Email-to-Case:

“Customize Application”To customize page layouts:

“Edit HTML Templates”To create or change HTML email templates:

“Manage Public Templates”To create or change public email template folders:

“Customize Application”To create or change Visualforce email templates:

If articles are associated with a case, users working on the case can attach PDF versions of the articles to an email simply by
choosing a template you create. This capability is available if Email-to-Case or On-Demand-Email-to-Case is set up and the
Email related list is visible on case page layouts.

To create an email template that converts articles to PDF format and attaches them to the message:

1. Click Setup ➤ Communication Templates ➤ Email Templates.
2. Click New Template to create a template from scratch or click Edit next to an existing template. The new or edited

template must include the Articles as PDFs case field.
3. For example, If you want to edit the SUPPORT: Case Response with Solution (SAMPLE) template to include articles instead

of solutions, complete these steps:

a. Click Edit next to the SUPPORT: Case Response with Solution (SAMPLE) template.
b. Change the Email Template Name to SUPPORT: Case Response with Article (SAMPLE).
c. Modify the Template Unique Name as needed.
d. Choose Case Fields from the Select Field Type drop-down menu.
e. Choose Articles as PDFs from the Select Field drop-down menu.
f. Copy the value from the Copy Merge Field Value field and paste it in the email body.

4. Click Save.

On the case detail page in the Emails related list, users can now click Send an Email and choose the new template. Articles
associated with the case are automatically converted to PDF attachments, and the attachments can be previewed or deleted
if needed before the email is sent.

Note:  Article fields restricted by field-level security are not included in the PDF version. Also, fields in the Properties
section of an article, including First Published, Last Modified, Last Published, and Summary, are not
included in the PDF version.
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Using Suggested Articles to Solve Cases

User Permissions Needed

“Manage Cases”

AND

“Customize Application”

To change support settings:

“View Articles”To view articles:

Suggested articles help knowledge base users solve cases quickly. As soon as a new case is saved, the search engine automatically
looks for articles that have keywords in common with the case subject. The user working the case can scan the articles and
attach them to the case if needed, or initiate another search with different keywords. Articles attached to the case appear on
the Articles related list, which also provides a Find Articles button to search the knowledge base at any time.

To enable suggested articles:

1. Click Setup ➤ Customize ➤ Cases ➤ Support Settings.
2. Click Edit and choose Enable suggested articles. Suggested articles and suggested solutions cannot be enabled at the

same time.
3. Choose each audience (channel) that should receive suggested articles when submitting a case. Suggested articles are

available for the internal app and the portals.
4. When you're done with the Support Settings page click Save.

Customizing Access for Article Managers

User Permissions Needed

“Customize Application”

AND

“Manage Users”

AND

“Manage Salesforce Knowledge”

To create public groups and assign them to article actions:

The “Manage Articles” user permission provides Salesforce Knowledge users with full access to the Article Management tab,
including the ability to create, edit, assign, publish, archive, and delete articles. Administrators can use public groups and the
Article Actions page to restrict article-management tasks to specific users:

1. Click Setup➤ Customize➤ Knowledge➤ Article Actions and decide which users need to perform which actions. For
example, you might decide that a group named Publishers needs to publish, archive, and delete articles and that a group
named Editors needs to edit and assign articles.

2. Create a public group for each set of users.
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Note:  Although you can add any Salesforce.com user to a public group, only users with the “Manage Articles”
user permission will be able to perform article actions.

3. Assign the public groups to article actions:

a. On the Setup ➤ Customize ➤ Knowledge ➤ Article Actions page click Edit.
b. For the action you want to modify, select the appropriate radio button and choose a public group. If you do not modify

an article action, all users with the “Manage Articles” permission can perform that action. You cannot restrict the Create
Articles, Edit Draft Articles, or Assign Articles to Other Article Manager actions.

c. Click OK and Save.

Following Articles in Salesforce Chatter Feeds

User Permissions Needed

“Customize Application”To enable feed tracking:

“View Articles”To view published articles:

“Manage Articles”To create, edit, assign, publish, archive, and delete articles:

Salesforce Chatter users who have access to the knowledge base can receive updates about articles in their Chatter feeds. To
enable feed tracking for article types:

1. Click Setup ➤ Customize ➤ Chatter ➤ Feed Tracking.
2. Select an article type. Each article type appears by name in the Object list. For example, if your organization has three

article types named Offer, FAQ, and Warranty, all three appear alphabetically in the Objects list.
3. Select Enable Feed Tracking, then click Save when you're done with the page.

Unlike other objects, individual fields on article types are not tracked. After a user opens a published article and clicks Follow
in the header, posts about that article on the user's home page feed can include:

• If the article is removed from the knowledge base for edit (unpublished). Three Months Free — Al Smith unpublished this
offer

• If the article is republished. Three Months Free — Al Smith published a new version of this offer

• If the article is republished and flagged as new by the publisher. Three Months Free — Al Smith published this new offer

• If the article is archived. Three Months Free — Al Smith archived this offer

The title link in all posts about a specific article opens the current version of that article in the knowledge base, whether
published, archived, or draft. A user without the “Manage Articles” permission who is following an article will not see posts
if the article's status changes from published to draft. When the article is republished, posts about the article resume. Users
with the “Manage Articles” permission see all posts about articles they follow except for article deletions. If an article is deleted
from the knowledge base, all posts about the article disappear from feeds regardless of user.
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New Custom Report Options

User Permissions Needed

“Manage Custom Report Types”To create or update custom report types:

Two new custom report types are available in Summer '10: Cases with Articles and Knowledge Keyword Search. The Cases
with Articles custom report identifies which articles have helped solve cases. The Knowledge Keyword Search custom report
lists the terms that users entered when searching the knowledge base and tells you whether each search returned any results.
This information reveals potential subjects for new articles and provides insight into user expectations. Summer '10 also
provides statistics about article views for the Knowledge Articles custom report.

To get started using the Cases with Articles custom report, on the Reports tab click Create New Custom Report or Create
New Custom Report With Report Builder. To get started with the Knowledge Keyword Search custom report, you must go
to Setup➤ Create➤ Custom Report Types and define the custom report before it will be available on the Reports tab. For
detailed information, see “Reporting on Articles” in the Salesforce.com online help.

Data Categories Visible to Users Without Roles

User Permissions Needed

“Manage Data Categories”To create data categories:

“Manage Users”To modify category group visibility settings on roles:

“Manage Data Categories”To modify default category group visibility settings:

In organizations that do not use roles, all data categories are visible. Once a role hierarchy is created, category group visibility
settings determine the individual data categories and categorized articles that a Salesforce Knowledge user can see. There are
two types of settings:

• Role-based visibility settings
• Default visibility settings

Role-based visibility settings restrict access to categorized articles by mapping data categories to roles. Users can only see the
data categories permitted by their role. If your organization uses roles but does not assign one to every user, Summer '10 now
provides default visibility settings that allow you to give category visibility to users without roles. For example, although
High-Volume Customer Portal users don't have roles, they can view categorized articles if the associated categories are visible
by default.

To modify the default visibility for data categories:

1. Click Setup ➤ Customize ➤ Data Categories ➤ Default Data Category Visibility. All active and inactive category
groups are listed.

2. Pick a category group and click Edit.
3. Choose All to make all the categories in the category group visible by default, None to make none of the categories visible

by default, or Custom to make some of the categories visible by default.
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4. If you chose Custom, move categories from the Available Categories area to the Selected Categories area as needed.
Selecting a category implicitly includes its child and parent categories as well. Move categories from the Selected Categories
area back to the Available Categories area to remove default visibility.

Community Enhancements
Ideas communities available in: Professional, Enterprise, Unlimited, and Developer Editions

Answers communities available in: Enterprise, Unlimited, and Developer Editions

Summer '10 enhancements for ideas and answers communities include:

Answers Available in Force.com Sites

You can now expose your answers community publicly using Force.com Sites.

Escalating a Question to a Case

Administrators and trusted community members who have permission to create cases can escalate an unanswered or
problematic question to a new case. After the case is created, a message on the original question indicates the case
association with a link to the case and the latest status.

Promoting a Reply to an Article

Community members who have permission to create articles for Salesforce Knowledge can choose to convert a particularly
helpful reply into a new article in the knowledge base. See Salesforce Knowledge Enhancements for more information.

Workflow Support for Questions

You can now set up workflow rules for questions to help you monitor your answers community. Workflow rules can
trigger for numerous conditions, such as a question that has gone unanswered for a certain length of time and questions
with replies that have no best answer.

Data Categories Available to Users Without Roles

Previously, visibility of data categories (and therefore categorized questions) depended on user role. In organizations
that use roles, users who were not assigned to a role, such as high-volume Customer Portal users, could only see
uncategorized questions. With the addition of default visibility settings in Summer '10, you can designate certain data
categories as visible to all users while still restricting access as needed for each role.

Community Members Can Delete Posts

Members of an answers community can delete their questions and replies. Previously, only administrators had permission
to delete.

All Users Can Change Their Community Nicknames

Previously, only administrators could modify the Community Nickname field on the user detail page.

New API Object for Data Category Selections

A data category selection represents a data category that classifies a question. This object can be used to associate a
question with a data category from a data category group or to query the categorization for a question. For more
information, see the Web Services API Developer's Guide.
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About the Community Enhancements

Answers Available in Force.com Sites

Available in: Enterprise, Unlimited, and Developer Editions

User Permissions Needed

“Customize Application”To create and edit Force.com sites:

“Manage Users”To edit public access settings for Force.com sites:

Force.com sites enables you to create public websites and applications that are directly integrated with your Salesforce.com
organization—without requiring users to log in with a username and password. You can also configure login settings that
allow users to log into your portal from your public Force.com site. For example, users browsing through your answers site
can register and login directly from that site, and as authenticated users, they can then ask questions, post replies, vote on a
reply, and participate in the answers community. When users successfully log in, they leave the public site and enter the
associated portal seamlessly.

After exposing your answers community in a Customer Portal, set up your site. The following steps highlight the information
pertinent to answers communities. For detailed information about how to customize and manage sites, see the Force.com
Sites Implementation Guide.

1. If you're setting up Force.com Sites for the first time, click Setup➤Deploy➤ Sites and register and enable your Force.com
domain.

2. On the Sites page, click New to create a new site for your answers community. Enter the site details as needed while noting
the following:

• You must use AnswersHome as the Active Site Home Page.
• For Site Template, you can choose your own custom template, the site template provided, or choose to leave it

blank. If you use the site template provided, be aware that it overrides the styling of your Customer Portal on the pages
that reference the site template. If you do not use the site template, then the login, registration, and password reset
pages inherit the styling of the Customer Portal.

3. On the site detail page:

• Click Edit on the Site Standard Pages related list and move Answers Pages from the Available Pages list to the
Selected Pages list. Click Save to return to the site detail page.

• If you want to configure login settings, click Login Settings and then Edit. From the Enable Login For menu, choose
the portal associated with your community. Your portal only appears in the menu if you selected Log in Enabled
when creating the portal. Modify the other settings as needed.

4. To change the default error messages, click Page Assignment
5. To modify the permissions of guest users to your site, click Public Access Settings.
6. Click Activate on the site detail page when you're ready to make your site public.
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Escalating a Question to a Case

Available in: Enterprise, Unlimited, and Developer Editions

User Permissions Needed

“Customize Application”To customize page layouts and change standard fields:

If a question remains unresolved or its reply isn't satisfactory, administrators and trusted community members can escalate the
question to a case. After a case is created, the question detail page provides a link to the case for the life of the question. This
link also shows the status of the case.

Note:  Closing the case does not mark the question as resolved, and resolving the question does not close the case. In
other words, the case and the question must be updated separately.

To enable an Escalate to Case button on questions:

1. Click Setup ➤ Customize ➤ Cases ➤ Page Layouts. Edit each case page layout to include the Question field.
2. Click Setup➤ Customize➤ Cases➤ Fields. Click the Question field and then Set Field-Level Security. Make sure

the field is visible for profiles that will escalate questions to cases, for example, System Administrator. (The profiles must
also grant permission to create cases.)

Workflow Support for Questions

Available in: Enterprise, Unlimited, and Developer Editions

User Permissions Needed

“Customize Application”To create or change workflow rules, email alerts, tasks, field
updates, and outbound messages:

In Summer '10, you can create workflow rules for questions in your answers community. For example, you may want to create
a workflow rule that sends the community administrator an email whenever a question has ten or more replies but no best
answer. Questions do not support approval processes or workflow tasks. For detailed information, see “Creating Workflow
Rules” in the Salesforce.com online help.

76

Service Cloud Community Enhancements



Data Categories Visible to Users Without Roles

Available in: Enterprise, Unlimited, and Developer Editions

User Permissions Needed

“Manage Data Categories”To create data categories:

“Manage Users”To modify category group visibility settings on roles:

“Manage Data Categories”To modify default category group visibility settings:

In organizations that do not use roles, all data categories are visible. Once a role hierarchy is created, category group visibility
settings determine the individual data categories and categorized questions that a community member can see. There are two
types of settings:

• Role-based visibility settings
• Default visibility settings

Role-based visibility settings restrict access to categorized questions by mapping data categories to roles. Users can only see the
data categories permitted by their role. If your organization uses roles but does not assign one to every user, Summer '10 now
provides default visibility settings that allow you to give category visibility to users without roles. For example, although
High-Volume Customer Portal users don't have roles, they can view categorized questions if the associated categories are
visible by default.

To modify the default visibility for data categories:

1. Click Setup ➤ Customize ➤ Data Categories ➤ Default Data Category Visibility. All active and inactive category
groups are listed.

2. Pick a category group and click Edit.
3. Choose All to make all the categories in the category group visible by default, None to make none of the categories visible

by default, or Custom to make some of the categories visible by default.
4. If you chose Custom, move categories from the Available Categories area to the Selected Categories area as needed.

Selecting a category implicitly includes its child and parent categories as well. Move categories from the Selected Categories
area back to the Available Categories area to remove default visibility.

Community Members Can Delete Their Posts

Ideas communities available in: Professional, Enterprise, Unlimited, and Developer Editions

Answers communities available in: Enterprise, Unlimited, and Developer Editions

A user who posts a question or reply in an answers community can now delete the post if it has not received replies or votes.
Once a question receives a reply, only administrators can delete the question. Also, only administrators can delete a reply that
has received a reply or vote. Users cannot delete their votes.
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Standard Users Can Change Their Community Nicknames

Ideas communities available in: Professional, Enterprise, Unlimited, and Developer Editions

Answers communities available in: Enterprise, Unlimited, and Developer Editions

All users who can access their user detail page at Setup ➤ My Personal Information ➤ Personal Information can update
the Community Nickname field. Previously, only administrators could edit this field.

Additional Service Cloud Enhancements
Enabling High Volume Customer Portal Users

Available in: Enterprise, Unlimited, and Developer Editions

With Summer '10, you can now enable contacts as High Volume Customer Portal users from the contact detail page.

High-volume Customer Portal users include both the High Volume Customer Portal User and Authenticated Website User
license types. You can use these user licenses to add significantly more users to a Customer Portal. After you purchase these
high-volume user licenses, you can assign them to portal-enabled contacts so that large numbers of users can log in to a
Customer Portal without affecting its performance.

Note: The High Volume Customer Portal User user license is currently available through a pilot program, while the
Authenticated Website User user license is generally available. For information on enabling High Volume Customer
Portal users, contact salesforce.com.

For more information, see “Enabling the Customer Portal for Contacts and Person Accounts” in the Salesforce.com online
help.
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Adobe Flash Builder for Force.com General Availability
Available in: Enterprise, Unlimited, and Developer Editions

Available for an additional cost in: Professional Edition

Adobe® Flash® Builder for Force.com is generally available in Summer '10. Adobe Flash Builder for Force.com is an enhanced
version of Adobe's Eclipse-based integrated development environment (IDE) with additional features for developing in
Force.com Flex—a framework for creating Flex-based desktop and Web applications that leverage Salesforce.com logic, data,
and security. The framework provides:

• Seamless handling of connected and disconnected states for desktop apps, including the detection of Internet connectivity
• Adobe’s Data Management Services (DMS), which creates and manages local databases for desktop applications that

operate online and offline
• Data synchronization between Salesforce.com and desktop applications
• Generated ActionScript classes that mirror your Salesforce.com enterprise WSDL and provide access to Salesforce.com

objects
• MXML components to simplify the implementation of user interfaces that render Salesforce.com data, a specialized status

bar, and popup notifications called toasts

• An engine and user interface for resolving data conflicts and errors in desktop applications

Force.com Flex is intended for developers with a working knowledge of MXML (Adobe's user interface markup language),
ActionScript (Adobe's scripting language), Adobe Flash Builder 4, and the Force.com API. To obtain Adobe Flash Builder
for Force.com, visit http://developer.force.com/flashbuilder.

Analytics Enhancements
Salesforce.com analytics enhancements in Summer '10 include:

Dynamic Dashboards

Previously, a dashboard could have a single, static running user, whose security settings determined data access for all
dashboard viewers, regardless of their own personal security settings. With Summer '10, you can also set up dynamic
dashboards, which run using the security settings of the logged-in user. All users see the same dashboard components,
but each sees data according to his or her own access level. A single dynamic dashboard can display a standard set of
metrics across all levels of your organization.

Drag-and-Drop Dashboard Builder

Summer '10 introduces dashboard builder: a powerful and interactive way to quickly create dashboards. Simply drag a
component type onto a column, then drop a data source onto it. Quick Find and filters make it easy to find the data
source you're looking for. To change the source or type, drop a different one onto the component. You can also drag

CUSTOM CLOUD
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and drop to reorder components, edit component properties using the component editor, and directly edit the description,
headers, titles, and footers.

Dashboard Table Summaries

In Spring '10, we released customizable dashboard tables with up to four columns. With Summer '10, you can show
column totals on those tables.

Report Builder Enhancements—Developer Preview

In Spring '10, report builder became available as a Developer Preview. In Summer '10, we added new features to make
report builder more powerful. Now you can create and edit summary reports, manage custom and advanced filters, and
edit row count limits for tabular reports. Use the drag-and-drop interface to reorder columns, add and rearrange groupings,
and change date granularities.

About Analytics Enhancements

Dynamic Dashboards

You asked for it! This enhancement is from an idea on the IdeaExchange.

Available in: Unlimited and Developer Editions

User Permissions Needed

“Run Reports”

AND

“Manage Dynamic Dashboards”

To create, edit, and delete dynamic dashboards:

Previously, a dashboard could only have a single, static running user. With Summer '10, the running user can be:

• A specific user. The dashboard runs using the security settings of that single, specific user. All users with access to the
dashboard see the same data, regardless of their own personal security settings. This approach is perfect for sharing the
big picture across a hierarchy, or motivating team members by showing peer performance within a team.

• The logged-in user. A dynamic dashboard runs using the security settings of the user viewing the dashboard. Each user
sees the dashboard according to his or her own access level. This approach helps administrators share one common set of
dashboard components to users with different levels of access.

Previously, to control data visibility, administrators would create a dashboard, then clone it for each level of data access. They'd
have to assign a different running user for each level, and store the dashboards in different folders. With dynamic dashboards,
administrators can accomplish the same thing without having to create and maintain all those extra dashboards and folders.
A single dynamic dashboard can display a standard set of metrics across all levels of your organization.

Note: You can't schedule refreshes for dynamic dashboards. They must be refreshed manually.
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Example Business Scenario
Let's say that your sales team consists of one vice president, four sales managers, and 40 sales reps—10 reps per manager.
You've been asked to create dashboards that display the following metrics, restricted by role and hierarchy:

Number of Activities by
Meeting Type

Close Rates by CompetitorTotal BookingsRole

Sales Rep

Sales Manager

VP of Sales

Sales reps should only see their own data; managers should only see data for the reps they manage; and the VP should see data
across the entire team. In this scenario, you'd typically have to create 45 different dashboards—one for every single person.
You'd also have to create multiple folders to manage access rights.

With dynamic dashboards, you can create just two dashboards and store them in a single folder:

• Create a dynamic dashboard for sales reps with the following components:

- A gauge of total bookings
- A table of activities by meeting type

• Create a dynamic dashboard for managers and the VP with the following components:

- A gauge of total bookings
- A column chart of close rates by competitor

All users only see data that they can access. Sales reps see their own bookings and activities. Managers see bookings and close
rates for the reps they manage. The VP sees bookings and close rates for the whole team. Because the metrics are the same
for managers and the VP, you can use the same dynamic dashboard for both roles. The dynamic dashboards feature reduces
the number of required dashboards from 45 to two!

Setting Up Dynamic Dashboards
Before you get started, create folders accessible to all dashboard viewers to store dynamic dashboards and corresponding
component source reports.

Tip:  For source reports used in dynamic dashboards:

• Set the appropriate View option on the report run page. For example, if you choose “My Team's Opportunities,”
each dynamic dashboard viewer can see all opportunities for the team.

• To avoid restricting the dashboard's view of the data:

- Make sure advanced filters don't include specific record owners (for example,Opportunity Owner equals
Frank Smith).

- Don't click Save Hierarchy Level when saving opportunity reports.

To create dynamic dashboards:

1. From the Dashboards tab, create a new dashboard or edit an existing one.
2. Click Dashboard Properties.
3. For the Dashboard User option, select Run as logged-in user.

81

Custom Cloud Analytics Enhancements



4. Set the View Edit Page as field to preview the dashboard from the point of view of the selected user.

Use this feature to test what various users see before you send out the dashboard.

Note: The View Edit Page as setting only affects the running user of the Dashboard Edit page, not the view
page. For dashboards with a specific running user, view and edit pages display data as the same user.

5. Click Save.

Drag-and-Drop Dashboard Builder

You asked for it! This enhancement is from an idea on the IdeaExchange.

Available in: Professional, Enterprise, Unlimited, and Developer Editions

User Permissions Needed

“Run Reports”

AND

“Manage Dashboards”

To create, edit, and delete dashboards:

“Drag-and-Drop Dashboard Builder”To create, edit, and delete dashboards using the dashboard
builder interface:

Summer '10 introduces dashboard builder: a powerful and interactive way to quickly create dashboards. Simply drag a component
type onto a column, then drop a data source onto it. Quick Find and filters make it easy to find the data source you're looking
for.To change the source or type, drop a different one onto the component. You can also drag and drop to reorder components,
edit component properties using the component editor, and directly edit the description, headers, titles, and footers.

82

Custom Cloud Analytics Enhancements

http://sites.force.com/ideaexchange/ideaView?c=09a30000000D9xt&id=08730000000BrU5AAK


Figure 1: Example Dashboard Builder Interface

Customizing Dashboards with Dashboard Builder
To customize a dashboard, view it and click Edit. Dashboard builder has the following controls:

Dashboard-Level Controls

• Save or close the dashboard. You'll lose your changes if you close or navigate away from the dashboard builder without
saving first.

• Click Dashboard Properties to change the title, folder, running user, and more.
• See the running user for the dashboard in the Displaying data as field.
• Click the text field at the top of the dashboard to add a description.

Column-Level Controls

• Click  to add a new column. Dashboards can have up to three columns.
• Click  for a column to delete it. Dashboards must have at least two columns. Before deleting a column, move its

components to another column.
• Select Narrow, Medium, or Wide in the drop-down to set a column's width.

Component-Level Controls

• Add components by:

- Dragging a component type onto a column, then dropping a data source (report, s-control, or Visualforce page)
onto it. To change the source, simply drop a different one onto the component.
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To hone in on the right data source, use Quick Find and the Recent, My, and All filters.

- Dragging a data source onto a column, then dropping a component type onto it. To change the type, simply drop
a different one onto the source.

Each component must have a type and a data source. Visualforce components must use Visualforce pages as the data
source.

Note:  Each folder can display up to 200 data sources. If you have more than 200, use Quick Find or filters
to narrow the list.

• Drag and drop to rearrange components. Grab components by the header bar and drag them to the right location
on the dashboard.

• Click  to open the component editor.
• Click  for a component to remove it from the dashboard.
• Click  for a data source to remove it from the component.
• Click component header, title, and footer fields to edit them.

Note:  Hover details and drill-down aren't available while editing a dashboard. To use these functions, go to the
dashboard's view page.

Setting Dashboard Properties with Dashboard Builder
To set dashboard properties:

1. Edit a dashboard and click Dashboard Properties.
2. Do the following:

• Enter a title for the dashboard.
• If you have the “Customize Application” permission, enter a unique name to be used by the API and managed packages.

This name can contain only underscores and alphanumeric characters, and must be unique in your organization. It
must begin with a letter, not include spaces, not end with an underscore, and not contain two consecutive underscores.
The unique name lets developers change certain components' names or titles in a managed package and the changes
are reflected in a subscriber's organization.

• Select a folder to store the dashboard. The folder should be accessible by all of your intended viewers.
• Choose the Dashboard User to set visibility settings for the dashboard:

- Select Run as specified user and set the Run as field to show all dashboard users the same data, regardless
of their personal security settings. Unless you have the “View All Data” permission, you can only choose yourself.

- Select Run as logged-in user to show data to each user according to his or her access level. Optionally, set
the View Edit Page as field to preview the dashboard from the point of view of the selected user. See “Setting
Up Dynamic Dashboards” in the Salesforce.com online help.

• Under Component Settings, select the title color and size, text color, and background fade. If you don't want a gradient,
choose the same color for both Starting Color and Ending Color.

3. Click Save.
4. Edit the dashboard to organize the layout and add components.

Editing Components with Dashboard Builder
To edit a component:
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1. Click  to open the component editor.
2. Choose a component type or select Use chart as defined in source report. This option uses settings from

the report chart for your dashboard component and disables certain settings in the component editor.

Tip:  Use this option to show combination charts in your dashboard.

3. Enter the appropriate settings on the Component Data subtab for the component type you selected.

DescriptionField

For horizontal bar and vertical column charts, choose Side-by-Side, Stacked, or Stacked
to 100%.

For line charts, choose Line Grouped, Line Cumulative, or Line Grouped Cumulative.

Grouping Display

For metrics, enter the label to associate with the grand total for the source report.Metric Label

Choose a scale for displaying your chart values. For table components, this setting
applies only to the first column. For best results, choose Auto to let Salesforce.com
select appropriate units.

Display Units

Select what happens when users click a dashboard component:Drill Down to

• Source Report—Takes the user to the full source report for the dashboard
component.

• Filtered Source Report—When users click individual groups, axis values, or legend
entries, they are taken to the source report filtered by what they clicked.

For example, if you had a stacked vertical column chart of opportunities grouped
by stage, with months as the X-axis, you could click an individual stage in a bar, a
month on the X-axis, or a legend entry for a stage to drill down to the filtered
source report. (Not available for metrics or tables.)

• Other URL—Takes the user to the URL that you specify.

4. Enter the appropriate settings on the Formatting subtab for the component type you selected. For Visualforce pages and
s-controls, set the Height.

5. Click OK.
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Dashboard Table Summaries

You asked for it! This enhancement is from an idea on the IdeaExchange.

Available in: Professional, Enterprise, Unlimited, and Developer Editions

User Permissions Needed

“Run Reports”

AND

“Manage Dashboards”

To create, edit, and delete dashboards:

In Spring '10, we released customizable dashboard tables with up to four columns. With Summer '10, you can show column
totals on those tables.

To create a custom dashboard table component with totals:

1. Edit the table component and click Customize Table.

Note: To customize a table, the source report must be summary or matrix and contain a chart.

2. Specify up to four columns to display in the table. Available columns can be any grouping or summary field in the chart,
or the second-level grouping in the source report. Update the report's chart or groupings to make more columns available
for the dashboard table.

3. Click Show Total for number and currency fields to include that column's sum in the table.

Figure 2: Example Dashboard Table with Totals
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Report Builder Enhancements—Developer Preview

Available in: Developer Edition

User Permissions Needed

“Create and Customize Reports”To create custom reports:

“Report Builder”To create, edit, and delete reports using the report builder
interface:

In Spring '10, report builder became available as a Developer Preview. In Summer '10, we added new features to make report
builder more powerful. Now you can create and edit summary reports, manage custom and advanced filters, and edit row count
limits for tabular reports. Use the drag-and-drop interface to reorder columns, add and rearrange groupings, and change date
granularities.

Note:  For Developer Preview, report builder only works with tabular and summary reports, and functionality is limited.
You can't use it for matrix reports.

Figure 3: The Report Builder Interface

Creating Reports with Report Builder
To create a new report using report builder:

1. From the Reports tab, Click Create Report Using Report Builder.
2. Select the report type for the report, and click Next.
3. Customize your report, then save or run it.
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Working with Report Builder
To customize an existing report using report builder, click the name of a report and click Customize Using Report Builder.

Using the report builder, you can:

• Save or run the report.
• Click Report Properties to change a report's name, description, or folder.
• Find fields using Quick Find and field-type filters.
• Add fields and formulas to the report by double-clicking or dragging them into the Preview pane.
• Set report filters in the Filters pane.
• Click the Format drop-down to change between tabular and summary formats.
• Click the Show drop-down to toggle the Details, Drop Zones, and Chart options, and edit Conditional Highlighting

settings.
• Click Add Chart to define a chart for the report.
• Reorder columns by dragging them.
• Sort the report by a particular column.
• Summarize fields on summary reports.
• Add and reorder grouping levels on summary reports.
• Maximize the Preview pane by resizing or collapsing the Fields and Filters panes by dragging the divider or clicking the

arrow.

Note: To optimize screen real estate, report builder uses a compressed page header. To view your application tabs,
simply save and close the builder.

Working with Fields in Report Builder
The Fields pane lists all accessible fields in the selected report type, organized by the sections defined in the page layout. It
also lists custom summary formulas and lets you create, edit, and delete them.

Finding Fields
Find a field by typing its name into the Quick Find search box. You can also filter the list by type:

• Click  to see all field types, as well as custom summary formulas.
• Click  to see just text fields.
• Click  to see just number fields.
• Click  to see just date fields.

Adding and Removing Fields
To add a field to your report, double-click it or drag it into the Preview pane. Drag an entire folder to add all its fields.
To remove a field, grab the column header and drag it back to the Fields pane. You can also click the column menu and
choose Remove Column, or click Remove All Columns. You can't add non-summarizable fields when Show➤Details
is deselected.

Adding and Removing Formulas
Formulas apply only to summary reports. To add a new formula to your report, double-click Add Formula. Once you
define it, it's automatically added as a column in the preview. To edit a formula, hover over the name and click .

To remove a formula from the preview, grab the column header and drag it back to the Fields pane, or click the column
menu and choose Remove Column. Removing the formula from the preview doesn't delete it. To delete a formula,

hover over the name and click , or click Delete Formula from the column menu.
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Adding and Removing Summary Fields
For summarizable columns on summary reports, click the column menu and choose Summarize this Field. Select Sum,
Average, Max, or Min. The summary field shows at all grouping levels and the grand total level.

To change or remove a summary, choose Summarize this Field and deselect all options.

Note:  If you drag a summarizable field to the preview while Show Summaries Only is enabled, the Summarize
dialog appears automatically.

Adding and Removing Groupings
For summary reports, add a group by dropping a field onto the drop zone. If you can't see the drop zones, click Show
➤ Drop Zones. You can also click the column menu and choose Group by this Field. A summary report can have up
to three grouping levels.

To remove a group, click  for the top-level group and choose Remove Group. You can also grab the group and:

• Drag it to the column bar to remove the group, but keep the field as a column in the report.
• Drag it back to the Fields pane to remove both the group and the field from the report.

Ordering and Sorting Columns
Reorder report columns by grabbing the column header and dragging it to a new location. To sort your report by a
column, click its column header. You can also click the column menu and choose Sort Ascending or Sort Descending
from the drop-down list. Sort is disabled when Show ➤ Details is deselected.

Reordering Groups

For summary reports, to change the hierarchy of groups, drop a group above or below another group, or click  and
choose Move Group Up or Move Group Down.

Setting Filters in Report Builder
To limit the data shown in the report, set the view, time frame, and custom filters:

• Use the View drop-down to select your, your team's, or all records.
• Set the Time Frame options to filter by a column's duration, start date, and end date for a particular column.
• Click Edit Custom Filters to add, edit, or remove filters defined by field, operator, and value. You can also view and

remove filters in the Filters pane. To create advanced filter conditions, click Add filter logic. Click Clear filter
logic to remove conditions.

Note:  If you have Translation Workbench enabled, you can filter on translated strings by specifying the Filter
Language for filter criteria that use contains, does not contain, or starts with operators.

Depending on your organization's setup, you may see additional filters, such as probability, hierarchy, territory, and others.

Tabular reports that have a limited row count can be used in dashboard tables and charts. To prepare a tabular report for use
in a dashboard:

1. Click Edit Custom Filters or select Limit Rows by this Field in the column menu.
2. Set the Rows to Display option to 10, 25, or Custom. If you choose Custom, enter a number between one and 99.
3. Set the Sort By and Sort Order options. If you chose Limit Rows by this Field for a column, these options are already

set.
4. Click OK.
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5. Click Dashboard Settings in the toolbar
6. Choose a Name and Value to use in dashboard tables and charts. Tables show both name and value. Charts are grouped

by name.
7. Click OK. You can now use this tabular report as the source report for a dashboard component.

Dependent Lookups and Other Lookup Filters
Enhancements—Beta

You asked for it! This enhancement is from an idea on the IdeaExchange.

Available in: All Editions

Note: Salesforce.com beta features are production-quality but are not functionally complete.

Lookup filters are administrator settings that restrict the valid values and lookup dialog results for lookup, master-detail, and
hierarchical relationship fields. Administrators specify the restrictions by configuring filter criteria that compare fields and
values on:

• The current record (source)
• The lookup object (target)
• The user's record, profile, and role
• Records directly related to the target object

Summer '10 includes significant enhancements to the lookup filters beta feature, including:

Dependent Lookups

A dependent lookup is a relationship field with a lookup filter that references fields on the source object. Similar to
dependent picklists, the valid values in the dependent lookup change according to other values the user enters on the
record.

Lookup Filter Definitions in Custom Field Wizard

You can create lookup filters for new relationship fields in step 3 of the custom field wizard.

Related Lookup Filters Lists for Target Objects

You can quickly see a list of the lookup filters that restrict the values of each target object. This is useful when creating
similar filters for a target object. Also, lookup filters that reference fields on related objects count against the cross-object
reference limit, which is the number of unique relationships allowed for a target object. The Related Lookup Filters list
lets you see which lookup filters might impact that limit.

• For standard objects, click Setup ➤ Customize, select the object from the Customize menu, and click Related
Lookup Filters.

• For custom objects, click Setup ➤ Create ➤ Objects, select one of the custom objects in the list, and scroll to the
Related Lookup Filters related list.
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These enhancements resulted in additions and changes to the current lookup filter administrator settings. In Summer '10:

• The new lookup filter criteria syntax prefixes fields with the relationship field label.
• When defining a filter, start typing in the filter criteria area and Salesforce.com displays the available options.
• To deactivate a filter, deselect the Active  checkbox.
• Radio buttons for specifying required and optional filters replace the Optional Filters checkbox.

These changes do not impact your existing filters

About the Lookup Filters Enhancements

About Lookup Filters

Available in: All Editions

User Permissions Needed

“Customize Application”To manage lookup filters:

Note: Salesforce.com beta features are production-quality but are not functionally complete.

Improve user productivity and data quality with lookup filters.

Lookup filters are administrator settings that restrict the valid values and lookup dialog results for lookup, master-detail, and
hierarchical relationship fields. Administrators specify the restrictions by configuring filter criteria that compare fields and
values on:

• The current record (source)
• The lookup object (target)
• The user's record, profile, and role
• Records directly related to the target object

For example, you can:

• Restrict the Account Name field on opportunities to allow only accounts with a record type of Customer, filtering out
Partner and Competitor.

• Restrict the Account Name field on opportunities to allow only active accounts.
• Restrict the Contact field on cases to allow only contacts associated with the account specified in the Account Name

field on the case record.
• Restrict the Account Name field on cases to allow only users with the “International Sales” profile to create or edit cases

for accounts outside the United States.

Tip: When you define a lookup filter, optionally click Insert Suggested Criteria to choose from a list of
lookup filter criteria that Salesforce.com suggests based on the relationships between objects in your organization.
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Administrators can make lookup filters required or optional.

• For fields with required lookup filters, only values that match the lookup filter criteria appear in the lookup dialog. Also,
users can't save invalid values manually typed in the field when editing the record. If a user tries to save an invalid value,
Salesforce.com displays an error message, which administrators can customize.

• For fields with optional lookup filters, only values that match the lookup filter criteria appear in the lookup dialog initially;
however, users can click the Show all results link in the lookup dialog to remove the filter and view all search result values
for the lookup field. Also, optional lookup filters allow users to save values that don't match the lookup filter criteria, and
Salesforce.com does not display an error message if a user tries to save such values.

About Dependent Lookups

Available in: All Editions

User Permissions Needed

“Customize Application”To manage dependent lookups:

Note: Salesforce.com beta features are production-quality but are not functionally complete.

A dependent lookup is a relationship field with a lookup filter that references fields on the source object. For example, you can
configure the case Contact field to only show contacts associated with the account selected in the case Account Name field.

When a user changes the value of a referenced field on the source object, Salesforce.com immediately verifies that the value
in the dependent lookup still meets the lookup filter criteria. If the value doesn't meet the criteria, Salesforce.com displays an
error message and users can't save the record until the value is valid.

If the referenced field on the source object is a lookup, master-detail, or hierarchy field, users can't change its value by typing.
Instead, users must click the lookup icon and select a value in the lookup search dialog.

Defining Lookup Filters

Available in: All Editions

User Permissions Needed

"Customize Application"To define lookup filters:

Note: Salesforce.com beta features are production-quality but are not functionally complete.

To define a lookup filter:
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1. You can create lookup filters for new relationship fields in step 3 of the custom field wizard. To create a lookup filter on
an existing field:

a. Navigate to the fields area of the object that contains the relationship field:

• For standard objects, click Setup➤Customize, select the appropriate object from the Customize menu, and click
Fields.

• For custom objects, click Setup ➤ Create ➤ Objects, and select one of the custom objects in the list.

b. Click Edit next to the name of the lookup or master-detail relationship field to which you want to apply the filter.

2. In the Lookup Filter Options section, click Show Filter Settings.
3. Specify the filter criteria a record must meet to be a valid value. To specify criteria, click Insert Suggested Criteria

and choose from a list of suggested criteria, or manually enter your own criteria. To enter your own criteria:

a. In the first column, click the lookup icon or start typing in the text box and select a field.
b. In the second column, select an operator.
c. In the third column, select Value if Salesforce.com should compare the field in the first column with a static value,

or select Field if Salesforce.com should compare the field in the first column with the value of another field.
d. In the fourth column, enter the value or select the field that Salesforce.com should compare with the field in the first

column.

Note:

• To specify advanced filter conditions, click Advanced Options. See “Working with Advanced Filter Conditions”
in the Salesforce.com online help.

• You can select from fields on the current record, the lookup object, or the user record. You can also choose
related fields that are one relationship away from the lookup object. Salesforce.com assists you by listing the
available fields and relationships when you click the lookup icon or click inside the text boxes.

• Lookup filter criteria can compare fields of different types as long as they are compatible.

4. Specify whether the filter is required or optional. For fields with optional lookup filters, only values that match the lookup
filter criteria appear in the lookup dialog initially; however, users can click the Show all results link in the lookup dialog
to remove the filter and view all search result values for the lookup field. Also, optional lookup filters allow users to save
values that don't match the lookup filter criteria, and Salesforce.com does not display an error message if a user tries to
save such values.

For required lookup filters, specify whether you want Salesforce.com to display the standard error message or a custom
message when a user enters an invalid value.

5. Optionally, enter text to display in the lookup search dialog. Consider text that guides users in their searches and explains
the business rule that the lookup filter implements.

6. Leave Active selected.
7. Click Save.

Important: When creating a lookup filter on a master-detail relationship field, verify that the current values of the
field on all of the detail records meet the criteria you specify. If you specify criteria that an existing value doesn't meet,
Salesforce.com prevents the user from saving changes to the detail record. If this occurs, the user must first modify
the value on the master record to meet the criteria. For example, consider a custom object with a master-detail
relationship field that points to accounts. If you define a lookup filter that excludes all accounts with a Create Date
before 01/01/2009, verify that no existing records of that custom object have a master-detail relationship with any
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account created before 2009. A quick way to do this is to create a report that shows all accounts with a Create Date
before 01/01/2009.

If at some point you no longer need this lookup filter, return to this page and do one of the following:

Deactivate the lookup filter

Deactivating a lookup filter preserves the lookup filter configuration but:

• Prevents it from applying to the relationship field
• Prevents it from impacting the cross-object references limit
• Removes it as a dependency for fields referenced in the lookup filter criteria

To deactivate the lookup filter, deselect Active, then click Save.

Delete the lookup filter

Deleting a lookup filter permanently removes it. You cannot recover deleted lookup filters. To delete the lookup filter,
click Clear Filter Criteria, then click Save.

Viewing a List of Lookup Filters for a Target Object
You can quickly see a list of all of the lookup filters that restrict the values of each target object. This is useful when creating
similar filters for a target object. Also, lookup filters that reference fields on related objects count against the cross-object
reference limit, which is the number of unique relationships allowed for a target object. The Related Lookup Filters list lets
you see which lookup filters might impact that limit. To see which lookup filters affect the limit for a particular target object:

• For standard objects, click Setup ➤ Customize, select the object from the Customize menu, and click Related Lookup
Filters.

• For custom objects, click Setup➤ Create➤Objects, select one of the custom objects in the list, and scroll to the Related
Lookup Filters related list.

Lookup Filter Examples

Available in: All Editions

User Permissions Needed

"Customize Application"To define lookup filters:

Note: Salesforce.com beta features are production-quality but are not functionally complete.

Record Types in Lookup Filters
If the value of a relationship field should only consist of records with a particular record type, specify the record type in a
lookup filter. For example, if the Account Name field on opportunities should only have accounts with a Customer Account
custom record type, define the following lookup filter to restrict users to only creating or editing opportunities associated with
accounts that have a Customer Account record type, excluding accounts with Partner Account and Competitor Account record
types:
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Filter Criteria
Account Name: Account Record Type equals value Customer Account

Custom Error Message
Account does not exist or is not a customer account.

Lookup Window Text
You can only associate customer accounts to an opportunity. Search results only
display customer accounts.

Record Status in Lookup Filters
If the value of a relationship field should only consist of records with particular status, specify the status in a lookup filter. For
example, consider a Job Application object with a relationship field that points to the Position object. If the relationship
field should only have open positions, define the following lookup filter to restrict users to only creating or editing job applications
for positions with the Status field set to Open:

Filter Criteria
Position: Status equals value Open

Custom Error Message
Position does not exist or is not an open position.

Lookup Window Text
You can associate only open positions with job applications. Search results display
open positions only.

Profiles in Lookup Filters
When a business rule does not apply to users with every profile, use the Current User Profile global variable fields to
define lookup filters that only affect users with a particular profile.

For example, the following lookup filter on the Case object Account Name field restricts users with a “Domestic Sales” profile
to only creating or editing opportunities associated with accounts that have a billing country of “USA” while allowing other
users to associate opportunities with any account:

Filter Criteria

1. Current User Profile: Name equals value Domestic Sales
2. Account Name: Billing Country equals value USA
3. Current User Profile: Name not equal to value Domestic Sales

Advanced Criteria
(1 AND 2) OR 3

Custom Error Message
Account does not exist or the account billing country is not USA. Domestic sales
reps can only create opportunities for accounts in the United States.

Lookup Window Text
Search results show only United States accounts in the for domestic sales
representatives.
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You can modify the above example to simultaneously restrict users with a “Global Sales” custom profile to only associating
opportunities to accounts with a non-US billing country:

Filter Criteria

1. Current User Profile: Name equals value Global Sales
2. Account Name: Billing Country not equal to value USA
3. Current User Profile: Name equals value Domestic Sales
4. Account Name: Billing Country equals value USA
5. Current User Profile: Name not equal to value Global Sales, Domestic Sales

Advanced Criteria
(1 AND 2) OR (3 AND 4) OR 5

Custom Error Message
Account does not exist or the account billing country is not in your sales area.
Sales reps can only create opportunities for accounts in their sales area.

Lookup Window Text
Search results only display accounts in your region.

Important:  If you do not include line 5 in the filter criteria, users who are not in Global Sales or Domestic Sales
cannot select or save any values on account records.

Roles in Lookup Filters
When a business rule does not apply to users in every role, use the Current User Role global variable fields to define
lookup filters that only affect users with particular roles. For example, in a recruiting application that has a Position object
with a lookup field to a Compensation Package object, you can restrict users from editing or creating positions that have an
executive compensation plan unless they are executive administrators or vice presidents.To do this, define the following lookup
filter on the Position object Compensation Package Name field:

Filter Criteria

1. Current User Role: Name does not start with value VP
2. Current User Role: Name does not equal value Executive Administrator
3. Compensation Package: Plan Type does not equal value Executive
4. Current User Role: Name starts with value VP
5. Current User Role: Name equals value Executive Administrator

Advanced Criteria
((1 OR 2) AND 3) OR (4 OR 5)

Custom Error Message
The compensation plan does not exist, or you have selected an executive compensation
plan but do not have access to create executive positions.

Lookup Window Text
Search results only display compensation plans that are relevant to positions you
are allowed to create.
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Important:  Include the condition you are testing and the opposite condition. In this example, lines 1, 2, and 3 of
the filter criteria ensure that users who are not VPs or Executive Administrators cannot select Executive compensation
plans, while lines 4 and 5 ensure that VPs and Executive Administrators can select Executive compensation plans.

Blank Values in Lookup Filters
Your lookup filter criteria might reference a field that users often leave blank. You can design your lookup filter criteria to
accept blank values by using the Advanced Options in the filter criteria to create an OR condition. For example, if you have
a Partner Contact custom field on opportunities, restrict the field to only allow contacts that are associated to an account
with a Partner Account record type, or private contacts not associated with any account.

Filter Criteria

1. Partner Contact: Account: Account Record Type equals value Partner Account

2. Partner Contact: Account: Account Name equals value

Advanced Criteria
1 OR 2

Custom Error Message
The partner contact must be associated with a partner account, or must be a private
contact.

Lookup Window Text
Search results only display contacts from partner accounts or your private contacts.

User IDs in Lookup Filters
Using user IDs in optional lookup filters can significantly improve user efficiency by first showing lookup search dialog results
that are most relevant to the user while still allowing users to see all results if necessary. For example, on a lookup field to
accounts, you can create an optional lookup filter that restricts the search results to accounts that the user owns in the search
lookup dialog results. If the user is looking for an account that someone else owns, the user can remove the filter.

Filter Criteria
Current User: User ID equals Field Account: Owner ID

Lookup Window Text
By default, search results only display accounts you own. To search all accounts,
click “Show all results.”

Simple Dependent Lookups
If the value of a relationship field should depend on the value of another relationship field on the current record, specify the
field to field comparison in the criteria. For example, if the case Contact Name field should only have contacts associated
to the account specified in the case Account Name field, use the following lookup filter:

Filter Criteria
Contact Name: Account ID equals field Case: Account ID

Custom Error Message
Contact does not exist or is not associated to the case account.
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Lookup Window Text
Search results only display contacts associated to the case account.

Note: When comparing lookup fields in lookup filter criteria, Salesforce.com always uses the ID of the relationship
field, not the name.

Complex Lookup Filters and Dependent Lookups
Achieving complex business rules with lookup filters often involves combing your rules with advanced options and fields of
various types. For example, consider an app for booking conference rooms that has the following data model:

FieldsObject

Meeting • Meeting Name

• Office lookup to the Office object
• Projector Required checkbox
• Number of Participants number field
• Conference Room lookup to the Conference Room

object

Conference Room • Conference Room Name

• Has Projector checkbox
• Number of Seats Available number field
• Conference Room Location lookup to the Office

object

Office • Office Name

The following lookup filter on the meeting Conference Room field restricts the valid values to conference rooms that have
a projector if the meeting requires one, as well as the necessary number of seats:

Filter Criteria

1. Meeting: Projector Required equals field Meeting Conference Room: Has Projector

2. Meeting: Projector Required equals value False
3. Conference Room: Number of Seats Available greater or equal field Meeting: Number

of Participants

Advanced Criteria
(1 OR 2) AND 3

Custom Error Message
Conference room not found or is insufficient for your meeting.

Lookup Window Text
Search results only display conference rooms that can support your meeting
requirements.

To refine the valid values even further, incorporate the office where the conference room is located:
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Filter Criteria

1. Meeting: Projector Required equals field Meeting Conference Room: Has Projector

2. Meeting: Projector Required equals value False
3. Conference Room: Number of Seats Available greater than field Meeting: Number of

Participants

4. Meeting: Office equals Field Conference Room: Conference Room Location

Advanced Criteria
(1 OR 2) AND 3 AND 4

Custom Error Message
Conference room not found or is insufficient for your meeting.

Lookup Window Text
Search results only display conference rooms that can support your meeting
requirements.

Lookup Filters Limitations and Best Practices

Beta Limitations
• You cannot create filtered lookups on person account fields; however, lookup filter criteria can reference person account

fields.
• Visualforce pages, the Salesforce to Salesforce invitation page, Ideas, and the Division field don't fully support dependent

lookups. Fields on these pages with dependent lookups still appear and Salesforce.com still prevents the user from saving
the record if the lookup is required; however, Salesforce.com does not dynamically filter lookup the dialog results or prevent
users from entering invalid values.

• Some standard objects, such as Content, Products, or Cases, can't use dependent lookups. You can have a dependent
lookup on a field on the Opportunity object, but it can't lookup to the Opportunity object.

• If you create a filtered lookup on a field that looks up to another object, both objects must be deployed into the organization
at the same time.

Best Practices
Custom Help

Define custom help for fields with lookup filters to let users know about the business rule the filter enforces. For example,
if the lookup filter restricts the Account Name on opportunities to only allow active accounts, define custom help that
states You can only associate active accounts with opportunities.

Error Messages
Customize lookup filter error messages to guide users who type invalid values. For example, if the lookup filter restricts
the Account Name on opportunities to only allow active accounts, define an error message that states Value doesn't
exist or isn't an active account.

Important: Salesforce.com translates the standard error message for required lookup filters, but not custom
error messages. Use the Translation Workbench to translate lookup filter custom error messages. To restore
the standard error message after modifying it, click Reset to default message.
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Profile-Based Lookup Filters
Use Current User Profile: ID in filter criteria to define different filter criteria for different users, or to let
administrators enter values that don't match the criteria. Avoid using Current User Profile: Name due to
technical limitations on standard profiles. See “Lookup Filter Examples” in the Salesforce.com online help.

Record IDs vs. Record Names
To reference a specific record in filter criteria, use the ID of the record instead of its name. IDs are always unique whereas
names are not.

Testing
After creating a lookup filter, test it to make sure it is not too restrictive. Some relationship fields may be read only to
users with certain profiles; ensure your lookup filters don't prevent those users from editing records critical to their job
functions.

Dependent Lookups on Page Layouts and Mini Page Layouts in the Console
When designing page layouts with dependent lookups:

• If a dependent lookup is above its controlling field on a layout, make its lookup filter optional or redesign the layout.
Moving a required dependent lookup above its controlling field may confuse users who typically start from the top
of a page when entering data.

• Ensure that both the controlling and dependent fields are visible so users can correct invalid values.

Lookup Filters and the Lookup Filter Fields Search Layout
Do not reference the same fields in both lookup filter criteria and the Lookup Filter Fields search layout. Users might
assume that results from their custom search override administrator-controlled lookup filters.

Implementation Notes
• Salesforce.com supports lookup filters on relationship fields that point to:

- Accounts
- Assets
- Contacts
- Entitlements
- Quotes
- Service contracts
- Users
- Custom objects

For example, you can define a lookup filter on opportunities that points to accounts, but not vice-versa.
• Lookup filter criteria can compare fields on the source object with different types of fields on the target object as long as

the fields are compatible.

Compatible Target Object Field TypesSource Object Field Type

Currency, Roll-Up SummaryCurrency

Date, Date/Time, Roll-Up SummaryDate

Date, Date/Time, Roll-Up SummaryDate/Time

Hierarchy, Lookup, Master-DetailHierarchy

Hierarchy, Lookup, Master-DetailLookup
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Lookup, Hierarchy, Master-DetailMaster-Detail

Number, Percent, Roll-Up SummaryNumber

Number, Percent, Roll-Up SummaryPercent

Text, Text Area, Email, URLPicklist

Currency, Number, Date, Date/Time, Roll-Up SummaryRoll-Up Summary

• Lookup filter criteria cannot reference the following types of fields on the source object:

- Autonumber
- Encrypted
- Formula
- Long text area
- Multi-select picklist
- Roll-up summary
- Text
- Text area
- URL

• On the Fields page, the  icon indicates all fields with active lookup filters. The  icon indicates that the lookup filter
is required.

• If you enter Current User Profile: Name or Profile: Name in the Field column of your lookup filter criteria,
Salesforce.com displays a lookup icon in that row. Click the lookup icon to select from a list of existing profiles rather than
typing profile names.

• The lookup filters you create in Salesforce.com also appear in the partner portal and Customer Portal.
• Lookup filters are case-sensitive.
• If you convert a required lookup filter with a custom error message to optional, Salesforce.com deletes the message.
• If you create a lookup filter that invalidates an existing value for that field, the value persists; however, when a user edits

the record, Salesforce.com displays an error message and requires the user to change the invalid value before saving.
• Salesforce.com prevents you from saving changes that cause required lookup filters on related records to contain invalid

values.
• Lookup auto-completion does not work for fields referenced by lookup filter criteria.
• Salesforce.com ignores lookup filters when converting leads if the Enforce Validation and Triggers from Lead

Convert checkbox on the Lead Settings page is deselected.
• Versions 16.0 and higher of the Salesforce.com API support lookup filters. Lookup filters are enforced when you load data

through the API.
• If you configure a lookup filter to show inactive users only, the relationship field has no valid options because inactive users

are never valid for relationship fields that point to the User object.
• In enhanced list views, you cannot change fields that a dependent lookup filter criteria references.
• Lookup filters do not support mass owner changes. If your lookup filter criteria reference the Owner field, performing a

mass owner change can result in incorrect values that won't be noticed until you attempt to save the record.
• Lookup filters cannot reference formulas that reference global merge fields that lookup filters do not support.
• Salesforce.com does not display an error message if the value of a controlling field invalidates the value of a dependent

master-detail relationship field.
• Salesforce.com does not support inline editing in list views for:

- Fields on the source object that are referenced in dependent lookups.
- Fields with dependent lookups.

101

Custom Cloud Dependent Lookups and Other Lookup Filters Enhancements—Beta



Spanning Relationships in Lookup Filters
Filter criteria can include fields directly related to the target object (one level only). For example, on a lookup field pointing
to contacts, a lookup filter can reference fields on the account related to the contact via the Account Name relationship field.
The lookup field can also reference fields on the contact related to the contact via the Reports To relationship field.

For required lookup filters, each field referenced on a related lookup object counts against the number of unique relationships
allowed for the referenced object, not the source object. For example, the two unique relationships described above count
against the number allowed for the Contact object. Optional lookup filters don't count against the limit on the number of
unique relationships allowed per object.

To see which lookup filters affect the limit for a particular target object:

• For standard objects, click Setup ➤ Customize, select the object from the Customize menu, and click Related Lookup
Filters.

• For custom objects, click Setup➤ Create➤Objects, select one of the custom objects in the list, and scroll to the Related
Lookup Filters related list.

Lookup Filters vs. Validation Rules
Validation rules and lookup filters achieve similar ends, but offer different advantages. Use a lookup filter if:

• You want to improve user efficiency by limiting the number of available options in a lookup search dialog.
• You want to improve user efficiency by automating filters on lookup search dialogs that your users manually set.

Use a validation rule if:

• You're close to the maximum number of lookup filters allowed.
• You must implement a complex business rule that requires you to use a formula. Formulas can reference fields that basic

filter criteria can't reference, such as fields on the parent of the source object. Formulas can also use functions. For example,
use ISNEW if the rule should only apply on record creation, or ISCHANGED if the rule should apply when a field changes.

Other Limitations
• Lookup filter criteria can reference fields on accounts, assets, contacts, entitlements, quotes, service contracts, users, and

custom objects, with the following exceptions:

- Relationship fields on activities
- System fields that are always read only, such as Created By  and Modified By

- Relationship fields that support queues, such as Case Owner, Lead Owner, and Delegated Approver

• Each object can have up to five active required lookup filters and an unlimited number of optional lookup filters. If you
reach the limit of required lookup filters for an object, create optional filters instead and use validation rules to enforce
your business rule when a user saves.

• Lookup filters on currency fields don't convert currencies. For example, if your organization uses multiple currencies and
a lookup filter criteria is Expected Revenue greater than 100000, the lookup shows all records with an
Expected Revenue field value greater than 100,000, regardless of the currency.

• You can't use special date values, such as “Today” or “This Month,” in lookup filter criteria.
• You can't delete fields that are referenced in an active lookup filter.
• You can't change the field type of fields referenced by an active lookup filter.

Using Lookup Filters with Person Accounts
If your organization uses person accounts, note the following:

• Person Accounts don't support dependent lookups.
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• Lookup filter criteria on Account Name only apply to business accounts, not person accounts. For example, if your lookup
filter criteria is Account Name does not contain book, business accounts with "book" in the name, such as John's
Bookstore, are not valid, but person accounts with “book” in the name, such as John Booker, are valid and appear in the
lookup dialog for the Account field. If you need to filter on the name for a person account, use the First Name or Last
Name fields instead.

• Use the Is Person Account field in your lookup filter criteria to restrict the valid values of a lookup field to one type
of account (either person accounts or business accounts). For example, to restrict a lookup to only person accounts, include
the following in your lookup filter criteria: Is Person Account equals True.

• You can't package lookup filters that reference standard fields specific to person accounts, such as the Email and Title
fields.

Force.com Sites Enhancements
Available in: Developer, Enterprise, and Unlimited Editions

Summer '10 includes new features that improve the capabilities of Force.com sites. To access these features, sites must be
enabled for your organization. Summer '10 enhancements for sites include:

Administrator Preview for Sites

With Summer '10, troubleshooting your site is easier with administrator preview. If you see errors on site pages and can't
figure out the cause, use administrator preview mode to look at them in context and in greater detail.

Sites Single Sign-On

You asked for it! This enhancement is an idea from the IdeaExchange.

With Summer '10, your identity provider can use SAML with sites to do single sign-on. Single sign-on enables your
organization's users to sign-on to Salesforce.com once, rather than several times for each integrated product.

Rewriting URLs for Sites

You asked for it! This enhancement is from an idea on the IdeaExchange.

Use the new urlRewriter interface for Apex to display user-friendly URLs and links to site visitors.

New Cookie Class for Force.com Sites

You asked for it! This enhancement is from an idea on the IdeaExchange.

The cookie class lets you access cookies for your Force.com site using Apex. Use this in conjunction with the new
getCookies and setCookies Methods for PageReference to create and store cookies in Apex.

New getCookies and setCookies Methods for PageReference to create and store cookies in Apex.

Use getCookies to return a map of cookie names and cookie objects. Use setCookies to create cookie objects for
your site.
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About the Sites Enhancements

Administrator Preview for Force.com Sites

User Permissions Needed

“Customize Application”To create and edit Force.com sites:

With Summer '10, troubleshooting your site is easier with administrator preview. If you see errors on site pages and can't
figure out the cause, use administrator preview mode to look at them in context and in greater detail.

Note:  Administrator preview mode is available for all active sites, including those with a branded custom Web address.

To access administrator preview mode:

1. Click Setup ➤ Develop ➤ Sites.
2. Click the name of the site you want to preview.
3. In the Site Detail section, click the Preview as Admin link. A new browser window opens with a preview of your site, and

the enhanced error message appears at the bottom of the page.
4. Click Logout of Administrator Preview Mode to clear the administrator cookie and be redirected to the site's home page.

The detailed error messages in administrator preview mode are driven by the <site:previewAsAdmin /> component in
your Visualforce error pages. Starting with Summer '10, new organizations include the <site:previewAsAdmin />
component by default in standard error pages. You must add the component manually to all custom error pages and pages
from older organizations. We recommend that you add it right before the closing </apex:page> tag, like this:

<site:previewAsAdmin />
</apex:page>

Note: The <site:previewAsAdmin /> component contains the <apex:messages /> tag, so if you have that
tag elsewhere on your error pages, you will see the detailed error message twice.

Sites Single Sign-On

User Permissions Needed

“Customize Application”To create and edit Force.com sites:

Enabling Single Sign-On for Sites
Single sign-on is a process that allows network users to access all authorized network resources without having to log in
separately to each resource. Single sign-on allows you to validate usernames and passwords against your corporate user database
or other client application rather than having separate user passwords managed by Salesforce.com.
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You can set up Sites to use SAML single sign-on, so that a customer only has to login once.

To enable single sign-on for Sites using an identity provider:

1. Set up either a Customer Portal or a partner portal.
2. Set up your Sites.
3. If you are using the Customer Portal, set up your Sites to use Customer Portal.
4. In addition to the SAML sign-on information that must be gathered and shared with your identity provider, you must

supply your information provider with the following:

• Organization ID
• Portal ID
• Sites URL

The following must be added as attributes to the SAML assertion sent from your identity provider:

• organization_id

• portal_id

• siteurl

To find these values:

a. Click Setup ➤ Company Profile ➤ Company Information and copy the ID located in the Salesforce.com
Organization ID.

b. For the Customer Portal, click Setup➤ Customize➤ Customer Portal➤ Settings, click the name of the Customer
Portal, and copy the ID located in the Portal ID.

For partner portals, click Setup➤ Customize➤ Partners➤ Settings, click the name of the partner portal, and copy
the ID located in the salesforce.com Portal ID.

c. Click Setup ➤ Develop ➤ Sites, click the name of the Site, then copy the URL either located in the Default Web
Address, the Secure Web Address, or the Custom Web Address, depending on which one you want your users
to use when logging into Salesforce.com.

Service Provider Initiated SAML for Sites
Salesforce.com automatically provides single sign-on for Sites using SAML for when your company's identity provider initiates
login.

If you wanted to use SAML for Sites for when a service provider initiates sign-on, you must first create a Visualforce page
that provides a redirect to your server. The following is an example:

<apex:page showHeader="false" sidebar="false">
<script>

var PingSpURL =
"https://my.pingserver.com:9031/idp/startSSO.ping?PartnerSpId=salesforce.com.sp";

var siteLoginPage =
"&TargetResource={!$Site.CurrentSiteUrl}siteLogin?startUrl={!$Site.OriginalUrl}";

window.location = PingSpURL+siteLoginPage;
</script>
</apex:page>
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Rewriting URLs for Sites

User Permissions Needed

“Customize Application”To create and edit Force.com sites:

Create rules to rewrite URL requests typed into the address bar, launched from bookmarks, or linked from external websites.
You can also create rules to rewrite the URLs for links within site pages. URL rewriting not only makes URLs more descriptive
and intuitive for users, it allows search engines to better index your site pages.

For example, let's say that you have a blog site. Without URL rewriting, a blog entry's URL might look like this:
http://myblog.force.com/posts?id=003D000000Q0PcN

With URL rewriting, your users can access blog posts by date and title, say, instead of by record ID. The URL for one of your
New Year's Eve posts might be: http://myblog.force.com/posts/2009/12/31/auld-lang-syne

You can also rewrite URLs for links shown within a site page. If your New Year's Eve post contained a link to your Valentine's
Day post, the link URL might show: http://myblog.force.com/posts/2010/02/14/last-minute-roses

To rewrite URLs for a site, create an Apex class that maps the original URLs to user-friendly URLs, and then add the Apex
class to your site.

The following are the instance methods for the urlRewriter interface, which is part of Force.com sites.

DescriptionReturn TypeArgumentsName

Maps a list of Salesforce.com URLs
to a list of user-friendly URLs. You

System.PageReference[]System.PageReference[]generateUrlFor

can use List<PageReference>
instead of PageReference[], if you
prefer.

Important: The size and
order of the input list of
Salesforce.com URLs must
exactly correspond to the size
and order of the generated
list of user-friendly URLs.
The generateUrlFor
method maps input URLs
to output URLs based on the
order in the lists.

Maps a user-friendly URL to a
Salesforce.com URL.

System.PageReferenceSystem.PageReferencemapRequestUrl
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Creating the Apex Class
The Apex class that you create must implement the Force.com provided interface Site.UrlRewriter. In general, it must
have the following form:

global class yourClass implements Site.UrlRewriter {
global PageReference mapRequestUrl(PageReference

yourFriendlyUrl)
global PageReference[] generateUrlFor(PageReference[]

yourSalesforceUrls);
}

Consider the following restrictions and recommendations as you create your Apex class:

Class and Methods Must be Global
The Apex class and methods must all be global.

Class Must Include Both Methods
The Apex class must implement both the mapRequestUrl and generateUrlFor methods. If you don't want to use
one of the methods, simply have it return null.

Rewriting Only Works for Visualforce Site Pages
Incoming URL requests can only be mapped to Visualforce pages associated with your site. You can't map to standard
pages, images, or other entities.

To rewrite URLs for links on your site's pages, use the !URLFOR function with the $Page merge variable. For example,
the following links to a Visualforce page named myPage:

<apex:outputLink value="{!URLFOR($Page.myPage)}"></apex:outputLink>

Note: Visualforce <apex:form> elements with forceSSL=”true” aren't affected by the urlRewriter.

See the “Functions” appendix of the Visualforce Developer's Guide.

Encoded URLs
The URLs you get from using the Site.urlRewriter interface are encoded. If you need to access the unencoded
values of your URL, use the urlDecode method of the EncodingUtil class.

Restricted Characters
User-friendly URLs must be distinct from Salesforce.com URLs. URLs with a three-character entity prefix or a 15- or
18-character ID are not rewritten.

You can't use periods in your rewritten URLs.

Restricted Strings
You can't use the following reserved strings as part of a rewritten URL path:

• apexcomponent

• apexpages

• ex

• faces

• flash

• flex
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• google

• home

• ideas

• images

• img

• javascript

• js

• lumen

• m

• resource

• search

• secur

• services

• servlet

• setup

• sfc

• sfdc_ns

• site

• style

• vote

• widg

Relative Paths Only
The pageReference.getUrl method only returns the part of the URL immediately following the host name or site
prefix (if any). For example, if your URL is http://mycompany.force.com/sales/MyPage?id=12345, where
“sales” is the site prefix, only /MyPage?id=12345 is returned.

You can't rewrite the domain or site prefix.

Unique Paths Only
You can't map a URL to a directory that has the same name as your site prefix. For example, if your site URL is
http://acme.force.com/help, where “help” is the site prefix, you can't point the URL to help/page. The
resulting path, http://acme.force.com/help/help/page, would be returned instead as
http://acme.force.com/help/page.

Query in Bulk
For better performance with page generation, perform tasks in bulk rather than one at a time for the generateUrlFor
method.

Enforce Field Uniqueness
Make sure the fields you choose for rewriting URLs are unique. Using unique or indexed fields in SOQL for your queries
may improve performance.

You can also use the Site.lookupIdByFieldValue method to look up records by a unique field name and value.
The method verifies that the specified field has a unique or external ID; otherwise it returns an error.

Here is an example, where mynamespace is the namespace, Blog is the custom object name, title is the custom field
name, and myBlog is the value to look for:

Site.lookupIdByFieldValue(Schema.sObjectType.
mynamespace__Blog__c.fields.title__c,'myBlog');
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Adding URL Rewriting to a Site
Once you've created the URL rewriting Apex class, follow these steps to add it to your site:

1. Click Setup ➤ Develop ➤ Sites.
2. Click New or click Edit for an existing site.
3. On the Site Edit page, choose an Apex class for URL Rewriter Class.
4. Click Save.

Note:  If you have URL rewriting enabled on your site, all PageReferences are passed through the URL rewriter.

Code Example
In this example, we have a simple site consisting of two Visualforce pages: mycontact and myaccount. Be sure you have “Read”
permission enabled for both before trying the sample. Each page uses the standard controller for its object type. The contact
page includes a link to the parent account, plus contact details.

Before implementing rewriting, the address bar and link URLs showed the record ID (a random 15-digit string), illustrated
in the “before” figure. Once rewriting was enabled, the address bar and links show more user-friendly rewritten URLs, illustrated
in the “after” figure.

The Apex class used to rewrite the URLs for these pages is shown in Example URL Rewriting Apex Class, with detailed
comments.

Example Site Pages
This section shows the Visualforce for the account and contact pages used in this example.

The account page uses the standard controller for accounts and is nothing more than a standard detail page. This page should
be named myaccount.

<apex:page standardController="Account">
<apex:detail relatedList="false"/>

</apex:page>

The contact page uses the standard controller for contacts and consists of two parts. The first part links to the parent account
using the URLFOR function and the $Page merge variable; the second simply provides the contact details. Notice that the
Visualforce page doesn't contain any rewriting logic except URLFOR. This page should be named mycontact.

<apex:page standardController="contact">
<apex:pageBlock title="Parent Account">

<apex:outputLink value="{!URLFOR($Page.mycontact,null,
[id=contact.account.id])}">{!contact.account.name}
</apex:outputLink>

</apex:pageBlock>
<apex:detail relatedList="false"/>

</apex:page>

Example URL Rewriting Apex Class
The Apex class used as the URL rewriter for the site uses the mapRequestUrl method to map incoming URL requests to
the right Salesforce.com record. It also uses the generateUrlFor method to rewrite the URL for the link to the account
page in a more user-friendly form.

global with sharing class myRewriter implements Site.UrlRewriter {
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//Variables to represent the user-friendly URLs for
//account and contact pages
String ACCOUNT_PAGE = '/myaccount/';
String CONTACT_PAGE = '/mycontact/';
//Variables to represent my custom Visualforce pages
//that display account and contact information
String ACCOUNT_VISUALFORCE_PAGE = '/myaccount?id=';
String CONTACT_VISUALFORCE_PAGE = '/mycontact?id=';

global PageReference mapRequestUrl(PageReference
myFriendlyUrl){

String url = myFriendlyUrl.getUrl();

if(url.startsWith(CONTACT_PAGE)){
//Extract the name of the contact from the URL
//For example: /mycontact/Ryan returns Ryan
String name = url.substring(CONTACT_PAGE.length(),

url.length());

//Select the ID of the contact that matches
//the name from the URL
Contact con = [select id from Contact where name =:

name LIMIT 1];

//Construct a new page reference in the form
//of my Visualforce page
return new PageReference(CONTACT_VISUALFORCE_PAGE + con.id);

}
if(url.startsWith(ACCOUNT_PAGE)){

//Extract the name of the account
String name = url.substring(ACCOUNT_PAGE.length(),

url.length());

//Query for the ID of an account with this name
Account acc = [select id from Account where name =:name LIMIT 1];

//Return a page in Visualforce format
return new PageReference(ACCOUNT_VISUALFORCE_PAGE + acc.id);

}
//If the URL isn't in the form of a contact or
//account page, continue with the request
return null;

}
global List<PageReference> generateUrlFor(List<PageReference>

mySalesforceUrls){
//A list of pages to return after all the links
//have been evaluated
List<PageReference> myFriendlyUrls = new List<PageReference>();

//a list of all the ids in the urls
List<id> accIds = new List<id>();

// loop through all the urls once, finding all the valid ids
for(PageReference mySalesforceUrl : mySalesforceUrls){
//Get the URL of the page
String url = mySalesforceUrl.getUrl();

//If this looks like an account page, transform it
if(url.startsWith(ACCOUNT_VISUALFORCE_PAGE)){

//Extract the ID from the query parameter
//and store in a list
//for querying later in bulk.

String id= url.substring(ACCOUNT_VISUALFORCE_PAGE.length(),
url.length());
accIds.add(id);

}
}
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// Get all the account names in bulk
List <account> accounts = [select name from Account where id in :accIds];

// make the new urls
Integer counter = 0;

// it is important to go through all the urls again, so that the order
// of the urls in the list is maintained.
for(PageReference mySalesforceUrl : mySalesforceUrls) {

//Get the URL of the page
String url = mySalesforceUrl.getUrl();

if(url.startsWith(ACCOUNT_VISUALFORCE_PAGE)){
myFriendlyUrls.add(new PageReference(ACCOUNT_PAGE + accounts.get(counter).name));
counter++;

} else {
//If this doesn't start like an account page,
//don't do any transformations
myFriendlyUrls.add(mySalesforceUrl);

}
}

//Return the full list of pages
return myFriendlyUrls;

}

}

Before and After Rewriting
Here is a visual example of the results of implementing the Apex class to rewrite the original site URLs. Notice the ID-based
URLs in the first figure, and the user-friendly URLs in the second.

Figure 4: Site URLs Before Rewriting

The numbered elements in this figure are:

1. The original URL for the contact page before rewriting
2. The link to the parent account page from the contact page
3. The original URL for the link to the account page before rewriting, shown in the browser's status bar
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Figure 5: Site URLs After Rewriting

The numbered elements in this figure are:

1. The rewritten URL for the contact page after rewriting
2. The link to the parent account page from the contact page
3. The rewritten URL for the link to the account page after rewriting, shown in the browser's status bar

Force.com Apex Code Enhancements
Available in: Unlimited, Developer, and Enterprise Editions

Force.com Apex code includes the following enhancements in Summer '10. Refer to the Force.com Apex Code Developer's
Guide for complete information about Apex.

The following enhancements are available for pilot only:

Improved System Log Console

Note: The new version of the System Log console is currently available through a pilot program. For information
on enabling the new version of the System Log console for your organization, contact salesforce.com.

The System Log console is a separate window that displays debugging information about a transaction, as well as its
cumulative limits and source code. It can be considered a context-sensitive execution viewer, showing the source of an
operation in a transaction, what triggered that operation, and what occurred afterward. You can use it for tracking code
execution, workflow, validation rules, and other operations that were executed during the transaction. Access the System
Log console from the Salesforce.com user interface by clicking System Log in the upper right corner of any page.
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Note: The first time you access the System Log console, the old version displays. Click the Try it now! link to
display the new System Log console.To return to the old version from the new System Log console, click Switch
to old System Log.

New getApplicationReadWriteMode Method and System.ApplicationReadWriteMode enum for 5 Minute
Upgrade

Note: 5 Minute Upgrade is currently available through a pilot program. For information on enabling 5 Minute
Upgrade for your organization, contact salesforce.com.

Use the System.ApplicationReadWriteMode enum returned by the getApplicationReadWriteMode to
programmatically determine if the application is in read-only mode during Salesforce.com upgrades and downtimes.

The following enhancements are generally available:

New Cookie Class for Force.com Sites

You asked for it! This enhancement is from an idea on the IdeaExchange.

The cookie class lets you access cookies for your Force.com site using Apex. Use this in conjunction with the new
getCookies and setCookies Methods for PageReference to create and store cookies in Apex.

New getCookies and setCookies Methods for PageReference to create and store cookies in Apex.

Use getCookies to return a map of cookie names and cookie objects. Use setCookies to create cookie objects for
your site.

New urlRewriter Interface for Force.com Sites

Use urlRewriter to display user-friendly URLs and links to site visitors. Create rules to rewrite URL requests typed
into the address bar, launched from bookmarks, or linked from external websites. You can also create rules to rewrite
the URLs for links within site pages. URL rewriting not only makes URLs more descriptive and intuitive for users, it
allows search engines to better index your site pages.

New isFeedEnabled Method for DescribeSObjectResult

Returns true if Salesforce Chatter feeds are enabled for the object, false otherwise.

New Encryption, Decryption, and Key Generating Methods

You asked for it! This enhancement is an idea from the IdeaExchange.

The Crypto class has the following new methods.

• decrypt—used to decrypt data
• decryptWithManagedIV—used to decrypt data with Salesforce.com managing the initialization vector.
• encrypt—used to encrypt data.
• encryptWithManagedIV—used to encrypt data with Salesforce.com managing the initialization vector.
• generateAesKey—used to generate an Advanced Encryption Standard (AES) key.
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Sets Now Take Both Primitives and sObjects

Prior to Summer '10, you could only create Sets using primitive data types, such as String or Integer. As of Summer '10,
you can create sets of sObject data types, such as account or lead.

Account a1 = new account(name='MyAccount');
Set<Account> accountSet = new Set<Account>{a1};

sObject Clone Method Improvements

The sObject Clone method now uses the user running the Apex code for the CreateBy value, and the current date and
time for CreatedDate. This is only applicable for Apex code saved using Salesforce.com API version 19.0 and later.

Batch Apex Limit of 250,000 execute Method Calls Lifted

Prior to Summer '10, you could only call the batch Apex execute method 250,000 times in a 24 hour period per
organization. This limit has been removed.

Total Heap Size Increased

As of Summer '10, the total heap size has increased as follows:

• In a trigger context, heap size is now 300,000.
• In an anonymous block, Visualforce controller, or WSDL method, heap size is now 3,000,000.
• In a test method, heap size is now 1,500,000.

New Status Details Column for Monitoring Apex Jobs

If one or more errors occur during batch processing, the Status Details column gives a short description of the first error.
A more detailed description of that error, along with any subsequent errors, is emailed to the user who started the running
batch class.

SOQL Subqueries Respect IsDeleted Field

Prior to Summer '10, subqueries in SOQL returned all records, regardless of the status of the IsDeleted field. Now,
subqueries respect the IsDeleted field, and only return deleted records when IsDeleted = true is explicitly stated
as part of the query.

Trigger Execution Order Applies to Record Owner Changes in the User Interface

Starting in Summer '10, when a user changes a record owner through the Salesforce.com user interface, any record owner
changes specified in before triggers are executed after the new record owner is assigned. That is, the before triggers
take precedence over users' actions.This is in accordance with the behavior described in “Triggers and Order of Execution”
in the Force.com Apex Code Developer's Guide.

Visualforce Enhancements
Available in: Group, Professional, Enterprise, Unlimited, and Developer Editions

Custom controllers and standard controller extensions are not supported in Group or Professional Editions.

Summer '10 introduces several new features that enhance the capabilities of previous versions of Visualforce. For detailed
information on these new features, see the Visualforce Developer's Guide.
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The following enhancements are now available in Visualforce:

Well-formed XML Required for All Visualforce Pages and Components

Visualforce pages and components created using Salesforce.com API version 19.0 or higher must be written as well-formed
XML. In general, this means that elements must be correctly nested, non-empty elements must have an end tag, empty
elements must be terminated with a closing slash (“/”), and so on. The World Wide Web Consortium (W3C) provides
an article on the specifications of well-formed XML.

The following exceptions are allowed:

• Code that violates well-formed XML is permitted inside JavaScript. For example, you don't need to use
<![CDATA[]]> tags in Visualforce.

• Code that violates well-formed XML is permitted inside expressions. For example, you don't need to escape quotation
marks inside formulas.

• XML directives that are normally required at the beginning of a page—such as <?xml version="1.0"
encoding="UTF-8"?>—can occur inside top-level container tags, like <apex:page> and <apex:component>.

Visualforce pages and components that don't meet well-formed XML requirements won't save.

Ability to Add Dependent Picklists

You asked for it! This enhancement is an idea from the IdeaExchange.

Starting with the Summer '10 release, you can add your organization's dependent picklists to Visualforce pages with
Salesforce.com API version 19.0 or higher. This implementation requires no additional custom controller or JavaScript
logic.

To use this feature, define a field dependency between picklist, multi-picklist, radio button, or checkbox fields on any
object. Then, place these fields on your page using the <apex:inputField> component.

Consider the following when using dependent picklists in Visualforce pages:

• You can mix controlling and dependent fields across various field types, such as picklists, multi-picklists, radio buttons,
and checkboxes.

• There's a limit of 10 dependent picklist pairs per page. This is totalled across all objects. Thus, you could have five
dependent picklists on Account, and five on Contact, but no more. However, you can repeat the same pair of dependent
picklists, such as in an iterative tag like <apex:repeat>, without counting more than once against your limit.

A full tutorial can be found in the “Getting a Quick Start with Visualforce” chapter.

View State Inspector—Pilot

Note: This release contains a pilot version of the View State tab that is production-quality but has known
limitations. You must contact Salesforce.com Support to enable this feature.

The Summer '10 release adds a new View State tab to the Visualforce development mode footer. The View State tab
lists which Visualforce elements are contributing to the size of your view state. You can use this tab to monitor the
performance of Visualforce pages where users submit data using forms. By minimizing your view state size, you can
reduce load times.
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Note: The View State tab should be used by developers that understand the page request process. Familiarize
yourself with the order of execution in a Visualforce page before using the tab.

To enable the View State tab:

1. Click Setup ➤ My Personal Information ➤ Personal Information, and click Edit.
2. Select the Development Mode checkbox if it isn't selected.
3. Select the Show View State in Development Mode checkbox.
4. Click Save.

Note:  Since the view state is linked to form data, the View State tab only appears if your page contains an
<apex:form> tag. In addition, the View State tab displays only on pages using custom controllers or controller
extensions.

The new “Tools for Visualforce Development” chapter contains more information about the View State tab, including
its beta limitations.

Postback Requests Return ID Parameter

For Visualforce pages with a Salesforce.com API version 19.0 or later, <apex:form> actions return only the ID query
parameter on a postback request. Previous page versions returned no parameter after post requests.

Rendering of Contact Information Detail Page Prohibited for Person Accounts

For Visualforce pages created with Salesforce.com API version 18.0 or earlier, it was possible to render the detail page
for contact information associated with a person account. Beginning with API version 19.0, the detail page for contact
information can no longer be rendered. The detail page for the associated person account is rendered instead.

Removed Rendering of Related List Hover Panels

Starting with Visualforce pages created with Salesforce.com API version 19.0, the <apex:relatedList> component
won't generate hover panels.

String Literals for value Attribute in <apex:attribute> Must Evaluate to an Object Type

For Visualforce pages with a Salesforce.com API version 19.0 or later, the value attribute on the <apex:attribute>
component must evaluate to an equivalent object reference. String literals that don't evaluate to an object type aren't
accepted, and the custom component won't save.

For example, the following code:

<apex:component name="myComponent">
<apex:attribute name="myAttribute" type="Integer" />

</apex:component>

. . .

<c:myComponent myAttribute="NotAnInteger" />

won't compile. Furthermore, references to null must instead be changed to {!null} to evaluate correctly.
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Web Services API Enhancements
Available in: Enterprise, Unlimited, and Developer Editions

The Web services API version 19.0 contains new features and bug fixes that improve the capabilities of applications that
leverage the Force.com platform. Considerable effort has been made to ensure backwards capability for applications that have
been written against previous versions of the API, starting with API 2.5.

The new API provides a number of powerful enhancements that further improve any integration already in place between
Salesforce.com and your other systems.

After the Summer '10 release, the 18.0 version of the WSDL file is no longer available. Instead, all requests for a WSDL
return the 19.0 version. Remember to save WSDL files with your project, as the enterprise WSDL is custom to your
organization. Salesforce.com maintains backwards compatibility with previous versions of our API in accordance with our
stated support policy. We recommend that developers migrate to the latest version of the API as often as is feasible in order
to receive the benefit of new enhancements from release to release. Developers with integrations on API versions prior to
version 2.5 should plan to migrate to the most recent API in preparation for the eventual end of support for the older API
versions.

Generally Available Enhancements
The Web services API has been improved for Summer '10 (API version 19.0):

New Objects
The following new objects have been added in API version 19.0:

• The Article__DataCategorySelection object associates an article with data categories from a data category group.
• The QuestionDataCategorySelection object associates a question with a data category from a data category group.
• The KnowledgeArticle object provides read–only access to an article independent of its version.
• The ApexLog object represents a debug log.
• The SlaProcess object represents an entitlement process associated with an entitlement.
• The following Salesforce Chatter objects were added in API version 18.0 as part of a Salesforce Chatter limited

release. To access these objects, Salesforce Chatter must be enabled for your organization.

Note:  A feed is a list of recent activities in Salesforce.com, which can include status updates, changes to
record fields, and posts about records. Feeds are a useful way to stay up-to-date with what's going on in
Salesforce.com.

- The AccountFeed object represents a single feed item in an account record feed.
- The AssetFeed object represents a single feed item in an asset record feed.
- The CampaignFeed object represents a single feed item in a campaign record feed.
- The CaseFeed object represents a single feed item in a case record feed.
- The ContactFeed object represents a single feed item in a contact record feed.
- The ContractFeed object represents a single feed item in a contract record feed.
- The EntitySubscription object represents a subscription for a user following a record.
- The FeedComment object represents a comment added to a feed by a user.
- The FeedPost object represents the following types of changes in a NewsFeed, UserProfileFeed, or record feed,

such as AccountFeed: status updates, posts, link posts, and content posts.
- The FeedTrackedChange object represents an individual field change in a feed.
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- The LeadFeed object represents a single feed item in a lead record feed.
- The NewsFeed object represents a single feed item in the news feed on a user's home page. A news feed shows

recent changes to records which the user is following.
- The OpportunityFeed object represents a single feed item in an opportunity record feed.
- The Product2Feed object represents a single feed item in a product record feed.
- The SolutionFeed object represents a single feed item in a solution record feed.
- The UserFeed object represents a single feed item in a user record feed.
- The UserProfileFeed represents a user profile feed, which tracks all actions by a user on records that can be tracked

in a feed. This feed is displayed on the user profile page.

• The following Salesforce Chatter objects were added in API version 19.0. To access these objects, Salesforce Chatter
must be enabled for your organization.

- The CollaborationGroup object represents a Salesforce Chatter group.
- The CollaborationGroupFeed object represents a single feed item in a Salesforce Chatter group feed.
- The CollaborationGroupMember object represents a single member of a Salesforce Chatter group.

Changed Objects
The following objects have been changed in API version 19.0:

• The AsyncApexJob object includes an ExtendedStatus field that displays more details about the first error that
occurred with a batch job.

• The Entitlement object includes a SlaProcessId field that displays the ID of an associated entitlement process.
• The EntitlementTemplate object includes a SlaProcessId field that displays the ID of an associated entitlement

process.
• The Event object includes the GroupEventType field to identify the type of event. Valid values are 0 (Non-group

Event), 1 (Group Event), and 2 (Proposed Event).
• Only users with the “Modify All Data” permission can delete a FeedPost of Type TrackedChange.
• The KnowledgeArticleVersion object now supports the create() call.

Changed Calls
The result objects returned by describeSObjects() and describeGlobal() in API version 19.0 and later include
a new feedEnabled property that indicates whether Salesforce Chatter feeds are enabled for an object.

The FIELD_INTEGRITY_EXCEPTION has been renamed to FIELD_FILTER_VALIDATION_EXCEPTION.

New Concurrent API Request Limit
The limit for production and sandbox instances for concurrent requests (calls) has been reduced from 50 to 25. The
method used to track concurrent API requests counting against this limit has been modified to only track requests lasting
longer than 20 seconds.

New DataCategoryGroupReference Field Type
The DataCategoryGroupReference field type applies to category group and category unique name used to classify articles
in Salesforce Knowledge and questions in the Answers feature. You can use the describeDataCategoryGroups()
and describeDataCategoryGroupStructures() calls to retrieve the category groups and categories associated to
these objects.
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SOQL Subqueries Respect IsDeleted Field
Prior to Summer '10, subqueries in SOQL returned all records, regardless of the status of the IsDeleted field. Now,
subqueries respect the IsDeleted field, and only return deleted records when IsDeleted = true is explicitly stated
as part of the query.

API Migration Issues
The following technical notes are available to assist you in migrating from earlier versions:

• Release 18.0: Web services API Developer's Guide Version 18.0
• Release 17.0: Web services API Developer's Guide Version 17.0
• Release 16.0: Web services API Developer's Guide Version 16.0
• Release 15.0: Web services API Developer's Guide Version 15.0
• Release 14.0: Web services API Developer's Guide Version 14.0
• Release 13.0:

http://wiki.developerforce.com/index.php/What%27s_New_in_Force.com_Web_Services_API_Summer_%2708

• Release 12.0:
http://wiki.developerforce.com/index.php?title=What%27s_New_in_Force.com_Web_Services_API_Spring_%2708

• Release 11.0:
http://wiki.developerforce.com/index.php/What%27s_New_in_Force.com_Web_Services_API_Winter_%2708

• Release 10.0:
http://wiki.developerforce.com/index.php/What%27s_New_in_Apex_Web_Services_API_Summer_%2707

• Release 9.0:
http://wiki.developerforce.com/index.php/What%27s_New_in_Apex_Web_Services_API_Spring_%2707

• Release 8.0: http://www.salesforce.com/developer/tech-notes.jsp?tn=TN-19
• Release 7.0: http://www.salesforce.com/developer/tech-notes.jsp?tn=TN-17
• Release 6.0: http://www.salesforce.com/developer/tech-notes.jsp?tn=TN-15
• Release 5.0: http://www.salesforce.com/developer/tech-notes.jsp?tn=TN-13
• Release 4.0: http://www.salesforce.com/developer/tech-notes.jsp?tn=TN-10

Documentation for these earlier versions is also available. See
wiki.developerforce.com/index.php/Earlier_Reference_Documentation on Developer Force for links to
online and PDF versions.

Bulk API Enhancements
Available in: Enterprise, Unlimited, and Developer Editions

The REST-based Bulk API is optimized to process a large number of records asynchronously. It allows you to load large
batches of data that are processed in the background. The Bulk API has been improved for Summer '10 (API version 19.0):

Download Schema for Multiple API Versions

The Bulk API service is described by an XML Schema Document (XSD) file. With Summer '10, you can download
the schema file for API versions prior to the current release. You can download the schema file for API version 18.0 and
later. For example, if your organization is on the na2 instance and you want to download the schema file for API version
18.0, use the following URI:

https://na2.salesforce.com/services/async/18.0/AsyncApi.xsd
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Improved Retry Handling for Batch Timeout and Lock Errors

With API version 19.0, the Bulk API has improved logic for retrying batches with errors. Previously, timeouts and lock
contention errors resulted in a failed batch, which required the user to submit a new batch or run a new job to process
the remaining records. In API version 19.0, the Bulk API places the remainder of the batch back in the queue for later
processing up to 10 times when processing fails due to either lock contention or timeouts.

Support for Relationship Fields in XML Batches

With API version 19.0, the Bulk API now supports relationship fields in XML batches.

For more information, see Preparing XML Files.

Support for Polymorphic Relationship Fields in Batches

With API version 19.0, the Bulk API now supports polymorphic relationship fields in CSV and XML batches. For
more information, see Preparing CSV Files and Preparing XML Files.

BatchInfo stateMessage Field Enhancement

The stateMessage field now contains all the reasons associated with a Failed batch state. If there are multiple
failures, the message may be truncated. If so, fix the known errors and re-submit the batch.

Permanent Deletion of Records

The operation field in JobInfo now supports a hardDelete option. When this value is specified, deleted records
are not kept in the Recycle Bin. Instead, the records become immediately eligible for deletion, and don't count toward
the storage space used by your organization. This may improve performance. To perform this operation, a user must
have the “Bulk API Hard Delete”, permission. It is disabled for all profiles by default and is only available for Salesforce
user licenses. The Hard Delete operation is also available in Data Loader.

Monitoring Batch Details in Jobs

Previously, you could monitor the status of Bulk API jobs that were in progress or recently completed by clicking Setup
➤ Monitoring ➤ Bulk Data Load Jobs. With Summer '10, the job detail page also includes details for all the batches
in the job. The related list provides View Request and View Response links for each batch.

The job detail page also includes new Apex Processing Time (ms), API Active Processing Time (ms),
Retries, and Total Processing Time (ms) fields. The timing fields help you understand where time is spent
when the Bulk API processes your data.

New Resource for Getting a Batch Request

With API version 19.0, you can get a batch request by sending a GET request to a new resource URI. For more
information on the new resource, see the Bulk API Developer's Guide.

New Resource Fields
The following fields are new in API version 19.0:

DescriptionFieldResource

The number of milliseconds taken to process triggers and other processes
related to the batch data. If there are no triggers, the value is 0. This

apexProcessingTimeBatchInfo

doesn't include the time used for processing asynchronous and batch
Apex operations.

The number of milliseconds taken to actively process the batch, and
includes apexProcessingTime. This doesn't include the time the

apiActiveProcessingTimeBatchInfo
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DescriptionFieldResource

batch waited in the queue to be processed or the time required for
serialization and deserialization.

The number of records that were not processed successfully in this batch.numberRecordsFailedBatchInfo

The number of milliseconds taken to process the batch. This excludes
the time the batch waited in the queue to be processed.

totalProcessingTimeBatchInfo

The number of milliseconds taken to process triggers and other processes
related to the job data. This is the sum of the equivalent times in all

apexProcessingTimeJobInfo

batches in the job. This doesn't include the time used for processing
asynchronous and batch Apex operations. If there are no triggers, the
value is 0.

The number of milliseconds taken to actively process the job and includes
apexProcessingTime, but doesn't include the time the job waited in

apiActiveProcessingTimeJobInfo

the queue to be processed or the time required for serialization and
deserialization. This is the sum of the equivalent times in all batches in
the job.

The number of records that were not processed successfully in this job.
This is the sum of the failures for all batches in the job.

numberRecordsFailedJobInfo

The number of milliseconds taken to process the job. This is the sum of
the total processing times for all batches in the job.

totalProcessingTimeJobInfo

Force.com Development as a Service
Available in: Enterprise, Unlimited, and Developer Editions

Force.com Development as a Service (DaaS) provides the tools and technologies used by professional developers who build
applications for the Force.com platform, as well as those who migrate application changes between development organizations
and production. The DaaS feature area includes support for creating, retrieving, and deploying changes to your organization's
metadata.

New Metadata Types
The following metadata types are new in Metadata API version 19.0:

DescriptionMetadata Type

Represents a remote site setting. Before any Visualforce page, Apex callout, or JavaScript
code using XmlHttpRequest in an s-control or custom button can call an external site, that
site must be registered in the Remote Site Settings page, or the call will fail.

RemoteSiteSetting

Represents the metadata associated with an article type. An ArticleType is defined as a
custom object and is stored in the objects folder. ArticleTypes have a suffix __kav (instead
of __c  for custom objects).

ArticleType
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DescriptionMetadata Type

Represents the metadata associated with an article type page layout. Article type layouts
determine which fields users can view and edit when entering data for an article, they also
determine which sections appear when users view articles.

ArticleType Layout

Updated Metadata
The following metadata fields have been added or changed in Metadata API version 19.0:

DescriptionChangeFieldMetadata Type or Related
Object

The hidden field is set to true by default for
portal profiles

UpdatedProfileFieldLevelSecurityProfile

Determines the way visibility settings are set for
a dashboard. The vaild values are:

NewdashboardTypeDashboard

• SpecifiedUser—All users see data at the
access level of one specific running user,
regardless of their own security settings.

• LoggedInUser—Each logged-in user sees
data according to his or her own access level.

Displays the totals for each summarizable column
in the dashboard table.

NewshowTotalDashboardTableColumn

Force.com IDE

Available in: Enterprise, Unlimited, and Developer Editions

Summer '10 includes new enhancements to the Force.com IDE. For complete details, visit the Force.com IDE release notes
page at http://wiki.developerforce.com/index.php/Force.com_IDE_Release_Notes.

Note: The Force.com IDE for Summer '10 will be released after all instances have been upgraded. Release notes and
downloads are not available until that time.

Push Patch Updates
Available in: Developer Edition

Starting with the Summer '10, you can develop a new package type called a patch version, which enables a developer to change
the functionality of existing components in a managed package, while ensuring that subscribers experience no visible changes
to the package. Patch versions can only be created for major release packages. Subscribers can receive patch upgrades just like
any other package version. However, you can also distribute a patch by using push upgrades to automatically upgrade all eligible
customers running the same major release.

122

Custom Cloud Push Patch Updates

http://wiki.developerforce.com/index.php/Force.com_IDE_Release_Notes


A push upgrade is a method of automatically upgrading your customers to a newer version of your package. You can only push
patches for existing installed managed packages.

A package subscriber doesn't need to do anything to receive the push upgrade. The only indication a subscriber receives after
a successful push upgrade is that the patch number has changed in the package's Version Number. Any upgrades that fail
must be resolved by the developer initiating the push.

Push upgrades minimize the potential risk of having multiple subscriber organizations running variations of the same major
release. Rather than asking each subscriber to manually install the upgrade, a push guarantees that all subscribers are running
the same patch version for a major release by automatically upgrading subscribers.

You can push an upgrade to any number of organizations that have installed your managed package.

About Push Upgrades and Patch Versions

Creating and Uploading Patches

Available in: Developer Edition

User Permissions Needed

“Upload AppExchange Packages”To push an upgrade, or create a patch development
organization:

Note:  Patch versions and push upgrades are only available to Salesforce.com ISV partners.

Patch versions are developed and maintained in a patch development organization. For more information on push upgrades
and patches, see the Force.com Quick Reference for Developing Packages. You can also read the “Best Practices for Push
Upgrades and Patch Versions” in the Salesforce.com online help for more information.

To create a patch version:

1. Click Setup ➤ Create ➤ Packages.
2. Click the name of your managed package.
3. In the Development Organization section, click New.
4. Select the package version that you want to create a patch for in the Patching Major Release drop-down list. The release

type must be Managed - Released for a patch to be created.
5. Enter a Username for a login to your patch organization.
6. Enter an Email Address associated with your login.
7. Click Save.

Note:  If you ever lose your login information, click Reset on the package detail page under Patch Development
Organizations to reset the login to your patch development organization.

123

Custom Cloud Push Patch Updates

http://sites.force.com/partners/PP2Page?p=P_PartnerPrograms
http://na1.salesforce.com/help/doc/en/salesforce_packaging_guide.pdf


After you receive an email indicating Salesforce.com has created your patch development organization, you can click Login
to begin developing your patch version.

Development in a patch development organization is restricted. The following is a list of caveats when developing patches in
a patch development organization:

• New package components can't be added.
• Existing package components can't be deleted.
• API and dynamic Apex access controls can't change for the package.
• No deprecation of Apex, objects, or fields.
• No new Apex class relationships, such as extends, can be added.
• No new Apex access modifiers, such as virtual or global, can be added.
• No new Web services can be added.

When you finish developing your patch, in your patch development organization:

1. Click Setup ➤ Create ➤ Packages and click the name of the package.
2. Click Upload. On the Upload Package page, do the following:

a. Enter a Version Name, such as June 2009.This field is required for managed and unmanaged packages.The version
name is the marketing name for a specific release of a package and allows you to create a more descriptive title for the
version.

b. Notice that the Version Number has had its patchNumber incremented.
c. For managed packages, select a Release Type:

• Choose Managed - Released to upload an upgradeable version. After upload, some attributes of Salesforce.com
components are locked. For a list of locked attributes, see the Force.com Quick Reference for Developing Packages.

• Choose Managed - Beta if you want to upload a version of your package to a small sampling of your audience for
testing purposes. You'll still be able to change the components and upload additional beta versions. For information
on beta versions, see the Force.com Quick Reference for Developing Packages.

Note:  Beta packages can only be installed in Developer Edition or sandbox organizations, and thus can't
be pushed to customer organizations.

d. Change the Description, if necessary.
e. Optionally, enter and confirm a password to share the package privately with anyone who has the password. Don't

enter a password if you want to make the package available to anyone on AppExchange and share your package publicly.
f. Salesforce.com automatically selects the requirements it finds. In addition, select any other required components from

the Package Requirements and Object Requirements sections to notify installers of any requirements for this
package.

g. Click Upload.

To distribute your patch, you can either share the upload link, or schedule a push upgrade.
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Scheduling Push Upgrades

Available in: Developer Edition

User Permissions Needed

“Upload AppExchange Packages”To push an upgrade, or create a patch development
organization:

Note:  Patch versions and push upgrades are only available to Salesforce.com ISV partners.

After you have created a patch version of your package, you can automatically deploy it to customers using a push upgrade.

Tip: Salesforce.com strongly recommends the following sequence for pushing package upgrades:

1. Push the patch to your own organizations so that you can run tests and fix any bugs before upgrading subscribers.
2. When you're ready, push to your customer's organizations. Try sandbox organizations first, if possible.
3. If the patch applies to your most recent release, deprecate the previous version of your package in your main

development organization. Replace the version on AppExchange if necessary, and update your Trialforce.
4. Run the push upgrade once again to ensure any remaining subscribers are upgraded.
5. After your patch is successfully distributed to subscriber organizations, reintegrate those changes into your main

development organization.

For more information about combining patches into the main development organization, see “Working with Patch
Versions” in the Force.com Quick Reference for Developing Packages.

Read the “Best Practices for Push Upgrades and Patch Versions” in the Salesforce.com online help for more information.

To schedule a push upgrade:

1. Log into your main development organization.
2. Under Setup ➤ Create ➤ Packages, click the name of your managed package with a patch you want to push. On the

package detail page, click Push Upgrades.
3. Click Schedule Push Upgrades.
4. Select a patch version to push from the Patch Version drop-down list. Only packages that have been uploaded from a

patch development organization are available in this list.

Note:  Beta versions aren't eligible for push.

5. Enter a Scheduled Start Date, indicating when a push upgrade should begin.
6. Optionally, check Ignore Apex test failures during upgrade.

Caution:

This checkbox should be selected in rare cases when a push upgrade is failing due to an Apex test failure. Only
select this option if both you and your subscriber have reviewed the package you want to upgrade and both agree
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that upgrading to the new version is safe. For more information on why your install might have failed, see “Resolving
Apex Test Failures” in the Salesforce.com online help.

7. In the Select Target Organizations section, select the organizations to receive your push upgrade. If an organization already
received a push upgrade for the selected package version, it won't appear in this list. You can select organizations by:

• Entering a term that filters based on an organization's name or ID. Names can match by partial string, but IDs must
match exactly.

• Choosing between production and sandbox organizations from the Organizations drop-down list.
• Choosing organizations that have already installed a particular version.
• Clicking on individual organizations, or the Select All and Deselect All checkboxes.

This section lists the following information about the organization (in alphabetical order):

DescriptionField

The current package version an organization has installed.Current Version

The ID that uniquely identifies the organization to
salesforce.com.

Organization ID

The name of the organization. Clicking this name shows
the upgrade history for the organization.

Organization Name

The name of the contact who installed the package.Primary Contact

8. Click Schedule.

While a push upgrade is in progress, you can click Abort to stop it.

On the previous push upgrades page, the Push Upgrade History table lists recently scheduled push upgrades for the package.

Integrating Patch Development
If you are developing your packages using the Force.com IDE, you can take advantage of revision control systems in Eclipse
to compare and merge different project branches.

The following diagram illustrates the workflow of creating a patch and integrating any work into future versions:
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In the diagram above, after version 2.0 is released, the developer creates a patch. The package version number in the patch
development organization starts at 2.0.1. As the main development organization moves towards a released version of 3.0, a
second patch is created for 2.0.2. Finally, the developer merges the changes between the main development organization and
the patch development organization and releases the package as version 3.0.

Salesforce.com recommends using the Subversion plug-in. To install Subversion for the Force.com IDE:

1. Go to http://subclipse.tigris.org to get the latest Eclipse Update Site URL compatible with your version of
Eclipse.

2. In the Force.com IDE, navigate to Help➤ Software Updates, and select the Available Software tab. Click Add Site, and
enter the URL from the previous step.

3. Select the new site and click Finish to fetch the latest version of the Subclipse plug-in. Select the required Subclipse plug-in
from the list returned from the site.

4. Click Next, accept the terms, and click Next again.
5. Click Finish to begin the installation, and then Install All when prompted. You will be required to restart Eclipse once

the installation completes.

You have now linked your Force.com IDE environment to Subclipse. The next step is to connect your repository to the
environment:

1. Open the SVN Repository Exploring perspective in the IDE, which will open the SVN Repositories view.
2. Use the Add SVN Repository icon on the far right to configure Subclipse to access the local repository.The URL to access

your repository locally is file:///svn_repos.
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The subversion repository tracks changes made to stored projects. Because working with patches involves two different
branches—a main development organization and a patch development organization—you need to combine your changes for
a future release. To view the different versions of your package:

1. Open the Project Explorer perspective.
2. Navigate to a file in your main development project that you want to compare, and use the context menu to select Compare

With... ➤ Branch/Tag....
3. In the Compare to field, select the patch version of the file.
4. Click Graphical, then click Ok.

The changes between the main development organization's file and the file stored in the patch development organization are
highlighted. You can use this view to merge any differences between the two projects.

For more information on using the Force.com IDE, see the Platform Developer's Guide.

Additional Custom Cloud Enhancements
Approval Email Settings

Available in: Enterprise, Unlimited, and Developer Editions

With Summer '10, you can set your preferences for receiving approval request emails, including opting not to receive them at
all. To set up or edit your Approver Settings, click Setup➤My Personal Information➤ Personal Information. Click Edit
on the User detail page. Note that the Delegated Approver field has been relocated to the Approver Settings section of
the User detail page.

In the Approver Settings section, you can:

• Optionally, select your Delegated Approver.
• Optionally, enter your Manager.
• Set your preference for receiving approval request emails. The options are:

- Only if I am an approver

- Never—If you select this option, you will not receive any approval request emails, even if your organization has email
approval response enabled. However, if the assignee of an approval step is a queue, selecting Never may not block all
approval request emails, depending the queue settings.

Custom Field Enhancements
Enhanced Security for Custom Fields in Portal Profiles

Available in: Enterprise, Unlimited, and Developer Editions

Summer '10 introduces enhanced security for custom fields in portal profiles. When you create a custom field, by default
the field isn't visible or editable for portal profiles, unless the field is universally required.This ensures that administrators
are explicitly granting access to custom fields for their customers and partners. If you want portal users to have access to
a custom field, you can always enable access for portal profiles, either when you create the field or anytime after.
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Note: This change doesn't affect custom fields created before the Summer '10 release.

Rich Text Area Enhancements

Available in: Enterprise, Unlimited, and Developer Editions

With the use of a toolbar, users can format the field content and add images and hyperlinks. The toolbar allows the user
to undo, redo, bold, italicize, underline, strike-out, add a hyperlink, upload or link to an image, modify alignment, add
a numbered or non-numbered list, indent, and outdent. The maximum field size is 32,000 characters, inclusive of all
the formatting and HTML tags. The maximum size for uploaded images is 1MB. Only gif, jpeg and png file types
are supported. See Creating Custom Fields and “Using Rich Text Area Fields” in the Salesforce.com online help.

With rich text area custom fields in Summer '10, you can now:

• Convert rich text area fields into long text area fields. Any images in the rich text area are deleted the next time the
long text area field is saved. See “Notes on Changing Custom Field Types” in the Salesforce.com online help.

• Publish rich text area fields in Salesforce to Salesforce. See, “Publishing Fields in Salesforce to Salesforce” in the
Salesforce.com online help.

Globalization Enhancements
Hebrew—Right-to-Left Language Supported

Available in: All Editions

You asked for it! This enhancement is an idea from the IdeaExchange.

In Summer '10, Salesforce.com successfully implemented Hebrew (iw), a language read from right to left.

Hebrew is available upon request as a Salesforce.com end user language. Users can update their personal language settings
as follows:

1. Click Setup ➤ My Personal Information ➤ Personal Information.
2. Click Edit.
3. Select a language from the Language picklist.
4. Click Save.

My Domain on Sandbox

Available in: Unlimited,  Enterprise, and Developer editions.

With Summer '10, My Domain is available for sandbox environments. Using My Domain, your organization can select a
custom Salesforce.com domain name that highlights your brand, or a different term that represents your business. Using a
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custom domain name provides other important advantages, such as increased security and better support for single sign-on.
For more information, see “My Domain Overview” in the Salesforce.com online help.

New User Interface Theme Enabled

Available in: All Editions

Starting with Summer '10, new organizations have the new user interface theme enabled by default.

Important:  Microsoft® Internet Explorer version 6.0 is not supported for use with the new user interface theme. For
more information, see “Supported Browsers” in the Salesforce.com online help.

Packaging Enhancements
Changes to Deleted Components in a Managed Package

Available in: Group, Professional, Enterprise, Unlimited, and Developer Editions

Summer '10 introduces changes that make it easier to retrieve deleted components from a package. You can now review
deleted components from the Package Detail page.

The components that you can review are:

• Apex classes and triggers that don't have global access
• Visualforce components with public access
• Protected components, including:

- Custom labels
- Custom links (for Home page only)
- Workflow alerts
- Workflow field updates
- Workflow outbound messages
- Workflow tasks

• Data components, such as Documents, Dashboards, and Reports. These are the only types of components that can
also be undeleted from the Recycle Bin

You can retrieve these components at any time before uploading a new version of your package. For more information,
see “Deleting Components From Managed Packages” in the Salesforce.com online help.

In addition, in previous versions, when a protected component was deleted, it remained in subscriber organizations.
Since protected components can't be modified or referenced by the subscriber, these components are now removed from
the subscribers' organization during the next package upgrade.This ensures that the developer and subscriber organizations
maintain the same behavior. This change may result in executable workflow actions being removed.
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Packageable Remote Site Settings

Available in: Group, Professional, Enterprise, Unlimited, and Developer Editions

You asked for it! This enhancement is an idea from the IdeaExchange.
Remote site settings are now packageable. You can include remote site settings related to Apex callouts in your packages.
This lets your application to be able to connect to third-party websites without subscriber intervention.

The installer of the package receives a warning regarding this access the first time the remote site setting is installed.
Remote site settings are not upgradeable, and a subscriber can delete a remote site setting at anytime. Deletion of a
remote site setting may cause the package to no longer function.

Security Enhancements
Default Certificate Key Size Changed

Available in: All Editions

The default value for a certificate's Key Size changed from 1024 to 2048. You can still select 1024 bits.

Increased Security When Logged in as Another User

Available in: All Editions

As part of salesforce.com's continuing focus on security and trust, an administrator can no longer change the access
expiration date for a user when logged in as that user.

New Custom Page URL for SAML Errors

Available in: All Editions

You asked for it! This enhancement is an idea from the IdeaExchange.
When configuring SAML, you can now specify the URL of a custom page that users will be directed to if there's an
error during SAML login. It must be a publicly accessible page, such as a public site Visualforce page. The URL can be
absolute or relative.
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Maximum Number of Certificates Now Enforced

Available in: All Editions

You can only have 50 certificates in an organization. To view the number of certificates saved in your organization, click
Setup ➤ Security Controls ➤ Certificate and Key Management, and view the information on the right-hand side at
the top of the list of certificates.

Download SAML Metadata

Available in: All Editions

As of Summer '10, after you have set up single sign-on using SAML version 2.0, you can download the metadata
associated with your setup. If your identity provider supports metadata, they can use this metadata to automatically
configure their settings for connecting to Salesforce.com. Click Setup➤ Security Controls➤ Single Sign-On Settings,
then click Download Metadata.

Invalid SAML Assertion Used to Populate SAML Assertion Validator

Available in: All Editions

As of Summer '10, when you have set up single sign-on using SAML and a user doesn't succeed when they try to log
into Salesforce.com using SAML, the invalid SAML assertion automatically populates the SAML Assertion Validator
if possible.To view the errors, click Setup➤ Security Controls➤ Single Sign-On Settings, then click SAML Assertion
Validator. The SAML assertion validator is only populated with the most recent failed attempt.

New Encryption, Decryption, and Key Generating Methods

Available in: Unlimited, Developer, and Enterprise Editions

You asked for it! This enhancement is an idea from the IdeaExchange.

The Apex Crypto class has the following new methods:

• decrypt—used to decrypt data
• decryptWithManagedIV—used to decrypt data with Salesforce.com managing the initialization vector.
• encrypt—used to encrypt data.
• encryptWithManagedIV—used to encrypt data with Salesforce.com managing the initialization vector.
• generateAesKey—used to generate an Advanced Encryption Standard (AES) key.
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Callback URL Now Takes Protocols Other than HTTPS

Available in: All Editions

The Callback URL field for remote access applications now uses https or any other protocol, instead of being limited
to just https. It cannot use http.

Remote Access Applications and Packaging Changes

Available in: All Editions

A remote access application in an unmanaged package can only be used in the organization in which it was created. Only
remote access applications in managed packages can be used across organizations.

Data Loader Hard Delete Operation

Available in: Enterprise, Unlimited, and Developer Editions

With Summer '10, you can permanently delete records with Data Loader. When you select the Hard Delete operation, the
deleted records are not stored in the Recycle Bin. Instead, they become immediately eligible for deletion. The administrative
permission for this operation, Bulk API Hard Delete, is disabled by default and must be enabled by an administrator. A
Salesforce user license is required for hard delete.

User Detail Page UI Enhancements

Available in: Professional, Enterprise, Unlimited, and Developer Editions

In Summer '10, the Public Group Membership and Queue Membership related lists on the user detail page are optimized for
large amounts of data. In both related lists, if the list contains more than five items, it includes a link to show more items and
a link to a separate list page. To view these related lists on the user detail page, click Setup ➤ Manage Users ➤ Users and
select the user.
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New: Guided Tours
Want a quick introduction to the why, where, and how of new features? When you first access certain Summer '10 features,
we offer you a quick tour!

Here's an example of the guided tour for the new drag-and-drop dashboard builder:

DOCUMENTATION ENHANCEMENTS
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New: Salesforce.com Limits Quick Reference
Want to know how many custom fields you can have per object? Need to find out daily API request limits for your Edition?
Want to know how much storage your organization is entitled to? The new Salesforce.com Limits Quick Reference contains
detailed information on the most commonly referenced Salesforce.com application limits.

You can access the Salesforce.com Limits Quick Reference from the Help & Training window in Salesforce.com.

New: PRM Portal Implementation Guide
We've removed the PRM Portal information from the online help and placed it in a new PRM Portal Implementation Guide.
Use this guide for information on administering and using the PRM Portal.

Who's using the PRM Portal?

• If you purchased or enabled PRM before February 2008, you are using the PRM Portal, unless you explicitly migrated to
the partner portal. For more information about the PRM Portal, see  PRM Portal Implementation Guide.

• If you purchased or enabled PRM after February 2008, you are using the partner portal. For information about the partner
portal, see “Setting Up Your Partner Portal” in the Salesforce.com online help.

Update: Force.com Cookbook
The Force.com Cookbook is a compilation of code samples that show you how to extend your Force.com apps using workflow,
approvals, Apex, Visualforce, the API, email, and sites. This edition contains some updated recipes and these new recipes:

• Publishing Documents Into a Salesforce CRM Content Personal Workspace
• Publishing Documents Into a Salesforce CRM Content Public Workspace and Setting Tags
• Publishing Documents in Salesforce CRM Content from a Personal Workspace to a Public Workspace
• Revising a Document Already Published in Salesforce CRM Content
• Downloading Content from Salesforce CRM Content
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http://na1.salesforce.com/help/doc/en/salesforce_app_limits_cheatsheet.pdf
http://na1.salesforce.com/help/doc/en/salesforce_prm_implementation_guide.pdf


• Displaying Salesforce CRM Content Documents in a Visualforce Page
• Querying a List of Workspaces in Salesforce CRM Content

Anyone can access the Force.com Cookbook online from the Developer Force Documentation page, or Developer Force members
can download a PDF at developer.force.com/books/cookbook.

Update: Videos
Like to learn by watching? In Summer '10 we offer some great product demos for new features:

• Salesforce Chatter
• Cloud Scheduler
• New Opportunity Page—Pilot

Additionally, here's a new demo on an existing feature: Watch a demo on creating workflow rules (2:40 minutes).
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Documentation Enhancements Update: Videos

http://www.salesforce.com/us/developer/docs/cookbook/index.htm
http://wiki.developerforce.com/index.php/Documentation
http://developer.force.com/books/cookbook
http://na1.salesforce.com/help/doc/en/../../../workflow/tutorial/creatingworkflowrule.htm
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