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About the Release Notes
The Release Notes are a comprehensive user guide for the latest release of Salesforce. Unlike a traditional release notes document
that includes only a simple list of enhancements and known bugs, the Salesforce Release Notes give you everything you need
to get up and running with the new features and enhancements in the latest release.

What's Included in the Release Notes

For every new major enhancement, the Release Notes provide:

• A brief, high-level description of the functionality
• Implementation tips to help you get started with setup and administration
• Best practice tips to help you maximize the benefit of the functionality
• Complete end-to-end instructions on how to set up and use the functionality

Beyond the major new features, the Additional Enhancements sections include a list and brief description of every other
enhancement or functional change included in the latest release—everything from new merge fields you can use in formulas
to improved icons for greater usability to additional fields that are available in standard reports.

Let the Release Notes be your guide to success with the latest release from salesforce.com!

Summary of Summer '07 Features and Impact on Salesforce Users
Summer '07 includes features that will immediately impact all Salesforce users when the release occurs. You may want to
communicate these changes to the users in your organization before the release so that they are prepared for any changes that
might affect them. Other features require direct action by a Salesforce administrator before your users can benefit from the
new functionality.

The following table summarizes the Summer '07 features and whether they will have an immediate impact on users:

Immediate User ImpactEnabled by
Default?

Feature

None until custom report types are set up and deployed to
users.

Yes.Custom Report Types

None.No. Contact
salesforce.com to
enable this feature.

Advanced Currency Management with
Historical Currency Exchange Rates

None until an administrator creates and sets up more than
one Customer Portal or enables any of the additional Customer
Portal enhancements.

Yes.Customer Portal featuring Multiple
Personalized Portals

None until an administrator enables HTML solutions.No. An
administrator must
set up this feature.

Rich-Content Solutions with HTML

After the feature is activated by an administrator, the Mass
Mail Merge link displays in the Tools area on the account,
contact, and lead home pages.

No. An
administrator must
set up this feature.

Extended Mail Merge

All Team Edition organizations are migrated to Group
Edition.

Yes.Group Edition featuring Google
AdWords
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Immediate User ImpactEnabled by
Default?

Feature

Salesforce for Google AdWords is automatically installed in
your Salesforce organization. You can set upSalesforce for

Yes.Salesforce for Google AdWords

Google AdWords to track leads resulting from online
advertisements you create in Google AdWords.

None.Yes.Apex Code

None.No. Contact
salesforce.com to
enable this feature.

Multiple Salesforce Sandboxes

None until an administrator creates roll-up summary fields.No. An
administrator must
set up this feature.

Roll-Up Summary Fields

Users with the "Mass Email" permission can schedule mass
emails, send mass emails according to the new increased limits,
and view and cancel their pending mass emails in the queue.

Yes.Advanced Mass Email

None until an administrator adds help to custom objects or
an administrator adds help text to custom fields by editing the
custom field definition.

Yes.Extended Customizable Help

None until an administrator changes the organization-wide
default sharing setting for contacts.

Yes.Contact Sharing

None until a user downloads the newest version of Outlook
Edition by clicking Setup ➤ Desktop Integration ➤ Outlook
Edition ➤ Install Now.

Yes.Salesforce Connect for Outlook

None until a user downloads the newest version of Lotus Notes
Edition by clicking Setup ➤ Desktop Integration ➤ Lotus
Notes Edition ➤ Install Now.

Yes.Salesforce Connect for Lotus Notes

None.Yes.Recycle Bin for Deleted Custom Fields

All search enhancements are available to all users except hiding
the Limit to items I own checkbox on sidebar search,
which must be done by an administrator.

Yes.Search Enhancements

Users will receive a notification email whenever they log into
Salesforce from a suspicious IP address and computer.

Yes.Security Enhancements

None until users download the newest version of the Apex
Mobile client application.

Yes.Apex Mobile Enhancements for
BlackBerry

None until users download the newest version of the Apex
Mobile client application.

Yes.Apex Mobile Enhancements for
Windows Mobile

None.Yes.Apex Web Services API 10.0
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SALESFORCE CRM

Custom Report Types
Available in: Professional, Enterprise, Unlimited, and Developer Editions

With custom report types in Summer '07, administrators can generate new report types and include them in the reporting
wizard so users can get more insight into your organization's data.

Custom report types allow you to define report criteria from which users can run and create custom reports. With custom
report types, you can enable users to create reports from predefined standard and custom objects, object relationships, and
standard and custom fields that you specify. For example, you may want users to run and customize reports based on accounts
with opportunities. Furthermore, if your organization has a Warranty custom object, you may want users to run and customize
reports based on accounts with opportunities and warranties that include specific fields from all three objects. For the total
number of custom report types you can create, see "App Setup Limits" in the Salesforce online help.

Implementation Tips

• Users with the "Manage Custom Report Types" permission can view and define custom report types that include objects
they do not have permission to access. However, they cannot access data stored in those objects. For example, a user with
the "Manage Custom Report Types" permission who does not have permission to view leads can view and define custom
report types that include leads, but he or she cannot access lead data. This enables specific users to build report types for
all users in their organization without compromising data security settings.

• The primary object you choose determines the views available to users creating or running reports from your custom report
type. For example, if you select accounts as the primary object for your custom report type, then users can view their report
results by All Accounts or My Accounts from the View drop-down list on the Select Criteria page of the report wizard
or on the Report Options of the report.

• You cannot add the following objects to custom report types:

• Reports
• Forecasts

• You can add up to four objects to a custom report type. However, some of the object combinations you choose may not
be able to reach that limit. For example, if you add contacts as the primary object, cases as the secondary object, and activities
as the tertiary object, then you cannot add any additional objects because activities does not have any object relationships
that extend beyond it.

• You cannot add the following fields to custom report types:

• Product schedule fields
• History fields
• Person account fields
• Territory fields
• The Age field on cases and opportunities

• You can add up to 1000 fields to each custom report type. The total number of fields from which a user can choose to
report on for a specific object in the report wizard is displayed in the Selected Fields column on a custom report type's
detail page.
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• Renamed fields from standard objects, as well as renamed standard objects, do not display as such on the field layout of
the custom report type. However, renamed fields from standard objects and renamed standard objects do display their new
names on the Select Columns page of the report wizard and on the preview page of the Select Columns page, which you
can access by clicking Preview Layout.

• Consider the following when adding fields via lookup to the field layout page of a custom report type:

• You can only add fields via lookup that are associated with objects included in the custom report type. For example, if
you add the accounts object to the custom report type, then you can add fields from objects to which accounts have a
lookup relationship.

• Selecting a lookup field on the Add Fields Via Lookup overlay may allow you to access additional lookup fields from
other objects to which there is a lookup relationship. For example, if you select the Contact Name field from cases,
you can then select the Account field from contacts because accounts have a lookup relationship to contacts which
have a lookup relationship to cases.

• The fields displayed in the Add Fields Via Lookup overlay do not include lookup fields to primary objects. For example,
if accounts are the primary object on your custom report type, and contacts are the secondary object, then the Add
Fields Via Lookup overlay does not display lookup fields from contacts to accounts.

• Fields added to the layout via the Add fields related via lookup link are automatically included in the section of the
object from which they are a lookup field. For example, if you add the Contact field as a lookup from accounts, then
the Contact field is automatically included in the Accounts section. However, you can drag a field to any section.

• Fields added via lookup automatically display the lookup icon ( ) on the field layout of the custom report type.
• You can add up to 60 objects per custom report type via lookup. For example, if you select the maximum limit of four

object relationships for a custom report type, then you could select fields via lookup from an additional 56 objects.
• If you include activities as the primary object on a custom report type, then you can only add lookup fields from activities

to accounts on the select column layout of the custom report type.

• Reports run from custom report types that include cases do not display the Units drop-down list, which allows users to
view the time values of certain case fields by hours, minutes, or days.

Best Practices

• After you save a custom report type, you cannot change the primary object associated with it. If you want to change the
primary object, you must define a new custom report type.

• Choose "In Development" as the Deployment Status when first creating your custom report type to hide it from users
while you are designing and testing it. Making the status "In Development" hides the custom report type and any reports
created from it from all users except those with the "Manage Custom Report Types" permission. Furthermore, making
the status "In Development" prevents all users except those with the "Manage Custom Report Types" permission from
creating and running reports from the report type.

• Choose "Deployed" as the Deployment Status when you want to allow users to create and run reports from the custom
report type.

• After deploying a custom report type, change the Deployment Status back to "In Development" if you want to make
more enhancements to it.

• Arrange fields on sections as they should appear to users in the report wizard.
• Preview how the Select Columns page in the report wizard will display to users in reports run from the custom report type

by clicking Preview Layout on the Fields Exposed for Reporting section.
• If translation workbench is enabled for your organization, you can translate custom report types for international users.
• You can add custom report type to apps you upload to the AppExchange. For more information, see "What is the

AppExchange?" in the Salesforce online help and "About AppExchange Apps" in the Salesforce online help.
• You can preselect commonly used fields on the Select Column layout in the report wizard via a custom report type by

clicking Edit Properties on the custom report type's field layout, and then selecting the Checked by Default checkbox
next to the field. Fields selected by default automatically display the checkbox icon ( ) on the field layout of the custom
report type.
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• You can reduce the amount of time it takes a user to find fields to report on in the Select Column layout in the report
wizard by grouping similar fields together on custom report types' field layouts. Furthermore, you can create new page
sections in which to group fields that are related to one another. Additionally, you can group fields to match specific detail
pages and record types.

About Custom Report Types

Setting Up Custom Report Types

Available in: Professional, Enterprise, Unlimited, and Developer Editions

User Permissions Needed

"Manage Custom Report Types"To create or update custom report types:

You can quickly set up a custom report type so that users can create and run reports from predefined standard and custom
objects, object relationships, and standard and custom fields that you specify.

To set up a custom report type:

1. Define a custom report type by name, description, primary object, development status, and the category in which it will
be stored in on the Select the Report Type page of the report wizard.

2. Choose the objects for the custom report type.

The objects available for you to choose from are based on the primary object's relationships to other objects. For example,
if accounts are selected as the primary object for your custom report type, then you can only choose standard and custom
objects associated with accounts, such as contacts or opportunities. This also applies to additional objects added to the
custom report type. For example, if accounts are selected as the primary object for your custom report type, and contacts
are selected as the secondary object, then you can only select objects associated with contacts as the third object on your
custom report type.

For more information on object relationships, see "Overview of Relationships" in the Salesforce online help.

3. Edit the layout of the Select Columns page in the report wizard to specify which standard and custom fields a report can
display when created or run from the custom report type.

You can only include fields on the Select Columns page that are associated with the objects added to the custom report
type. For example, if you added the accounts object to the custom report type, then you can include account fields on the
Select Columns page of the report wizard.

4. Create a report from the custom report type to make sure it contains all of the objects and fields required for users.

When you are finished testing your custom report type, you can deploy the custom report type to users by marking its
Deployment Status as Deployed. For more information, see "Defining Custom Report Types" in the Salesforce online
help.

5. Optionally, you can do the following:

• If your organization uses the translation workbench, translate custom report types for international users. For more
information, see "Setting Up Translation Workbench" in the Salesforce online help.

Tip: When creating a custom report type that will be translated into multiple languages via the translation
workbench, we recommend that your personal language setting matches your organization's default language.
This is to ensure that words which will be translated display in the correct language for translators. For more
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information, see "Editing Your Personal Information" in the Salesforce online help and "Company Information
Fields" in the Salesforce online help.

• Add the custom report type to apps you upload to the AppExchange. For more information, see "What is the
AppExchange?" in the Salesforce online help and "About AppExchange Apps" in the Salesforce online help.

After you have set up a custom object, you can update it at any time. For more information, see "Managing Custom Report
Types" in the Salesforce online help.

Defining Custom Report Types

User Permissions Needed

"Manage Custom Report Types"To create or update custom report types:

You define custom report types by objects, object relationships, and fields. Once you have defined a custom report type, users
can create custom reports from it.

To define custom report types:

1. Click Setup ➤ Build ➤ Custom Report Types.
2. Click New Custom Report Type.
3. From the Primary Object drop-down list, select the primary object from which you want to build your custom report

type.

• All objects display in the Primary Object drop-down list, including those you do not have permission to view. For
example, even if you do not have permission to view leads, leads are available in the Primary Object drop-down list
so that you can build lead report types for other users. For more information on permissions, see "Managing Profiles"
in the Salesforce online help.

• The primary object you choose determines the views available to users creating or running reports from your custom
report type. For example, if you select accounts as the primary object for your custom report type, then users can view
their report results by All Accounts or My Accounts from the View drop-down list on the Select Criteria page of
the report wizard or on the Report Options of the report.

• After you save a custom report type, you cannot change the primary object associated with it. If you want to change
the primary object, you must define a new custom report type.

Important: If the primary object on a custom report type is a custom object, and the custom object is deleted,
then the custom report type and any reports created from it will automatically be deleted.

4. Enter a name for your custom report type in the Report Type Name field.

The name must be unique so that it can be distinguished from other custom report types in your organization.

5. Enter a description for your custom report type.
6. Select a category in which to store the custom report type on the Select the Report Type page of the report wizard.
7. Select a development status:

• Choose "In Development" as the Deployment Status when first creating your custom report type to hide it from
users while you are designing and testing it. Making the status "In Development" hides the custom report type and any
reports created from it from all users except those with the "Manage Custom Report Types" permission. Furthermore,
making the status "In Development" prevents all users except those with the "Manage Custom Report Types" permission
from creating and running reports from the report type.
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• Choose "Deployed" as the Deployment Status when you want to allow users to create and run reports from the
custom report type.

Tip: After deploying a custom report type, change the Deployment Status back to "In Development" if
you want to make more enhancements to it.

Note: A custom report type's Deployment Status will automatically change from "Deployed" to "In
Development" if its primary object is a custom object whose Deployment Status changes from "Deployed"
to "In Development."

8. Click Next.
9. Next, choose the object relationships a report can display when run from a custom report type.

Choosing the Object Relationships that Display on Reports Created from Custom
Report Types

User Permissions Needed

"Manage Custom Report Types"To create or update custom report types:

You can choose the object relationships a report can display when run from a custom report type. These object relationships
determine the objects and fields available for display on the reports. For more information about object relationships, see
"Overview of Relationships" in the Salesforce online help. Some examples of object relationships you could include in custom
report types are:

• Custom object with activities
• Contacts with opportunities with products
• Opportunities with contact roles with campaign history
• Campaigns with contacts with opportunities with products

Note: When setting up custom report types, you may not see some of the objects and object relationships in these
examples because they are not set up for your organization.

After you define a custom report type, you can choose the object relationships a report can display when created or run from
a custom report type:

1. Click Setup ➤ Build ➤ Custom Report Types to display the All Custom Report Types page.
2. Select the name of a custom report type.
3. Click Edit on the Object Relationships section.

• To add an object that is associated with another object to the report type, select Click to relate another object
field, and choose the object from the drop-down list.

The objects available for you to choose from are based on the primary object's relationships to other objects. For example,
if accounts are selected as the primary object for your custom report type, then you can only choose standard and custom
objects associated with accounts, such as contacts or opportunities. This also applies to additional objects added to the
custom report type. For example, if accounts are selected as the primary object for your custom report type, and contacts
are selected as the secondary object, then you can only select objects associated with contacts as the third object on your
custom report type.

You can add up to four objects to a custom report type. However, some of the object combinations you choose may
not be able to reach that limit. For example, if you add contacts as the primary object, cases as the secondary object,
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and activities as the tertiary object, then you cannot add any additional objects because activities does not have any
object relationships that extend beyond it.

Note: Users with the "Manage Custom Report Types" permission can view and define custom report types
that include objects they do not have permission to access. However, they cannot access data stored in those
objects. For example, a user with the "Manage Custom Report Types" permission who does not have permission
to view leads can view and define custom report types that include leads, but he or she cannot access lead data.
This enables specific users to build report types for all users in their organization without compromising data
security settings.

• To remove an object associated with another object from the report type, click remove.

You cannot change the primary object itself. If you want to change the primary object, you must define a new custom
report type.

Note: If you remove an object from a custom report type from which reports and dashboards have been created,
then all references to the object are automatically removed from the reports and dashboards. Futhermore, any
references to objects associated with the object you remove from the custom report type will also be removed
from any existing reports and dashboards.

4. Click Save.
5. Next, edit the layout of the Select Columns page in the report wizard to specify which standard and custom fields a report

can display when created or run from the custom report type.

Editing the Select Columns Layout in the Report Wizard for a Custom Report Type

User Permissions Needed

"Manage Custom Report Types"To create or update custom report types:

After you define a custom report type and choose its object relationships, you can specify the standard and custom fields a
report can display when created or run from a custom report type:

1. Click Setup ➤ Build ➤ Custom Report Types to display the All Custom Report Types page.
2. Select the name of a custom report type.
3. Click Edit Layout on the Fields Available for Reports section.

Note: You can click Preview Layout to preview which fields will display on the Select Columns page of a report
customized or run from this report type. When previewing the layout, all fields and objects are displayed, including
fields and objects you may not have permission to access. However, you cannot access any data stored in the fields
or objects that you do not have permission to access.

4. Select fields from the right-hand box and drag them to a section on the left.

You can view a specific object's fields by selecting an object from the View drop-down list.

5. Optionally, click Add fields related via lookup to display the Add Fields Via Lookup overlay, from which you can add
fields via the lookup relationship the object selected in the View drop-down list has to other objects.

• A lookup field is a field on an object that displays information from another object. For example, the Contact Name
field on an account. For more information on object relationships, see "Overview of Relationships" in the Salesforce
online help
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• You can only add fields via lookup that are associated with objects included in the custom report type. For example, if
you add the accounts object to the custom report type, then you can add fields from objects to which accounts have a
lookup relationship.

• Selecting a lookup field on the Add Fields Via Lookup overlay may allow you to access additional lookup fields from
other objects to which there is a lookup relationship. For example, if you select the Contact Name field from cases,
you can then select the Account field from contacts because accounts have a lookup relationship to contacts which
have a lookup relationship to cases.

You can access up to four levels of object relationships via lookup.

• The fields displayed in the Add Fields Via Lookup overlay do not include lookup fields to primary objects. For example,
if accounts are the primary object on your custom report type, and contacts are the secondary object, then the Add
Fields Via Lookup overlay does not display lookup fields from contacts to accounts. For more information on primary
objects, see "Defining Custom Report Types" in the Salesforce online help.

• Fields added to the layout via the Add fields related via lookup link are automatically included in the section of the
object from which they are a lookup field. For example, if you add the Contact field as a lookup from accounts, then
the Contact field is automatically included in the Accounts section. However, you can drag a field to any section.

• Fields added via lookup automatically display the lookup icon ( ) on the field layout of the custom report type.

You can add up to 60 objects per custom report type via lookup. For example, if you select the maximum limit of four
object relationships for a custom report type, then you could select fields via lookup from an additional 56 objects.

6. Arrange fields on sections as they should appear to users in the report wizard. Fields not dragged onto a section will be
unavailable to users when they generate reports from this report type.

You can add up to 1000 fields to each custom report type. The total number of fields from which a user can choose to
report on for a specific object in the report wizard is displayed in the Selected Fields column on a custom report type's
detail page.

7. Click Preview Layout to preview which fields will display on the Select Columns page of a report customized or run from
this report type. When previewing the layout, all fields and objects are displayed, including fields and objects you may not
have permission to access. However, you cannot access any data stored in the fields or objects that you do not have permission
to access.

Tip:  Use the legend to determine which fields are included on the layout, checked by default on the Select Columns
page in the report wizard, and added to the layout via a lookup relationship.

Caution:  Users can view roll-up summary fields on reports that include data from fields they do not have access
to view. For example, a user that does not have access to view the Price field on an opportunity product can view
the Total Price field on opportunity reports if he or she has access to the Total Price field. For more
information, see "About Roll-Up Summary Fields" in the Salesforce online help.

8. To rename or set which fields are selected by default for users on the Select Columns page of the report wizard, select one
or more fields and click Edit Properties.

• Click the Checked by Default checkbox next to the field you want selected by default.

Fields selected by default automatically display the checkbox icon ( ) on the field layout of the custom report type.

• Change the text in the Display As field next to the field you want to rename.

Note: Renamed fields from standard objects, as well as renamed standard objects, do not display as such on
the field layout of the custom report type. However, renamed fields from standard objects and renamed standard
objects do display their new names on the Select Columns page of the report wizard and on the preview page
of the Select Columns page, which you can access by clicking Preview Layout.
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9. To rename the sections on the Select Columns page of the report wizard, click Edit next to an existing section, or create
a new section by clicking Create New Section.

10. Click Save.

Managing Custom Report Types

User Permissions Needed

"Manage Custom Report Types"To create or update custom report types:

After you create a custom report type, you can customize, edit, and delete it. Click Setup ➤ Build ➤ Custom Report Types
to display the All Custom Report Types page, which shows the list of custom report types defined for your organization.

From the All Custom Report Types page, you can:

• Select a list view from the View drop-down list to go directly to that list page, or click Create New View to define your
own custom view. For more information, see "Creating Custom List Views" in the Salesforce online help.

• Define a new custom report type by clicking New Custom Report Type.
• Update a custom report type's name, description, report type category, and deployment status by clicking Edit next to a

custom report type's name.

Note: You cannot change the primary object associated with a custom report type. However, you can create a new
custom report type instead.

• Delete a custom report type by clicking Del next to the custom report type's name. All the data stored in the custom report
type will be deleted and cannot be restored from the Recycle Bin.

Important: When you delete a custom report type, any reports based off it will also be deleted. Furthermore, any
dashboard components created from a report based off of a deleted custom report type display an error message
when viewed.

• Display detailed information about a custom report type and customize it further by clicking a custom report type's name.
After you click a custom report type name you can:

• Update which object relationships a report can display when run from the custom report type. For more information,
see "Choosing the Object Relationships that Display on Reports Created from Custom Report Types" in the Salesforce
online help.

• Edit the layout of the Select Columns page in the report wizard to specify which standard and custom fields a report
can display when created or run from the custom report type. For more information, see "Editing the Select Columns
Layout in the Report Wizard for a Custom Report Type" in the Salesforce online help.

• Preview how the Select Columns page in the report wizard will display to users in reports run from the custom report
type by clicking Preview Layout on the Fields Exposed for Reporting section.

Note: If translation workbench is enabled for your organization, you can translate custom report types for international
users. For more information, see "Setting Up Translation Workbench" in the Salesforce online help and "Entering
Translated Terms" in the Salesforce online help.

When creating a custom report type that will be translated into multiple languages via the translation workbench, we
recommend that your personal language setting matches your organization's default language. This is to ensure that
words which will be translated display in the correct language for translators. For more information, see "Editing Your
Personal Information" in the Salesforce online help and "Company Information Fields" in the Salesforce online help
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Advanced Currency Management with Historical Currency
Exchange Rates

Available in: Professional, Enterprise, Unlimited, and Developer Editions

Summer ’07 delivers the advanced currency management you need to keep track of ever-changing exchange rates in the various
geographies where you do business. With advanced currency management, you can start tracking exchange rates when an
opportunity closes, allowing you to accurately report opportunity converted amounts based on the exchange rate at the
opportunity’s close date while still keeping track of fluctuations after that point as well. Since these historic exchange rates are
stored, all alerts and reports can include the opportunity amount based on the exchange rate at the close date rather than the
exchange rate at the time that the report or alert is generated.

In addition to advanced currency management, in Summer '07, you can now use three new currencies:

• Romanian Leu (RON)
• Serbian Dinar (RSD)
• Turkish Lira (TRY)

Best Practices

• Use the Apex Data Loader to update your dated exchange rates. This allows you to rapidly update your values for all of
your currencies.

• Use the audit trail to easily verify changes you have made to dated exchange rates.
• Set your non-dated exchange rate to your most recent dated exchange rate. This can help you when you are comparing

currency fields in opportunities with other currency fields that do not use dated exchange rates, or when you are doing
forecasts.

Setting Up Advanced Currency Management

About Advanced Currency Management

User Permissions Needed

"View Setup and Configuration"To view currencies:

"Customize Application"To change currencies:

Advanced Currency Management allows you to manage dated exchange rates within opportunities using Salesforce. Dated
exchange rates allow you to map a conversion rate to a specific date range. For example, the exchange rate on January 1 was
1 USD to 1.39 AUD, but on February 1, it changed to 1 USD to 1.42 AUD. Your opportunities that closed between January
1 and February 1 use the first exchange rate (1 = 1.39), while opportunities that closed after February 1 used the second
exchange rate (1 = 1.42).

Dated exchange rates are defined using a start date and a conversion rate. Each rate is in effect until either the end of time or
the day before the next start date for that currency.The time between on start date and the next start date is called the exchange
rate date range. These ranges can be as small as a day and as large as all of time.

13

Salesforce CRM Advanced Currency Management with Historical Currency Exchange Rates



When advanced currency management is first enabled, your existing exchange rates automatically become the first set of dated
exchange rates. These rates will be valid for all time, until you define another set of exchange rates.

• To manage dated exchange rates, click Setup ➤ Company Profile ➤ Manage Currencies and click Manage Dated
Exchange Rates.

• To manage other multicurrency settings, such as setting your corporate currency, adding new currencies, activating or
deactivating currencies, click Setup ➤ Company Profile ➤ Manage Currencies and click Manage Currencies.

Note: To enable advanced currency management, contact salesforce.com.

Advanced Currency Management Considerations

• Dated exchange rates are used for opportunities, opportunity products, opportunity product schedules, campaign opportunity
fields, and reports related to these objects and fields. Dated exchange rates are not used in forecasting, currency fields in
other objects, or currency fields in other types of reports.

• If you enable advanced currency management, you cannot create roll-up summary fields that calculate currency on the
opportunity object. All existing currency-related roll-up summary fields on the opportunity object will be disabled and
their values will no longer be calculated.

• Campaign opportunity fields use dated exchange rates when calculating the amount in the campaign currency, but are not
used when converting those amounts to the user currency.

Editing Dated Exchange Rates

User Permissions Needed

"View Setup and Configuration"To view currencies:

"Customize Application"To change currencies:

To add new dated exchange rates:

1. Click Setup ➤ Company Profile ➤ Manage Currencies.
2. Click Manage Dated Exchange Rates.
3. Click New Exchange Rates.
4. Enter the date that the exchange rates go into effect.
5. Enter the exchange rates.

Note: The exchange rates will default to the current exchange rate. If you do not want to set a new exchange rate
for a currency, delete the exchange rate (leave the field blank).

6. Click Save to save the new dated exchange rates.

To view existing dated exchange rates:

1. Click Setup ➤ Company Profile ➤ Manage Currencies.
2. Click Manage Dated Exchange Rates.
3. Select the date range you want to view either by entering the date and clicking Go!, or by selecting Previous Range or

Next Range.

To delete a dated exchange rate for a particular currency:

1. Click Setup ➤ Company Profile ➤ Manage Currencies.
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2. Click Manage Dated Exchange Rates.
3. Click the name of the currency you want to edit.
4. Click Del for the date range you want to delete.

If the date range you want is not displayed, enter it in the Show all rates with start dates between fields and
click Go!.

To edit your dated exchange rates for a particular currency:

1. Click Setup ➤ Company Profile ➤ Manage Currencies.
2. Click Manage Dated Exchange Rates.
3. Click the name of the currency you want to edit.
4. Click Edit for the date range you want to edit. If the date range you want is not displayed, enter it in the Show all rates

with start dates between fields and click Go!.
5. Edit the exchange rate, setting it to the new value for the date range, and click Save.

Customer Portal featuring Multiple Personalized Portals
Available in: Enterprise and Unlimited Editions

With Spring ’07, salesforce.com introduced a powerful, new Customer Portal to step up the self-service experience for your
customers. With Summer '07, salesforce.com extends the general availability of the Customer Portal along with numerous
enhancements so everyone in your company can truly collaborate with your customers in a secure, branded, online portal. Now
you can create multiple personalized portals so that your organization can fully exploit the capabilities of the Web to deliver
superior self-service that suits the specific business needs of all of your products, services, and levels of customer support.
Because each Customer Portal you create is 100% hosted by salesforce.com just like the Salesforce application itself, you get
the same service delivery benefits and none of the maintenance and infrastructure headaches that come with hosting a portal
yourself.

Implementation Tips

• Portal users can only log into Customer Portals assigned to their profile. To assign a profile to a Customer Portal, select
the name of a portal from the Customer Portal Setup page, click Edit Profiles in the Assigned Profiles section, and select
the Active checkbox next to the profile you want to assign to the portal.

A portal user can access all the Customer Portals assigned to his or her profile with one username and password.

You can view the number of users associated with each profile assigned to a Customer Portal on the Users field on the
Assigned Profiles section.

• The login URL of each Customer Portal you create contains a unique identifier, such as portalId=060D00000000Q1F.
The unique identifier determines the specific portal a user can access. If a user accesses a login URL that does not contain
a unique identifier, they are automatically directed to the login URL of the first Customer Portal you created. Note that
portal users can only log into a Customer Portal via the portal's login page and not through the Salesforce login page.

• The settings on the following items apply to both your organization and your Customer Portals:

• List views
• Search layouts
• Case assignment rules
• Workflow alerts

15

Salesforce CRM Customer Portal featuring Multiple Personalized Portals



Best Practices

• Because you can uniquely customize the fonts, colors, email templates, and login message of each Customer Portal you
create, you can build a Customer Portal for each product and customer service level supported by your organization. For
example, if your organization provides gold, silver, and bronze levels of customer support, then you could create a unique
Customer Portal for each.

• You can standardize the communication templates sent to the users of all your Customer Portals by clicking the Set Default
Email Templates for All Customer Portals link on the Tools section of the Customer Portal Setup page. These settings
determine the email templates to use when sending email notifications, such as a new case comment or a reset password,
to portal users whose profiles are associated with more than one Customer Portal.

By default, sample templates are automatically selected for you in the New User Template, New Password Template,
and Lost Password Template lookup fields. However, sample templates are not selected for you in the New Comment
Template and Change Owner to Portal User Template lookup fields. Unless you select templates for these fields,
users whose profiles are associated with more than one Customer Portal will not receive email notifications when new
comments are added to their cases or when they become the new owner of a record in the Customer Portal. To create
templates or modify the samples, see "Managing Email Templates" in the Salesforce online help. Email templates must
be marked as Available for Use to be sent to portal users.

Tip:  Because the default email templates are sent to users of multiple Customer Portals, we recommend that you
create default email templates that do not contain portal-specific branding.

• You cannot delete a Customer Portal, but you can prevent users from logging into a portal by deselecting the Login
Enabled checkbox. For more information, see "Enabling Customer Portal Login and Settings" in the Salesforce online
help.

About the Customer Portal

Creating Multiple Customer Portals

Available in: Enterprise and Unlimited Editions

User Permissions Needed

"Customize Application"To create multiple Customer Portals:

After you have enabled the Customer Portal, you can create multiple Customer Portals to satisfy the various business needs
of your customers.

To create more than one Customer Portal:

1. Click Setup ➤ Customize ➤ Customer Portal ➤ Settings.
2. Click New.
3. Follow the same steps used to set up your organization's first Customer Portal. For details, see "Setting Up Your Customer

Portal" in the Salesforce online help.

Note:  Contact salesforce.com for information about the number of Customer Portals you can activate for your
organization.
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Additional Customer Portal Enhancements

Summer '07 includes the following enhancements to the Customer Portal:

Enhanced Style Editor
With Summer '07, it is even easier for you to customize the fonts and colors of your Customer Portal.
Now, when you click Setup ➤ Customize ➤ Customer Portal ➤ Settings, select a Customer Portal
name, and click Change Portal Fonts and Colors, you can:

• Easily select fonts and colors with a new a point-and-click editor
• Automatically view your font and color selections in the preview pane on the point-and-click editor
• Update the look and feel of your Customer Portal with additional theme attributes, such as tab

background colors and field label text colors
• View examples of all the Customer Portal theme attributes you can customize by clicking the See

examples link

Additional Custom Branding and Self-Resolution with Suggested Solutions
Now, you can enable three new settings on your Customer Portal when you click Setup ➤ Customize
➤ Customer Portal ➤ Settings, select a Customer Portal name, and click Edit:

• Login Message

A text or HTML file that allows you to incorporate your organization’s branding into the header of
the login page, forgot password page, and change password page of your Customer Portal.

Click the lookup icon ( ) to choose a file that has been uploaded to a publicly accessible folder on
the Documents tab.

The file you include in the Login Message lookup field can be up to 2 KB.

• Enable Self-Close Case from Suggested Solutions

Allows users to close cases in the Customer Portal directly from suggested solutions. For example,
when a user views a suggested solution that helps them solve a case, he or she can click Yes, please
close my case if this setting is enabled.

For more information about suggested solutions, see "What are Suggested Solutions?" in the Salesforce
online help

• Show Action Confirmation

Allows users to view confirmation messages after they complete an action in the Customer Portal. For
example, after a user creates a case in your Customer Portal, he or she views the message: "Case has
been submitted" if this setting has been enabled.

Confirmation messages may help users clearly understand actions they have completed in your Customer
Portal.

My Profile
With Summer '07, you can include the Customer Portal Welcome component on home page layouts
assigned to Customer Portal users so that when they log in to your portal they receive a welcome message
with their name, plus the ability to change their own portal username, password, locale, language, time
zone, and contact information. When portal users change information about themselves their user record
is updated but their contact record is not automatically updated with those changes. For more information
about defining home page components and assigning home page layouts, see "Customizing Home Page
Layouts" in the Salesforce online help.
Note that Customer Portal users whose profile includes the "Is Single Sign-On Enabled" permission
cannot change their username via the Customer Portal Welcome component. For more information on
Single Sign-On, see "Company Information Fields" in the Salesforce online help.
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New Internal User Group
If your organization uses sharing rules that share to Roles and Subordinates, you can now easily update
those sharing rules to share to Roles and Internal Subordinates instead. This is to ensure that no records
owned by a Salesforce user are shared with a portal user
The new Roles and Internal Subordinates sharing rule category allows you to create sharing rules in which
you can choose specific Salesforce users in your organization by role plus all of the users in roles below
that role, excluding any Customer Portal and PRM portal roles.
Only organization-wide sharing rules are updated when you convert Roles and Subordinates to Roles and
Internal Subordinates. Roles and Subordinates in queues, public groups, list views, documents, and manual
sharing created on specific records by clicking the Sharing button are not converted to Roles and Internal
Subordinates. For more information, see "Managing the Sharing Model" in the Salesforce online help.
You can easily convert sharing rules that include Roles and Subordinates to include Roles and Internal
Subordinates instead by using the sharing rule conversion wizard. For more information, see "Converting
the Roles and Subordinates Sharing Rule Category" in the Salesforce online help.

Rich-Content Solutions with HTML
Available in: Professional, Enterprise, Unlimited, and Developer Editions

HTML solutions provide a more flexible way to create solutions, by allowing you to easily format paragraphs, and insert images
and links. Using HTML solutions, you create solutions with an HTML editor and display those solutions to users in Salesforce,
your public knowledge base, Self-Service portal, and Customer Portal.

Using the HTML editor, you can:

• Change fonts
• Increase or decrease font sizes
• Insert images from the Documents tab
• Set text color
• Set the background color of text
• Insert hyperlinks
• Change paragraph alignment
• Create bulleted and numbered lists

Implementation Tips

• Once you enable HTML solutions, you cannot disable it.
• If you open a text solution with the HTML editor and save it, the solution becomes an HTML solution.
• HTML solutions are presented as such to Self-Service portal, public knowledge base, Customer Portal, and Salesforce

users.
• Any HTML tags entered into the HTML editor will display to users as text when the solution is saved.
• When the HTML solution detail is displayed in list views and search results, only the first 255 characters are displayed.

This number includes HTML tags and images that are removed.
• Each HTML solution can contain up to 32000 characters, including HTML tags.
• HTML formatting is preserved in the printable view of a solution.
• Hyperlinks in HTML solutions open in a new browser window when users click on them.
• All images that you want to include in your HTML solutions must be uploaded to the Documents tab. Images in HTML

solution details will not show up in list views and reports.
• HTML solutions can be created in any of the languages supported by Salesforce. For more information, see What are

Multilingual Solutions?

18

Salesforce CRM Rich-Content Solutions with HTML



• For security purposes, Salesforce automatically filters all HTML solutions for potentially malicious HTML. If potentially
malicious HTML is detected in an HTML solution, then the potentially malicious HTML is either automatically removed
or transformed into text for users who view the HTML solution. Note that users will not be able to notice when potentially
malicious HTML is removed from an HTML solution.

Best Practices

• You can import solutions written in HTML format into Salesforce. However, for security purposes, only the HTML tags
listed below are allowed. The content of any HTML tags not listed below is automatically removed when saved in HTML
solutions. Furthermore, the content of all <script> and <iframe> tags, as well as all JavaScript, is automatically removed
when saved in HTML solutions. Additionally, Cascading Style Sheets (CSS) are not supported in HTML solutions. See
"Preparing to Import Solutions" in the Salesforce online help for more information.

The following HTML tags are allowed in HTML solutions imported into Salesforce:

• <a>

• <abbr>

• <acronym>

• <address>

• <b>

• <bdo>

• <big>

• <blockquote>

• <br>

• <caption>

• <cite>

• <code>

• <col>

• <colgroup>

• <dd>

• <del>

• <dfn>

• <div>

• <dl>

• <dt>

• <em>

• <font>

• <h1>

• <h2>

• <h3>

• <h4>

• <h5>

• <h6>

• <hr>

• <i>

• <img>

• <ins>

• <kbd>

• <li>

• <ol>
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• <p>

• <pre>

• <q>

• <samp>

• <small>

• <span>

• <strong>

• <sub>

• <sup>

• <table>

• <tbody>

• <td>

• <tfoot>

• <th>

• <thead>

• <tr>

• <tt>

• <ul>

• <var>

Within the above tags, you can include the following attributes:

• alt
• background
• border
• colspan
• face
• height
• href
• rowspan
• size
• src
• style
• width

The above attributes which can include a URL are limited to URLs that begin with the following:

• http:
• https:
• file:
• ftp:
• mailto:
• / for relative links
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About Rich-Content Solutions with HTML

Creating HTML Solutions

User Permissions Needed

"Create" on solutionsTo create solutions:

By default, solutions are created and displayed in text format. Your administrator must enable HTML solutions. For more
information on enabling HTML solutions, see "Customizing Solution Settings" in the Salesforce online help.

To create HTML solutions:

1. Select Solution from the Create New drop-down list in the sidebar, or click New next to Recent Solutions on the solutions
home page.

2. Enter the solution title, then enter the solution details in the HTML editor.

The HTML editor allows you to use a toolbar to insert images and format the text and paragraphs in your solution. For
more information on the available formatting options, see Using the Format Toolbar.

3. Click Check Spelling to spell-check the solution.
4. Click Save.

Extended Mail Merge—Limited Release
Available in: All Editions

With Summer ’07, you can use Extended Mail Merge to create personalized letters, envelopes, and mailing labels right from
Salesforce, without requiring additional software or downloads. You can set up a mail merge in Salesforce to add a personal
touch to your communications without spending the time to manually personalize each document.

A mail merge is the process of generating form letters and other Microsoft Word documents that are personalized for the
recipient, who is often a contact or lead. The content of each document is predefined in a mail merge template. Mail merge
templates include variables called merge fields where data from your Salesforce records—for example a contact's name and
address—displays in the generated document. Extended Mail Merge, which is available through a limited release program in
Summer '07, is a fast, feature-rich alternative to standard mail merge. Please review the following comparison chart:

Extended Mail MergeStandard Mail Merge

Supports multiple records at the same time, selected from a
list view

Supports only one record at a time

Can generate letters, envelopes, and labelsCan only generate letters

Delivers output via email or the Salesforce Documents tabDelivers output by opening the user's Word program on his
or her PC

Supports most Web browsers, including Mozilla FirefoxRequires Internet Explorer 6 or 7 as your Web browser
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Extended Mail MergeStandard Mail Merge

Does not require any browser add-ons, including ActiveX
controls

Requires the installation of an ActiveX control on the user's
Web browser

Supports most operating systems, including the Apple Mac
OS

Requires Microsoft Windows 2000, XP, or Vista as your
operating system

Does not currently support .docx or .dotx file formats; Word
2007 users must save their files in .doc or .dot (Word 2003)
formats

Supports Word 2007 templates saved in .docx or .dotx file
formats

Implementation Tips

• Extended Mail Merge is available by request only. Please contact salesforce.com Customer Support if you are interested
in this feature.

• After salesforce.com Customer Support has enabled Extended Mail Merge for your organization, an administrator or user
with the "Customize Application" permission must activate it to make it available to your users. To activate the feature,
click Setup ➤ Customize ➤ User Interface, then select the Activate Extended Mail Merge checkbox.

When the checkbox is selected, the Mass Mail Merge link is available in the Tools area on the home pages for accounts,
contacts, and leads. Also, single mail merges requested from the Activity History related list on a record are performed
using Extended Mail Merge functionality.

• By default, Extended Mail Merge delivers output as email attachments in either .doc or .zip file formats. However, output
files that are 3 MB or larger are delivered to the user's personal documents folder on the Salesforce Documents tab.
Optionally, administrators can opt out of email attachments and restrict delivery to the Salesforce Documents tab. To do
so, select the Always save Extended Mail Merge documents to the Documents tab checkbox on the User
Interface settings page.

• Administrators and users with the "Manage Public Templates" permission are responsible for managing mail merge
templates. Before activating Extended Mail Merge, please ensure that all necessary mail merge templates are uploaded to
Salesforce and available to users. We recommend that mail merge templates not exceed 1 MB. For more information, see
"Managing Mail Merge Templates" in the Salesforce online help.

• Extended Mail Merge is not available via the Apex API.

Best Practices

• Uploaded mail merge templates are stored at Setup ➤ Communication Templates ➤ Mail Merge Templates. When
requesting mail merges, users are presented with the entire list of templates. We recommend that you implement a standard
naming convention for mail merge templates so that users in different departments can quickly choose the appropriate
one.

• Monitor your organization's document storage usage regularly. Mail merge output that is delivered to the Salesforce
Documents tab counts against your organization's storage limits. For more information about storage limits, see Monitoring
Resources.
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About Extended Mail Merge

Using the Mass Mail Merge Wizard

Note: Extended Mail Merge is available by request only. Please contact salesforce.com Customer Support if you are
interested in this feature.

In addition, your administrator must activate the feature before you can use Extended Mail Merge. See "Customizing
User Interface Settings" in the Salesforce online help.

With Extended Mail Merge, you can easily generate mail merge Word documents—such as form letters with matching
envelopes and address labels—for multiple records at the same time.

1. Open the tab home page for accounts, contacts, or leads. Other kinds of records are not currently supported.
2. In the Tools area, click Mass Mail Merge to start the mass mail merge wizard.
3. Choose an appropriate list view from the View drop-down list. To create or edit a list view, see "Creating Custom List

Views" in the Salesforce online help.
4. Select the records to include in the mail merge. To select all records currently displayed on the page, select the checkbox

in the column header.
5. Click Next.
6. Select the types of Word documents you would like to generate. The supported document types are documents, envelopes,

and labels.
7. Select the Log an activity... checkbox to log the generation of these mail merge documents by adding a completed

task on each record.
8. Click Next.
9. Select the appropriate mail merge templates.

For documents, choose whether to create one Word document that includes all output or a separate Word document for
each record.

10. Optionally, click Preview Template to review a template's contents. Note that although the Word document that opens
may be editable, changes made in Word will not be applied to your current mail merge request. To make a newly revised
template available for mail merge, it must be uploaded first.

11. Click Finish. Salesforce sends you an email when the operation is complete. Your generated documents may be attached
to the email as either a Word document (.doc) or a Zip file (.zip).

If the attachment size exceeds your organization's maximum allowed email attachment size or if your administrator has
set all mail merge documents to be saved to the Documents tab, then your generated documents will be automatically saved
on the Documents tab and you will receive an email with a link to their location.

Mail Merge Considerations

• Standard mail merge requires Internet Explorer 6 or 7 as your Web browser, Microsoft Word 2000, 2002 (XP), 2003, or
2007 as your word processor, and Microsoft Windows 2000, XP, or Vista as your operating system.

Extended Mail Merge supports the following additional environments: the Mozilla Firefox Web browser and the Apple
Mac OS. Furthermore, it does not require the installation of an ActiveX control. Extended Mail Merge is available by
request only. Please contact salesforce.com Customer Support if you are interested in this feature.

• Standard mail merge currently supports Word 2007 templates saved in .docx or .dotx file formats, but Extended Mail
Merge does not.
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• Mail merge documents give you access only to the fields that are accessible to you via your page layout and field-level
security settings. (Field-level security is available in Enterprise, Unlimited, and Developer Editions only.)

Sending Single Mail Merge Documents

To generate a single Microsoft Word mail merge document:

1. Click Mail Merge in the Activity History related list on the appropriate record. Accounts, contacts, leads, cases,
opportunities, and custom objects are supported.

Note:

With standard mail merge, the first time you create a mail merge document you must install an ActiveX control
that helps Salesforce communicate with Word. For more information, see "Installing the Mail Merge ActiveX
Control" in the Salesforce online help.

2. Use the lookup to specify the record from which information will be merged.

If your organization uses person accounts, person accounts are returned in both account and contact lookup searches.

3. Select a mail merge template.
4. Optionally, select the checkbox to log a task for the mail merge.
5. Click Generate.

If the custom object has a master-detail relationship with opportunities, the primary contact for the opportunity is selected
by default.

6. If you are using standard mail merge, Word opens with your generated document. When the document displays, choose
Save As from the File menu to save the document to your hard drive.

If you are using Extended Mail Merge, Word does not open when you click Generate. Instead, Salesforce sends you an
email when the operation is complete. The email either includes your generated Word document as an attachment or
provides a link to it on the Documents tab.

7. If you chose to log an activity for the mail merge, enter the task information, and optionally create a follow-up task.

The Subject of the mail merge task is set to the mail merge template name by default, and the task is displayed as a
completed activity in the Activity History related list. The merged document is not stored with the task.

Note: You can log an activity for mail merge if you have access to view or edit the record you are merging and are
able to create tasks (that is, you have the "Edit Task" permission).

8. You can then print and mail your document or send it as an email attachment.

Group Edition featuring Google AdWords
Team Edition™ has been replaced with Group Edition featuring Google AdWords. In addition to the existing Team Edition
functionality, Group Edition includes:

• Read-only Dashboards
• Leads
• Web-to-Lead
• Salesforce for Google AdWords

Implementation Tips

For information on getting started with Group Edition:
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• Visit Successforce for more information on Group Edition featuring Google AdWords.
• Salesforce.com offers a quick start program—a brief professional consultation to help you get your Google AdWords

programs set up with Salesforce lead tracking. For more information, contact salesforce.com at 1-800-NO-SOFTWARE.
• Visit the Salesforce for Google AdWords blog for tips and information on Salesforce for Google AdWords.
• Visit the Google AdWords Learning Center for information on implementing Google AdWords.

About Group Edition

Group Edition Features

Read-only Dashboards

All Group Edition users have access to read-only dashboards. Users cannot create, edit, or delete dashboards or dashboard
components.

Note: When you sign up for Salesforce, your organization is in a trial status.This trial status contains many dashboards
that are not available in Group Edition. Therefore, if you subsequently subscribe to Group Edition, the dashboards
that you were able to view and edit in the trial become read-only.

For more information on dashboards, see What is a Dashboard?.

Leads

Group Edition users have the same leads functionality as Professional Edition users, with the exception of mass email for leads
and lead auto-response rules. For more information, see "Leads Home" in the Salesforce online help.

Web-to-Lead

Group Edition organizations can use Web-to-Lead to gather information from their company's website and automatically
generate leads. Web-to-Lead is automatically enabled for all Group Edition organizations with the default lead owner defaulted
to the user who originally signed up for Salesforce. For more information, see Capturing Web Leads.

Salesforce for Google AdWords

Salesforce for Google AdWords is automatically installed into all Group Edition organizations and does not count against
custom app limits.

Salesforce for Google AdWords
Available in: Group, Professional, Enterprise, Unlimited, and Developer Editions

Salesforce for Google AdWords is an AppExchange app that connects Google AdWords with Salesforce, allowing you to
track the effectiveness of your online advertising investments. Salesforce for Google AdWords is automatically installed in all
Salesforce organizations.

Implementation Tips

• For information on getting started with Salesforce for Google AdWords:
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Visit Successforce for more information on Group Edition featuring Google AdWords.•
• Salesforce.com offers a quick start program—a brief professional consultation to help you get your Google AdWords

programs set up with Salesforce lead tracking. For more information, contact salesforce.com at 1-800-NO-SOFTWARE.
• Visit the Salesforce for Google AdWords blog for tips and information on Salesforce for Google AdWords.
• Visit the Google AdWords Learning Center for information on implementing Google AdWords.

• Ensure that you complete all lead tracking setup steps. If lead tracking is not set up properly, you cannot see your tracked
leads in Salesforce. For instructions, see https://sfma.salesforce.com/lead_tracking_setup/printable_instructions.

Best Practices

• Ensure that your advertisements show up on Google by avoiding the following:

• Your Google AdWords account may not be active with valid billing information.
• You may be bidding on a very competitive keyword.
• Your ad may not be showing up on the first few pages of results due to a low ad rank.
• Your campaign daily budget is too low.
• You may be running geographic-targeted ads and searching outside of the targeted area.
• Your ads may be disapproved or flagged for editorial review by Google.

• When setting up lead tracking, we recommend adding the tracking code to the bottom of all pages of your website so that
you can maximize your lead tracking capabilities and capture leads from as many sources as possible. At a minimum, you
should add the tracking code to all landing pages and Web-to-Lead forms.

• Make sure that the Salesforce tracking code is at the bottom of your pages just before the closing body tag, even if other
tracking codes are present on the page. Your tracking code must be in this position to be effective.

• After your website is configured for lead tracking, Salesforce for Google AdWords automatically tracks inbound
website-generated leads and populates the Lead Source field. It is currently not possible to configure or change this
option. If you need to track custom lead source information from your website, we recommend that you create a custom
field on leads.

• You can only link one Google AdWords account to one Salesforce organization. Salesforce does not support linking a
Google Client Manager (also known as an AdWords MCC) account that contains multiple sub-accounts.

About Salesforce for Google AdWords

What is Salesforce for Google AdWords?

Google AdWords™ (http://adwords.google.com) is an online advertising service used to create advertisements that display on
major search engines, including Google. Many Salesforce customers advertise online with Google AdWords as a mechanism
to generate leads.

Salesforce for Google AdWords connects Salesforce with Google AdWords, allowing you to track the effectiveness of your
online advertising investments. With Salesforce for Google AdWords, you can:

• Take advantage of Google AdWords as a lead generation tool
• Correlate clicks on Google advertisements with Salesforce leads
• Track the results of Google AdWords campaigns from Salesforce
• Analyze which keywords and advertisements are generating leads, sales opportunities, and new customers
• Measure effectiveness using the Google AdWords dashboard and intelligently optimize your AdWords campaigns
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How Does It Work?

Use Google AdWords to create an online advertisement, including a series of keywords that will trigger your advertisement
to display on www.google.com and other major search engines. When a user clicks on your advertisement in Google, they are
directed to a landing page, an existing page on your corporate website or a page that you have designed specifically for your
Google advertisements. Landing pages typically contain an offer and a Web-to-Lead form. An offer is something that entices
a user to fill out a Web-to-Lead form, such as "send me more information" or "download a whitepaper."

When a user enters information into a Web-to-Lead form, a lead is created in your Salesforce organization. You can easily
recognize leads that come from your Google AdWords campaigns by the value in the Lead Source field. Leads that originate
from Google AdWords have a Lead Source value of Google AdWords and an activity record that shows the Google AdWords
campaign, ad group, ad headline, and keyword that drove the lead to your website.

With every new lead, a Google AdWords dashboard and several Google AdWords reports are updated in Salesforce. Use the
dashboard and reports to analyze the effectiveness of your Google AdWords investment. In addition, when leads are converted
into sales opportunities, you can easily track how your Google AdWords investment is generating pipeline and resulting in
closed deals.

After analyzing Google AdWords reports and dashboard, you can go back into Google AdWords and adjust your advertisements
accordingly for optimal performance.

For additional information on Google AdWords, see the Google AdWords Learning Center.

Setting Up Salesforce for Google AdWords

Getting started with Salesforce for Google AdWords is simple. Review the following sections to set up Salesforce for Google
AdWords:

1. Registering for Google AdWords
2. Setting Up Your Website for Lead Tracking
3. Tracking Leads and Measuring ROI

Registering for Google AdWords

In Salesforce, click the Google AdWords Setup tab to create a new Google AdWords account or link to an existing one:

• Option A: To create a new Google AdWords account, enter an email address, password, currency, and time zone, and
click Create New Account. For additional instructions and information, see Registration: New Google AdWords Account.

• Option B: To link an existing Google AdWords account to Salesforce, enter your AdWords Customer ID, and click Link
Account. For additional instructions and information, see Registration: Linking an Existing Google AdWords Account.
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Setting Up Your Website for Lead Tracking

To convert your website visitors into leads, you must capture website visitor information. This can be accomplished with a
basic Web-to-Lead form, an HTML form that you can add to any page of your website. Web-to-Lead forms capture website
visitor information and automatically create new leads in Salesforce.

Once your new or existing Google AdWords account is active and linked to Salesforce, click Set up Lead Tracking on the
Google AdWords Setup tab, and then follow these basic steps:

1. To create a simple Web-to-Lead form for your website, click Create Web-to-Lead Form, select the fields you want to
capture, enter the URL of the page to display after the website visitor submits information, and click Generate. Copy and
paste the HTML code to post to your website, or click Complete Printable Instructions to send the information to your
webmaster.

2. After the Web-to-Lead form is posted to your website, you must insert a JavaScript tracking code on all pages of your
website. The tracking code captures details of your website visitors and correlates that information with leads generated
from your website. The tracking code provides details on exactly where your website-generated leads originate, and which
aspects of your Google AdWords campaigns are generating results for your business. Click View Instructions on the Lead
Tracking Setup page for more information on how to do this.

3. Finally, confirm that everything is set up correctly. From the Lead Tracking Setup page on the Google AdWords Setup
tab, click Test Your Setup.

4. Click Done when you have finished.

For more detailed instructions, see "Setting Up Lead Tracking" in the Salesforce online help.

Tracking Leads and Measuring ROI

Website lead tracking provides the ability for Salesforce customers to correlate Google AdWords investments with the resulting
leads, opportunities, and sales. You can see the value and results that website lead tracking provides in the following locations:

• Lead Source: Salesforce automatically populates the Lead Source field on leads based on where the lead originated,
whether it came from a user clicking on your ad or keyword in a search engine, a website referral, an organic lead, or a user
directly entering your URL.

Caution: Salesforce automatically populates the Lead Source field on leads generated as a result of your Google
campaigns. If you need to track custom lead source information from your website, we recommend that you create
a custom field.

• Lead Source Details: When the Lead Source field is updated, Salesforce also creates a Lead Source Detail activity record
that provides additional details about a lead's origin, such as campaign, ad group, keyword, referring URL, or search engine.

• Reports: Salesforce includes 17 standard Salesforce for Google AdWords reports that track leads, opportunities, and closed
deals generated by Google AdWords campaigns, ad groups, text ads, and keywords. To view Google AdWords reports,
click the Reports tab. From the Folder drop-down list, select Google AdWords Reports.

• Dashboards: Salesforce includes a one-stop search marketing dashboard that helps you to track your Google AdWords
performance for lead and pipeline generation, closed opportunities, and AdWords ROI.

Additional Salesforce CRM Enhancements

Service & Support—Advanced Assignment, Escalation, and Auto-Response Rules

With Summer '07, you can use the full power of the Salesforce rule engine to set rule entries on assignment, escalation, and
auto-response rules. With a user interface that is similar to the one available for rule criteria in workflow, you can now easily
build complex rules that automatically trigger when specific field values or formula criteria match the rule entries you assign
to cases and leads.
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For example, now when you create or update an assignment rule for an object such as cases by clicking Setup ➤ Cases ➤
Assignment Rules, you can enter your rule criteria by doing one of the following:

• Choose criteria are met and select the filter criteria that a record must meet to trigger the rule.

If your organization uses multiple languages, enter filter values in your organization's default language. Note that you can
click the Advanced Options... link to add up to 25 filter criteria that can include up to 255 characters. For more information
on using filter criteria, see "Entering Filter Criteria" in the Salesforce online help.

• Choose formula evaluates to true and enter a formula that returns a value of "True" or "False." Salesforce triggers
the rule if the formula returns "True."

For information on using formulas, see "Building Formulas" in the Salesforce online help.

Each assignment, auto-response, and escalation rule can have:

• 3000 rule entries
• 300 formula criteria rule entries
• 25 filter criteria per rule entry

Note that in previous Salesforce releases, rule detail pages displayed rule entry criteria as links, which you could click to update
rule entry criteria. With Summer '07, rule detail pages do not display rule entry criteria as links. However, you can update rule
entry criteria on rule detail pages by clicking Edit next to the rule entry criteria you want to update.

Escalation rules and auto-response rules are available in Professional, Enterprise, Unlimited, and Developer Editions. Assignment
rules for cases are available in Professional, Enterprise, Unlimited, and Developer Editions, and for leads in Group, Professional,
Enterprise, Unlimited, and Developer Editions.

Service & Support—Call Center Edition Generally Available

Call Center Edition is now generally available to all Professional, Enterprise, Unlimited, and Developer Edition customers.

Call Center Edition seamlessly integrates Salesforce with third-party computer-telephony integration (CTI) systems. After
a lightweight CTI adapter program has been installed on a Salesforce user's machine, the user can use the features of a CTI
system through the Salesforce SoftPhone, a customizable call control tool that appears in the sidebar of every Salesforce page.

Additionally, Call Center Edition now includes the following enhancements:

• During a call, you can edit the Subject of the call log.
• You can edit recent call logs in the SoftPhone window.
• Outside, domestic, and international dialing codes are optional in call center setup.

For information on working with Call Center Edition as a call center user, see "Using the SoftPhone" in the Salesforce online
help.

For information on deploying and customizing Call Center Edition as an administrator, see "Setting Up Call Center Edition"
in the Salesforce online help.

For information on customizing and building CTI adapters as a developer, see the CTI Toolkit Developer's Guide.

Marketing—Adding Campaign Member Statuses

You can now add up to 50 campaign member statuses at one time to a campaign. To add new member statuses:

1. View the campaign you want to customize, and click Advanced Setup.
2. Click Edit to add or update Member Status values.
3. Update the existing entries or add new values.
4. Click Add More as needed to add additional entries. You can add up to 50 entries.
5. Select one entry as the "Default" value.
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6. Choose which values will be counted as "Responded." Members with "Responded" values will be tallied in the Total
Responses field on the campaign.

Campaigns are available in Enterprise, Unlimited, and Developer Editions, and available for an additional cost in Professional
Edition.

Marketing—Merging Contacts or Leads on Campaigns

With Summer '07, when you merge duplicate contacts or leads that are members of different campaigns, the campaign Member
Status Updated date for each is retained and associated with the newly-merged contact or lead.

Campaigns are available in Enterprise, Unlimited, and Developer Editions, and available for an additional cost in Professional
Edition.

PRM—Accounts and Opportunities in the PRM Portal

With Summer ’07, you can give your partner users access to accounts in the PRM portal. Your partner users can now create
and edit accounts. You can also allow your partner users to create opportunities directly without requiring that they first create
a lead and convert the lead to an opportunity.

In addition, there is a new group, Roles and Internal Subordinates, that allows you to create sharing rules that exclude all
partner users. You can easily convert sharing rules that include Roles and Subordinates to include Roles and Internal Subordinates
instead by using the sharing rule conversion wizard. For more information, see "Converting the Roles and Subordinates Sharing
Rule Category" in the Salesforce online help.

The PRM portal is available in Enterprise and Unlimited Editions.

Report Enhancements

Specify the Number of Records to Display in Report Results
Now, you can limit the number of records that display in tabular report results by selecting a value from
the Rows to Display drop-down list on the Select Criteria page of the report wizard. If you select
Custom from the Rows to Display drop-down list, you can enter a specific number of records to
display in report results. When limiting the number of records that display in tabular report results, you
must select a field and order in which to sort the results.
You can create a dashboard from a tabular report as long as the tabular report has a limited record count.
First, save the report; then edit the Dashboard Components settings on the Order Columns page of the
report. Note that you cannot use the gauge or metric component types in dashboards created from reports
with limited record counts.

Reports with Custom Objects Include the Division Filter
If your organization uses divisions and you have the "Affected by Divisions" permission, the Division
drop-down list now appears on report results that include custom objects marked Enable Divisions.
For more information on divisions, see "Overview of Divisions" in the Salesforce online help.

Tabular Reports with Subtotals of Data Automatically Convert to Summary Reports
In previous releases of Salesforce, you could change summary and matrix reports to tabular reports and
maintain the fields by which you chose to subtotal data via the Select Grouping page on the report wizard.
However, because tabular reports do not include subtotals of data, Salesforce now automatically converts
tabular reports with subtotals of data to summary reports, as this is the proper format. You can convert
summary and matrix reports to tabular reports if you remove any field subtotals on the Select Grouping
page on the report wizard first.

Role Hierarchy Drill-Down Alphabetically Sorts Role Names
Now, report results that include the role hierarchy drill-down display the list of roles below the current
role, separately from the list of users in that role. Furthermore, role names and user names are sorted
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alphabetically. In previous releases of Salesforce, role names were not alphabetically sorted in the role
hierarchy drill-down.

Reports are available in all Salesforce Editions. Some features of reporting, such as filtering by division, may not be available
depending on your organization's Edition and configuration.

Date Field Enhancements

With Summer '07, date fields in all Salesforce Editions now use a new date picker that makes it easier to enter dates by allowing
you to quickly scroll through months or years and enter special date values.

If your language is English, and your locale is English (United States), you can use the following special date values for entering
dates:

RangeSpecial Date Value

The day before the current day.Yesterday

The current day.Today

The day after the current day.Tomorrow

The next Monday. If the current day is Monday, the current
day.

Monday

The next Tuesday. If the current day is Tuesday, the current
day.

Tuesday

The next Wednesday. If the current day is Wednesday, the
current day.

Wednesday

The next Thursday. If the current day is Thursday, the current
day.

Thursday

The next Friday. If the current day is Friday, the current day.Friday

The next Saturday. If the current day is Saturday, the current
day.

Saturday

The next Sunday. If the current day is Sunday, the current
day.

Sunday

The values for the day and month and the current year. For
example, 12/31 would expand to 12/31/2007 if the year is
2007.

mm/dd

The values for the day and month and the current year. For
example, 12.31 would expand to 12/31/2007 if the year is
2007.

mm.dd

The values for the day and month and the current year. For
example, 12-31 would expand to 12/31/2007 if the year is
2007.

mm-dd

If the field is a date/time field, the time will be set to the current time. These special date values are not case sensitive.

Tip: These special date values can be set using the first three letters. For example, "yes" for yesterday or "mon" for
Monday.
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Opt-Out of System Maintenance Notifications

With Summer '07, administrators can go to Setup ➤ Company Profile ➤ Company Information to prevent advance notices
about planned system maintenance or downtime from displaying to users when they log in. This is available in all Salesforce
Editions.
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APEX PLATFORM

Apex Code
Available in: Unlimited and Developer Editions

Available for an additional cost in: Enterprise Edition

With Summer ’07, Apex Code becomes available for Unlimited and Developer Edition users. Apex Code, the world’s first
on-demand programming language, takes on-demand customization much further, allowing developers to customize business
logic to create an entirely new class of features and apps.

Apex Code includes the following enhancements in Summer '07:

Classes Replace Packages
Apex Code packages are now deprecated and replaced with Apex Code classes. While you can edit an
existing package, you cannot create any new packages.

The following example converts a package to a class.

package myFirstPackage{

public void helloWorld(Accounts accounts){

for (Accounts a:accounts){
if (a.Hello_World__c != 'World') {
a.Hello_World__c = 'World';
}

}
}
private testMethod void myFirstTest(){
// Test code here
}

}

The following is the converted code:

public class myFirstPackage{

public void helloWorld(Accounts accounts){

for (Accounts a:accounts){
if (a.Hello_World__c != 'World') {
a.Hello_World__c = 'World';
}

}
}
static testMethod void myFirstTest() {

// Test code here
}

}

Note the following changes:

• The package keyword is replaced with public and class. All outer classes require an access modifier.
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• The private keyword is not used. The default access modifier is no longer public. private is the
default, and means that the method or variable is accessible only within the Apex Code class in which
it is defined. If you do not specify an access modifier, the method or variable is private.

• All test methods must be declared static.

Classes can be automatically generated from a WSDL document that is stored on a local hard drive or
network.

Class Level Security
You can specify which users can execute methods in a particular top-level class based on their user profile.
Note that you can only set security on Apex Code classes, not on triggers.

Debug Log Levels
You can now use the Apex Log to specify debug log levels. In addition, a new debug log level CALLOUT
has been added. It includes all messages generated by the PROFILE log level as well as the request-response
XML that the server sends and receives from any external Web service. Use this log level to debug issues
related to using Apex Web Services API calls.

Note: You can only set the CALLOUT log level in Developer Edition organizations.

Deploying Apex Code

There are three types of organizations where you can run your Apex Code:

• A developer organization: an organization created with a Developer Edition account.
• A production organization: an organization that has live users accessing your data.
• A sandbox organization: an organization created on your production organization that is a copy of

your production organization.

You never want to develop Apex Code in your Salesforce production organization. Live users accessing
the system while you are developing can destabilize your data or corrupt your application. Instead,
salesforce.com recommends that you do all your development work in a Developer Edition organization.

You can add, edit or delete Apex Code through the application only in a Developer Edition or sandbox
organization. In a Salesforce production organization, you can only make changes to Apex Code by using
the compileAndTest API call.

Download the Apex Deployment Tool if you want to use a script for deploying Apex Code from a
Developer Edition or sandbox organization to a Salesforce production organization using Apache's Ant
build tool.

Exact Equality Operator
Apex Code now supports the exact equality operator (===). This operator enables equality conditions
based on a value's location in memory.

Generating Apex Code From A WSDL Document
You can now generate Apex Code classes from a valid WSDL document using the Salesforce user interface.
This allows you to make callouts to external Web services in your Apex Code scripts.

Literal Values in Maps or Sets
You can now populate a map or set with literal values when you declare it. For example:

Map<String, String> MyStrings = new Map<String, String>{'a' => 'b', 'c' =>
'd'.toUpperCase()};
Account [] accs = new Account [5];
Map<integer, List<Account>> m4 = new Map<Integer, List<Account>>{1 => accs};
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Monitoring Apex Code Debug Logs

You can retain as well as manage the Apex Code debug logs for specific users in your organization.

The total number of debug logs retained for an organization is twenty.The oldest log is overwritten when
the maximum number of logs is reached.

Platform Prevents Changes That Invalidate Apex Code Scripts
The platform prevents users from making the following types of modifications when those changes cause
an Apex Code script to become invalid:

• changing a field or object name
• converting from one data type to another
• deleting a field or object
• making certain organization-wide changes, such as record sharing, field history tracking, or record

types.

Regular Expressions
Regular expressions are now available. A regular expression is a string that is used to match another string,
using a specific syntax. Apex Code supports the use of regular expressions through its Pattern and Matcher
classes.

Runtime Limits Methods
Because Apex Code runs in a multitenant environment, the Apex Code runtime engine strictly enforces
a number of limits to ensure that runaway scripts do not monopolize shared resources. The Limits methods
return the specific limit for the context in which they are being executed, that is, from a trigger, a Web
service method, and so on.

Salesforce Ant Tool

Download the Apex Deployment Tool if you want to use a script for deploying Apex Code from a
Developer Edition or sandbox organization to a Salesforce production organization using Apache's Ant
build tool.

Setup Audit Trail Tracking
The setup audit trail history now tracks changes to classes and triggers.

sort Method Added
You can now use the sort method on lists.

Test Static Methods Added
The following new methods are now included in the system static Test class:

• startTest

• stopTest

Transaction Control
Earlier releases of Apex Code required that you include transaction control statements (such as commit
or rollback) in your Apex Code script. In this release, all transactions are controlled by the trigger, Web
Service, or anonymous block that executes the Apex Code script. If the Apex Code script completes
successfully, all changes are committed to the database. If the Apex Code script does not complete
successfully, all database changes are rolled back.
However, sometimes during the processing of records, your business rules require that partial work (already
executed DML statements) be “rolled back” so that the processing can continue in another direction.
Apex Code gives you the ability to generate a Savepoint, that is, a point in the transaction that specifies
the state of the database at that time. Any DML statement that occurs after the Savepoint can be discarded,
and the database can be restored to the same condition it was in at the time you generated the Savepoint.

35

Apex Platform Apex Code



Trigger Enhancements and Changes
For standard objects, triggers are now stored under the object with which they are associated. Click Setup
➤ Customize, click the name of the standard object, and then click Triggers. The location for triggers
on custom objects is unchanged.
The new UNDELETE trigger event runs after a record is restored from the Recycle Bin.
The bulk keyword is now optional. All triggers automatically run in bulk mode.

UserInfo Class Changes
The following new methods are now included in the system static UserInfo class:

• getProfileId

• getSessionId

• getUserName

Warning and Exception Changes
The SObjectException system exception type is now included.
ArrayException is now called ListException.

webService Keyword Changes
You must define any method that uses the webService keyword as static. There is no need for a
commit statement with webService methods. If your Apex Code script completes successfully, any
database changes are automatically committed. If your Apex Code script does not complete successfully,
any changes made to the database are rolled back.

Web Service API Testing Calls
The following Apex Web Service API calls are now included:

• compileAndTest

• compileClasses

• compileTriggers

For more information on the syntax and use of Apex Code, see the Apex Code Language Reference.

Multiple Salesforce Sandboxes
Available in: Unlimited Edition

Available for an additional cost in: Enterprise Edition

With Summer '07, Salesforce gives you the ability to create multiple copies of your organization in separate environments for
a variety of purposes, such as testing and training, without compromising the data and applications in your Salesforce production
organization. These copies are called sandboxes and are nearly identical to your Salesforce production organization.

There are two types of sandboxes:

Full Copy
Full copy sandboxes copy your entire production organization and all of its data, including standard and
custom object records, documents, and attachments.

Quick Copy
Quick copy sandboxes copy all of your production organization's reports, dashboards, price books, products,
apps, and customizations under Setup, but exclude all of your organization's standard and custom object
records, documents, and attachments. Creating a quick copy sandbox can decrease the time it takes to
create or refresh a sandbox from several hours to just a few minutes, but it can only include up to 500 MB
of data.
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Contact salesforce.com to order sandboxes for your organization and to learn about how many sandboxes you can create.

Implementation Tips

• Sandboxes automatically append .<sandbox_name> to email addresses on user records in the sandbox environment. This
invalidates all user email addresses and prevents sandboxes from sending email to your production organization's users
because Salesforce does not deliver any email with an invalid From address. You can manually correct email addresses in
the sandbox user records for users who will use your the sandbox for testing and training.

Caution:  Sandboxes automatically change Salesforce user email addresses, but do not change other email addresses
in Salesforce, such as those in contact records. To avoid sending unsolicited email from your sandboxes, manually
invalidate or delete all email addresses in your sandboxes that do not belong to users. When testing the generation
of outbound email, change contact email addresses to those of testers or an automated test script.

• Customizations to your production organization do not automatically appear in your sandboxes. You must create a new
sandbox or refresh an existing one to see the customizations made to your organization since the last time you created or
refreshed a sandbox.

• The following features are disabled and cannot be enabled in sandboxes:

• Case escalation
• Opportunity reminders
• Contract expiration warnings
• Subscription summary
• Automated weekly data exports
• The ability to create Salesforce sandboxes

Note:  Case escalation, opportunity reminders, and contract expiration warnings are disabled because they
automatically send email to contacts and customers who should not interact with sandboxes.

• While full copy sandboxes have the same storage limit as you production organization, quick copy sandboxes have a 500
MB storage limit.

• The organization IDs of your sandboxes differ from your production organization ID, and will change each time your
sandbox is refreshed.

• Only custom links created as relative URLs, such as /00Oz0000000EVpU&pv0={!Account_ID} will work in your sandboxes.
All custom links created as absolute URLs, such as https://na1.salesforce.com/00Oz0000000EVpU&pv0={!Account_ID},
will not work in your organization's sandboxes.

• Sandboxes do not send storage limit email warnings. To check your storage usage and limits, click Setup ➤ Data
Management ➤ Storage Usage in your sandbox. For more information on storage limits, see "Monitoring Resources" in
the Salesforce online help.

• Salesforce has a background process that permanently deletes records in the Recycle Bin that are older than 30 days. The
time of the latest execution of this process is available through the GetDeleted() API call. For more information, see the
Apex Web Services API Developer's Guide.

This process runs at different times on different servers, so its timestamp in your sandbox differs from its timestamp in
your production organization. Applications and integrations that depend on this timestamp may fail if they are first
connected to one environment, such as your production organization, and then later connected to another environment,
such as your sandbox. Keep this in mind when developing applications and integrations that depend on this timestamp.

• You can add, edit or delete Apex Code through the application only in a Developer Edition or sandbox organization. In
a Salesforce production organization, you can only make changes to Apex Code by using the compileAndTest API call.

• If your sandbox is the same version as the AppExchange, you can:

• Install and deploy apps from the AppExchange in your sandbox.
• Publish apps from your sandbox to the AppExchange.
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Note: The version of your sandboxes may differ from the AppExchange around the time of a Salesforce release.
Check the logo in the upper left corner of your sandbox home page for version information.

Best Practices

• Use quick copy sandboxes instead of full copy sandboxes, and use the data loader to load sample data instead of copying
all the data in your organization, as is done with a full copy sandbox. When using a sandbox for training purposes, this
method enables trainers to use a standardized small data set for each training session and to include data relevant to the
concepts being taught. When using a sandbox for testing purposes, this method enables testers to use standard data sets
for regression testing.

• Choose sandbox names that:

• Reflect the purpose of this sandbox, such as "QA" for a test environment sandbox
• Have few characters because Salesforce automatically appends the sandbox name to email addresses on user records in

the sandbox environment. Names with fewer characters make sandbox logins easier to type.

• Use multiple sandboxes for different long term development projects that might conflict with each other or be delivered
on different schedules.

About Multiple Sandboxes

Managing Your Salesforce Sandboxes

User Permissions Needed

"View Setup and Configuration"To view a sandbox:

"Modify All Data"To create, refresh, activate, and delete sandboxes:

Salesforce gives you the ability to create multiple copies of your organization in separate environments for a variety of purposes,
such as testing and training, without compromising the data and applications in your Salesforce production organization.
These copies are called sandboxes and are nearly identical to your Salesforce production organization. For a list of differences,
see "Differences Between Salesforce Sandbox and Your Production Organization" in the Salesforce online help.

Sandboxes are completely isolated from your Salesforce production organization, so operations you perform in your sandboxes
do not affect your Salesforce production organization, and vice-versa.

There are two types of sandboxes:

Full Copy
Full copy sandboxes copy your entire production organization and all of its data, including standard and
custom object records, documents, and attachments.

Quick Copy
Quick copy sandboxes copy all of your production organization's reports, dashboards, price books, products,
apps, and customizations under Setup, but exclude all of your organization's standard and custom object
records, documents, and attachments. Creating a quick copy sandbox can decrease the time it takes to
create or refresh a sandbox from several hours to just a few minutes, but it can only include up to 500 MB
of data.
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Note:  Contact salesforce.com to order sandboxes for your organization and to learn about how many sandboxes you
can create.

To manage your sandboxes, click Setup ➤ Data Management ➤ Salesforce Sandbox.

• Click New Sandbox to create a new sandbox. For more information, see "Creating or Refreshing a Salesforce Sandbox"
in the Salesforce online help.

Salesforce deactivates the New Sandbox button when an organization reaches its sandbox limit. If necessary, contact
salesforce.com to order more sandboxes for your organization.

• Click Show Sandbox Refreshes to see a list of all sandbox refreshes. For more information, see "Creating or Refreshing
a Salesforce Sandbox" in the Salesforce online help.

• Click Refresh to replace an existing sandbox with a new copy. Salesforce only displays the Refresh option for sandboxes
that are eligible for refreshing. You can optionally refresh a sandbox thirty days after activating it. The refreshed copy is
inactive until you activate it.

• Click Activate to activate a refreshed sandbox. You must activate your refreshed sandbox before you can access it. Salesforce
only displays this option for sandboxes that are not activated.

Caution:  Activating a refreshed sandbox replaces the existing sandbox with the refreshed version.This permanently
deletes the existing version and all data in it. Your production organization and its data will not be affected.

• Click Del to delete a sandbox. The delete option is only available if your organization exceeds its sandbox limit. .

Caution:  Deleting a sandbox permanently erases the sandbox and all data in it. Your production organization and
its data will not be affected.

• Click Login to log in to a sandbox. Salesforce only displays this option for active sandboxes.

Salesforce Sandbox Implementation Tips

Consider the following differences before you create a sandbox:

• Sandboxes automatically append .<sandbox_name> to email addresses on user records in the sandbox environment. This
invalidates all user email addresses and prevents sandboxes from sending email to your production organization's users
because Salesforce does not deliver any email with an invalid From address. You can manually correct email addresses in
the sandbox user records for users who will use your the sandbox for testing and training.

Caution:  Sandboxes automatically change Salesforce user email addresses, but do not change other email addresses
in Salesforce, such as those in contact records. To avoid sending unsolicited email from your sandboxes, manually
invalidate or delete all email addresses in your sandboxes that do not belong to users. When testing the generation
of outbound email, change contact email addresses to those of testers or an automated test script.

• Customizations to your production organization do not automatically appear in your sandboxes. You must create a new
sandbox or refresh an existing one to see the customizations made to your organization since the last time you created or
refreshed a sandbox.

• The following features are disabled and cannot be enabled in sandboxes:

• Case escalation
• Opportunity reminders
• Contract expiration warnings
• Subscription summary
• Automated weekly data exports
• The ability to create Salesforce sandboxes
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Note:  Case escalation, opportunity reminders, and contract expiration warnings are disabled because they
automatically send email to contacts and customers who should not interact with sandboxes.

• While full copy sandboxes have the same storage limit as you production organization, quick copy sandboxes have a 500
MB storage limit.

• The organization IDs of your sandboxes differ from your production organization ID, and will change each time your
sandbox is refreshed.

• Only custom links created as relative URLs, such as /00Oz0000000EVpU&pv0={!Account_ID} will work in your sandboxes.
All custom links created as absolute URLs, such as https://na1.salesforce.com/00Oz0000000EVpU&pv0={!Account_ID},
will not work in your organization's sandboxes.

• Sandboxes do not send storage limit email warnings. To check your storage usage and limits, click Setup ➤ Data
Management ➤ Storage Usage in your sandbox. For more information on storage limits, see "Monitoring Resources" in
the Salesforce online help.

• Salesforce has a background process that permanently deletes records in the Recycle Bin that are older than 30 days. The
time of the latest execution of this process is available through the GetDeleted() API call. For more information, see the
Apex Web Services API Developer's Guide.

This process runs at different times on different servers, so its timestamp in your sandbox differs from its timestamp in
your production organization. Applications and integrations that depend on this timestamp may fail if they are first
connected to one environment, such as your production organization, and then later connected to another environment,
such as your sandbox. Keep this in mind when developing applications and integrations that depend on this timestamp.

• You can add, edit or delete Apex Code through the application only in a Developer Edition or sandbox organization. In
a Salesforce production organization, you can only make changes to Apex Code by using the compileAndTest API call.

• If your sandbox is the same version as the AppExchange, you can:

• Install and deploy apps from the AppExchange in your sandbox.
• Publish apps from your sandbox to the AppExchange.

Note: The version of your sandboxes may differ from the AppExchange around the time of a Salesforce release.
Check the logo in the upper left corner of your sandbox home page for version information.

Creating or Refreshing a Salesforce Sandbox

User Permissions Needed

"View Setup and Configuration"To view a sandbox:

"Modify All Data"To create, refresh, activate, and delete sandboxes:

To create or refresh a sandbox:

1. Click Setup ➤ Data Management ➤ Salesforce Sandbox.
2. Select one of the following:

• Click New Sandbox to create a new sandbox. For more information, see "Creating or Refreshing a Salesforce Sandbox"
in the Salesforce online help.

Salesforce deactivates the New Sandbox button when an organization reaches its sandbox limit. If necessary, contact
salesforce.com to order more sandboxes for your organization.
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• Click Refresh to replace an existing sandbox with a new copy. Salesforce only displays the Refresh option for sandboxes
that are eligible for refreshing. You can optionally refresh a sandbox thirty days after activating it. The refreshed copy
is inactive until you activate it.

3. Enter a name and description for the sandbox. You can only change the name when you create or refresh a sandbox.

Tip: We recommend that you choose a name that:

• Reflects the purpose of this sandbox, such as "QA."
• Has few characters because Salesforce automatically appends the sandbox name to email addresses on user

records in the sandbox environment. Names with fewer characters make sandbox logins easier to type.

4. Optionally, select the Quick Copy checkbox to create a quick copy sandbox.

Quick copy sandboxes copy all of your production organization's reports, dashboards, price books, products, apps, and
customizations under Setup, but exclude all of your organization's standard and custom object records, documents, and
attachments. Creating a quick copy sandbox can decrease the time it takes to create or refresh a sandbox from several hours
to just a few minutes, but it can only include up to 500 MB of data.

5. Click Start Copy.

The process may take several hours, depending on the size of your organization and whether you are creating a quick copy.

6. You will receive a notification email when your newly created or refreshed sandbox is ready for use. Click the link in the
notification email to access your sandbox.

Users can log into the sandbox at https://www.test.salesforce.com/login.jsp by appending .<sandbox_name> to their
Salesforce username. For example, if your username for your production account is user1@acme.com, then your username
for a sandbox named "test" is user1@acme.com.test.

Note: Salesforce automatically changes sandbox usernames but does not change passwords.

Roll-Up Summary Fields
Available in: Group, Professional, Enterprise, Unlimited, and Developer Editions

Fields that aggregate information from records in a related list are available with Summer ’07. With roll-up summary fields,
you can quickly see summarized information such as record count, total sum, largest value, or smallest value—all without
running a report.

While your formula fields calculate values using fields within a single record, roll-up summary fields calculate values from a
set of related records, such as those in a related list. You can create roll-up summary fields that automatically display a value
on a master record based on the values of records in a detail record. These detail records must be directly related to the master
through a master-detail relationship. For example, a custom account field called Total Invoice Amount displays the sum
of invoice amounts for all related invoice custom object records in the Invoices related list on an account.

Before you begin creating roll-up summary fields for your organization, review these implementation tips and best practices.

Implementation Tips

• Create roll-up summary fields on:

• Any custom object that is on the master side of a master-detail relationship
• Any standard object that is on the master side of a master-detail relationship with a custom object
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• The types of fields you can calculate in a roll-up summary field depend on the type of calculation. For example,

• Number, currency, and percent fields are available when you select SUM as the roll-up type.
• Number, currency, percent, date, and date/time fields are available when you select MIN or MAX as the roll-up type.

• For the maximum number of roll-up summary fields allowed in your organization, see "App Setup Limits" in the Salesforce
online help.

• Roll-up summary fields cannot calculate the values of other roll-up summary fields.
• Roll-up summary fields can calculate the values of formula fields if they do not contain functions that automatically derive

values on the fly, such as NOW or TODAY.

Note: The value of a formula field can result in "#Error!", which affects the summarized total. If your roll-up
summary type is COUNT, records are included regardless of whether they contain a formula field with an error,
but when the Field to Aggregate is a formula field that results in "#Error!", calculations of type MIN, MAX,
and SUM exclude those formula values.

• Make sure that the filter for your roll-up summary does not encounter a formula field that results in "#Error!". If your filter
criteria uses a formula field that results in an error, Salesforce does not return any matches for that filter criterion. For
example, if your roll-up summary filter is "Formula Field equals 10" and two records contain errors while one contains the
value "10" in that field, your summary only includes the record with the value "10."

• Changes to the value of a roll-up summary field can trigger assignment rules to run. If a roll-up summary field is part of
the criteria in an assignment rule, the field's new value is used to evaluate if the record should be reassigned.

• Roll-up summary fields can trigger workflow rules and field validations. However, workflow rules and field validations do
not fire when the following changes cause a mass recalculation of roll-up summary values:

• Changing the roll-up summary definition (such as the object, function, or field being aggregated)
• Changing the expression of a formula field referenced in a roll-up summary field
• Replacing picklist values for picklist fields referenced in the roll-up summary filter
• Changing picklist record type definitions
• Changing currency conversion rates

• Calculating roll-up summary field values may take up to 30 minutes, depending on the number of records affected and
other factors.

• If your organization uses multiple currencies, the currency of the master record determines the currency of the roll-up
summary field. For example, if the master and detail records are in different currencies, Salesforce converts the values in
the detail record into the currency of the master record before calculating the final value and displaying it in the same
currency as the master record.

• Long text area, multi-select picklist, Description, and system fields like Last Activity cannot be used in the field
column of roll-up summary filters.

• Auto number fields are not available as the field to aggregate in a roll-up summary field.
• After you have created a roll-up summary field on an object, you cannot convert the object's master-detail relationship into

a lookup relationship.

Best Practices

• Apply field-level security to your roll-up summary fields if they calculate values that you do not want visible to users. Fields
that your users cannot see due to field-level security settings on the detail record are still calculated in a roll-up summary
field.

• If you have validation rules, consider how they affect roll-up summary fields. A validation error can display when saving
either the detail or master record because the value in a roll-up summary field changes when the values in the detail records
change.

• Because roll-up summary fields are not displayed on edit pages, you can use them in validation rules but not as the error
location for your validation.
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• Plan your implementation of roll-up summary fields carefully before creating them. Once created, you cannot change the
detail object selected or delete any field referenced in your roll-up summary definition.

• If your organization disables roll-up summary fields, delete all existing ones. Otherwise, the fields continue to display with
an invalid roll-up summary icon ( ). because Salesforce no longer calculates their values.

• Roll-up summary fields do not support objects with advanced currency management. If advanced currency management
is enabled in your organization, we recommend deleting any existing currency roll-up summary fields on opportunities to
prevent the invalid roll-up summary icon from displaying.

• Automatically derived fields such as current date or current user are not allowed in roll-up summary fields. This includes
formula fields containing functions that automatically derive values on the fly, such as NOW and TODAY.

About Roll-Up Summary Fields

Creating Roll-Up Summary Fields

To create a roll-up summary field:

1. Click Setup ➤ Customize, select the appropriate object link from the Customize menu, and then click Fields.
2. Click New in the Custom Fields & Relationships section of the page.
3. Select Roll-Up Summary, and click Next.
4. Enter a field label, name, description, and click Next to continue.
5. Choose the related object.This object is on the detail side of the master-detail relationship with the parent object on which

you are creating the field.
6. Choose the type of calculation you want to make and click Next to continue. For sum, min, and max, select the field to

use when calculating this value. Review the descriptions of each type below:

DescriptionType

Totals the number of related records.COUNT

Totals the values in the field you select in the Field to Aggregate option. Only number, currency,
and percent fields are available.

SUM

Displays the lowest value of the field you select in the Field to Aggregate option for all
directly-related records. Only number, currency, percent, date, and date/time fields are available.

MIN

Displays the highest value of the field you select in the Field to Aggregate option for all
directly-related records. Only number, currency, percent, date, and date/time fields are available.

MAX

7. In Enterprise, Unlimited, and Developer Editions, set the field-level security to determine whether the field should be
visible or read only for specific profiles, and click Next.

8. Choose the page layouts that should display the field and click Next.
9. Click Save to finish or Save & New to create more custom fields.

Advanced Mass Email
Available in: Professional, Enterprise, Unlimited, and Developer Editions

Summer ’07 features several enhancements to the mass email functionality:
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Scheduled Email Delivery
Select the date, time, and time zone of your mass email so that your message can go out at the precise
time you want without requiring your involvement at send time.

Tracking and Monitoring with the Mass Email Queue
View your scheduled and completed mass emails, cancel scheduled emails, and see which email templates
you used, all in one spot.

Increased Mass Email Limits for Enterprise and Unlimited Editions
The maximum number of external addresses you can include in a single mass email has increased to 500
for Enterprise Edition customers and 1,000 for Unlimited Edition customers.

Implementation Tips

• The mass email capability is enabled by default for organizations using Professional, Enterprise, Unlimited, and Developer
Editions.

• Enable the "Mass Email" permission on profiles for users who need the ability to send mass emails.
• The mass email limits apply to emails sent within a 24 hour period. That time period is calculated based on Greenwich

Mean Time (GMT).

Best Practices

• Before you send a mass email, create a custom view of contacts, leads, person accounts, or cases without an email address.
In the search criteria, choose "Email equals," and leave the third field blank. You can then update those records before
sending your emails. Unfortunately, there is no way to validate an email address without sending an actual email message.

About Advanced Mass Mail

Sending Mass Email

User Permissions Needed

"Mass Email"To send mass emails to contacts, person accounts, or leads:

"Mass Email"

AND

To send mass emails to users:

"Manage Users"

"Mass Email"

AND

To send mass emails and log them in the Activity History
related list:

"Edit Tasks"

You can send a mass email message to a recipient list that consists of contacts, leads, person accounts, or users you can view
in Salesforce.

You can send mass email to a maximum of 1000 external email addresses per day based on Greenwich Mean Time (GMT).
The maximum number of external addresses you can include in a single mass email depends on the Edition of Salesforce you
are using:
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LimitEdition

250Professional

500Enterprise Edition

1000Unlimited Edition

You can send an unlimited amount of email to your internal users.

1. Choose the type of recipients for your mass email:

• To send mass email to contacts or person accounts, click Mass Email Contacts in the Tools section of the Contacts
or Cases tab. If your organization uses person accounts, the link is also in the Tools section of the Accounts tab.

• To send mass email to leads, click Mass Email Leads in the Tools section of the Leads tab.
• To send mass email to users, click Setup ➤ Manage Users ➤ Mass Email Users.This link is available to administrators

and users with the "Manage Users" permission.

2. Select a list view of recipients and click Go!. By default, the My Contacts, My Leads, Active Users, or My Cases views
include all records of that type with an email address. To change the list of recipients, create a new custom view. See
"Creating Custom List Views" in the Salesforce online help.

Contacts, leads, or person accounts that have the Email Opt Out field selected or do not have an email address are not
included in any email list views.

Note: Person accounts are included in contact list views.

3. All recipients in the list view are selected by default. If there are recipients who should not receive the mass email, deselect
them.

4. Click Next.
5. Choose an email template. Optionally, click the Preview links to view the templates.

Note:  In the email template preview window, the template displays with any merge fields included, such as
{!Account.AccountNumber}. When you send your email, data from the recipients' records, or any applicable
substitute text, is inserted into the email in place of those merge fields.

6. Click Next.
7. On the confirmation page, select from the available Processing Options:

• BCC me on one message

• Store an activity for each message

The Activity History item is associated with the contact, lead, or person account and displays as "Mass Email:<Template
Description>." The email subject, body, and attachments are not stored in the Activity History item. To log Activity
History items, you must have access to view or edit the records in the recipient list and have the "Edit Task" permission.

• Use my signature

Optionally, include your email signature in this mass email. This option applies to text emails only. See "Editing Email
Settings" in the Salesforce online help for information on creating an email signature.

• Mass Email Name

Enter a name you can use to identify this mass email in the mass email queue. See "Monitoring the Mass Email Queue"
in the Salesforce online help for more information.
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Note: The mass email name only appears in the mass email queue and status messages you receive from
Salesforce. Salesforce does not add the mass email name to the mass email you are sending.

8. In the Delivery Options section, do one of the following:

• Select Send now.
• Select Schedule for delivery on and click the date/time link to specify when Salesforce will send the mass email. Use

the adjacent drop-down menu to specify the time zone.

Note:  Users can click Setup ➤ Email ➤ My Mass Emails to view and cancel mass emails they scheduled.
Administrators can click Setup ➤ Monitoring ➤ Mass Email Monitoring to view and cancel mass emails
scheduled by all users in their organization. See "Monitoring the Mass Email Queue" in the Salesforce online
help for more information.

9. Click Send to submit the mass email.
10. Click Finished to complete the mass email wizard.

Notes on Sending Mass Email

• Before you send a mass email, create a custom view of contacts, leads, person accounts, or cases without an email address.
In the search criteria, choose "Email equals," and leave the third field blank. You can then update those records before
sending your emails. Unfortunately, there is no way to validate an email address without sending an actual email message.

• If your template contains a merge field for which there is no data in a particular record, that field does not display in the
email you send. To find such blank fields, modify your recipient list view to search for the merge fields you are using in
your template, and enter the criterion "<field> equals," leaving the third field blank. Edit those records that have blank
fields before you send your emails.

• You receive an auto-generated status email from Salesforce for each mass email you send. The subject line of the status
email contains the value you entered in the Mass Email Name field when sending the mass email.

• Both the mass email queue and the status email contain the following information:

Addressed To
The number of recipients you selected when creating the mass email.

Sent To
The number of recipients to which Salesforce sent the message. This number may differ from the
Addressed To number for the following reasons:

• The mass email would cause your organization to exceed its daily mass email limit. Salesforce does
not send the message to any of the intended recipients in this case.

• One or more selected recipients opted out of receiving mass email after the mass email was
scheduled but before it was processed.

• One or more selected recipient email addresses were removed from the contact or lead after the
mass email was scheduled but before it was processed.

• The user who sent the mass email was deactivated after the mass email was scheduled but before
it was processed. Salesforce does not send mass emails scheduled by a user who is deactivated.

• Attachments in mass emails are sent as links rather than as physical files. When recipients click the attachment link in the
email, the attachment opens in a separate Web browser, and they can download the file. Mass email attachments display
the filename and extension and are stored for 30 days.

• Email templates give you access only to the fields that are accessible to you via your page layout and field-level security
settings. (Field-level security is available in Enterprise, Unlimited, and Developer Editions only.)
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Monitoring the Mass Email Queue

User Permissions Needed

"Mass Email"To view your mass email or cancel your pending mass email:

"Modify All Data"To view all mass email or cancel pending mass email in your
organization:

Use the mass email queue to view the status of scheduled mass emails and cancel mass emails if necessary.

To view the mass emails you have scheduled, click Setup ➤ Email ➤ My Mass Emails. If you have permission to view all
mass emails in your organization, click Setup ➤ Monitoring ➤ Mass Email Monitoring.

From these pages, you can:

• Click Cancel to cancel a pending mass email.
• Click Stop to stop a mass email that Salesforce is in the process of sending.
• Click Del to delete the record of a sent or canceled mass email from the queue.
• Click the name of the mass email to view details about an individual mass email.

Extended Customizable Help
Field-level help available in: All Editions

Object-level help available in: Group, Professional, Enterprise, Unlimited, and Developer Editions

Providing custom help to your users is easy with Summer ’07. New customization options are available to provide customized
help for custom fields and custom objects, allowing you to provide the guidance your users need to get up and running. With
Summer '07, extended customizable help includes:

• Field-level help for custom fields

Administrators can provide up to 255 characters of help text to describe any custom field. That help text displays to users
in a help hover tip whenever they mouse over the help indicator next to the custom field.

• Context-sensitive object-level help for custom objects

Administrators can override the standard Help for this Page link on any custom object to provide customized help
documentation for their users.

About Extended Customizable Help

Field-Level Help

Field-level help allows you to provide help text detailing the purpose and function of any custom field. You can define custom
help text for your organization's custom fields to provide users with a helpful description for any field on all detail and edit
pages where that field displays. Users can view the field-level help text by hovering their mouse over the help icon next to the
field.
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Implementation Tips

• Field-level help is enabled by default for all editions. To add help text to your custom fields, see "Defining Field-Level
Help" in the Salesforce online help. If you do not add help text for any custom fields, your users do not see field-level help
and nothing changes on their detail and edit pages.

• You can add field-level help only for custom fields. For descriptions of standard fields, see the Salesforce online help.
• The help text for a custom field is automatically added to a package when you add the associated custom field to any

AppExchange package.
• In a managed package, the help text is locked to the developer, giving installers full capabilities to change it.

Best Practices

• Because your custom help text displays on both edit and detail pages, avoid instructions for entering data. Instead, construct
help text that defines the field's purpose, such as:

The maximum discount allowed for this account.

• Provide information in your help text about the attributes of the field, such as:

A detailed description of the purpose for the expense report. Up to 32 KB of data are allowed. Only the first 255 characters
display in reports.

• Provide examples in your help text that help users understand the field's meaning clearly, such as:

The four-digit promotional code used to determine the amount charged to the customer, for example, 4PLT (for level-four
platinum pricing).

• If your organization uses more than one language, provide translations for your Help Text using the translation workbench.

Defining Field-Level Help

User Permissions Needed

"Customize Application"To define or change field-level help:

Field-level help allows you to provide help text detailing the purpose and function of any custom field. You can define custom
help text for your organization's custom fields to provide users with a helpful description for any field on all detail and edit
pages where that field displays. Users can view the field-level help text by hovering their mouse over the help icon next to the
field.

To make field-level help available to all your users, simply edit the custom field definition to add the text you want displayed,
and field-level help becomes available to all your users.

To define field-level help for custom fields:

1. Select the field for which you want to define custom help text:

• For standard objects, click Setup ➤ Customize, select the appropriate activity, object, or users link from the Customize
menu, and then click Fields.

• For custom objects, click Setup ➤ Build ➤ Custom Objects, and select one of the custom objects in the list.

2. Click Edit next to the field’s name.
3. In the Help Text field, enter the text you want displayed when a user mouses over the field on a detail or edit page. You

can enter up to 255 characters.
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Note: To view field-level help, hover your mouse over the help icon that appears adjacent to the field.

4. Click Save.

Object-Level Help

Object-level help gives you the power to override the Salesforce Help for this Page links for any custom object with your
custom help content contained in an s-control. The Help & Training link at the top of any page always opens the Salesforce
Help & Training window, yet every Help for this Page link on your custom object pages opens the content in the s-control
you select. Your users can access this content from the custom object home (overview), detail, and edit pages as well as any
list views and related lists.

Implementation Tips

• Object-level help is available for all custom objects. For a list of editions that support custom objects, see "App Setup
Limits" in the Salesforce online help.

• When creating an s-control to use for your object-level help, select one of the following types: HTML or URL.
• If you have defined object-level help for a custom object that you add to an AppExchange package, Salesforce automatically

adds the s-control referenced in your Context-Sensitive Help Settings for that object.
• In managed packages, object level help is locked to the developer, giving installers the ability to change it if needed.

Best Practices

• The window that displays your object-level help has the same height and width dimensions as the standard Salesforce
Help & Training window. Be sure to size and style your content appropriately to increase usability of your custom help
content.

• Because s-controls are the source of your object-level help content, you can use merge fields to make the experience more
personalized. For example, you can design the s-control to address the user directly by adding a merge field for the user's
name to the help page when it is displayed.

Defining Object-Level Help

User Permissions Needed

"Customize Application"To define or change object-level help:

Object-level help overrides the Help for this Page links for any custom object with your own custom help content contained
in an s-control. To make object-level help available to all your users, simply create an s-control that contains your help content
and edit the custom object definition to reference that s-control. Object-level help becomes available to all your users instantly.

To define object-level help for custom objects:

1. Create an s-control of type HTML or URL that contains your help content.
2. Edit the custom object definition that should use this s-control when users click the Help for this Page context sensitive

help link for these custom object records. To edit a custom object, see "Defining Custom Objects" in the Salesforce online
help.

3. Choose Open a window using a custom s-control from the Context-Sensitive Help Setting.
4. Select the s-control that contains your help content.
5. Click Save.
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Contact Sharing
Available in: Professional, Enterprise, Unlimited, and Developer Editions

Contact sharing is now available with Summer '07, empowering you to specify sharing settings for contacts independent from
accounts. You can now share accounts across business units while limiting contact access between those business units. Contact
sharing also allows your users to protect the information in their rolodexes. Contact sharing includes:

• An organization-wide sharing default for contacts separate from accounts
• Contact sharing rules
• Manually sharing of contacts for individual users to share contacts they own

Implementation Tips

• Initially, the organization-wide default setting for contacts is Controlled by Parent, which is the same as your existing
settings. Contacts continue to have the same sharing access as accounts until you change the organization-wide default for
contacts.

• Contact sharing is not available if you have enabled territory management or person accounts. The organization-wide
default for contacts is set to "Controlled by Parent" and it is not editable.

• Contacts that are not linked to an account are always private, regardless of your organization’s sharing model. Only the
owner of the contact and administrators can view it. Sharing rules and workflow rules do not apply to private contacts. If
your organization uses divisions, private contacts always belong to the global division.

• To control the account owner's access to contacts they do not own, change the Contact Access setting on the user's
role. For instructions on changing the settings for a role, see "Adding and Editing User Roles" in the Salesforce online
help.

Best Practices

• Create all contact sharing rules to provide users with the necessary contact record access prior to changing your
organization-wide default to reduce the affect the change has on your users.

• To share all contacts in your organization with a group of users or a specific role, create a sharing rule and select the "Entire
Organization" public group in the Contacts owned by members of option.

• Minimize the number of sharing rules you need to create by using the "Roles and Subordinates" option instead of choosing
a specific role.

• If your organization has already customized your contact sharing settings and you want to enable territory management or
person accounts, change your organization-wide default for contacts to Controlled by Parent, which removes all your
contact sharing rules and manually shared contacts.

• After changing your organization-wide default for contacts from Controlled by Parent, notify users of the new contact
access setting on default account teams so that they know to confirm the appropriate access level for new team members.
By default, the contact access setting uses the team member's account access setting.
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About Contact Sharing

Setting the Contact Sharing Model

To maintain your organization’s sharing model and specify sharing rules, select Setup ➤ Security Controls ➤ Sharing
Settings. This page now includes organization-wide sharing defaults for contacts as well as contact sharing rules. Click Edit
in the Organization Wide Defaults section to modify the default sharing for contacts.

You can either view all sharing settings at once, or you can use the Manage sharing settings for drop-down list at the
top of the page to view only organization-wide defaults and sharing rules for one object at a time.

Setting Contact Sharing Rules

Sharing rules allow you to selectively grant data access to defined sets of users. You can create contact sharing rules based on
who owns the contact and set default sharing access for individual contacts and associated records. Your account sharing rules
still control contact access if your organization-wide default is set to Controlled by Parent.

1. If you plan to share data with public groups, confirm that the appropriate public groups have been created. To create your
groups, see "Managing Groups" in the Salesforce online help.

2. Click Setup ➤ Security Controls ➤ Sharing Settings.
3. Click New in the appropriate related list. A page displays with sharing rule fields.
4. In the first line, select the source data set to be shared based on who owns the record. You can choose users who belong

to public groups, roles, or roles and subordinates.

a. In the first drop-down list, choose a data set category. The available categories include:

DescriptionCategory

All public groups defined by your administrator.Public Groups

All roles defined for your organization. This includes all
of the users in the specified role.

Roles

All roles defined by your organization including all of the
users in the specified role plus all of the users in roles below
that role in the role hierarchy.

Roles and Subordinates

b. In the second drop-down list, choose a specific data set.

5. In the Share with line, select the set of users who should have access to that data.

a. In the first drop-down list, choose a category. The available categories include:

DescriptionCategory

All public groups defined by your administrator.Public Groups

All roles defined for your organization. This includes all
of the users in the specified role.

Roles
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DescriptionCategory

All roles defined by your organization including all of the
users in the specified role plus all of the users in roles below
that role in the role hierarchy.

Roles and Subordinates

b. In the second drop-down list, choose a specific set of users.

6. In the Contact Access drop-down list, select the sharing access that the users should have to contacts. The available
settings include:

DescriptionAccess Setting

Users can view, but not update, records.Ready Only

Users can view and update records.Read/Write

Note: Contact Access is not available when the organization-wide default for contacts is set to Controlled by
Parent.

7. Click Save.

Notes on Sharing Rules

• You can use sharing rules to grant wider access to data. You cannot restrict access below your organization-wide default
levels.

• Sharing rules apply to all new and existing records that meet the definition of the source data set.
• Sharing rules apply to both active and inactive users.
• When you change the access levels for a sharing rule, all existing records are automatically updated to reflect the new access

levels.
• When you delete a sharing rule, the sharing access created by that rule is automatically removed.
• When you transfer records from one user to another, the sharing rules are reevaluated to add or remove access to the

transferred records as necessary.
• When you modify which users are in a group, role, or territory, the sharing rules are reevaluated to add or remove access

as necessary.
• Sharing rules automatically grant additional access to related records.
• Managers in the role hierarchy are automatically granted the same access that users below them in the hierarchy have from

a sharing rule.
• Making changes to sharing rules may require changing a large number of records at once.

Sharing Contacts

Your administrator defines your organization's sharing model for contact access. However, you can extend sharing privileges
for your own data on a contact-by-contact basis. Use contact sharing to increase access to your contacts; you cannot restrict
access beyond your organization’s default access levels.

To extend the sharing of a contact, click Sharing on the contact you want to share. To grant access to others, see "Granting
Access to Records" in the Salesforce online help. To view all users that have access to the record, see "Viewing Which Users
Have Access" in the Salesforce online help.
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Special Considerations

• Make sure you are sharing records with users who have the appropriate "Read" permission on their profiles for viewing
the shared records. See "Standard Object Permissions" in the Salesforce online help.

• You cannot manually share a private contact (a contact without an account).
• When granting sharing access to a contact, Salesforce automatically provides "Read" access to the associated account if the

recipient does not already have it.
• If your organization-wide default for contacts is set to Controlled by Parent, the Contact Access options are not available

when sharing related records like accounts; instead, all access to contacts is determined by the user's access to the contact's
account.

• Contact sharing is not available for organizations that have territory management or person accounts.

• If your organization already has territory management or person accounts enabled, the organization-wide default for
contacts is set to Controlled by Parent and is not editable.

• If your organization does not have territory management or person accounts yet you want to enable one of them, set
your organization-wide default for contacts to Controlled by Parent, which removes all your contact sharing rules and
manually shared contacts.

Contact Sharing for Account Teams

Account teams allow you to select a group of users in your organization and give them access to one of your accounts. With
contact sharing, you can grant a different level of access to the contacts on those accounts. To do this:

1. Set your organization-wide default to Private. The Contact Access option on account teams is not available when the
organization-wide default for contacts is set to Controlled by Parent.

2. If you have not yet done so, enable account teams for your organization.
3. Add account team members.

Salesforce Connect for Outlook
Available in: Personal, Group, Professional, Enterprise, and Unlimited Editions

Salesforce Connect for Outlook, also known as Outlook Edition, is a free add-in for Microsoft® Outlook® that integrates
Salesforce with Outlook. If you use both Outlook and Salesforce, Outlook Edition increases your productivity by embedding
useful commands in Outlook windows and keeping your data consistent and up-to-date. Summer '07 includes Outlook Edition
version 3.2.

Implementation Tips

• Outlook Edition can be customized according to your organization's security and business needs. As an administrator, you
can control which commands display in Outlook Edition menus, whether users can modify field mappings, and so on. For
more information, see the Administering Outlook Edition tip sheet.

• Distribute the Using Outlook Edition tip sheet to all users who will have Outlook Edition.This document provides concise
procedural instructions for working successfully with the add-in.

• In Enterprise and Unlimited Editions, administrators can set which profiles have access to Outlook Edition and which
profiles are automatically reminded to update to the latest available version. This setting is a drop-down list in the Desktop
Integration Clients section at the bottom of the profile edit page. Ensure that the option for Outlook Edition is not set to
Off (access denied) if that profile has users who require Outlook Edition. For more information, see "Setting User
Permissions for Desktop Clients" in the Salesforce online help and the Administering Salesforce Desktop Clients tip sheet.
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• If your organization has IT considerations such as a terminal server environment or a single sign-on implementation, please
contact salesforce.com for assistance.

Best Practices

• For simple and easy contact maintenance, set up Outlook Edition to import contacts from Salesforce rather than
synchronizing contacts in both directions. In Outlook, go to Tools ➤ Salesforce Options ➤ Contacts ➤ Data Movement
and select Import with overwrites from Salesforce from the drop-down list. Then, use Salesforce exclusively to add or
edit contact details. By treating your Outlook contacts folder as read-only, you can rely on the latest and greatest information
arriving in Outlook from Salesforce during each synchronization.

• Color-code your Outlook calendar events that have been marked for sync by creating an automatic formatting rule. In your
Outlook calendar, right-click next to an appointment and choose Automatic Formatting on the shortcut menu. Then
create a rule that applies a particular color to an appointment, on the condition that it has the "salesforce.com" category.

• Rely on the lookup tools (magnifying glass icons) in the Outlook Edition dialogs. Using the lookup tools instead of typing
names manually ensures correct and complete values.

About Salesforce Connect for Outlook

New Enhancements

In Summer '07, Outlook Edition 3.2 offers several exciting new enhancements over the previous generally available version
(version 2.0):

Synchronizing person accounts
Outlook Edition can synchronize person accounts between your Accounts tab in Salesforce and your
contacts folder in Outlook. Also, you can associate Outlook emails, calendar events, and tasks with person
accounts.

Uploading email attachments to Salesforce
When adding a sent or received email message to Salesforce, you can simultaneously upload that email's
attachments as well. Uploaded email attachments are associated with a Salesforce record of your choice.

Associating Outlook events, tasks, and contacts with Salesforce records
You can associate calendar events, tasks, and contacts with Salesforce records. For example, you can
associate the Outlook task "Call Jane Doe to confirm meeting time" with the Salesforce contact "Jane
Doe."

Associating Outlook items to custom objects
You can associate Outlook items with custom objects. For example, if your Salesforce organization has
the custom object Expense Reports, in Outlook you can associate an email, event, or task with an existing
expense report record. (As always, you can alternatively associate the item with an account, asset, campaign,
case, contact, contract, lead, or opportunity.)

Viewing associated Salesforce records in the toolbar
When you select an Outlook item that is associated with a Salesforce record, a dynamic button in the
Outlook Edition toolbar displays the name of the associated record. Clicking the button opens that record's
detail page in Salesforce. For example, if an Outlook calendar event is associated with the opportunity
"Acme - 10 widgets," then selecting that event creates a button labeled Opportunity: Acme - 10 widgets
in the Outlook Edition toolbar.
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Quickly creating new Salesforce records
Where appropriate, Quick Create links allow you to create new accounts, contacts, or leads directly from
Outlook Edition dialog boxes. You are only prompted to enter a minimal amount of information for the
new record.

Logging in to Salesforce on startup
In the Salesforce Options dialog, you can allow Outlook Edition to automatically log you in to Salesforce
when you start Outlook. This can increase the speed of your first Outlook Edition operation during that
Outlook session.

Support for more Microsoft products
Outlook Edition now supports the Microsoft Windows Vista operating system and the Microsoft Office
Outlook 2007 program.

Installing Outlook Edition

To download and install Outlook Edition:

1. Back up your Outlook data, saving each of your folders as a .pst file: File ➤ Import and Export ➤ Export to a File ➤
Personal Folder File (.pst).

2. Back up your Salesforce data. We recommend you run reports of your contacts and activities and then export them to
Excel. Alternatively, users with Enterprise or Unlimited Editions can ask their Salesforce administrator to back up their
organization’s data using weekly export; see "Exporting Backup Data" in the Salesforce online help.

3. Uninstall any previous versions of Outlook Edition, which appear in the program removal tool of your Windows Control
Panel as "Salesforce Outlook Edition."

4. Uninstall Intellisync for salesforce.com if it is present on your computer. Before uninstalling Intellisync for salesforce.com,
perform a final sync to reconcile any outstanding data changes.

5. Exit Outlook, making sure to close all Outlook windows.
6. In Salesforce, click Setup ➤ Desktop Integration ➤ Outlook Edition.

In Enterprise and Unlimited Editions, your administrator may have prohibited access to the download page. For more
information, see "Setting User Permissions for Desktop Clients" in the Salesforce online help.

7. Click Install Now.

The Outlook Edition download page also includes a link to download a .msi file so system administrators can centrally
deploy Outlook Edition to their entire organization. See "Deploying Outlook Edition System-Wide" in the Salesforce
online help for more information.

8. Run the installer, following the prompts on each screen.
9. Start Outlook. A wizard introduces you to features and options.To change your Outlook Edition options later, see "Setting

Outlook Edition Options" in the Salesforce online help.

Note:  Outlook Edition requires Salesforce to install components that edit the registry on your computer. If your
organization imposes security that prevents you from editing the registry, log in as the administrator of your machine
before installing these components or contact your IT department for assistance.

Outlook Edition System Requirements

The system requirements for Outlook Edition are:

• Microsoft® Outlook® XP (2002), 2003, or 2007
• Microsoft Windows® 2000, XP, or Vista™

• Microsoft Exchange Server
• Microsoft Word XP (2002), 2003, or 2007
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Note:  Outlook Edition is available in all supported languages offered by Salesforce. However, your Outlook Edition
language is determined by your Windows display language setting rather than your Salesforce language.

To display non-English characters in Outlook Edition, you must install the Windows language service packs for the
characters you want to display.

Outlook Edition fully supports Unicode encoding. However, versions of Outlook prior to Outlook 2003 do not. If
you use an earlier version of Outlook, synchronized items may not display properly in Salesforce if they contain
characters that are not native to your Outlook locale.

Using Outlook Edition

Outlook Edition is easy to use—most actions take only a few clicks to perform. Outlook Edition commands are conveniently
located in toolbars, right-click shortcut menus, and the Ribbon (if you have Outlook 2007).

Working with Outlook Emails

• "Adding Contacts and Leads as Outlook Email Recipients" in the Salesforce online help
• "Adding Outgoing Emails to Salesforce" in the Salesforce online help
• "Adding Sent or Received Emails to Salesforce" in the Salesforce online help
• "Creating Cases from Outlook Emails" in the Salesforce online help

Working with Outlook Contacts, Calendar Events, and Tasks

• "Associating Outlook Items with Salesforce Records" in the Salesforce online help
• "Synchronizing Your Contacts and Activities with Outlook Edition" in the Salesforce online help
• "Opening Salesforce Records from Outlook" in the Salesforce online help

Working with Person Accounts

• "Working with Person Accounts in Outlook Edition" in the Salesforce online help

Note: The version of Outlook Edition that you have installed may not include all of these features. To upgrade to
the most recent Outlook Edition version, go to Setup ➤ Desktop Integration ➤ Outlook Edition.

If your administrator has renamed any Salesforce standard tab names, the tab names you see in Outlook are different
than those mentioned in these help topics. Also, your administrator may have customized Outlook Edition to disallow
certain operations such as synchronizing contacts or uploading attachments. If your administrator has prohibited a
particular operation, all related commands are disabled in your user interface.

Outlook Edition version 3.2 and later supports person accounts if they have been implemented in your organization.
For more information, see "Working with Person Accounts in Outlook Edition" in the Salesforce online help.

Salesforce Connect for Lotus Notes
Available in: Personal, Group, Professional, Enterprise, and Unlimited Editions

Salesforce Connect for Lotus Notes, also known as Lotus Notes Edition, is a free add-in for IBM® Lotus Notes® that integrates
Salesforce with Lotus Notes. If you use both Lotus Notes and Salesforce, Lotus Notes Edition increases your productivity by
embedding useful commands in Lotus Notes windows and keeping your data consistent and up-to-date. Summer '07 includes
Lotus Notes Edition version 3.2.
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Implementation Tips

• For information on how IT departments can centrally roll out Lotus Notes Edition to an existing user base, see "Deploying
Lotus Notes Edition System-Wide" in the Salesforce online help.

• Lotus Notes Edition can be customized according to your organization's security and business needs. As an administrator,
you can control which commands display in Lotus Edition menus, whether users can modify field mappings, and so on.
For more information, see the Administering Lotus Notes Edition tip sheet.

• Distribute the Using Lotus Notes Edition tip sheet to all users who will have Lotus Notes Edition.This document provides
concise procedural instructions for working successfully with the add-in.

• In Enterprise and Unlimited Editions, administrators can set which profiles have access to Lotus Notes Edition and which
profiles are automatically reminded to upgrade to the latest available version.This setting is a drop-down list in the Desktop
Integration Clients section at the bottom of the profile edit page. Ensure that the option for Lotus Notes Edition is not
set to Off (access denied) if that profile has users who require Lotus Notes Edition. For more information, see "Setting
User Permissions for Desktop Clients" in the Salesforce online help and the Administering Salesforce Desktop Clients
tip sheet.

• If your organization has IT considerations such as a terminal server environment or a single sign-on implementation, please
contact salesforce.com for assistance.

• To view solutions for common installation issues, search for the keyword "lotus" in the Help & Training window.

Best Practices

• Consider disabling context-sensitive menu commands to improve system performance. This reduces the number of
round-trips to the server. See "Setting Lotus Notes Edition Options" in the Salesforce online help.

About Lotus Notes Edition

New Enhancements

In Summer '07, Lotus Edition 3.2 offers exciting new enhancements over the previous generally available version (version
3.0):

Synchronizing person accounts
Lotus Notes Edition can synchronize person accounts between your Accounts tab in Salesforce and your
Lotus Notes address book. Also, you can associate Lotus Notes emails, calendar events, and tasks with
person accounts.

Marking items for sync automatically
You can automatically mark Lotus Notes items for synchronization without needing to manually select
Mark for Sync from the Actions menu. When this option is enabled in the Salesforce Options dialog,
from that point forward the new items you create are automatically marked for synchronization, as well
as the existing items you update.

Logging in to Salesforce on startup
In the Salesforce Options dialog, you can allow Lotus Notes Edition to automatically log you in to
Salesforce when you start Lotus Notes. This can increase the speed of your first Lotus Notes Edition
operation during that Lotus Notes session.

Support for more software environments
Lotus Notes Edition now supports the Microsoft Windows Vista operating system and the IBM Lotus
Notes 7.0 program.
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Installing Lotus Notes Edition

To download and install Lotus Notes Edition:

1. Back up your Lotus Notes databases. Contact your IT department for its preferred backup procedures.
2. Back up your Salesforce data. We recommend you run reports of your contacts and activities and then export them to

Excel. Alternatively, users with Enterprise or Unlimited Editions can ask their Salesforce administrator to back up their
organization’s data using weekly export; see "Exporting Backup Data" in the Salesforce online help.

3. Within Salesforce, click Setup ➤ Desktop Integration ➤ Lotus Notes Edition.

In Enterprise and Unlimited Editions, your administrator may have prohibited access to the download page. For more
information, see "Setting User Permissions for Desktop Clients" in the Salesforce online help.

4. Click Install Now.

The Lotus Notes Edition download page also includes a link to download a .msi file so administrators can centrally deploy
Lotus Notes Edition to their organizations. See "Deploying Lotus Notes Edition System-Wide" in the Salesforce online
help for more information.

5. Run the installer, following the prompts on each screen.
6. Start Lotus Notes. A wizard introduces you to features and options. To change your Lotus Notes Edition options later,

see "Setting Lotus Notes Edition Options" in the Salesforce online help.

Note:  Lotus Notes Edition requires Salesforce to install components that edit the registry on your computer. If your
organization imposes security that prevents you from editing the registry, log in as the administrator of your computer
before installing these components or contact your IT department for assistance.

Lotus Notes Edition System Requirements

The system requirements for Lotus Notes Edition are:

• Microsoft® Windows® 2000, Windows XP Professional, or Windows Vista™

• IBM® Lotus Notes® 6.0, 6.5, or 7.0

Caution:  If your organization uses a custom Lotus Notes design template (.ntf ) with modified fields, Lotus Notes
Edition may not function as expected.

Note:  Lotus Notes Edition is available in all supported languages offered by Salesforce.. However, your Lotus Notes
Edition language is determined by your Windows display language setting rather than your Salesforce language.

To display non-English characters in Lotus Notes Edition, you must install the Windows language service packs for
the characters you want to display.

Using Lotus Notes Edition

Lotus Notes Edition is easy to use—most actions take only a few clicks to perform. Lotus Notes Edition commands are
conveniently located in right-click shortcut menus and the Actions menu.

Working with Lotus Notes Emails

• "Adding Contacts and Leads as Lotus Notes Email Recipients" in the Salesforce online help
• "Adding Outbound Lotus Notes Emails to Salesforce" in the Salesforce online help
• "Adding Sent or Received Lotus Notes Emails to Salesforce" in the Salesforce online help
• "Creating Cases from Lotus Notes Emails" in the Salesforce online help
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Working with Lotus Notes Contacts, Calendar Events, and Tasks

• "Associating Lotus Notes Events and Tasks with Salesforce Records" in the Salesforce online help
• "Associating Lotus Notes Contacts with Salesforce Records" in the Salesforce online help
• "Synchronizing Your Contacts and Activities with Lotus Notes Edition" in the Salesforce online help
• "Opening Salesforce Records from Lotus Notes" in the Salesforce online help

Working with Person Accounts

• "Working with Person Accounts in Lotus Notes Edition" in the Salesforce online help

Note: The version of Lotus Notes Edition that you have installed may not include all of these features. To upgrade
to the most recent Lotus Notes Edition version, go to Setup ➤ Desktop Integration ➤ Lotus Notes Edition.

If your administrator has renamed any Salesforce standard tab names, the tab names you see in Lotus Notes are different
than those mentioned in these help topics. Also, your administrator may have customized Lotus Notes Edition to
disallow certain operations such as synchronizing contacts or uploading attachments. If your administrator has prohibited
a particular operation, all related commands are disabled in your user interface.

Lotus Notes Edition version 3.2 and later supports person accounts if they have been implemented in your organization.
For more information, see "Working with Person Accounts in Lotus Notes Edition" in the Salesforce online help.

Recycle Bin for Deleted Custom Fields
Available in: Group, Professional, Enterprise, Unlimited, and Developer Editions

Now with Summer '07 Salesforce stores your deleted custom fields and their data in a special list so that you can restore them
if necessary. Restoring a deleted custom field restores both the field and its values to the appropriate custom or standard object.

Implementation Tips

• Deleting a custom object permanently deletes all of the custom fields on it. They cannot be restored.
• Deleted custom fields are hidden from page layouts. Restoring the field makes it automatically reappear on the appropriate

page layouts. However, if you edit the page layout after deleting the custom field yet before restoring it, the field is
permanently removed from the page layout. You must add the field to the appropriate page layouts again.

Best Practices

• Avoid permanently erasing custom fields until you are certain you no longer need the data.
• If you have deleted custom fields because they were not tracking business data, permanently erase them. For example, if

you have created custom fields while developing a custom app that you did not end up using, permanently erase those
fields.

• If you deleted custom fields because you exported the data to track elsewhere, permanently erase the field to make space
available.

• Do not remove the "_del" characters at the end of a custom field developer name after you have restored it.These characters
indicate that the field was deleted and has been restored and must remain unique in your organization.
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About the Recycle Bin for Deleted Custom Fields

Managing Deleted Custom Fields

User Permissions Needed

"Customize Application"To restore deleted custom fields and relationships:

"Customize Application"To permanently delete custom fields or relationships:

Salesforce stores deleted custom fields and their data until your organization permanently deletes them. Until that time, you
can restore the field and its data. However, the field still counts against the maximum number of custom fields allowed in your
organization. To view a list of the maximum number of custom fields and relationships allowed in your organization, see "App
Setup Limits" in the Salesforce online help.

To view a list of your deleted custom fields and relationships:

1. For standard objects, click Setup ➤ Customize, select the appropriate activity, object, or users link from the Customize
menu, and then click Fields.

2. For custom objects, click Setup ➤ Build ➤ Custom Objects, and select one of the custom objects in the list.

3. Click Deleted Fields at the bottom of the list of custom fields and relationships. The number in parentheses indicates the
total number of deleted custom fields for this object. This link only displays when you have a deleted custom field.

4. Use the list of deleted fields to perform the following actions:

• To view details about a field, click the field label.
• To permanently remove the custom field and its data, click Erase.
• To restore the field and its data, click Undelete. Some attributes of deleted fields are not restored automatically. To

restore these attributes manually:

a. Add the field to any page layouts that changed during the time the custom field was deleted. If reports and page
layouts were not edited, the restored field remains on them.

b. Make the field unique if necessary. Salesforce automatically removes the unique attribute from any deleted custom
field.

c. Make the field required if necessary. Salesforce automatically removes the required attribute for any deleted custom
field.

d. Add the custom field to any appropriate AppExchange packages. Salesforce automatically removes deleted custom
fields from packages that contain them.

e. Convert any lookup relationships to master-detail relationships if necessary. Salesforce converts all relationships to
lookup relationships when they are deleted.To convert a lookup relationship to a master-detail relationship, populate
all the applicable records with the appropriate data.

f. Redefine any field dependencies that Salesforce removed when the field was deleted.
g. Edit and save any formula fields, prompting a syntax check that you may have to resolve.
h. Set up field history tracking if necessary. If the list of fields enabled for history tracking has been modified during

the time the custom field was deleted, the restored field is no longer set up to track field history.
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Notes on Restored Custom Fields

• Salesforce appends the following characters to the end of a custom field's developer name when it is deleted unless a deleted
field already has that developer name: "_del." These characters remain when you restore the custom field.

• Formula fields are restored in a disabled state, which means they do not contain updated data until you edit and save them.
While a formula field is disabled, "#Error!" displays in place of the formula value.

• Restored fields do not display in search results immediately after you restore them. It may take a short time before the
restored custom field and its data is available in search results.

• Lead fields that are mapped to account, contact, or opportunity fields for lead conversion are still mapped accordingly
when restored.

• Auto number fields continue to increment after they are deleted and contain the correct values when restored.
• Field history data for the deleted custom field is restored.

Apex Mobile Enhancements for BlackBerry
Available in: Unlimited and Developer Editions

Available for an additional cost in: Professional and Enterprise Editions

Summer '07 offers several exciting new features and enhancements for BlackBerry smartphone users, including the new home
page, a recent items view for each object, an improved search interface, and the ability to run reports on a mobile device.

For detailed information about using the mobile application, read the Apex Mobile User Guide for BlackBerry.

Implementation Tips

In order to use the new features in Apex Mobile, mobile users must upgrade the client application installed on their BlackBerry
smartphone.

• Mobile administrators can notify all wireless users about the availability of a new version from the Mobile Administration
Console. Log in to the console and click Users in the navigation pane. Select the Select All checkbox, and then click
Communications ➤ Upgrade Application. The console sends an email to the users that contains a link for downloading
the new version of the application.

• Users can upgrade the application without any assistance from their mobile administrator. Open the Web browser on your
device and navigate to http://mobile.salesforce.com/setup to display the Web page for the Apex Mobile installer. Click
the Click here to download the installer link and follow the instructions to download the latest version of Apex Mobile
to your device.

About Apex Mobile Enhancements for BlackBerry

Home Page

A Home tab is now available in Apex Mobile for BlackBerry smartphones. By default, the application opens to the home
page, which contains a list of recently viewed items. The Views drop-down list on the home page lets you change the view
from Recent Items to Search Results, which shows you the results of the last search you performed from the home page. The
Search box on the home page lets you search for information across all objects, and the search results for each object display
in collapsed sections on the home page.
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Recent Items View

The behavior of the mobile application more closely mimics the behavior of the Salesforce user interface.The Views drop-down
list on each object's tab contains a Recent Items option, so users can quickly access the ten most recently viewed or added
records of that type.

Search Improvements

With Summer ’07, the search user interface has been completely redesigned, making searching for customer information easier
and faster than ever before. With the new release, the search box appears on all tabs, putting the information at users' fingertips.
To make it easier to find what users need from among a long list of search results, the results are grouped by object and include
additional relevant information, such as phone number, email address, and location.

Search Overview

Apex Mobile offers two main ways to search for information: the Search box located below the tabs and Advanced Search,
which is accessible via a menu option. The Search box is a tool that lets you quickly search for records of a specific object type
or across all objects. Advanced Search allows you to restrict your search based on data in a single field or constrain the search
to the related items of a specific record.

When you search for information in Apex Mobile, the application looks for records stored locally on the device and for records
online in Salesforce. The main differences between the two searches are outlined below:

Online SearchLocal Search

Triggered from the Search box and Advanced Search.Triggered from the Search box.

Searches all objects with tabs that have been mobilized and
marked as searchable. Does not search products or solutions.

Searches all objects with tabs that have been mobilized and
marked as searchable.

Searches the same fields as the Sidebar Search on the
Salesforce website. See "Search Fields" in the Salesforce online
help for a complete list of the fields.

Searches name fields, email fields, and phone fields, excluding
fields that were not mobilized by the Salesforce administrator.

A wildcard is automatically added to the end of your search
string.

A wildcard is automatically added to the beginning and end
of your search string.

Note: Without a wireless connection, Apex Mobile cannot perform an online search.

Search Box

Searching for information from the Search box returns both local and online search results.

• Type keywords in the Search box at the top of the page.

• To search across all objects, use the Search box on the Home tab.
• To find only the records of a particular object, use the Search box on the relevant tab. For example, search for leads

from the Leads tab.

• Click the Search icon or press ENTER. The Search icon switches to a Cancel icon, and the progress indicator below the
Search box lets you know that the search is still running. Click the Cancel icon to stop the search.
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• If you perform the search on the Home tab, the search results for each object display in collapsible sections. Click the
section headers to open and close the containers. From any tab other than home, the search results display in a list. You
do not have to wait for the search to stop running before drilling down into the search results.

• To obtain more information about an item in the search results, highlight the record to populate the detail pane at the
bottom of the page. The detail pane layout is different for each object. With a record highlighted in the search results, you
can use the Send Email and Place a Call menu options if the record contains phone and email fields.

• To open an item in the search results, highlight the record and select Open from the menu. If the record is online instead
of local, it is automatically downloaded to your device when you open it. Records you retrieve through a search are flagged
on the mobile server and become a permanent part of your mobile dataset.

• You can access the last set of search results on a tab by selecting Search Results from the Views drop-down list.

Advanced Search

The Advanced Search option in the main menu lets you search online for records and restrict your search based on data in a
single field or constrain the search to the related items of a specific record.

1. From a tab, a record, or a related list, open the menu and select Advanced Search.
2. Enter your search string in the Keyword field.
3. The value in the In drop-down list defaults to the tab from which you initiated the search. You can select a different object.

Note:  If you initiate the advanced search from a record, the name of the record appears next to the Related To
checkbox. To constrain your search to the related items of the record, select the checkbox.

4. In the Where drop-down list, choose the field you will use as search criteria for the selected object.

If you select a picklist field, the Value drop-down list appears below the Condition field so you can select the value.

5. In the Condition drop-down list, choose the operator that will be applied to your search string.
6. In the Owner drop-down list, select Any to locate records owned by any user, select your name to search within items you

own, or select the name of another user.
7. Click Search.

• The search results display in a list. The detail pane at the bottom of the page provides information about the items in
the list; use the main menu to place a call or send an email if the highlighted record contains phone and email fields.

• To open an item in the search results, highlight the record and select Open from the menu. The record is automatically
downloaded to your device when you open it. Records you retrieve through a search are flagged on the mobile server
and become part of your mobile dataset.To remove these retrieved records from your device, open the System Information
page, select Forget Search Results from the menu, and then click Yes.

Search Detail Pane

Highlighting an item in the Search Results view populates the detail pane at the bottom of the page with limited information,
and different fields display for each object. The layout of each object's detail pane is described below:

Fields Included in Detail PaneObject

Billing City, Billing State, WebsiteAccount

Owner, StatusCase

Created ByCase Comment

Mailing City, Mailing State, EmailContact

Email, WebsiteCustom Object
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Fields Included in Detail PaneObject

DescriptionEvent

Mailing City, Mailing State, EmailLead

Owner, StageOpportunity

DescriptionPrice Book

Status, DescriptionSolution

DescriptionTask

Note: You cannot customize the detail pane layout.

Mobile Reports

Get the insight you need when you are in the field without having to turn on your laptop with the availability of reports in
Apex Mobile. Users can run any custom report in Salesforce from their smartphone, making it easier for them to get the data
they need to share. Plus, up to five reports can be stored locally on your device, for quicker access and availability when offline.

Implementation Tips

• In order to mobilize reports, an administrator or a user with the "Manage Public Reports" permission must create a Mobile
Reports folder in Salesforce and add reports to the folder. The reports folder cannot be created from a mobile device.

• From the Reports tab in Salesforce, click Create New Folder. Name the folder Mobile Reports. The server does not
load reports on the mobile device unless the folder is named Mobile Reports. Be sure to check for any typos in the
name before saving the folder.

• Choose a Public Folder Access option.
• Optionally, select any unfiled reports and click Add to store them in the Mobile Reports folder.
• Choose a folder visibility option. Do not mark the folder private.
• Click Save.
• To add a report to the Mobile Reports folder, click the report name on the Reports tab, and then click Save As. Save

the report in the Mobile Reports folder. After saving the report, you can edit the report options.

• Salesforce does not require folder names to be unique. Mobile users can see any report stored in folders named Mobile
Reports unless you restrict access with the folder visibility option.

• If you mobilize any reports by adding them to the public Mobile Reports folder, all users will have access to the reports,
even if they do not have access to the Reports tab in Salesforce. Users without permission to run reports will be able to see
the reports in the list view, but they will not be able to run them.

• Users can search for and run custom reports that are not stored in the Mobile Reports folder. However, Apex Mobile
cannot retrieve standard reports.

Best Practices

• To enhance the experience of viewing reports on a wireless device, create mobile versions of important or useful reports in
Salesforce that have fewer columns and additional filtering criteria.
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Reports Overview

If you create a public mobile reports folder in Salesforce, all reports you add to the folder are automatically available from your
wireless device. You can also download and run any reports in Salesforce stored in other public custom folders. While you can
run reports on your device, you cannot edit, delete, or create them.

Unlike Salesforce, Apex Mobile stores the data for the five most recently run reports. You can choose to view these cached
reports or refresh them. The benefit of storing reports on the mobile device is that you can access some data even when you
are not in wireless coverage.

Reports Home

Highlight the Reports tab and select Open from the menu to display the reports home page.

• The reports list view displays the names of your reports in alphabetical order. The reports mobilized on your device are
pulled from the Mobile Reports folder in Salesforce.

• The icon next to the report name indicates the availability of the report data. A description of each icon is below:

DescriptionReport Icon

No cached version of the report is stored on the device.

The report is running.

The report contains data and is available for viewing.

• Just like in any list view, you can filter the report list by typing a text string.
• The detail pane at the bottom of the reports home page displays information about the highlighted report. You can see

the name of the folder where each report is stored in Salesforce. For cached reports, the detail pane also displays the date
and time the report was run.

• You can download custom reports from Salesforce that are not on your device. Type part of the report name in the search
box on the reports home page and click the Search icon. Any custom reports matching the search string will be delivered
to your device. To remove a report from your reports list, click the report and select Remove From Device from the menu.

Note: The Search Results view is not available on the reports home page.

Running Reports

User Permissions Needed

"Run Reports"To run reports:

To run a report on your mobile device:

1. Open the reports home page.
2. Click a report name, and then select Run Report from the menu.

If the Run Report option is replaced by the Refresh Report option, a copy of the report is already cached on the device.
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You must be in wireless coverage to run or refresh a mobile report. If no network connection is available, the report is
queued and will run when a connection is established.

3. The device requests the report from the server. The report icon is flagged with a clock while the report is running. The
mobile server retrieves the report data, and a notification window appears when it arrives on the device.

Notes on Running Reports

• Running large reports - If your report is more than 128 kb, the server will not deliver the report to your device, and you
will receive a warning message.

• Visible records - The information you see in reports is only the data to which you have access. This includes records you
own, records to which you have read or read/write access, records that have been shared with you, records owned by or
shared with users in roles below you in the hierarchy, and records for which you have "Read" permissions.

• Visible fields - You can view only those fields that are visible in your page layout and field-level security settings.

Viewing Reports

To open a report on your mobile device, click Yes in the message window when you are notified that the report is available.
If you choose to view the report later, you can highlight the report name in the list view and select View Report from the
menu.

• The mobile report viewer displays the report in a basic table. The report header shows the report name and the date it was
received from the server. The viewer does not support sorting, summaries, subtotals, or grouping.

• With trackball navigation, you can use the trackball to scroll through the report horizontally and vertically. With the
trackwheel, scrolling moves the focus from left to right; hold down ALT as you scroll with the trackwheel to move the
focus down one row at a time. The ALT key will only scroll vertically after you move the focus out of the header row.

• The header row of the report is frozen so you can always see the column labels. The row above the header displays the full
text of the selected cell, which is helpful when the cell's content has been truncated. You can also highlight a cell and select
Show Cell from the menu to display the content in a pop-up window.

Refreshing Reports

Apex Mobile stores the last five reports you ran on the mobile device. Cached reports are flagged with a full-color report icon;
reports with no cached data have grayscale icons. You can view a cached report or request an updated version. To refresh a
report:

• From the reports home page, highlight a cached report and select Refresh Report from the menu. The device requests
the report from the server. The server retrieves the updated report data, and a notification window appears when it arrives
on the device.

• From a report, select Refresh Report from the menu. The device requests an update from the server, closes the report,
and displays the reports home page.

Supported Devices

Apex Mobile is now supported on the following BlackBerry smartphone:

• BlackBerry 8300

Apex Mobile Enhancements for Windows Mobile
Available in: Unlimited and Developer Editions
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Available for an additional cost in: Professional and Enterprise Editions

Summer '07 offers several exciting new features and enhancements for Windows Mobile users, including support for products
and price books, the ability to change record ownership, the ability to send email to multiple recipients, support for
administrator-generated custom views, a recent items view per object, search improvements, and the mobile reports feature.

For more detailed information about using the mobile application, read the Apex Mobile User Guide for Windows Mobile.

Implementation Tips

In order to use the new features in Apex Mobile, mobile users must upgrade the client application installed on their Windows
Mobile device.

• Mobile administrators can notify all wireless users about the availability of a new version from the Mobile Administration
Console. Log in to the console and click Users in the navigation pane. Select the Select All checkbox, and then click
Communications ➤ Upgrade Application. The console sends an email to the users that contains a link for downloading
the new version of the application.

• Users can upgrade the application without any assistance from their mobile administrator. Open Internet Explorer on your
device and navigate to http://mobile.salesforce.com/setup to display the Web page for the Apex Mobile installer. Tap the
Click here to download the installer link and follow the instructions to download the latest version of Apex
Mobile to your device.

About Apex Mobile Enhancements for Windows Mobile

Products and Price Books

Windows Mobile now supports products and price books. From your device, you can add products to your opportunities and
change the price book for a product.

Adding Products to Opportunities

To add a new product to an opportunity:

1. Highlight an opportunity in the list view, or open the detail page.
2. Tap Actions ➤ Related Items ➤ Opportunity Product.

Apex Mobile displays a list of opportunity products. If no products have been associated with the opportunity, the list page
is empty.

3. Tap Actions ➤ New.
4. Select the price book for the opportunity and tap OK.

Apex Mobile displays the Product Information page.

5. Enter the information for the new opportunity product record:

• Opportunity: Defaults to the current opportunity, but you can change it to a different opportunity record.
• Product: Choose a product from the selected price book.
• Sales Price and Quantity: Enter these values, and the value for the Total Price field will be calculated

automatically when the record is submitted to Salesforce.
• Date: Defaults to the current date.
• Line Description: Enter optional notes about the product.
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6. Tap Save.

The product is added to the opportunity.

Changing the Price Book for a Product

Changing the price book for an opportunity will delete existing opportunity product records from the opportunity.

1. Open an opportunity’s detail page.
2. Tap ActionsChange Price Book.
3. Tap Yes in the confirmation window to acknowledge that you want to delete existing products from the opportunity.

Apex Mobile displays the Select a Price Book window.

4. Select the new price book and tap OK. Apex Mobile associates the price book with the opportunity.

Changing the Record Owner

Windows Mobile users can now change ownership of a record using the mobile device.

1. Open the detail page of a record.
2. Tap Actions ➤ Change Owner.
3. In the Select a User pop-up window, tap the name of the user to whom you want to transfer record ownership.

You might only see your own name in the Select a User window. There are two ways to populate the window with other
users’ names:

• Download data records—such as accounts or contacts—that belong to other users.
• Perform an online search for specific users.

4. Tap OK.

Sending Email to Multiple Recipients

When composing a message in the application, Windows Mobile users now have the ability to add multiple recipients to the
email. Type additional email addresses in the To field separated by a semicolon, or tap the Lookup icon to the left of the field
to open a popup window so you can select contacts or leads from a list.

Views

A new standard view is available for mobilized objects. Additionally, Windows Mobile can now support custom views on a
limited basis.

• Recent items view per object: The behavior of the mobile application more closely mimics the behavior of the Salesforce
user interface. The Views drop-down list on each object's tab contains a Recent Items option, so users can quickly access
the ten most recently viewed or added records of that object type.

• Administrator-created custom views: Windows Mobile users can now access custom views created by their administrator
in the mobile administration console. However, you still cannot create, edit, or delete custom views from a Windows
Mobile device.

Search Improvements

With Summer ’07, the search user interface has been completely redesigned, making searching for customer information easier
and faster than ever before. With the new release, the search box appears on all tabs, putting information at users' fingertips.
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To make it easier to find what users need from among a long list of search results, the results are grouped by object and include
additional relevant information, such as phone number, email address, and location.

Search Overview

Apex Mobile offers two main ways to search for information: the Search box located below the tabs and Advanced Search,
which is accessible via a menu option. The Search box is a tool that lets you quickly search for records of a specific object type
or across all objects. Advanced Search allows you to restrict your search based on data in a single field or constrain the search
to the related items of a specific record.

When you search for information in Apex Mobile, the application looks for records stored locally on the device and for records
online in Salesforce. The main differences between the two searches are outlined below:

Online SearchLocal Search

Triggered from the Search box and Advanced Search.Triggered from the Search box.

Searches all objects with tabs that have been mobilized and
marked as searchable. Does not search products or solutions.

Searches all objects with tabs that have been mobilized and
marked as searchable.

Searches the same fields as the Sidebar Search on the
Salesforce website. See "Search Fields" in the Salesforce online
help for a complete list of the fields.

Searches name fields, email fields, and phone fields, excluding
fields that were not mobilized by the Salesforce administrator.

A wildcard is automatically added to the end of your search
string.

A wildcard is automatically added to the beginning and end
of your search string.

Note: Without a wireless connection, Apex Mobile cannot perform an online search.

Search Box

Searching for information from the Search box returns both local and online search results.

• Type keywords in the Search box at the top of the page.

• To search across all objects, use the Search box on the Home tab.
• To find only the records of a particular object, use the Search box on the relevant tab. For example, search for leads

from the Leads tab.

• Tap the Search icon or press ENTER. The Search icon switches to a Cancel icon, which lets you know that the search
is still running. Tap the Cancel icon to stop the search.

• If you perform the search on the Home tab, the search results for each object display in collapsed sections. Tap the section
headers to open and close the containers. From any other tab, the search results display in a list. You do not have to wait
for the search to stop running before drilling down into the results.

• To obtain more information about an item in the search results, highlight the record to populate the detail pane at the
bottom of the page. The detail pane layout is different for each object.

• To open an item in the search results, double-tap the record. If the record is online instead of local, it is automatically
downloaded to your device when you open it. Records you retrieve through an online search are flagged on the mobile
server and become a permanent part of your mobile dataset.

• You can access the last set of search results on a tab by selecting Search Results from the Views drop-down list.
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Advanced Search

The Advanced Search option in the Actions menu lets you search online for records and restrict your search based on data in
a single field or constrain the search to the related items of a specific record.

1. From a tab, a record, or a related list, tap Actions ➤ Advanced Search to open the Advanced Search pop-up window.

Note:  If you start an advanced search from a record or a related list, your search results are constrained to the
related items of the record.

2. Enter your search string in the Keyword field.
3. The value in the In drop-down list defaults to the tab from which you initiated the search. You can select a different object.
4. In the Where drop-down list, choose the field you will use as search criteria for the selected object.

If you select a picklist field, another drop-down list appears below the Condition field so you can select the value.

5. In the Condition drop-down list, choose the operator that will be applied to your search string.
6. In the Owner drop-down list, select Any to locate records owned by any user or select a specific user.
7. Tap Submit search.

• The search results display in a list. To obtain more information about an item in the search results, highlight the record
to populate the detail pane at the bottom of the page.

• To open an item in the search results, double-tap the record or tap Actions ➤ Open. If the record is online, it is
automatically downloaded to your device when you open it. Records you retrieve through an online search are flagged
on the mobile server and become part of your mobile dataset. To remove these retrieved records from your device, open
the System Information page, tap Actions ➤ Forget Search Results, and then tap Yes.

Search Detail Pane

Highlighting an item in the Search Results view populates the detail pane at the bottom of the page with limited information,
and different fields display for each object. The layout of each object's detail pane is described below:

Fields Included in Detail PaneObject

Billing City, Billing State, WebsiteAccount

Owner, StatusCase

Created ByCase Comment

Mailing City, Mailing State, EmailContact

Email, WebsiteCustom Object

DescriptionEvent

Mailing City, Mailing State, EmailLead

Owner, StageOpportunity

DescriptionPrice Book

Status, DescriptionSolution

DescriptionTask
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Note: You cannot customize the detail pane layout.

Mobile Reports

Get the insight you need when you are in the field without having to turn on your laptop with the availability of reports in
Apex Mobile. Users can run any custom report in Salesforce from their smartphone, making it easier for them to get to the
data they need to share. Plus, up to five reports can be stored locally on your device, for quicker access and availability when
offline.

Implementation Tips

• In order to mobilize reports, an administrator or a user with the "Manage Public Reports" permission must create a Mobile
Reports folder in Salesforce and add reports to the folder. The reports folder cannot be created from a mobile device.

• From the Reports tab in Salesforce, click Create New Folder. Name the folder Mobile Reports. The server will not
load reports on the mobile device unless the folder is named Mobile Reports. Be sure to check for any typos in the
name before saving the folder.

• Choose a Public Folder Access option.
• Optionally, select any unfiled reports and click Add to store them in the Mobile Reports folder.
• Choose a folder visibility option. Do not mark the folder private.
• Click Save.
• To add a report to the Mobile Reports folder, click the report name on the reports home page, and then click Save As.

Save the report in the Mobile Reports folder. After saving the report, you can edit the report options.

• Salesforce does not require folder names to be unique. Mobile users can see any report stored in folders named Mobile
Reports unless you restrict access with the folder visibility option.

• If you mobilize any reports by adding them to the public Mobile Reports folder, all users will have access to the reports,
even if they don't have access to the Reports tab in Salesforce. Users without permission to run reports will be able to see
the reports in the list view, but they will not be able to run them.

• Users can search for and run custom reports that are not stored in the Mobile Reports folder. However, Apex Mobile
cannot retrieve standard reports.

Best Practices

• To enhance the experience of viewing reports on a wireless device, you might want to create mobile versions of important
or useful reports in Salesforce that have fewer columns and additional filtering criteria.

Reports Overview

If you create a public mobile reports folder in Salesforce, all reports you add to the folder are automatically available from your
wireless device. You can also download and run any reports in Salesforce stored in other public custom folders. While you can
run reports on your device, you cannot edit, delete, or create them.

Unlike Salesforce, Apex Mobile stores the data for the five most recently run reports. You can choose to view these cached
reports or refresh them. The benefit of storing reports on the mobile device is that you can access some data even when you
are not in wireless coverage.

Reports Home

Tap the Reports tab to display the reports home page.
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• The reports list view displays the names of your reports in alphabetical order. The reports mobilized on your device are
pulled from the Mobile Reports folder in Salesforce.

• The icon next to the report name indicates the availability of the report data. A description of each icon is below:

DescriptionReport Icon

No cached version of the report is stored on the device.

The report is running.

The report contains data and is available for viewing.

• The detail pane at the bottom of the reports home page displays information about the highlighted report. You can see
the name of the folder where each report is stored in Salesforce. For cached reports, the detail pane also displays the date
and time the report was run.

• You can download custom reports from Salesforce that are not on your device. Type part of the report name in the search
box on the reports home page and tap the Search button. Any custom reports matching the search string will be delivered
to your device. To remove a report from your reports list, select the report and tap Actions ➤ Remove from Device.

Note: The Search Results view is not available on the reports home page.

Running Reports

User Permissions Needed

"Run Reports"To run reports:

To run a report on your mobile device:

1. Open the reports home page.
2. Tap a report name, and then tap Actions ➤ Run Report.

If the Run Report option is replaced by the Refresh Report option, a copy of the report is already cached on the device.

You must be in wireless coverage to run or refresh a mobile report. If no network connection is available, the report is
queued and will run when a connection is established.

3. The device requests the report from Salesforce. The report icon is flagged with a clock while the report is running. The
mobile server retrieves the report data, and a notification window appears when it arrives on the device.

Notes on Running Reports

• Running large reports - If your report is more than 128 kb, the server will not deliver the report to your device, and you
will receive a warning message.

• Visible records - The information you see in reports is only the data to which you have access. This includes records you
own, records to which you have read or read/write access, records that have been shared with you, records owned by or
shared with users in roles below you in the hierarchy, and records for which you have "Read" permissions.

• Visible fields - You can view only those fields that are visible in your page layout and field-level security settings.
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Viewing Reports

To open a report on your mobile device, tap Yes in the message window when you are notified that the report is available. If
you choose to view the report later, you can highlight the report name in the list view and tap Actions ➤ View Report.

• The mobile report viewer displays the report in a basic table. The report header shows the report name and the date it was
received from the server. The viewer does not support sorting, summaries, subtotals, or grouping.

• Use the horizontal and vertical scrollbars or the arrows on the keyboard to scroll through the report.
• The header row of the report is frozen so you can always see the column labels. The row above the header displays the full

text of the selected cell, which is helpful when the cell's content has been truncated.
• In the report viewer, tap Actions ➤ Refresh Report to request updated report data.

Refreshing Reports

To open a report on your mobile device, tap Yes in the message window when you are notified that the report is available. If
you choose to view the report later, you can highlight the report name in the list view and tap Actions ➤ View Report.

• The mobile report viewer displays the report in a basic table. The report header shows the report name and the date it was
received from the server. The viewer does not support sorting, summaries, subtotals, or grouping.

• Use the horizontal and vertical scrollbars or the arrows on the keyboard to scroll through the report.
• The header row of the report is frozen so you can always see the column labels. The row above the header displays the full

text of the selected cell, which is helpful when the cell's content has been truncated.
• In the report viewer, tap Actions ➤ Refresh Report to request updated report data.

Apex Web Services API 10.0
Available in: Enterprise, Unlimited, and Developer Editions

The Apex Web Services API and related toolkits have been improved for Summer '07:

• The AJAX Toolkit and Web services API have been updated to 10.0.
• You can create reports about API usage using the new standard report, "API Usage Last 7 Days", available in the

Administrative Reports folder on the Reports tab.
• In the CallOptions header, you can supply a value representing the namespace prefix which is assigned to all custom objects

and custom fields in some packages. This allows you to write client applications that do not refer to the namespace prefix,
improving code readability and reuse.

• You can use two additional clauses in SOSL:

• The optional WHERE clause allows you to filter search results for a given object based on individual field values.
• The optional WITH clause allows you to efficiently filter all search results based on division for organizations with

Territory Management.

• The Salesforce SOA feature allows you to call remote SOAP web services from Apex Code scripts.
• An AJAX proxy allows you to send requests to third party servers via Salesforce from an s-control. This is helpful because

Web browsers do not allow JavaScript code inside an s-control to connect to external servers directly.
• For greater security, Salesforce limits the outbound ports you can specify in Setup ➤ Security Controls ➤ Remote Site

Settings to the following:

• 80: This port only accepts HTTP connections.
• 443: This port only accepts HTTPS connections.
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• 7000-10000 (inclusive): These ports accept HTTP or HTTPS connections.

• You can use external ID fields as a foreign key, allowing you to create, update, or upsert records in a single step instead of
querying a record to get the ID first.

Metadata API—Developer Preview

Asynchronous versions of the create, delete, and update calls are available to manipulate objects representing custom objects
and custom fields, thus allowing programmatic creation of custom objects and custom fields.

Note:  Metadata calls and objects are only available with Developer Edition. The calls and objects described in this
topic are a developer preview release for version 10.0. This means changes are expected, and no client application
should be written for use with production data. A migration path may not be supplied to the General Availability
(GA) release.

For complete details about Apex Web Services API 10.0 enhancements, visit the detailed API 10.0 Release Notes on the
Apex Developer Network at https://wiki.apexdevnet.com/index.php/Apex_Wiki.

Additional Apex Platform Enhancements

AppExchange Packaging Enhancements

Summer '07 includes the following enhancements to AppExchange packaging:

Custom report types
You can package the new custom report types in both managed and unmanaged packages for the
AppExchange.

Export data on uninstall and import after reinstall
When you uninstall an AppExchange app, Salesforce automatically creates an export file containing the
package data as well as any associated notes and attachments. Salesforce sends an email containing a link
to the export file to the user performing the uninstall when the uninstall is complete. We recommend
storing the export file elsewhere because it is only available for a limited time after the uninstall completes.
If you choose to reinstall the app later, you can import your app data using one of the following import
tools:

• For Group Edition, use the appropriate import wizard.
• For Professional Edition, use the appropriate import wizard or any compatible AppExchange Certified

Partner integration tool on www.salesforce.com/appexchange/.
• For Enterprise, Developer, and Unlimited Edition, use the Apex Data Loader.

Importing your AppExchange app data requires some manual configuration. Use the list below to
understand what the import process includes:

• Salesforce converts date fields into date/time fields upon export. Convert the appropriate fields into
date fields before you import.

• Salesforce exports all date/time fields in Greenwich Mean Time (GMT). Before importing these
fields, convert them to the appropriate time zone.

• The value of auto number fields may be different when you import. To retain the old values, create a
new custom auto number field on a custom object before importing the data.

• Salesforce updates system fields such as Created Date and Last Modified Date when you import.
To retain the old values for these fields, contact salesforce.com support.

• Relationships are not included in the export file. Recreate any master-detail or lookup relationships
after importing your data.

• Record type IDs are exported but not the record type name.
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• Field history is not exported.
• Recreate any customizations that you made to the app after installation.

Home page layouts and components
You can package custom home page layouts and components.

Language translations
Summer '07 now allows you to create globalized packages of translated names, labels, and messages within
the translation workbench to easily deliver multilingual applications on the AppExchange. If you use the
translation workbench to translate your custom components, you can use globalized packages to package
translated terms. Installers of a multilingual application can take advantage of this without enabling the
translation workbench and with no additional cost.
Review these implementation tips for globalized packages:

• The developer of the AppExchange package must have the translation workbench enabled.
• The language the developer intends to package must be active.
• The installer of an AppExchange package with translations does not need to have the translation

workbench enabled. However, the installer needs to have the translation workbench enabled to change
translators or update translated terms.

• During installation, labels display in the language of the developer who created and packaged the app.
For example, an installer with a default language of French will see English labels during the installation
process if the developer's default language was English.

Consider these best practices when using globalized packages:

• Activate the language you intend to package and add it to your package after you have entered all the
necessary translated terms for each component in your package.

• Test your translations by uploading your managed package as a Managed - Beta package and have
a sampling of your intended installers review it.

• The properties of translated terms in a managed package depend on the properties of the translated
component. For a list of these properties, see "Properties of Managed Components" in the Salesforce
online help.

For more information about the translation workbench, see "Setting Up Translation Workbench" in the
Salesforce online help. For additional translation options, see Translation Enhancements for Multilingual
Organizations on page 82.

Workflow rules and actions
You can now include workflow rules and actions in both managed and unmanaged packages for the
AppExchange.

Note: You cannot package workflow rules that use time triggers.

AppExchange packaging is available in Group, Professional, Enterprise, Unlimited, and Developer Editions. Some features
of packaging, such as packaging language translations, may not be available depending on your organization's Edition and
configuration.
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Apex Data Loader Enhancements

Exports With Relationships
With Summer '07, you can include the values of related object fields when exporting data from Salesforce.
To do so, use a SOQL query in your export request that includes fields from a related object, called a
relationship query. For example:

Select Name, Pricebook2Id, Pricebook2.Name, Product2Id, Product2.ProductCode
FROM PricebookEntry WHERE IsActive = true

Or:

Select Id, LastName, Account.Name FROM Contact

For general instructions on using the Apex Data Loader to export data, see "Exporting Data" in the
Salesforce online help.

Runtime Logs
If you need to investigate a problem with the Apex Data Loader, or if requested by salesforce.com Customer
Support, you can access log files that track the operations and network connections made by the Apex
Data Loader. The two log files are:

• sdl.log - Contains a detailed chronological list of Apex Data Loader log entries. Log entries marked
"INFO" are procedural items, such as logging in to Salesforce. Log entries marked "ERROR" are
problems such as missing a required field in a submitted record.

• sdl_out.log - New for Summer '07, this is a supplemental log that contains information not captured
in sdl.log. For example, it includes log entries for the creation of proxy server network connections.

These files can be opened with commonly available text editor programs, such as Microsoft Notepad.

In Microsoft Windows, you can quickly open these files by entering %TEMP%\sdl.log and
%TEMP%\sdl_out.log in either the Start | Run dialog or the Windows Explorer address bar.

The Apex Data Loader is available in Enterprise, Unlimited, and Developer Editions. For more information, see "What is
the Apex Data Loader?" in the Salesforce online help.

Approval Process Enhancements

With Summer '07, approval processes include several new enhancements and capabilities:

Formula-based approval processes
You can now use formulas when defining entry criteria for approval processes and steps. Formulas can
include calculations and multi-field comparisons, letting you automate and enforce complex approval
processes. For example, you can create approval processes based on user thresholds.
To use a formula in an approval process, choose Formula evaluates to true in "Step 2: Specify
Entry Criteria " of the approval process wizard.
To use a formula in an approval step, choose Formula evaluates to true in "Step 2: Specify Step
Criteria " of the approval step wizard.

Conditional skipping of approval steps
Create dynamic approval processes by configuring some steps to be optional when a record does not meet
the step entry criteria.
To configure conditional skipping for a step, first create an approval process and all of its steps without
configuring the conditional skipping. After creating all the steps, edit each step you want the approval
process to conditionally skip as follows:

1. Go to "Step 2: Specify Step Criteria" in the approval step wizard.
2. Select the second radio button.
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3. Use a filter or a formula to specify the step criteria.
4. Select go to next step in the second drop-down list.

Note: You cannot change the go to next step option once the approval process is activated.

Submitter approval request recall
Optionally, enable submitters of approval requests to recall their requests from the approval process at
any time. If you select Allow submitters to recall approval requests, both submitters and administrators
can see the Recall Approval Request button in the Approval History related list on the detail page of
records submitted to this approval process; otherwise, only administrators can see it. Users can click Recall
Approval Request to withdraw the pending approval request for the record.
To enable this option for an approval process, select the Allow submitters to recall approval
requests checkbox in "Step 6: Specify Initial Submitters" of the approval process wizard.

Automated routing of approval requests using the record owner’s hierarchy
Create approval processes in which the approval path follows the hierarchy of the record's owner instead
of the person submitting the approval request.
To enable this option for an approval process:

1. Go to "Step 3: Specify Approver Field and Record Editability Properties " of the approval process
wizard.

2. From the Next Automated Approver Determined By picklist, select a custom user field or click
Create New Field to create a new custom hierarchy field that stores the direct manager for each user.

3. Select the Use Approver Field of Record Owner checkbox.

Important:  Make sure the assigned approver has access to read the records for the approval
requests. For example, a user who does not have read access to an Expenses custom object will
not be able to view expense approval requests.

Approval process enhancements are available in Enterprise, Unlimited, and Developer Editions.

Compliance BCC Emails

If your organization evaluates all outbound email messages for compliance, you can enable compliance BCC emails to
automatically send a hidden copy of each outbound email message to an email address you specify. Enabling compliance BCC
emails prevents users from editing the BCC field on any email and disables their Automatic Bcc setting under My Email
Settings.

To enable compliance BCC emails for your organization:

1. Click Setup ➤ Security Controls ➤ Compliance BCC Email.
2. Select the Enable checkbox.
3. Enter your compliance email address.
4. Click Save.

Note: The BCC copy is automatically sent to the address you specify for any emails your users send, excluding system
emails such as password reset or import completion notifications.

Compliance BCC emails are available in Enterprise and Unlimited Editions.

Delegated Administration Enhancements

Delegated administrators have new additional capabilities. Delegated administrators can log in as users who have granted
login access to their administrator. To use this new capability:
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• Notify users that they can grant login access to delegated administrators by selecting Setup ➤ My Personal Information
➤ Grant Login Access.

• Enable your delegated administration groups to log in as users by selecting the Enable Group for Login Access
option from the delegated administrators definition page.

• Notify delegated administrators that they can log in as users by clicking Setup ➤ Manage Users ➤ Users, selecting the
user, and clicking Login

This simplifies logging in as users from the manage users list because you can search for a user and login directly from the user
detail page when you select a user that appears in your search results.

All delegated administrators now have the ability to unlock users they administer directly from the user detail page. To unlock
a user that is locked out of Salesforce, click Unlock.

Delegated administration enhancements are available in Enterprise, Unlimited, and Developer Editions.

Formulas—Changes to $Profile Merge Fields

Previously, when you referenced a $Profile merge field in a formula, you had to use a special value for standard profiles. Those
special values are no longer necessary.

Use profile names to reference standard profiles in $Profile merge fields. If you previously referenced the special value for a
profile, use the following list to determine the name to use instead:

$Profile ValueStandard Profile Name

PT1System Administrator

PT2Standard User

PT3Ready Only

PT4Solution Manager

PT5Marketing User

PT6Contract Manager

PT7Partner User

PT8Standard Platform User

PT9Standard Platform One App User

PT13Customer Portal User

PT14Customer Portal Manager

Formula fields are available in all Salesforce Editions.

License Details Now on the Company Information Page

With Summer '07, the Company Information page displays lists of the active user licenses and feature licenses purchased for
your organization.

To view the User License or Feature License related lists, click Setup ➤ Company Profile ➤ Company Information.

This page lists the following for each type of license:

• Status indicates the status of the license.
• Total Licenses indicates the number of licenses for which your organization is billed and that are available to you.
• Used Licenses is the number of licenses that you have assigned to users.
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• Remaining Licenses is the number of unused licenses.

User Licenses
A user license entitles a user to different functionality within Salesforce and determines the profiles
available to the user. In previous releases, user licenses were called license types. Your organization may
have more than one type of user license and may also include custom user licenses. For a list of the standard
Salesforce user licenses, see "Viewing User License Types" in the Salesforce online help.

Feature Licenses
A feature license entitles a user to an additional Salesforce feature, such as Marketing or Offline. Your
organization may have more than one type of feature license available to assign to users.

The following feature licenses are available:

• Marketing User
• Offline User
• Wireless User
• Sales Anywhere User
• Apex Mobile User

You assign user and feature licenses when creating or editing a user. For more information, see "Adding New Users" in the
Salesforce online help. User and feature licenses are available in Enterprise, Unlimited, and Developer Editions.

Lookup Field Hovers

Hover details are available for records in the Recent Items list in the sidebar, and now, with Summer '07, they are also available
for lookup fields on detail pages in all Salesforce Editions. You can mouse-over a lookup field on a record detail page to display
the details of the corresponding record. You can quickly view or edit the details by clicking on the View or Edit buttons in
the hover. Like sidebar hovers, the Enable Hover Details user interface setting must be enabled.

Mass Delete Enhancements—Permanently Delete Records

In Enterprise, Unlimited, and Developer Editions, you can now choose to permanently delete records during mass deletion
by selecting Permanently delete the selected records. Please note that selecting this option prevents you from
recovering the selected records from the Recycle Bin. For information on deleting multiple records, see "Deleting Mass Data"
in the Salesforce online help.

Office Edition—Expanded System Requirements

Office Edition now supports the Microsoft® Windows Vista™ operating system and the Microsoft Office 2007 productivity
suite, in addition to the versions previously supported. For more information about Office Edition, see "What is Office
Edition?" in the Salesforce online help.

Office Edition is available with all Salesforce Editions.

Page Layouts—Enhanced Administration

Enhanced page layout assignment increases administrator productivity and simplifies managing large numbers of record types
or profiles. When assigning page layouts, the new AJAX user interface allows administrators to select multiple pages of record
types, highlight groups of cells by clicking and dragging, and mass change cells across pages without losing previous selections.
From the new page layout assignment page, you can:

• Click a cell, column, or row heading to select all the table cells in that column or row.
• Press Shift+click to select multiple adjacent table cells, columns, or rows.
• Press Ctrl+click to select multiple nonadjacent table cells, columns, or rows.
• Click any cell and drag your mouse pointer to select a range of cells.
• Click Next or Prev to view another set of record types.
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Tip:  Selected page layout assignments are highlighted. Page layout assignments you change are italicized until you
save your changes.

Page layout enhancements are available in all Salesforce Editions.

Record Locking to Avoid Conflicting Updates

With Summer '07, Salesforce includes new functionality to prevent users from inadvertently overriding each other's changes
while editing a record. If two users are editing the same record simultaneously, the user who saves the record first will have
his or her changes saved, and the second user will receive an error message and be prompted to reload the record with the
changes made by the first user. The error message is:
Your changes cannot be saved. The record you were editing was modified by <name of the other
user (or process)> during your edit session. Please re-display the record before attempting
any additional edits.

Record updates due to processes such as API integrations or Apex Code scripts may also cause a user to receive this error
message.

This features applies to all Salesforce Editions and is automatically enabled.

Recycle Bin Enhancements—Restoring Record Associations

When you deleted a record in previous releases, Salesforce permanently deleted its record associations. This meant that
Salesforce could not restore the associations if the deleted object was restored. In Summer '07, when you undelete a record,
Salesforce restores the record associations for the following types of relationships:

• Parent accounts (as specified in the Parent Account field on an account)
• Parent cases (as specified in the Parent Case field on a case)
• Master solutions for translated solutions (as specified in the Master Solution field on a solution)
• Managers of contacts (as specified in the Reports To field on a contact)
• Products related to assets (as specified in the Product field on an asset)
• All custom lookup relationships

Note: Salesforce only restores lookup relationships that have not been replaced. For example, if an asset is related to
a different product prior to the original product record being undeleted, that asset-product relationship is not restored.

Recycle Bin enhancements are available in all Salesforce Editions.

Sidebar Enhancements—New "Show Custom Sidebar on All Pages" Permission

You can now determine which users see custom sidebar components on all pages by assigning certain profiles the "Show
Custom Sidebar On All Pages" permission. For more information, see "User Permissions on Profiles" in the Salesforce online
help. If you have home page layouts that include components in the sidebar, this permission makes the sidebar components
available on all pages in Salesforce.

Note: You can only assign this permission to custom profiles.

If the Show Custom Sidebar Components on All Pages user interface setting is selected, the "Show Customer
Sidebar On All Pages" permission is not available.

To enable this permission:

1. Click Setup ➤ Manage Users ➤ Profiles.
2. Click Edit next to the appropriate custom profile.
3. Select the Show Custom Sidebar On All Pages checkbox and click Save.
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If you want all users in your organization to see custom sidebar components on all pages, use the Show Sidebar Components
on All Pages user interface setting. For more information, see "Customizing User Interface Settings" in the Salesforce
online help.

Search Enhancements

With Summer '07, search includes the following new enhancements and capabilities:

'Limit to Items I Own' Checkbox on Sidebar Search Now Optional
The Limit to items I own checkbox can now be removed from sidebar search.

To remove this checkbox, log in as an administrator, click Setup ➤ Customize ➤ User Interface, deselect
Enable "Limit to Items I Own" Search Checkbox, and click Save.

Solution Search Wildcards and Operators
You can now use wildcards and special operators to improve your solution search results:

DescriptionWildcard

Use an asterisk to match one or more characters at the middle or end of your
search term. Do not use the asterisk at the beginning of a search term, unless
you are performing a Lookup Search.

For example, a search for john* finds items that start with variations on the
term john, such as, johnson or johnny. A search for mi* meyers finds items with
mike meyers or michael meyers.

* (asterisk)

Note that the asterisk wildcard takes on the type of the preceding character.
For example, aa*a matches aaaa and aabcda, but not aa2a or aa.!//a.

Use a question mark to match one character at the middle or end of your
search term. For example, a search for jo?n finds items with the term john or

? (question mark)

joan. The question mark wildcard does not work at the beginning of a search
term.

Note that the question mark wildcard takes on the type of the preceding
character. For example, pi? matches pin and pig, but not pi1 or pi!. Likewise,
12? matches 123 and 124, but not 12a or 12b.

DescriptionOperator

Finds items that match all of the search terms. For example, acme AND
california finds items with both the word acme and the word california.

AND

Finds items with at least one of the search terms. For example, acme OR
california finds items with either acme or california or both words.

OR

Finds items that do not contain the search term. For example, acme AND
NOT california finds items that have the word acme but not the word california.

AND NOT

Use quotation marks around search terms to find an exact phrase match. This
can be especially useful when searching for text with punctuation. For example,

" " (quotation marks)

"acme.com" finds items that contain the exact text acme.com. A search for "monday
meeting" finds items that contain the exact phrase monday meeting.
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Back Button Support on the Search Results Page
You can now view the most recent filter, sort, and page settings in a search results page when you navigate
back to it using a browser's Back button. Previously, filter, sort, and page settings were not saved when
a user returned to search results.

'Search' Category in Help Table of Contents
You can now find help topics related to searching under Using the Application ➤ Search in the Help
and Training window's table of contents. In earlier releases, these help topics were categorized under
Using the Application ➤ Home Tab.

Search enhancements are available in all Salesforce Editions, but solution searching is available only in Professional, Enterprise,
Unlimited, and Developer Editions.

Security Enhancements

With Summer '07, users will receive a notification email whenever they log into Salesforce from a suspicious IP address and
computer.

A user will receive an email if all of the following are true:

• The option Do not send a notification email when a user logs in with an IP address and computer
that they have not used before. is not selected in Setup ➤ Security Controls ➤ Session Settings.

• The browser does not have a session cookie from salesforce.com.
• The user is logging into Salesforce from an IP address he or she has not used before

Note:  If a user's profile has a limited login IP range, he or she will not receive an email when logging in. For more
information on restricting login IP ranges, see "Restricting Login IP Ranges" in the Salesforce online help.

For more information on session security options, see "Setting Session Security" in the Salesforce online help.

Setup Audit Trail Enhancements

Now, you can view changes for custom buttons, links, and s-controls using the View Setup Audit Trail link from Setup ➤
Security Controls in Group, Professional, Enterprise, Unlimited, and Developer Editions.

Tab Home Page Overrides

Tab home pages, which are displayed when a user clicks any standard tab or custom object tab, can be overridden with internal
or external content using custom s-controls. You can change tab home page behavior to skip directly to a specific list view (for
example, “My New Leads”) or bring in third-party mash-ups to display key information.

To override the tab home page for a standard tab, click Setup ➤ Customize, select the appropriate tab link, click Buttons
and Links, and then click Override next to the name of the tab in the Standard Buttons and Links list.

To override the tab home page for a custom object tab, click Setup ➤ Build ➤ Custom Objects, select the appropriate object,
and then click Override next to the name of the tab in the Standard Buttons and Links list.

This feature is available in Enterprise, Unlimited, and Developer Editions.

Translation Enhancements for Multilingual Organizations

Summer '07 includes the following enhancements to improve the ease of administration and usability for multilingual
organizations:

Renaming Tabs and Labels Automatically Enabled
With Summer '07, the ability to change the display labels of tabs, objects, fields, and other related user
interface labels is automatically enabled for all Professional, Enterprise, Unlimited, and Developer Edition
organizations. You no longer need to contact salesforce.com to enable this feature.
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To rename tabs and labels, click Setup ➤ Customize ➤ Tab Names and Labels ➤ Rename Tabs and
Labels. For more information, see "Renaming Tab and Field Labels" in the Salesforce online help.

Translating Custom Objects
With Summer '07, you can now translate custom object names in Professional, Enterprise, Unlimited,
and Developer Edition organizations. Your translators can translate objects and tabs in addition to field
names. For more information, see "Renaming Tab and Field Labels" in the Salesforce online help.

Translating Additional Data Using the Translation Workbench
With Summer '07, you can now translate the following items using the translation workbench in
Professional, Enterprise, Unlimited, and Developer Editions:

• Custom field-level help
• Custom report types
• Custom web tabs

Click Setup ➤ Translation Workbench to translate these items.

New Supported Language: Russian
Salesforce now includes support for Russian in the application, increasing the supported languages to
fifteen:

• Brazilian Portuguese
• Simplified Chinese
• Traditional Chinese
• English
• Dutch
• Finnish
• French
• German
• Italian
• Japanese
• Korean
• Russian
• Spanish
• Swedish
• Thai

Users can change their personal language setting by clicking Setup ➤ My Personal Information ➤

Personal Information ➤ Edit.

Workflow Rule Enhancements

With Summer '07, workflow rules include the following enhancements:

Formula-based workflow rules
When defining entry criteria for workflow rules, you can now use formulas that include calculations and
multi-field comparisons, letting you create complex workflow rules. For example, you can leverage formula
functions such as ISCHANGED and PRIORVALUE to build rules based on field value changes.
To use a formula in a workflow rule, choose Formula evaluates to true in "Step 2: Configure Rule"
of the workflow rule wizard.

Tip:  Unlike formula fields, workflow rule formulas can reference fields on master objects when
a standard master-detail relationship exists. However, workflow rule formulas cannot reference
fields on master objects in a custom master-detail or lookup relationship.
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Time-based workflow with a granularity of hours
In Spring '07, Salesforce introduced the ability to create workflow rules that execute actions according to
time triggers based on days. In Summer '07, you can specify time triggers based on hours, letting you
automate business processes with greater precision.

Dynamic selection of email alert recipients
Send email alerts to any related user, contact, or email address that appears in any custom or standard
field on the object specified for the email alert. For example, you can create a workflow rule that sends
an email alert to the case contact seven days after a case is closed.

Note:  Email alerts to contacts are not supported for person accounts.

Workflow packaging
You can now include workflow rules and actions in both managed and unmanaged packages for the
AppExchange.

Note: You cannot package workflow rules that use time triggers.

Workflow rule enhancements are available in Enterprise, Unlimited, and Developer Editions.
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